]> git.pld-linux.org Git - packages/Coin.git/blame - Coin.spec
- updated to 4.0.2
[packages/Coin.git] / Coin.spec
CommitLineData
fe21aefb 1#
899bef05 2# Conditional build:
e9103d17 3%bcond_without apidocs # API documentation (with man pages)
899bef05 4%bcond_without static_libs # static library
e05060fa 5
fe21aefb 6Summary: High-level, retained-mode toolkit for effective 3D graphics development
899bef05 7Summary(pl.UTF-8): Wysokopoziomowy toolkit do efektywnego rozwijania grafiki 3D
fe21aefb 8Name: Coin
34dc79b9 9Version: 4.0.2
e9103d17
JB
10Release: 1
11License: BSD
466db9d4 12Group: X11/Libraries
34dc79b9
JB
13Source0: https://github.com/coin3d/coin/releases/download/v%{version}/coin-%{version}-src.tar.gz
14# Source0-md5: 1dd89262e2e9e44a046e803515387bdf
e9103d17
JB
15Patch0: %{name}-link.patch
16URL: https://github.com/coin3d/coin/wiki
17BuildRequires: OpenAL-devel
466db9d4 18BuildRequires: OpenGL-GLU-devel
19BuildRequires: OpenGL-devel
e9103d17 20BuildRequires: boost-devel
899bef05 21BuildRequires: bzip2-devel
e9103d17
JB
22BuildRequires: cmake >= 3.0
23%{?with_apidocs:BuildRequires: doxygen}
24BuildRequires: expat-devel >= 1:2.2.6
25BuildRequires: fontconfig-devel
26BuildRequires: freetype-devel >= 2
466db9d4 27BuildRequires: libstdc++-devel
aa71e61c 28BuildRequires: pkgconfig
e9103d17 29BuildRequires: simage-devel
466db9d4 30BuildRequires: xorg-lib-libX11-devel
899bef05 31BuildRequires: zlib-devel
fe21aefb
MK
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
466db9d4 34%description
35High-level, retained-mode toolkit for effective 3D graphics
899bef05
JB
36development. It's fully compatible with SGI Open Inventor 2.1.
37
38%description -l pl.UTF-8
39Wysokopoziomowy toolkit trybu przechowującego do efektywnego
40rozwijania grafiki 3D. Jest w pełni kompatybilny z pakietem SGI Open
41Inventor 2.1.
fe21aefb
MK
42
43%package devel
899bef05
JB
44Summary: Header files for Coin3D library
45Summary(pl.UTF-8): Pliki nagłówkowe biblioteki Coin3D
466db9d4 46Group: X11/Development/Libraries
14b3cc83 47Requires: %{name} = %{version}-%{release}
34dc79b9
JB
48Obsoletes: openinventor-devel < 2.2
49Obsoletes: sgi-OpenInventor-devel < 2.2
fe21aefb
MK
50
51%description devel
899bef05 52Header files for Coin3D library.
fe21aefb
MK
53
54%description devel -l pl.UTF-8
899bef05 55Pliki nagłówkowe biblioteki Coin3D.
fe21aefb 56
899bef05
JB
57%package static
58Summary: Static Coin3D library
59Summary(pl.UTF-8): Statyczna biblioteka Coin3D
60Group: X11/Development/Libraries
61Requires: %{name}-devel = %{version}-%{release}
fe21aefb 62
899bef05
JB
63%description static
64Static Coin3D library.
fe21aefb 65
899bef05
JB
66%description static -l pl.UTF-8
67Statyczna biblioteka Coin3D.
fe21aefb 68
e9103d17
JB
69%package apidocs
70Summary: API documentation for Coin library
71Summary(pl.UTF-8): Dokumentacja API biblioteki Coin
72Group: Documentation
ab598284 73BuildArch: noarch
e9103d17
JB
74
75%description apidocs
76API documentation for Coin library.
77
78%description apidocs -l pl.UTF-8
79Dokumentacja API biblioteki Coin.
80
899bef05 81%prep
e9103d17 82%setup -q -n coin
899bef05 83%patch0 -p1
fe21aefb
MK
84
85%build
e9103d17
JB
86# COIN_HAVE_JAVASCRIPT=OFF because it relies on obsolete JS_GetStringBytes function
87%define cmake_opts \\\
88 -DCOIN_BUILD_TESTS=OFF \\\
89 -DCOIN_HAVE_JAVASCRIPT=OFF \\\
90 -DFONTCONFIG_RUNTIME_LINKING=OFF \\\
91 -DFREETYPE_RUNTIME_LINKING=OFF \\\
92 -DGLU_RUNTIME_LINKING=OFF \\\
93 -DLIBBZIP2_RUNTIME_LINKING=OFF \\\
94 -DOPENAL_RUNTIME_LINKING=OFF \\\
95 -DSIMAGE_RUNTIME_LINKING=OFF \\\
96 -DSPIDERMONKEY_INCLUDE_DIR=/usr/include/js187 \\\
97 -DSPIDERMONKEY_RUNTIME_LINKING=OFF \\\
98 -DZLIB_RUNTIME_LINKING=OFF \\\
99 -DUSE_EXTERNAL_EXPAT=ON
100
101install -d builddir
102cd builddir
103%cmake .. \
104 %{cmake_opts} \
105%if %{with apidocs}
106 -DCOIN_BUILD_DOCUMENTATION=ON \
107 -DCOIN_BUILD_DOCUMENTATION_MAN=ON
108%endif
109
110%{__make}
111cd ..
112
113%if %{with static_libs}
114install -d builddir-static
115cd builddir-static
116%cmake .. \
117 %{cmake_opts} \
118 -DCOIN_BUILD_SHARED_LIBS=OFF
119
120%{__make}
121cd ..
122%endif
fe21aefb
MK
123
124%install
125rm -rf $RPM_BUILD_ROOT
899bef05 126
e9103d17
JB
127%if %{with static_libs}
128%{__make} -C builddir-static install \
129 DESTDIR=$RPM_BUILD_ROOT
130%endif
fe21aefb 131
e9103d17 132%{__make} -C builddir install \
fe21aefb
MK
133 DESTDIR=$RPM_BUILD_ROOT
134
e9103d17
JB
135# missed by cmake suite
136install -d $RPM_BUILD_ROOT%{_mandir}/man1
137cp -p man/man1/coin-config.1 $RPM_BUILD_ROOT%{_mandir}/man1
138
139%if %{with apidocs}
140# packaged as %doc
141%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/html
142# too generic names, not public API etc.
34dc79b9 143%{__rm} $RPM_BUILD_ROOT%{_mandir}/man3/{_*_,[a-z]*}.3
e9103d17 144%endif
899bef05 145
fe21aefb
MK
146%clean
147rm -rf $RPM_BUILD_ROOT
148
fe21aefb
MK
149%post -p /sbin/ldconfig
150%postun -p /sbin/ldconfig
fe21aefb 151
fe21aefb
MK
152%files
153%defattr(644,root,root,755)
34dc79b9 154%doc AUTHORS COPYING ChangeLog FAQ FAQ.legal NEWS README.UNIX README.md RELNOTES THANKS
466db9d4 155%attr(755,root,root) %{_libdir}/libCoin.so.*.*.*
e9103d17 156%attr(755,root,root) %ghost %{_libdir}/libCoin.so.80
fe21aefb 157%{_datadir}/%{name}
fe21aefb 158
14b3cc83 159%files devel
fe21aefb 160%defattr(644,root,root,755)
e05060fa 161%attr(755,root,root) %{_bindir}/coin-config
e9103d17 162%attr(755,root,root) %{_libdir}/libCoin.so
899bef05
JB
163%dir %{_includedir}/Inventor
164%{_includedir}/Inventor/C
165%{_includedir}/Inventor/VRMLnodes
166%{_includedir}/Inventor/actions
167%{_includedir}/Inventor/annex
168%{_includedir}/Inventor/bundles
169%{_includedir}/Inventor/caches
170%{_includedir}/Inventor/collision
171%{_includedir}/Inventor/details
172%{_includedir}/Inventor/draggers
173%{_includedir}/Inventor/elements
174%{_includedir}/Inventor/engines
175%{_includedir}/Inventor/errors
176%{_includedir}/Inventor/events
177%{_includedir}/Inventor/fields
178%{_includedir}/Inventor/lists
179%{_includedir}/Inventor/lock
180%{_includedir}/Inventor/manips
181%{_includedir}/Inventor/misc
e9103d17 182%{_includedir}/Inventor/navigation
899bef05
JB
183%{_includedir}/Inventor/nodekits
184%{_includedir}/Inventor/nodes
185%{_includedir}/Inventor/projectors
186%{_includedir}/Inventor/scxml
187%{_includedir}/Inventor/sensors
188%{_includedir}/Inventor/system
189%{_includedir}/Inventor/threads
190%{_includedir}/Inventor/tools
191%{_includedir}/Inventor/Sb*.h
192%{_includedir}/Inventor/So*.h
193%{_includedir}/Inventor/non_winsys.h
194%{_includedir}/Inventor/oivwin32.h
14b3cc83
MK
195%{_includedir}/SoDebug.h
196%{_includedir}/SoWinEnterScope.h
197%{_includedir}/SoWinLeaveScope.h
899bef05 198%{_pkgconfigdir}/Coin.pc
e9103d17 199%{_libdir}/cmake/Coin-%{version}
e05060fa 200%{_mandir}/man1/coin-config.1*
e9103d17
JB
201%if %{with apidocs}
202%{_mandir}/man3/Coin*.3*
899bef05
JB
203%{_mandir}/man3/Sb*.3*
204%{_mandir}/man3/Sc*.3*
205%{_mandir}/man3/So*.3*
e9103d17 206%endif
899bef05
JB
207
208%if %{with static_libs}
209%files static
210%defattr(644,root,root,755)
211%{_libdir}/libCoin.a
212%endif
e9103d17
JB
213
214%if %{with apidocs}
215%files apidocs
216%defattr(644,root,root,755)
217%doc builddir/html/*.{css,html,js,png}
218%endif
This page took 0.103391 seconds and 5 git commands to generate.