]> git.pld-linux.org Git - packages/CHOLMOD.git/blob - CHOLMOD.spec
- updated to 2.1.0
[packages/CHOLMOD.git] / CHOLMOD.spec
1 #
2 # Conditional build:
3 %bcond_with     metis           # build with partition support (using metis lib)
4 #
5 Summary:        CHOLMOD: sparse supernodal Cholesky factorization and update/downdate
6 Summary(pl.UTF-8):      CHOLMOD - rzadki wielowęzłowy rozkład Cholesky'ego z poprawianiem
7 Name:           CHOLMOD
8 Version:        2.1.0
9 Release:        1
10 License:        GPL v2+ (some parts LGPL v2.1+)
11 Group:          Libraries
12 Source0:        http://www.cise.ufl.edu/research/sparse/cholmod/%{name}-%{version}.tar.gz
13 # Source0-md5:  9bc275f9117c3e3a6c4f23c29fd01761
14 Patch0:         %{name}-ufconfig.patch
15 Patch1:         %{name}-shared.patch
16 # http://www.cise.ufl.edu/research/sparse/cholmod/metis.patch (for METIS 5)
17 Patch2:         %{name}-metis.patch
18 URL:            http://www.cise.ufl.edu/research/sparse/cholmod/
19 BuildRequires:  AMD-devel >= 2.3.0
20 BuildRequires:  CAMD-devel >= 2.3.0
21 BuildRequires:  CCOLAMD-devel >= 2.8.0
22 BuildRequires:  COLAMD-devel >= 2.8.0
23 BuildRequires:  SuiteSparse_config-devel >= 4.1.0
24 BuildRequires:  blas-devel
25 BuildRequires:  gcc-fortran
26 BuildRequires:  lapack-devel
27 BuildRequires:  libtool >= 2:1.5
28 %if %{with metis}
29 BuildRequires:  metis-devel >= 5
30 %endif
31 Requires:       AMD >= 2.3.0
32 Requires:       CAMD >= 2.3.0
33 Requires:       CCOLAMD >= 2.8.0
34 Requires:       COLAMD >= 2.8.0
35 Requires:       SuiteSparse_config-libs >= 4.1.0
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 CHOLMOD is a set of ANSI C routines for sparse Cholesky
40 factorization and update/downdate.
41
42 %description -l pl.UTF-8
43 CHOLMOD to zbiór procedur ANSI C do rzadkiego rozkładu Cholesky'ego z
44 poprawianiem.
45
46 %package devel
47 Summary:        Header files for CHOLMOD library
48 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CHOLMOD
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       AMD-devel >= 2.3.0
52 Requires:       CAMD-devel >= 2.3.0
53 Requires:       CCOLAMD-devel >= 2.8.0
54 Requires:       COLAMD-devel >= 2.8.0
55 Requires:       SuiteSparse_config-devel >= 4.0.0
56
57 %description devel
58 Header files for CHOLMOD library.
59
60 %description devel -l pl.UTF-8
61 Pliki nagłówkowe biblioteki CHOLMOD.
62
63 %package static
64 Summary:        Static CHOLMOD library
65 Summary(pl.UTF-8):      Statyczna biblioteka CHOLMOD
66 Group:          Development/Libraries
67 Requires:       %{name}-devel = %{version}-%{release}
68
69 %description static
70 Static CHOLMOD library.
71
72 %description static -l pl.UTF-8
73 Statyczna biblioteka CHOLMOD.
74
75 %prep
76 %setup -q -n %{name}
77 %patch0 -p1
78 %patch1 -p1
79 %patch2 -p1
80
81 %build
82 %{__make} \
83         CC="%{__cc}" \
84         %{?with_metis:WITH_METIS=1} \
85         %{!?with_metis:PARTITION= LPARTITION=} \
86         CFLAGS="%{rpmcflags}" \
87         LDFLAGS="%{rpmldflags}" \
88         libdir=%{_libdir}
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92 install -d $RPM_BUILD_ROOT%{_includedir}/cholmod
93
94 %{__make} -C Lib install \
95         DESTDIR=$RPM_BUILD_ROOT \
96         %{!?with_metis:PARTITION= LPARTITION=} \
97         libdir=%{_libdir}
98
99 install Include/*.h $RPM_BUILD_ROOT%{_includedir}/cholmod
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %post   -p /sbin/ldconfig
105 %postun -p /sbin/ldconfig
106
107 %files
108 %defattr(644,root,root,755)
109 %doc README.txt Doc/ChangeLog
110 %attr(755,root,root) %{_libdir}/libcholmod.so.*.*.*
111 %attr(755,root,root) %ghost %{_libdir}/libcholmod.so.0
112
113 %files devel
114 %defattr(644,root,root,755)
115 %doc Doc/UserGuide.pdf
116 %attr(755,root,root) %{_libdir}/libcholmod.so
117 %{_libdir}/libcholmod.la
118 %{_includedir}/cholmod
119
120 %files static
121 %defattr(644,root,root,755)
122 %{_libdir}/libcholmod.a
This page took 0.037285 seconds and 3 git commands to generate.