]> git.pld-linux.org Git - packages/CGAL.git/blob - CGAL.spec
leave comment why CMAKE_BUILD_TYPE override is neccessary
[packages/CGAL.git] / CGAL.spec
1 %define boost_version 1.32
2 Summary:        Computational Geometry Algorithms Library
3 Name:           CGAL
4 Version:        4.6
5 Release:        1
6 License:        GPLv3+ and LGPLv3+
7 Group:          Libraries
8 Source0:        https://gforge.inria.fr/frs/download.php/file/34705/%{name}-%{version}.tar.xz
9 # Source0-md5:  65fa7e17cd654ef68da47df608000007
10 URL:            http://www.cgal.org/
11 BuildRequires:  blas-devel
12 BuildRequires:  boost-devel >= %{boost_version}
13 BuildRequires:  cmake
14 BuildRequires:  gmp-c++-devel
15 BuildRequires:  gmp-devel
16 BuildRequires:  lapack-devel
17 BuildRequires:  mpfr-devel
18 BuildRequires:  qt-devel >= 3.0
19 BuildRequires:  sed >= 4.0
20 BuildRequires:  zlib-devel
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Libraries for CGAL applications. CGAL is a collaborative effort of
25 several sites in Europe and Israel. The goal is to make the most
26 important of the solutions and methods developed in computational
27 geometry available to users in industry and academia in a C++ library.
28 The goal is to provide easy access to useful, reliable geometric
29 algorithms.
30
31 %package devel
32 Summary:        Development files and tools for CGAL applications
33 Group:          Development/Libraries
34 Requires:       %{name} = %{version}-%{release}
35 Requires:       blas-devel
36 Requires:       boost-devel >= %{boost_version}
37 Requires:       gmp-c++-devel
38 Requires:       gmp-devel
39 Requires:       lapack-devel
40 Requires:       mpfr-devel
41 Requires:       qt-devel
42 Requires:       zlib-devel
43
44 %description devel
45 The %{name}-devel package provides the headers files and tools you may
46 need to develop applications using CGAL.
47
48 %package demos-source
49 Summary:        Examples and demos of CGAL algorithms
50 Group:          Documentation
51 Requires:       %{name}-devel = %{version}-%{release}
52
53 %description demos-source
54 The %{name}-demos-source package provides the sources of examples and
55 demos of CGAL algorithms.
56
57
58 %prep
59 %setup -q
60
61 %build
62 install -d build
63 cd build
64 # override build type, because:
65 # PLD is not a valid build type: only Release or Debug is allowed
66
67 # XXX: what is ${CHANGE_SOVERSION} here?
68 %cmake \
69         -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
70         -DCGAL_INSTALL_LIB_DIR=%{_lib} \
71         -DCGAL_INSTALL_DOC_DIR= ${CHANGE_SOVERSION} \
72         ..
73
74 %{__make}
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78 %{__make} -C build install \
79         DESTDIR=$RPM_BUILD_ROOT
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %post   -p /sbin/ldconfig
85 %postun -p /sbin/ldconfig
86
87 %files
88 %defattr(644,root,root,755)
89 %doc AUTHORS LICENSE LICENSE.FREE_USE LICENSE.LGPL CHANGES
90 %attr(755,root,root) %{_libdir}/libCGAL.so.*.*.*
91 %attr(755,root,root) %ghost %{_libdir}/libCGAL.so.11
92 %attr(755,root,root) %{_libdir}/libCGAL_Core.so.*.*.*
93 %attr(755,root,root) %ghost %{_libdir}/libCGAL_Core.so.11
94 %attr(755,root,root) %{_libdir}/libCGAL_ImageIO.so.*.*.*
95 %attr(755,root,root) %ghost %{_libdir}/libCGAL_ImageIO.so.11
96 %attr(755,root,root) %{_libdir}/libCGAL_Qt4.so.*.*.*
97 %attr(755,root,root) %ghost %{_libdir}/libCGAL_Qt4.so.11
98
99 %files devel
100 %defattr(644,root,root,755)
101 %attr(755,root,root) %{_bindir}/cgal_create_CMakeLists
102 %attr(755,root,root) %{_bindir}/cgal_create_cmake_script
103 %{_includedir}/CGAL
104 %{_libdir}/CGAL
105 %attr(755,root,root) %{_libdir}/libCGAL*.so
106 %{_mandir}/man1/cgal_create_cmake_script.1*
This page took 0.07364 seconds and 3 git commands to generate.