]> git.pld-linux.org Git - packages/CEGUI.git/blob - CEGUI.spec
- -devel should not requires CEGUI-Ogre when builder was run without ogre bcond,...
[packages/CEGUI.git] / CEGUI.spec
1 # TODO:
2 # - external tinyxml
3 # - external tolua++
4 #
5 # Conditional build:
6 %bcond_without  xercesc         # build XercesParser
7 %bcond_with     ogre            # build without Ogre renderer
8 %bcond_without  opengl          # build without OpenGL renderer
9 %bcond_with     samples         # build samples
10 #
11 Summary:        CEGUI - a free library providing windowing and widgets
12 Summary(pl.UTF-8):      CEGUI - wolnodostępna biblioteka zapewniającą okienka i widgety
13 Name:           CEGUI
14 Version:        0.7.1
15 Release:        3
16 License:        LGPL v2.1+ (with MIT parts)
17 Group:          Libraries
18 Source0:        http://downloads.sourceforge.net/crayzedsgui/%{name}-%{version}.tar.gz
19 # Source0-md5:  0a2815d5204e3c5510884ab62285da97
20 Source1:        http://downloads.sourceforge.net/crayzedsgui/%{name}-DOCS-%{version}.tar.gz
21 # Source1-md5:  b6c1656d6b004c3dc11bf4b887fd5bd3
22 Patch0:         %{name}-link.patch
23 URL:            http://www.cegui.org.uk/
24 BuildRequires:  DevIL-devel
25 BuildRequires:  DirectFB-devel
26 BuildRequires:  FreeImage-devel
27 %if %{with opengl}
28 BuildRequires:  OpenGL-GLU-devel
29 BuildRequires:  OpenGL-glut-devel
30 %endif
31 BuildRequires:  SILLY-devel >= 0.1.0
32 BuildRequires:  autoconf >= 2.59
33 BuildRequires:  automake
34 BuildRequires:  corona-devel >= 1.0.2
35 BuildRequires:  expat-devel
36 BuildRequires:  freetype-devel >= 2.0
37 BuildRequires:  glew-devel
38 BuildRequires:  irrlicht-devel >= 1.4
39 BuildRequires:  libstdc++-devel
40 BuildRequires:  libtool >= 2:1.5
41 BuildRequires:  libxml2-devel >= 1:2.6
42 BuildRequires:  lua51-devel >= 5.1
43 %if %{with ogre}
44 BuildRequires:  ogre-devel >= 1.0.0
45 BuildRequires:  ois-devel
46 %endif
47 BuildRequires:  pcre-devel >= 5.0
48 BuildRequires:  pkgconfig
49 # for irrlicht renderer
50 BuildRequires:  xorg-lib-libXxf86vm-devel
51 %if %{with xercesc}
52 BuildRequires:  xerces-c-devel
53 %endif
54 Requires:       irrlicht >= 1.4
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %description
58 CEGUI stands for Crazy Eddie's Gui System; a free library providing
59 windowing and widgets for graphics APIs / engines where such
60 functionality is not natively available, or severely lacking. The
61 library is object orientated, written in C++, and targeted at games
62 developers who should be spending their time creating great games, not
63 building GUI sub-systems!
64
65 %description -l pl.UTF-8
66 CEGUI oznacza Crazy Eddie's Gui System - wolnodostępną bibliotekę
67 zapewniającą okienka i widgety dla graficznych API i silników tam,
68 gdzie natywnie taka funkcjonalność nie jest dostępna lub ma znaczące
69 braki. Biblioteka jest zorientowana obiektowo, napisana w C++ i
70 skierowana dla programistów gier, którzy powinni spędzać czas na
71 pisaniu świetnych gier, a nie tworzeniu podsystemów GUI!
72
73 %package devel
74 Summary:        Development files for CEGUI
75 Summary(pl.UTF-8):      Pliki programistyczne dla CEGUI
76 Group:          Development/Libraries
77 Requires:       %{name} = %{version}-%{release}
78 %{?with_ogre:Requires:  %{name}-Ogre = %{version}-%{release}}
79 %{?with_opengl:Requires:        %{name}-OpenGL = %{version}-%{release}}
80 Requires:       freetype-devel >= 2.0
81 Requires:       libstdc++-devel
82 Requires:       pcre-devel >= 5.0
83
84 %description devel
85 CEGUI headers.
86
87 %description devel -l pl.UTF-8
88 Pliki nagłówkowe CEGUI.
89
90 %package docs
91 Summary:        Documentation files for CEGUI
92 Summary(pl.UTF-8):      Pliki dokumentacji CEGUI
93 Group:          Documentation
94 Requires:       %{name} = %{version}-%{release}
95
96 %description docs
97 CEGUI documentation.
98
99 %description docs -l pl.UTF-8
100 Dokumentacja CEGUI.
101
102 %package OpenGL
103 Summary:        OpenGLRenderer library for CEGUI
104 Summary(pl.UTF-8):      Biblioteka OpenGLRenderer dla CEGUI
105 Group:          Libraries
106 Requires:       %{name} = %{version}-%{release}
107
108 %description OpenGL
109 OpenGLRenderer library for CEGUI.
110
111 %description OpenGL -l pl.UTF-8
112 Biblioteka OpenGLRenderer dla CEGUI.
113
114 %package Ogre
115 Summary:        OgreRenderer library for CEGUI
116 Summary(pl.UTF-8):      Biblioteka OgreRenderer dla CEGUI
117 Group:          Libraries
118 Requires:       %{name} = %{version}-%{release}
119
120 %description Ogre
121 OgreRenderer library for CEGUI.
122
123 %description Ogre -l pl.UTF-8
124 Biblioteka OgreRenderer dla CEGUI
125
126 %prep
127 %setup -q -a 1
128 %patch0 -p1
129
130 %build
131 %{__libtoolize}
132 %{__aclocal}
133 %{__autoconf}
134 %{__autoheader}
135 %{__automake}
136 %configure \
137         --with-default-image-codec=FreeImageImageCodec \
138         --with-default-xml-parser=LibxmlParser \
139         %{!?with_samples:--disable-samples} \
140         --%{?with_ogre:en}%{!?with_ogre:dis}able-ogre-renderer \
141         --%{?with_opengl:en}%{!?with_opengl:dis}able-opengl-renderer \
142         --%{?with_xercesc:en}%{!?with_xercesc:dis}able-xerces-c
143
144 %{__make}
145
146 %install
147 rm -rf $RPM_BUILD_ROOT
148
149 %{__make} install \
150         DESTDIR=$RPM_BUILD_ROOT
151
152 %clean
153 rm -rf $RPM_BUILD_ROOT
154
155 %post   -p /sbin/ldconfig
156 %postun -p /sbin/ldconfig
157
158 %files
159 %defattr(644,root,root,755)
160 %doc doc/README
161 %attr(755,root,root) %{_libdir}/libCEGUIBase-%{version}.so
162 # plugins
163 %attr(755,root,root) %{_libdir}/libCEGUICoronaImageCodec-%{version}.so
164 %attr(755,root,root) %{_libdir}/libCEGUICoronaImageCodec.so
165 %attr(755,root,root) %{_libdir}/libCEGUIDevILImageCodec-%{version}.so
166 %attr(755,root,root) %{_libdir}/libCEGUIDevILImageCodec.so
167 %attr(755,root,root) %{_libdir}/libCEGUIExpatParser-%{version}.so
168 %attr(755,root,root) %{_libdir}/libCEGUIExpatParser.so
169 %attr(755,root,root) %{_libdir}/libCEGUIFalagardWRBase-%{version}.so
170 %attr(755,root,root) %{_libdir}/libCEGUIFalagardWRBase.so
171 %attr(755,root,root) %{_libdir}/libCEGUIFreeImageImageCodec-%{version}.so
172 %attr(755,root,root) %{_libdir}/libCEGUIFreeImageImageCodec.so
173 %attr(755,root,root) %{_libdir}/libCEGUIIrrlichtRenderer-%{version}.so
174 %attr(755,root,root) %{_libdir}/libCEGUIIrrlichtRenderer.so
175 %attr(755,root,root) %{_libdir}/libCEGUILibxmlParser-%{version}.so
176 %attr(755,root,root) %{_libdir}/libCEGUILibxmlParser.so
177 %attr(755,root,root) %{_libdir}/libCEGUILuaScriptModule-%{version}.so
178 %attr(755,root,root) %{_libdir}/libCEGUILuaScriptModule.so
179 %attr(755,root,root) %{_libdir}/libCEGUISILLYImageCodec-%{version}.so
180 %attr(755,root,root) %{_libdir}/libCEGUISILLYImageCodec.so
181 %attr(755,root,root) %{_libdir}/libCEGUITGAImageCodec-%{version}.so
182 %attr(755,root,root) %{_libdir}/libCEGUITGAImageCodec.so
183 %attr(755,root,root) %{_libdir}/libCEGUITinyXMLParser-%{version}.so
184 %attr(755,root,root) %{_libdir}/libCEGUITinyXMLParser.so
185 %attr(755,root,root) %{_libdir}/libCEGUIXercesParser-%{version}.so
186 %attr(755,root,root) %{_libdir}/libCEGUIXercesParser.so
187 %attr(755,root,root) %{_libdir}/libCEGUItoluapp-%{version}.so
188 %attr(755,root,root) %{_libdir}/libCEGUItoluapp.so
189
190 %files docs
191 %defattr(644,root,root,755)
192 %doc docs/CEGUI-DOCS-%{version}
193 %dir %{_datadir}/%{name}
194 %dir %{_datadir}/%{name}/xml_schemas
195 %{_datadir}/%{name}/xml_schemas/*.xsd
196
197 %files devel
198 %defattr(644,root,root,755)
199 %attr(755,root,root) %{_libdir}/libCEGUIBase.so
200 %{?with_ogre:%attr(755,root,root) %{_libdir}/libCEGUIOgreRenderer.so}
201 %{?with_opengl:%attr(755,root,root) %{_libdir}/libCEGUIOpenGLRenderer.so}
202 %{_libdir}/libCEGUIBase.la
203 %{?with_ogre:%{_libdir}/libCEGUIOgreRenderer.la}
204 %{?with_opengl:%{_libdir}/libCEGUIOpenGLRenderer.la}
205 # plugins - but as their headers are included...
206 %{_libdir}/libCEGUICoronaImageCodec.la
207 %{_libdir}/libCEGUIDevILImageCodec.la
208 %{_libdir}/libCEGUIExpatParser.la
209 %{_libdir}/libCEGUIFalagardWRBase.la
210 %{_libdir}/libCEGUIFreeImageImageCodec.la
211 %{_libdir}/libCEGUIIrrlichtRenderer.la
212 %{_libdir}/libCEGUILibxmlParser.la
213 %{_libdir}/libCEGUILuaScriptModule.la
214 %{_libdir}/libCEGUISILLYImageCodec.la
215 %{_libdir}/libCEGUITGAImageCodec.la
216 %{_libdir}/libCEGUITinyXMLParser.la
217 %{_libdir}/libCEGUIXercesParser.la
218 %{_libdir}/libCEGUItoluapp.la
219 %{_includedir}/%{name}
220 %{_pkgconfigdir}/CEGUI.pc
221 %{?with_opengl:%{_pkgconfigdir}/CEGUI-OPENGL.pc}
222 %{?with_ogre:%{_pkgconfigdir}/CEGUI-OGRE.pc}
223
224 %if %{with opengl}
225 %files OpenGL
226 %defattr(644,root,root,755)
227 %attr(755,root,root) %{_libdir}/libCEGUIOpenGLRenderer-%{version}.so
228 %endif
229
230 %if %{with ogre}
231 %files Ogre
232 %defattr(644,root,root,755)
233 %attr(755,root,root) %{_libdir}/libCEGUIOgreRenderer-%{version}.so
234 %endif
This page took 0.054739 seconds and 3 git commands to generate.