]> git.pld-linux.org Git - packages/CEGUI.git/blob - CEGUI.spec
- release 9
[packages/CEGUI.git] / CEGUI.spec
1 # TODO:
2 # - python
3 # - separate packages for plugins
4 #
5 # Conditional build:
6 %bcond_without  xercesc         # build XercesParser
7 %bcond_without  ogre            # build without Ogre renderer
8 %bcond_without  opengl          # build without OpenGL renderer
9 %bcond_with     samples         # build samples
10 #
11 Summary:        CEGUI - a free library providing windowing and widgets
12 Summary(pl.UTF-8):      CEGUI - wolnodostępna biblioteka zapewniającą okienka i widgety
13 Name:           CEGUI
14 Version:        0.7.5
15 Release:        9
16 License:        LGPL v2.1+ (with MIT parts)
17 Group:          Libraries
18 Source0:        http://downloads.sourceforge.net/crayzedsgui/%{name}-%{version}.tar.gz
19 # Source0-md5:  38c79d1fdfaaa10f481c99a2ac479516
20 Source1:        http://downloads.sourceforge.net/crayzedsgui/%{name}-DOCS-%{version}.tar.gz
21 # Source1-md5:  cdf59df7503f752a70eea4081eaac6ef
22 Patch0:         %{name}-new-tinyxml.patch
23 Patch1:         %{name}-gcc.patch
24 URL:            http://www.cegui.org.uk/
25 BuildRequires:  DevIL-devel
26 BuildRequires:  DirectFB-devel >= 1.2.0
27 BuildRequires:  FreeImage-devel
28 BuildRequires:  SILLY-devel >= 0.1.0
29 BuildRequires:  autoconf >= 2.59
30 BuildRequires:  automake
31 BuildRequires:  corona-devel
32 BuildRequires:  expat-devel
33 BuildRequires:  freetype-devel >= 2.0
34 BuildRequires:  gtk+2-devel >= 2:2.4
35 BuildRequires:  irrlicht-devel >= 1.4
36 BuildRequires:  libstdc++-devel
37 BuildRequires:  libtool >= 2:1.5
38 BuildRequires:  libxml2-devel >= 1:2.6
39 BuildRequires:  lua51-devel >= 5.1
40 %if %{with ogre}
41 BuildRequires:  ogre-devel >= 1.6.0
42 BuildRequires:  ois-devel
43 %endif
44 BuildRequires:  pcre-devel >= 5.0
45 BuildRequires:  pkgconfig
46 BuildRequires:  sed >= 4.0
47 BuildRequires:  tinyxml-devel
48 BuildRequires:  tolua++-devel
49 # for irrlicht renderer
50 BuildRequires:  xorg-lib-libXxf86vm-devel
51 %if %{with opengl}
52 BuildRequires:  OpenGL-GLU-devel
53 BuildRequires:  OpenGL-glut-devel
54 BuildRequires:  glew-devel
55 %endif
56 %if %{with xercesc}
57 BuildRequires:  xerces-c-devel
58 %endif
59 Requires:       irrlicht >= 1.4
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62 %description
63 CEGUI stands for Crazy Eddie's Gui System; a free library providing
64 windowing and widgets for graphics APIs / engines where such
65 functionality is not natively available, or severely lacking. The
66 library is object orientated, written in C++, and targeted at games
67 developers who should be spending their time creating great games, not
68 building GUI sub-systems!
69
70 %description -l pl.UTF-8
71 CEGUI oznacza Crazy Eddie's Gui System - wolnodostępną bibliotekę
72 zapewniającą okienka i widgety dla graficznych API i silników tam,
73 gdzie natywnie taka funkcjonalność nie jest dostępna lub ma znaczące
74 braki. Biblioteka jest zorientowana obiektowo, napisana w C++ i
75 skierowana dla programistów gier, którzy powinni spędzać czas na
76 pisaniu świetnych gier, a nie tworzeniu podsystemów GUI!
77
78 %package devel
79 Summary:        Development files for CEGUI
80 Summary(pl.UTF-8):      Pliki programistyczne dla CEGUI
81 Group:          Development/Libraries
82 Requires:       %{name} = %{version}-%{release}
83 Requires:       freetype-devel >= 2.0
84 Requires:       libstdc++-devel
85 Requires:       pcre-devel >= 5.0
86
87 %description devel
88 CEGUI headers.
89
90 %description devel -l pl.UTF-8
91 Pliki nagłówkowe CEGUI.
92
93 %package docs
94 Summary:        Documentation files for CEGUI
95 Summary(pl.UTF-8):      Pliki dokumentacji CEGUI
96 Group:          Documentation
97 Requires:       %{name} = %{version}-%{release}
98
99 %description docs
100 CEGUI documentation.
101
102 %description docs -l pl.UTF-8
103 Dokumentacja CEGUI.
104
105 %package Ogre
106 Summary:        OgreRenderer library for CEGUI
107 Summary(pl.UTF-8):      Biblioteka OgreRenderer dla CEGUI
108 Group:          Libraries
109 Requires:       %{name} = %{version}-%{release}
110
111 %description Ogre
112 OgreRenderer library for CEGUI.
113
114 %description Ogre -l pl.UTF-8
115 Biblioteka OgreRenderer dla CEGUI
116
117 %package Ogre-devel
118 Summary:        Header files for CEGUI OgreRenderer library
119 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI OgreRenderer
120 Group:          Development/Libraries
121 Requires:       %{name} = %{version}-%{release}
122 Requires:       ogre-devel >= 1.6.0
123
124 %description Ogre-devel
125 Header files for CEGUI OgreRenderer library.
126
127 %description Ogre-devel -l pl.UTF-8
128 Pliki nagłówkowe biblioteki CEGUI OgreRenderer.
129
130 %package OpenGL
131 Summary:        OpenGLRenderer library for CEGUI
132 Summary(pl.UTF-8):      Biblioteka OpenGLRenderer dla CEGUI
133 Group:          Libraries
134 Requires:       %{name} = %{version}-%{release}
135
136 %description OpenGL
137 OpenGLRenderer library for CEGUI.
138
139 %description OpenGL -l pl.UTF-8
140 Biblioteka OpenGLRenderer dla CEGUI.
141
142 %package OpenGL-devel
143 Summary:        Header files for CEGUI OpenGLRenderer library
144 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI OpenGLRenderer
145 Group:          Development/Libraries
146 Requires:       %{name} = %{version}-%{release}
147 Requires:       OpenGL-GLU-devel
148 Requires:       OpenGL-glut-devel
149 Requires:       glew-devel
150
151 %description OpenGL-devel
152 Header files for CEGUI OpenGLRenderer library.
153
154 %description OpenGL-devel -l pl.UTF-8
155 Pliki nagłówkowe biblioteki CEGUI OpenGLRenderer.
156
157 %prep
158 %setup -q -a 1
159 %patch0 -p1
160 %patch1 -p1
161
162 sed -i -e 's/lua5\.1/lua51/' acinclude.m4
163
164 %build
165 %{__libtoolize}
166 %{__aclocal}
167 %{__autoconf}
168 %{__autoheader}
169 %{__automake}
170 %configure \
171         cegui_corona_config=/usr/bin/corona-config \
172         --with-default-image-codec=FreeImageImageCodec \
173         --with-default-xml-parser=LibxmlParser \
174         %{!?with_samples:--disable-samples} \
175         --enable-ogre-renderer%{!?with_ogre:=no} \
176         --enable-opengl-renderer%{!?with_opengl:=no} \
177         --enable-xerces-c%{!?with_xercesc:=no}
178
179 %{__make}
180
181 %install
182 rm -rf $RPM_BUILD_ROOT
183
184 %{__make} install \
185         DESTDIR=$RPM_BUILD_ROOT
186
187 %clean
188 rm -rf $RPM_BUILD_ROOT
189
190 %post   -p /sbin/ldconfig
191 %postun -p /sbin/ldconfig
192
193 %files
194 %defattr(644,root,root,755)
195 %doc doc/README
196 %attr(755,root,root) %{_libdir}/libCEGUIBase-%{version}.so
197 # plugins
198 %attr(755,root,root) %{_libdir}/libCEGUIDevILImageCodec-%{version}.so
199 %attr(755,root,root) %{_libdir}/libCEGUIDevILImageCodec.so
200 %attr(755,root,root) %{_libdir}/libCEGUIExpatParser-%{version}.so
201 %attr(755,root,root) %{_libdir}/libCEGUIExpatParser.so
202 %attr(755,root,root) %{_libdir}/libCEGUIFalagardWRBase-%{version}.so
203 %attr(755,root,root) %{_libdir}/libCEGUIFalagardWRBase.so
204 %attr(755,root,root) %{_libdir}/libCEGUIFreeImageImageCodec-%{version}.so
205 %attr(755,root,root) %{_libdir}/libCEGUIFreeImageImageCodec.so
206 %attr(755,root,root) %{_libdir}/libCEGUIIrrlichtRenderer-%{version}.so
207 %attr(755,root,root) %{_libdir}/libCEGUIIrrlichtRenderer.so
208 %attr(755,root,root) %{_libdir}/libCEGUILibxmlParser-%{version}.so
209 %attr(755,root,root) %{_libdir}/libCEGUILibxmlParser.so
210 %attr(755,root,root) %{_libdir}/libCEGUILuaScriptModule-%{version}.so
211 %attr(755,root,root) %{_libdir}/libCEGUILuaScriptModule.so
212 %attr(755,root,root) %{_libdir}/libCEGUISILLYImageCodec-%{version}.so
213 %attr(755,root,root) %{_libdir}/libCEGUISILLYImageCodec.so
214 %attr(755,root,root) %{_libdir}/libCEGUISTBImageCodec-%{version}.so
215 %attr(755,root,root) %{_libdir}/libCEGUISTBImageCodec.so
216 %attr(755,root,root) %{_libdir}/libCEGUITGAImageCodec-%{version}.so
217 %attr(755,root,root) %{_libdir}/libCEGUITGAImageCodec.so
218 %attr(755,root,root) %{_libdir}/libCEGUITinyXMLParser-%{version}.so
219 %attr(755,root,root) %{_libdir}/libCEGUITinyXMLParser.so
220 %attr(755,root,root) %{_libdir}/libCEGUIXercesParser-%{version}.so
221 %attr(755,root,root) %{_libdir}/libCEGUIXercesParser.so
222
223 %files docs
224 %defattr(644,root,root,755)
225 %doc docs
226 %dir %{_datadir}/%{name}
227 %dir %{_datadir}/%{name}/xml_schemas
228 %{_datadir}/%{name}/xml_schemas/*.xsd
229
230 %files devel
231 %defattr(644,root,root,755)
232 %attr(755,root,root) %{_libdir}/libCEGUIBase.so
233 %{_libdir}/libCEGUIBase.la
234 # plugins - but as their headers are included...
235 %{_libdir}/libCEGUIDevILImageCodec.la
236 %{_libdir}/libCEGUIExpatParser.la
237 %{_libdir}/libCEGUIFalagardWRBase.la
238 %{_libdir}/libCEGUIFreeImageImageCodec.la
239 %{_libdir}/libCEGUIIrrlichtRenderer.la
240 %{_libdir}/libCEGUILibxmlParser.la
241 %{_libdir}/libCEGUILuaScriptModule.la
242 %{_libdir}/libCEGUISILLYImageCodec.la
243 %{_libdir}/libCEGUISTBImageCodec.la
244 %{_libdir}/libCEGUITGAImageCodec.la
245 %{_libdir}/libCEGUITinyXMLParser.la
246 %{_libdir}/libCEGUIXercesParser.la
247 %dir %{_includedir}/%{name}
248 %{_includedir}/%{name}/CEGUI*.h
249 %{_includedir}/%{name}/ImageCodecModules
250 %dir %{_includedir}/%{name}/RendererModules
251 %{_includedir}/%{name}/RendererModules/Irrlicht
252 %{_includedir}/%{name}/ScriptingModules
253 %{_includedir}/%{name}/WindowRendererSets
254 %{_includedir}/%{name}/XMLParserModules
255 %{_includedir}/%{name}/elements
256 %{_includedir}/%{name}/falagard
257 %{_pkgconfigdir}/CEGUI.pc
258
259 %if %{with ogre}
260 %files Ogre
261 %defattr(644,root,root,755)
262 %attr(755,root,root) %{_libdir}/libCEGUIOgreRenderer-%{version}.so
263
264 %files Ogre-devel
265 %defattr(644,root,root,755)
266 %attr(755,root,root) %{_libdir}/libCEGUIOgreRenderer.so
267 %{_libdir}/libCEGUIOgreRenderer.la
268 %{_includedir}/%{name}/RendererModules/Ogre
269 %{_pkgconfigdir}/CEGUI-OGRE.pc
270 %endif
271
272 %if %{with opengl}
273 %files OpenGL
274 %defattr(644,root,root,755)
275 %attr(755,root,root) %{_libdir}/libCEGUIOpenGLRenderer-%{version}.so
276
277 %files OpenGL-devel
278 %defattr(644,root,root,755)
279 %attr(755,root,root) %{_libdir}/libCEGUIOpenGLRenderer.so
280 %{_libdir}/libCEGUIOpenGLRenderer.la
281 %{_includedir}/%{name}/RendererModules/OpenGL
282 %{_pkgconfigdir}/CEGUI-OPENGL.pc
283 %endif
This page took 0.421032 seconds and 3 git commands to generate.