]> git.pld-linux.org Git - packages/CEGUI.git/blob - CEGUI.spec
- TYPO
[packages/CEGUI.git] / CEGUI.spec
1 # TODO:
2 # - external tinyxml
3 # - external tolua++
4 # - STOP THIS ALL CAPS I CAN WRITE MADNESS. FOR EXAMPLE OPENGL IS NOT ALL CAPS
5 #   IN UPSTREAM AND SO IS NOT OGRE IN ALL CAPS
6 #
7 # Conditional build:
8 %bcond_without  xercesc         # build XercesParser
9 %bcond_without  ogre            # build without Ogre renderer
10 %bcond_without  opengl          # build without OpenGL renderer
11 %bcond_with     samples         # build samples
12 #
13 Summary:        CEGUI - a free library providing windowing and widgets
14 Summary(pl.UTF-8):      CEGUI - wolnodostępna biblioteka zapewniającą okienka i widgety
15 Name:           CEGUI
16 Version:        0.7.1
17 Release:        1
18 License:        LGPL v2.1+ (with MIT parts)
19 Group:          Libraries
20 Source0:        http://downloads.sourceforge.net/crayzedsgui/%{name}-%{version}.tar.gz
21 # Source0-md5:  0a2815d5204e3c5510884ab62285da97
22 Source1:        http://downloads.sourceforge.net/crayzedsgui/%{name}-DOCS-%{version}.tar.gz
23 # Source1-md5:  b6c1656d6b004c3dc11bf4b887fd5bd3
24 Patch0:         %{name}-link.patch
25 URL:            http://www.cegui.org.uk/
26 BuildRequires:  DevIL-devel
27 BuildRequires:  DirectFB-devel
28 BuildRequires:  FreeImage-devel
29 %if %{with opengl}
30 BuildRequires:  OpenGL-GLU-devel
31 BuildRequires:  OpenGL-glut-devel
32 %endif
33 BuildRequires:  SILLY-devel >= 0.1.0
34 BuildRequires:  autoconf >= 2.59
35 BuildRequires:  automake
36 BuildRequires:  corona-devel >= 1.0.2
37 BuildRequires:  expat-devel
38 BuildRequires:  freetype-devel >= 2.0
39 BuildRequires:  glew-devel
40 BuildRequires:  irrlicht-devel >= 1.4
41 BuildRequires:  libstdc++-devel
42 BuildRequires:  libtool >= 2:1.5
43 BuildRequires:  libxml2-devel >= 1:2.6
44 BuildRequires:  lua51-devel >= 5.1
45 %if %{with ogre}
46 BuildRequires:  ogre-devel >= 1.0.0
47 BuildRequires:  ois-devel
48 %endif
49 BuildRequires:  pcre-devel >= 5.0
50 BuildRequires:  pkgconfig
51 # for irrlicht renderer
52 BuildRequires:  xorg-lib-libXxf86vm-devel
53 %if %{with xercesc}
54 BuildRequires:  xerces-c-devel
55 %endif
56 Requires:       irrlicht >= 1.4
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %description
60 CEGUI stands for Crazy Eddie's Gui System; a free library providing
61 windowing and widgets for graphics APIs / engines where such
62 functionality is not natively available, or severely lacking. The
63 library is object orientated, written in C++, and targeted at games
64 developers who should be spending their time creating great games, not
65 building GUI sub-systems!
66
67 %description -l pl.UTF-8
68 CEGUI oznacza Crazy Eddie's Gui System - wolnodostępną bibliotekę
69 zapewniającą okienka i widgety dla graficznych API i silników tam,
70 gdzie natywnie taka funkcjonalność nie jest dostępna lub ma znaczące
71 braki. Biblioteka jest zorientowana obiektowo, napisana w C++ i
72 skierowana dla programistów gier, którzy powinni spędzać czas na
73 pisaniu świetnych gier, a nie tworzeniu podsystemów GUI!
74
75 %package devel
76 Summary:        Development files for CEGUI
77 Summary(pl.UTF-8):      Pliki programistyczne dla CEGUI
78 Group:          Development/Libraries
79 Requires:       %{name} = %{version}-%{release}
80 Requires:       %{name}-OGRE = %{version}-%{release}
81 Requires:       %{name}-OPENGL = %{version}-%{release}
82 Requires:       freetype-devel >= 2.0
83 Requires:       libstdc++-devel
84 Requires:       pcre-devel >= 5.0
85
86 %description devel
87 CEGUI headers.
88
89 %description devel -l pl.UTF-8
90 Pliki nagłówkowe CEGUI.
91
92 %package docs
93 Summary:        Documentation files for CEGUI
94 Summary(pl.UTF-8):      Pliki dokumentacji CEGUI
95 Group:          Documentation
96 Requires:       %{name} = %{version}-%{release}
97
98 %description docs
99 CEGUI documentation.
100
101 %description docs -l pl.UTF-8
102 Dokumentacja CEGUI.
103
104 %package OPENGL
105 Summary:        OpenGLRenderer library for CEGUI
106 Summary(pl.UTF-8):      Biblioteka OpenGLRenderer dla CEGUI
107 Group:          Libraries
108 Requires:       %{name} = %{version}-%{release}
109
110 %description OPENGL
111 OpenGLRenderer library for CEGUI.
112
113 %description OPENGL -l pl.UTF-8
114 Biblioteka OpenGLRenderer dla CEGUI.
115
116 %package OGRE
117 Summary:        OgreRenderer library for CEGUI
118 Summary(pl.UTF-8):      Biblioteka OgreRenderer dla CEGUI
119 Group:          Libraries
120 Requires:       %{name} = %{version}-%{release}
121
122 %description OGRE
123 OgreRenderer library for CEGUI.
124
125 %description OGRE -l pl.UTF-8
126 Biblioteka OgreRenderer dla CEGUI
127
128 %prep
129 %setup -q -a 1
130 %patch0 -p1
131
132 %build
133 %{__libtoolize}
134 %{__aclocal}
135 %{__autoconf}
136 %{__autoheader}
137 %{__automake}
138 %configure \
139         --with-default-image-codec=FreeImageImageCodec \
140         --with-default-xml-parser=LibxmlParser \
141         %{!?with_samples:--disable-samples} \
142         --%{?with_ogre:en}%{!?with_ogre:dis}able-ogre-renderer \
143         --%{?with_opengl:en}%{!?with_opengl:dis}able-opengl-renderer \
144         --%{?with_xercesc:en}%{!?with_xercesc:dis}able-xerces-c
145
146 %{__make}
147
148 %install
149 rm -rf $RPM_BUILD_ROOT
150
151 %{__make} install \
152         DESTDIR=$RPM_BUILD_ROOT
153
154 %clean
155 rm -rf $RPM_BUILD_ROOT
156
157 %post   -p /sbin/ldconfig
158 %postun -p /sbin/ldconfig
159
160 %files
161 %defattr(644,root,root,755)
162 %doc doc/README
163 %attr(755,root,root) %{_libdir}/libCEGUIBase-%{version}.so
164 # plugins
165 %attr(755,root,root) %{_libdir}/libCEGUICoronaImageCodec-%{version}.so
166 %attr(755,root,root) %{_libdir}/libCEGUICoronaImageCodec.so
167 %attr(755,root,root) %{_libdir}/libCEGUIDevILImageCodec-%{version}.so
168 %attr(755,root,root) %{_libdir}/libCEGUIDevILImageCodec.so
169 %attr(755,root,root) %{_libdir}/libCEGUIExpatParser-%{version}.so
170 %attr(755,root,root) %{_libdir}/libCEGUIExpatParser.so
171 %attr(755,root,root) %{_libdir}/libCEGUIFalagardWRBase-%{version}.so
172 %attr(755,root,root) %{_libdir}/libCEGUIFalagardWRBase.so
173 %attr(755,root,root) %{_libdir}/libCEGUIFreeImageImageCodec-%{version}.so
174 %attr(755,root,root) %{_libdir}/libCEGUIFreeImageImageCodec.so
175 %attr(755,root,root) %{_libdir}/libCEGUIIrrlichtRenderer-%{version}.so
176 %attr(755,root,root) %{_libdir}/libCEGUIIrrlichtRenderer.so
177 %attr(755,root,root) %{_libdir}/libCEGUILibxmlParser-%{version}.so
178 %attr(755,root,root) %{_libdir}/libCEGUILibxmlParser.so
179 %attr(755,root,root) %{_libdir}/libCEGUILuaScriptModule-%{version}.so
180 %attr(755,root,root) %{_libdir}/libCEGUILuaScriptModule.so
181 %attr(755,root,root) %{_libdir}/libCEGUISILLYImageCodec-%{version}.so
182 %attr(755,root,root) %{_libdir}/libCEGUISILLYImageCodec.so
183 %attr(755,root,root) %{_libdir}/libCEGUITGAImageCodec-%{version}.so
184 %attr(755,root,root) %{_libdir}/libCEGUITGAImageCodec.so
185 %attr(755,root,root) %{_libdir}/libCEGUITinyXMLParser-%{version}.so
186 %attr(755,root,root) %{_libdir}/libCEGUITinyXMLParser.so
187 %attr(755,root,root) %{_libdir}/libCEGUIXercesParser-%{version}.so
188 %attr(755,root,root) %{_libdir}/libCEGUIXercesParser.so
189 %attr(755,root,root) %{_libdir}/libCEGUItoluapp-%{version}.so
190 %attr(755,root,root) %{_libdir}/libCEGUItoluapp.so
191
192 %files docs
193 %defattr(644,root,root,755)
194 %doc docs/CEGUI-DOCS-%{version}
195 %dir %{_datadir}/%{name}
196 %dir %{_datadir}/%{name}/xml_schemas
197 %{_datadir}/%{name}/xml_schemas/*.xsd
198
199 %files devel
200 %defattr(644,root,root,755)
201 %attr(755,root,root) %{_libdir}/libCEGUIBase.so
202 %attr(755,root,root) %{_libdir}/libCEGUIOgreRenderer.so
203 %attr(755,root,root) %{_libdir}/libCEGUIOpenGLRenderer.so
204 %{_libdir}/libCEGUIBase.la
205 %{_libdir}/libCEGUIOgreRenderer.la
206 %{_libdir}/libCEGUIOpenGLRenderer.la
207 # plugins - but as their headers are included...
208 %{_libdir}/libCEGUICoronaImageCodec.la
209 %{_libdir}/libCEGUIDevILImageCodec.la
210 %{_libdir}/libCEGUIExpatParser.la
211 %{_libdir}/libCEGUIFalagardWRBase.la
212 %{_libdir}/libCEGUIFreeImageImageCodec.la
213 %{_libdir}/libCEGUIIrrlichtRenderer.la
214 %{_libdir}/libCEGUILibxmlParser.la
215 %{_libdir}/libCEGUILuaScriptModule.la
216 %{_libdir}/libCEGUISILLYImageCodec.la
217 %{_libdir}/libCEGUITGAImageCodec.la
218 %{_libdir}/libCEGUITinyXMLParser.la
219 %{_libdir}/libCEGUIXercesParser.la
220 %{_libdir}/libCEGUItoluapp.la
221 %{_includedir}/%{name}
222 %{_pkgconfigdir}/CEGUI.pc
223 %{_pkgconfigdir}/CEGUI-OPENGL.pc
224 %{_pkgconfigdir}/CEGUI-OGRE.pc
225
226 %if %{with opengl}
227 %files OPENGL
228 %defattr(644,root,root,755)
229 %attr(755,root,root) %{_libdir}/libCEGUIOpenGLRenderer-%{version}.so
230 %endif
231
232 %if %{with ogre}
233 %files OGRE
234 %defattr(644,root,root,755)
235 %attr(755,root,root) %{_libdir}/libCEGUIOgreRenderer-%{version}.so
236 %endif
This page took 0.499743 seconds and 3 git commands to generate.