]> git.pld-linux.org Git - packages/CEGUI.git/blob - CEGUI.spec
- release 2
[packages/CEGUI.git] / CEGUI.spec
1 # TODO:
2 # - external tinyxml
3 # - external tolua++
4 #
5 # Conditional build:
6 %bcond_without  xercesc         # build XercesParser
7 %bcond_with     ogre            # build without Ogre renderer
8 %bcond_without  opengl          # build without OpenGL renderer
9 %bcond_with     samples         # build samples
10 #
11 Summary:        CEGUI - a free library providing windowing and widgets
12 Summary(pl.UTF-8):      CEGUI - wolnodostępna biblioteka zapewniającą okienka i widgety
13 Name:           CEGUI
14 Version:        0.7.4
15 Release:        2
16 License:        LGPL v2.1+ (with MIT parts)
17 Group:          Libraries
18 Source0:        http://downloads.sourceforge.net/crayzedsgui/%{name}-%{version}.tar.gz
19 # Source0-md5:  081782a1005b8d9691970879572897be
20 Source1:        http://downloads.sourceforge.net/crayzedsgui/%{name}-DOCS-%{version}.tar.gz
21 # Source1-md5:  15501e4ec89410d7d256dc83c142a920
22 URL:            http://www.cegui.org.uk/
23 BuildRequires:  DevIL-devel
24 BuildRequires:  DirectFB-devel
25 BuildRequires:  FreeImage-devel
26 %if %{with opengl}
27 BuildRequires:  OpenGL-GLU-devel
28 BuildRequires:  OpenGL-glut-devel
29 %endif
30 BuildRequires:  SILLY-devel >= 0.1.0
31 BuildRequires:  autoconf >= 2.59
32 BuildRequires:  automake
33 BuildRequires:  corona-devel >= 1.0.2
34 BuildRequires:  expat-devel
35 BuildRequires:  freetype-devel >= 2.0
36 BuildRequires:  glew-devel
37 BuildRequires:  irrlicht-devel >= 1.4
38 BuildRequires:  libstdc++-devel
39 BuildRequires:  libtool >= 2:1.5
40 BuildRequires:  libxml2-devel >= 1:2.6
41 BuildRequires:  lua51-devel >= 5.1
42 %if %{with ogre}
43 BuildRequires:  ogre-devel >= 1.0.0
44 BuildRequires:  ois-devel
45 %endif
46 BuildRequires:  pcre-devel >= 5.0
47 BuildRequires:  pkgconfig
48 # for irrlicht renderer
49 BuildRequires:  xorg-lib-libXxf86vm-devel
50 %if %{with xercesc}
51 BuildRequires:  xerces-c-devel
52 %endif
53 Requires:       irrlicht >= 1.4
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %description
57 CEGUI stands for Crazy Eddie's Gui System; a free library providing
58 windowing and widgets for graphics APIs / engines where such
59 functionality is not natively available, or severely lacking. The
60 library is object orientated, written in C++, and targeted at games
61 developers who should be spending their time creating great games, not
62 building GUI sub-systems!
63
64 %description -l pl.UTF-8
65 CEGUI oznacza Crazy Eddie's Gui System - wolnodostępną bibliotekę
66 zapewniającą okienka i widgety dla graficznych API i silników tam,
67 gdzie natywnie taka funkcjonalność nie jest dostępna lub ma znaczące
68 braki. Biblioteka jest zorientowana obiektowo, napisana w C++ i
69 skierowana dla programistów gier, którzy powinni spędzać czas na
70 pisaniu świetnych gier, a nie tworzeniu podsystemów GUI!
71
72 %package devel
73 Summary:        Development files for CEGUI
74 Summary(pl.UTF-8):      Pliki programistyczne dla CEGUI
75 Group:          Development/Libraries
76 Requires:       %{name} = %{version}-%{release}
77 %{?with_ogre:Requires:  %{name}-Ogre = %{version}-%{release}}
78 %{?with_opengl:Requires:        %{name}-OpenGL = %{version}-%{release}}
79 Requires:       freetype-devel >= 2.0
80 Requires:       libstdc++-devel
81 Requires:       pcre-devel >= 5.0
82
83 %description devel
84 CEGUI headers.
85
86 %description devel -l pl.UTF-8
87 Pliki nagłówkowe CEGUI.
88
89 %package docs
90 Summary:        Documentation files for CEGUI
91 Summary(pl.UTF-8):      Pliki dokumentacji CEGUI
92 Group:          Documentation
93 Requires:       %{name} = %{version}-%{release}
94
95 %description docs
96 CEGUI documentation.
97
98 %description docs -l pl.UTF-8
99 Dokumentacja CEGUI.
100
101 %package OpenGL
102 Summary:        OpenGLRenderer library for CEGUI
103 Summary(pl.UTF-8):      Biblioteka OpenGLRenderer dla CEGUI
104 Group:          Libraries
105 Requires:       %{name} = %{version}-%{release}
106
107 %description OpenGL
108 OpenGLRenderer library for CEGUI.
109
110 %description OpenGL -l pl.UTF-8
111 Biblioteka OpenGLRenderer dla CEGUI.
112
113 %package Ogre
114 Summary:        OgreRenderer library for CEGUI
115 Summary(pl.UTF-8):      Biblioteka OgreRenderer dla CEGUI
116 Group:          Libraries
117 Requires:       %{name} = %{version}-%{release}
118
119 %description Ogre
120 OgreRenderer library for CEGUI.
121
122 %description Ogre -l pl.UTF-8
123 Biblioteka OgreRenderer dla CEGUI
124
125 %prep
126 %setup -q -a 1
127
128 %build
129 %{__libtoolize}
130 %{__aclocal}
131 %{__autoconf}
132 %{__autoheader}
133 %{__automake}
134 %configure \
135         --with-default-image-codec=FreeImageImageCodec \
136         --with-default-xml-parser=LibxmlParser \
137         %{!?with_samples:--disable-samples} \
138         --%{?with_ogre:en}%{!?with_ogre:dis}able-ogre-renderer \
139         --%{?with_opengl:en}%{!?with_opengl:dis}able-opengl-renderer \
140         --%{?with_xercesc:en}%{!?with_xercesc:dis}able-xerces-c
141
142 %{__make}
143
144 %install
145 rm -rf $RPM_BUILD_ROOT
146
147 %{__make} install \
148         DESTDIR=$RPM_BUILD_ROOT
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %post   -p /sbin/ldconfig
154 %postun -p /sbin/ldconfig
155
156 %files
157 %defattr(644,root,root,755)
158 %doc doc/README
159 %attr(755,root,root) %{_libdir}/libCEGUIBase-%{version}.so
160 # plugins
161 %attr(755,root,root) %{_libdir}/libCEGUIDevILImageCodec-%{version}.so
162 %attr(755,root,root) %{_libdir}/libCEGUIDevILImageCodec.so
163 %attr(755,root,root) %{_libdir}/libCEGUIExpatParser-%{version}.so
164 %attr(755,root,root) %{_libdir}/libCEGUIExpatParser.so
165 %attr(755,root,root) %{_libdir}/libCEGUIFalagardWRBase-%{version}.so
166 %attr(755,root,root) %{_libdir}/libCEGUIFalagardWRBase.so
167 %attr(755,root,root) %{_libdir}/libCEGUIFreeImageImageCodec-%{version}.so
168 %attr(755,root,root) %{_libdir}/libCEGUIFreeImageImageCodec.so
169 %attr(755,root,root) %{_libdir}/libCEGUIIrrlichtRenderer-%{version}.so
170 %attr(755,root,root) %{_libdir}/libCEGUIIrrlichtRenderer.so
171 %attr(755,root,root) %{_libdir}/libCEGUILibxmlParser-%{version}.so
172 %attr(755,root,root) %{_libdir}/libCEGUILibxmlParser.so
173 %attr(755,root,root) %{_libdir}/libCEGUISILLYImageCodec-%{version}.so
174 %attr(755,root,root) %{_libdir}/libCEGUISILLYImageCodec.so
175 %attr(755,root,root) %{_libdir}/libCEGUISTBImageCodec-%{version}.so
176 %attr(755,root,root) %{_libdir}/libCEGUISTBImageCodec.so
177 %attr(755,root,root) %{_libdir}/libCEGUITGAImageCodec-%{version}.so
178 %attr(755,root,root) %{_libdir}/libCEGUITGAImageCodec.so
179 %attr(755,root,root) %{_libdir}/libCEGUITinyXMLParser-%{version}.so
180 %attr(755,root,root) %{_libdir}/libCEGUITinyXMLParser.so
181 %attr(755,root,root) %{_libdir}/libCEGUIXercesParser-%{version}.so
182 %attr(755,root,root) %{_libdir}/libCEGUIXercesParser.so
183
184 %files docs
185 %defattr(644,root,root,755)
186 %doc docs/CEGUI-DOCS-%{version}
187 %dir %{_datadir}/%{name}
188 %dir %{_datadir}/%{name}/xml_schemas
189 %{_datadir}/%{name}/xml_schemas/*.xsd
190
191 %files devel
192 %defattr(644,root,root,755)
193 %attr(755,root,root) %{_libdir}/libCEGUIBase.so
194 %{?with_ogre:%attr(755,root,root) %{_libdir}/libCEGUIOgreRenderer.so}
195 %{?with_opengl:%attr(755,root,root) %{_libdir}/libCEGUIOpenGLRenderer.so}
196 %{_libdir}/libCEGUIBase.la
197 %{?with_ogre:%{_libdir}/libCEGUIOgreRenderer.la}
198 %{?with_opengl:%{_libdir}/libCEGUIOpenGLRenderer.la}
199 # plugins - but as their headers are included...
200 %{_libdir}/libCEGUIDevILImageCodec.la
201 %{_libdir}/libCEGUIExpatParser.la
202 %{_libdir}/libCEGUIFalagardWRBase.la
203 %{_libdir}/libCEGUIFreeImageImageCodec.la
204 %{_libdir}/libCEGUIIrrlichtRenderer.la
205 %{_libdir}/libCEGUILibxmlParser.la
206 %{_libdir}/libCEGUISILLYImageCodec.la
207 %{_libdir}/libCEGUISTBImageCodec.la
208 %{_libdir}/libCEGUITGAImageCodec.la
209 %{_libdir}/libCEGUITinyXMLParser.la
210 %{_libdir}/libCEGUIXercesParser.la
211 %{_includedir}/%{name}
212 %{_pkgconfigdir}/CEGUI.pc
213 %{?with_opengl:%{_pkgconfigdir}/CEGUI-OPENGL.pc}
214 %{?with_ogre:%{_pkgconfigdir}/CEGUI-OGRE.pc}
215
216 %if %{with opengl}
217 %files OpenGL
218 %defattr(644,root,root,755)
219 %attr(755,root,root) %{_libdir}/libCEGUIOpenGLRenderer-%{version}.so
220 %endif
221
222 %if %{with ogre}
223 %files Ogre
224 %defattr(644,root,root,755)
225 %attr(755,root,root) %{_libdir}/libCEGUIOgreRenderer-%{version}.so
226 %endif
This page took 0.06697 seconds and 3 git commands to generate.