]> git.pld-linux.org Git - packages/CEGUI.git/blob - CEGUI.spec
- up to 0.6.2
[packages/CEGUI.git] / CEGUI.spec
1 # TODO:
2 # - external tinyxml
3 # - external tolua++
4 # - ogre-renderer (BR: CEGUI-OGRE >= 1.0.0 through pkgconfig)
5 # - maybe we should make subpackages? For example CEGUI-OPENGL (smc.spec)?
6 #
7 # Conditional build:
8 %bcond_without  xercesc         # build XercesParser
9 %bcond_with     ogre            # build samples with ogre3d
10 %bcond_with     samples         # build samples
11 #
12 Summary:        CEGUI - a free library providing windowing and widgets
13 Summary(pl.UTF-8):      CEGUI - wolnodostępna biblioteka zapewniającą okienka i widgety
14 Name:           CEGUI
15 Version:        0.6.2
16 Release:        1
17 License:        LGPL v2.1+ (with MIT parts)
18 Group:          Libraries
19 Source0:        http://dl.sourceforge.net/crayzedsgui/%{name}-%{version}b.tar.gz
20 # Source0-md5:  4fbd95e5a2ac1c7acf2a8f5df3ac6b93
21 Source1:        http://dl.sourceforge.net/crayzedsgui/%{name}-%{version}-DOCS.tar.gz
22 # Source1-md5:  5c6b54b9472ffaefc27ed4a9b8fefe25
23 Patch0:         %{name}-link.patch
24 URL:            http://www.cegui.org.uk/
25 BuildRequires:  DevIL-devel
26 BuildRequires:  FreeImage-devel
27 BuildRequires:  OpenGL-GLU-devel
28 BuildRequires:  OpenGL-glut-devel
29 BuildRequires:  SILLY-devel >= 0.1.0
30 BuildRequires:  autoconf >= 2.59
31 BuildRequires:  automake
32 BuildRequires:  corona-devel >= 1.0.2
33 BuildRequires:  expat-devel
34 BuildRequires:  freetype-devel >= 2.0
35 BuildRequires:  glew-devel
36 BuildRequires:  irrlicht-devel >= 1.4
37 BuildRequires:  libstdc++-devel
38 BuildRequires:  libtool >= 2:1.5
39 BuildRequires:  libxml2-devel >= 1:2.6
40 BuildRequires:  lua51-devel >= 5.1
41 %if %{with ogre}
42 BuildRequires:  ogre-devel >= 1.0.0
43 BuildRequires:  ois-devel
44 %endif
45 BuildRequires:  pcre-devel >= 5.0
46 BuildRequires:  pkgconfig
47 # for irrlicht renderer
48 BuildRequires:  xorg-lib-libXxf86vm-devel
49 %if %{with xercesc}
50 BuildRequires:  xerces-c-devel
51 %endif
52 Requires:       irrlicht >= 1.4
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 %description
56 CEGUI stands for Crazy Eddie's Gui System; a free library providing
57 windowing and widgets for graphics APIs / engines where such
58 functionality is not natively available, or severely lacking. The
59 library is object orientated, written in C++, and targeted at games
60 developers who should be spending their time creating great games, not
61 building GUI sub-systems!
62
63 %description -l pl.UTF-8
64 CEGUI oznacza Crazy Eddie's Gui System - wolnodostępną bibliotekę
65 zapewniającą okienka i widgety dla graficznych API i silników tam,
66 gdzie natywnie taka funkcjonalność nie jest dostępna lub ma znaczące
67 braki. Biblioteka jest zorientowana obiektowo, napisana w C++ i
68 skierowana dla programistów gier, którzy powinni spędzać czas na
69 pisaniu świetnych gier, a nie tworzeniu podsystemów GUI!
70
71 %package devel
72 Summary:        Development files for CEGUI
73 Summary(pl.UTF-8):      Pliki programistyczne dla CEGUI
74 Group:          Development/Libraries
75 Requires:       %{name} = %{version}-%{release}
76 Requires:       freetype-devel >= 2.0
77 Requires:       libstdc++-devel
78 Requires:       pcre-devel >= 5.0
79
80 %description devel
81 CEGUI headers.
82
83 %description devel -l pl.UTF-8
84 Pliki nagłówkowe CEGUI.
85
86 %package docs
87 Summary:        Documentation files for CEGUI
88 Summary(pl.UTF-8):      Pliki dokumentacji CEGUI
89 Group:          Documentation
90 Requires:       %{name} = %{version}-%{release}
91
92 %description docs
93 CEGUI documentation.
94
95 %description docs -l pl.UTF-8
96 Dokumentacja CEGUI.
97
98
99 %prep
100 %setup -q -b 1
101 %patch0 -p1
102
103 %build
104 %{__libtoolize}
105 %{__aclocal}
106 %{__autoconf}
107 %{__autoheader}
108 %{__automake}
109 %configure \
110         --with-default-image-codec=FreeImageImageCodec \
111         --with-default-xml-parser=LibxmlParser \
112         %{!?with_samples:--disable-samples} \
113         %{!?with_ogre:--without-ogre-renderer} \
114         --%{?with_xercesc:en}%{!?with_xercesc:dis}able-xerces-c
115
116 %{__make}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %post   -p /sbin/ldconfig
128 %postun -p /sbin/ldconfig
129
130 %files
131 %defattr(644,root,root,755)
132 %doc AUTHORS ChangeLog README
133 # libs
134 %attr(755,root,root) %{_libdir}/libCEGUIBase.so.*.*.*
135 %attr(755,root,root) %ghost %{_libdir}/libCEGUIBase.so.1
136 %attr(755,root,root) %{_libdir}/libCEGUIOpenGLRenderer.so.*.*.*
137 %attr(755,root,root) %ghost %{_libdir}/libCEGUIOpenGLRenderer.so.0
138 # plugins
139 %attr(755,root,root) %{_libdir}/libCEGUICoronaImageCodec.so.*.*.*
140 %attr(755,root,root) %ghost %{_libdir}/libCEGUICoronaImageCodec.so.0
141 %attr(755,root,root) %{_libdir}/libCEGUICoronaImageCodec.so
142 %attr(755,root,root) %{_libdir}/libCEGUIDevILImageCodec.so.*.*.*
143 %attr(755,root,root) %ghost %{_libdir}/libCEGUIDevILImageCodec.so.0
144 %attr(755,root,root) %{_libdir}/libCEGUIDevILImageCodec.so
145 %attr(755,root,root) %{_libdir}/libCEGUIExpatParser.so.*.*.*
146 %attr(755,root,root) %ghost %{_libdir}/libCEGUIExpatParser.so.0
147 %attr(755,root,root) %{_libdir}/libCEGUIExpatParser.so
148 %attr(755,root,root) %{_libdir}/libCEGUIFalagardWRBase.so.*.*.*
149 %attr(755,root,root) %ghost %{_libdir}/libCEGUIFalagardWRBase.so.1
150 %attr(755,root,root) %{_libdir}/libCEGUIFalagardWRBase.so
151 %attr(755,root,root) %{_libdir}/libCEGUIFreeImageImageCodec.so.*.*.*
152 %attr(755,root,root) %ghost %{_libdir}/libCEGUIFreeImageImageCodec.so.0
153 %attr(755,root,root) %{_libdir}/libCEGUIFreeImageImageCodec.so
154 %attr(755,root,root) %{_libdir}/libCEGUIIrrlichtRenderer.so.*.*.*
155 %attr(755,root,root) %ghost %{_libdir}/libCEGUIIrrlichtRenderer.so.0
156 %attr(755,root,root) %{_libdir}/libCEGUIIrrlichtRenderer.so
157 %attr(755,root,root) %{_libdir}/libCEGUILibxmlParser.so.*.*.*
158 %attr(755,root,root) %ghost %{_libdir}/libCEGUILibxmlParser.so.0
159 %attr(755,root,root) %{_libdir}/libCEGUILibxmlParser.so
160 %attr(755,root,root) %{_libdir}/libCEGUILuaScriptModule.so.*.*.*
161 %attr(755,root,root) %ghost %{_libdir}/libCEGUILuaScriptModule.so.1
162 %attr(755,root,root) %{_libdir}/libCEGUILuaScriptModule.so
163 %attr(755,root,root) %{_libdir}/libCEGUISILLYImageCodec.so.*.*.*
164 %attr(755,root,root) %ghost %{_libdir}/libCEGUISILLYImageCodec.so.0
165 %attr(755,root,root) %{_libdir}/libCEGUISILLYImageCodec.so
166 %attr(755,root,root) %{_libdir}/libCEGUITGAImageCodec.so.*.*.*
167 %attr(755,root,root) %ghost %{_libdir}/libCEGUITGAImageCodec.so.0
168 %attr(755,root,root) %{_libdir}/libCEGUITGAImageCodec.so
169 %attr(755,root,root) %{_libdir}/libCEGUITinyXMLParser.so.*.*.*
170 %attr(755,root,root) %ghost %{_libdir}/libCEGUITinyXMLParser.so.0
171 %attr(755,root,root) %{_libdir}/libCEGUITinyXMLParser.so
172 %attr(755,root,root) %{_libdir}/libCEGUIXercesParser.so.*.*.*
173 %attr(755,root,root) %ghost %{_libdir}/libCEGUIXercesParser.so.0
174 %attr(755,root,root) %{_libdir}/libCEGUIXercesParser.so
175 %attr(755,root,root) %{_libdir}/libCEGUItoluapp.so.*.*.*
176 %attr(755,root,root) %ghost %{_libdir}/libCEGUItoluapp.so.1
177 %attr(755,root,root) %{_libdir}/libCEGUItoluapp.so
178
179 %files docs
180 %defattr(644,root,root,755)
181 %doc documentation
182 %dir %{_datadir}/%{name}
183 %dir %{_datadir}/%{name}/XMLRefSchema
184 %{_datadir}/%{name}/XMLRefSchema/*.xsd
185 %{_datadir}/%{name}/XMLRefSchema/Readme.txt
186
187 %files devel
188 %defattr(644,root,root,755)
189 %attr(755,root,root) %{_libdir}/libCEGUIBase.so
190 %attr(755,root,root) %{_libdir}/libCEGUIOpenGLRenderer.so
191 %{_libdir}/libCEGUIBase.la
192 %{_libdir}/libCEGUIOpenGLRenderer.la
193 # plugins - but as their headers are included...
194 %{_libdir}/libCEGUICoronaImageCodec.la
195 %{_libdir}/libCEGUIDevILImageCodec.la
196 %{_libdir}/libCEGUIExpatParser.la
197 %{_libdir}/libCEGUIFalagardWRBase.la
198 %{_libdir}/libCEGUIFreeImageImageCodec.la
199 %{_libdir}/libCEGUIIrrlichtRenderer.la
200 %{_libdir}/libCEGUILibxmlParser.la
201 %{_libdir}/libCEGUILuaScriptModule.la
202 %{_libdir}/libCEGUISILLYImageCodec.la
203 %{_libdir}/libCEGUITGAImageCodec.la
204 %{_libdir}/libCEGUITinyXMLParser.la
205 %{_libdir}/libCEGUIXercesParser.la
206 %{_libdir}/libCEGUItoluapp.la
207 %{_includedir}/%{name}
208 %{_pkgconfigdir}/CEGUI.pc
209 %{_pkgconfigdir}/CEGUI-OPENGL.pc
This page took 0.081286 seconds and 3 git commands to generate.