]> git.pld-linux.org Git - packages/CEGUI.git/blob - CEGUI.spec
- start update to 0.7.2
[packages/CEGUI.git] / CEGUI.spec
1 # TODO:
2 # - external tinyxml
3 # - external tolua++
4 # - some plugins are missing
5 #
6 # Conditional build:
7 %bcond_without  xercesc         # build XercesParser
8 %bcond_with     ogre            # build without Ogre renderer
9 %bcond_without  opengl          # build without OpenGL renderer
10 %bcond_with     samples         # build samples
11 #
12 Summary:        CEGUI - a free library providing windowing and widgets
13 Summary(pl.UTF-8):      CEGUI - wolnodostępna biblioteka zapewniającą okienka i widgety
14 Name:           CEGUI
15 Version:        0.7.2
16 Release:        0.1
17 License:        LGPL v2.1+ (with MIT parts)
18 Group:          Libraries
19 Source0:        http://downloads.sourceforge.net/crayzedsgui/%{name}-%{version}.tar.gz
20 # Source0-md5:  f22ea030aeebc7d8c25070fdae413a18
21 Source1:        http://downloads.sourceforge.net/crayzedsgui/%{name}-DOCS-%{version}.tar.gz
22 # Source1-md5:  b7e4768040dda4105d0b9770c3bcda07
23 URL:            http://www.cegui.org.uk/
24 BuildRequires:  DevIL-devel
25 BuildRequires:  DirectFB-devel
26 BuildRequires:  FreeImage-devel
27 %if %{with opengl}
28 BuildRequires:  OpenGL-GLU-devel
29 BuildRequires:  OpenGL-glut-devel
30 %endif
31 BuildRequires:  SILLY-devel >= 0.1.0
32 BuildRequires:  autoconf >= 2.59
33 BuildRequires:  automake
34 BuildRequires:  corona-devel >= 1.0.2
35 BuildRequires:  expat-devel
36 BuildRequires:  freetype-devel >= 2.0
37 BuildRequires:  glew-devel
38 BuildRequires:  irrlicht-devel >= 1.4
39 BuildRequires:  libstdc++-devel
40 BuildRequires:  libtool >= 2:1.5
41 BuildRequires:  libxml2-devel >= 1:2.6
42 BuildRequires:  lua51-devel >= 5.1
43 %if %{with ogre}
44 BuildRequires:  ogre-devel >= 1.0.0
45 BuildRequires:  ois-devel
46 %endif
47 BuildRequires:  pcre-devel >= 5.0
48 BuildRequires:  pkgconfig
49 # for irrlicht renderer
50 BuildRequires:  xorg-lib-libXxf86vm-devel
51 %if %{with xercesc}
52 BuildRequires:  xerces-c-devel
53 %endif
54 Requires:       irrlicht >= 1.4
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %description
58 CEGUI stands for Crazy Eddie's Gui System; a free library providing
59 windowing and widgets for graphics APIs / engines where such
60 functionality is not natively available, or severely lacking. The
61 library is object orientated, written in C++, and targeted at games
62 developers who should be spending their time creating great games, not
63 building GUI sub-systems!
64
65 %description -l pl.UTF-8
66 CEGUI oznacza Crazy Eddie's Gui System - wolnodostępną bibliotekę
67 zapewniającą okienka i widgety dla graficznych API i silników tam,
68 gdzie natywnie taka funkcjonalność nie jest dostępna lub ma znaczące
69 braki. Biblioteka jest zorientowana obiektowo, napisana w C++ i
70 skierowana dla programistów gier, którzy powinni spędzać czas na
71 pisaniu świetnych gier, a nie tworzeniu podsystemów GUI!
72
73 %package devel
74 Summary:        Development files for CEGUI
75 Summary(pl.UTF-8):      Pliki programistyczne dla CEGUI
76 Group:          Development/Libraries
77 Requires:       %{name} = %{version}-%{release}
78 %{?with_ogre:Requires:  %{name}-Ogre = %{version}-%{release}}
79 %{?with_opengl:Requires:        %{name}-OpenGL = %{version}-%{release}}
80 Requires:       freetype-devel >= 2.0
81 Requires:       libstdc++-devel
82 Requires:       pcre-devel >= 5.0
83
84 %description devel
85 CEGUI headers.
86
87 %description devel -l pl.UTF-8
88 Pliki nagłówkowe CEGUI.
89
90 %package docs
91 Summary:        Documentation files for CEGUI
92 Summary(pl.UTF-8):      Pliki dokumentacji CEGUI
93 Group:          Documentation
94 Requires:       %{name} = %{version}-%{release}
95
96 %description docs
97 CEGUI documentation.
98
99 %description docs -l pl.UTF-8
100 Dokumentacja CEGUI.
101
102 %package OpenGL
103 Summary:        OpenGLRenderer library for CEGUI
104 Summary(pl.UTF-8):      Biblioteka OpenGLRenderer dla CEGUI
105 Group:          Libraries
106 Requires:       %{name} = %{version}-%{release}
107
108 %description OpenGL
109 OpenGLRenderer library for CEGUI.
110
111 %description OpenGL -l pl.UTF-8
112 Biblioteka OpenGLRenderer dla CEGUI.
113
114 %package Ogre
115 Summary:        OgreRenderer library for CEGUI
116 Summary(pl.UTF-8):      Biblioteka OgreRenderer dla CEGUI
117 Group:          Libraries
118 Requires:       %{name} = %{version}-%{release}
119
120 %description Ogre
121 OgreRenderer library for CEGUI.
122
123 %description Ogre -l pl.UTF-8
124 Biblioteka OgreRenderer dla CEGUI
125
126 %prep
127 %setup -q -a 1
128
129 %build
130 %{__libtoolize}
131 %{__aclocal}
132 %{__autoconf}
133 %{__autoheader}
134 %{__automake}
135 %configure \
136         --with-default-image-codec=FreeImageImageCodec \
137         --with-default-xml-parser=LibxmlParser \
138         %{!?with_samples:--disable-samples} \
139         --%{?with_ogre:en}%{!?with_ogre:dis}able-ogre-renderer \
140         --%{?with_opengl:en}%{!?with_opengl:dis}able-opengl-renderer \
141         --%{?with_xercesc:en}%{!?with_xercesc:dis}able-xerces-c
142
143 %{__make}
144
145 %install
146 rm -rf $RPM_BUILD_ROOT
147
148 %{__make} install \
149         DESTDIR=$RPM_BUILD_ROOT
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %post   -p /sbin/ldconfig
155 %postun -p /sbin/ldconfig
156
157 %files
158 %defattr(644,root,root,755)
159 %doc doc/README
160 %attr(755,root,root) %{_libdir}/libCEGUIBase-%{version}.so
161 # plugins
162 #%%attr(755,root,root) %{_libdir}/libCEGUICoronaImageCodec-%{version}.so
163 #%%attr(755,root,root) %{_libdir}/libCEGUICoronaImageCodec.so
164 %attr(755,root,root) %{_libdir}/libCEGUIDevILImageCodec-%{version}.so
165 %attr(755,root,root) %{_libdir}/libCEGUIDevILImageCodec.so
166 %attr(755,root,root) %{_libdir}/libCEGUIExpatParser-%{version}.so
167 %attr(755,root,root) %{_libdir}/libCEGUIExpatParser.so
168 %attr(755,root,root) %{_libdir}/libCEGUIFalagardWRBase-%{version}.so
169 %attr(755,root,root) %{_libdir}/libCEGUIFalagardWRBase.so
170 %attr(755,root,root) %{_libdir}/libCEGUIFreeImageImageCodec-%{version}.so
171 %attr(755,root,root) %{_libdir}/libCEGUIFreeImageImageCodec.so
172 %attr(755,root,root) %{_libdir}/libCEGUIIrrlichtRenderer-%{version}.so
173 %attr(755,root,root) %{_libdir}/libCEGUIIrrlichtRenderer.so
174 %attr(755,root,root) %{_libdir}/libCEGUILibxmlParser-%{version}.so
175 %attr(755,root,root) %{_libdir}/libCEGUILibxmlParser.so
176 #%%attr(755,root,root) %{_libdir}/libCEGUILuaScriptModule-%{version}.so
177 #%%attr(755,root,root) %{_libdir}/libCEGUILuaScriptModule.so
178 %attr(755,root,root) %{_libdir}/libCEGUISILLYImageCodec-%{version}.so
179 %attr(755,root,root) %{_libdir}/libCEGUISILLYImageCodec.so
180 %attr(755,root,root) %{_libdir}/libCEGUITGAImageCodec-%{version}.so
181 %attr(755,root,root) %{_libdir}/libCEGUITGAImageCodec.so
182 %attr(755,root,root) %{_libdir}/libCEGUITinyXMLParser-%{version}.so
183 %attr(755,root,root) %{_libdir}/libCEGUITinyXMLParser.so
184 %attr(755,root,root) %{_libdir}/libCEGUIXercesParser-%{version}.so
185 %attr(755,root,root) %{_libdir}/libCEGUIXercesParser.so
186 #%%attr(755,root,root) %{_libdir}/libCEGUItoluapp-%{version}.so
187 #%%attr(755,root,root) %{_libdir}/libCEGUItoluapp.so
188
189 %files docs
190 %defattr(644,root,root,755)
191 %doc docs/CEGUI-DOCS-%{version}
192 %dir %{_datadir}/%{name}
193 %dir %{_datadir}/%{name}/xml_schemas
194 %{_datadir}/%{name}/xml_schemas/*.xsd
195
196 %files devel
197 %defattr(644,root,root,755)
198 %attr(755,root,root) %{_libdir}/libCEGUIBase.so
199 %{?with_ogre:%attr(755,root,root) %{_libdir}/libCEGUIOgreRenderer.so}
200 %{?with_opengl:%attr(755,root,root) %{_libdir}/libCEGUIOpenGLRenderer.so}
201 %{_libdir}/libCEGUIBase.la
202 %{?with_ogre:%{_libdir}/libCEGUIOgreRenderer.la}
203 %{?with_opengl:%{_libdir}/libCEGUIOpenGLRenderer.la}
204 # plugins - but as their headers are included...
205 #%%{_libdir}/libCEGUICoronaImageCodec.la
206 %{_libdir}/libCEGUIDevILImageCodec.la
207 %{_libdir}/libCEGUIExpatParser.la
208 %{_libdir}/libCEGUIFalagardWRBase.la
209 %{_libdir}/libCEGUIFreeImageImageCodec.la
210 %{_libdir}/libCEGUIIrrlichtRenderer.la
211 %{_libdir}/libCEGUILibxmlParser.la
212 #%%{_libdir}/libCEGUILuaScriptModule.la
213 %{_libdir}/libCEGUISILLYImageCodec.la
214 %{_libdir}/libCEGUITGAImageCodec.la
215 %{_libdir}/libCEGUITinyXMLParser.la
216 %{_libdir}/libCEGUIXercesParser.la
217 #%%{_libdir}/libCEGUItoluapp.la
218 %{_includedir}/%{name}
219 %{_pkgconfigdir}/CEGUI.pc
220 %{?with_opengl:%{_pkgconfigdir}/CEGUI-OPENGL.pc}
221 %{?with_ogre:%{_pkgconfigdir}/CEGUI-OGRE.pc}
222
223 %if %{with opengl}
224 %files OpenGL
225 %defattr(644,root,root,755)
226 %attr(755,root,root) %{_libdir}/libCEGUIOpenGLRenderer-%{version}.so
227 %endif
228
229 %if %{with ogre}
230 %files Ogre
231 %defattr(644,root,root,755)
232 %attr(755,root,root) %{_libdir}/libCEGUIOgreRenderer-%{version}.so
233 %endif
This page took 0.460036 seconds and 3 git commands to generate.