]> git.pld-linux.org Git - packages/A3Com.git/blob - A3Com.spec
- pl description
[packages/A3Com.git] / A3Com.spec
1 %include        /usr/lib/rpm/macros.perl
2 Summary:        A3Com - manipulation of 3Com SuperStack II
3 Summary(pl):    A3Com - manipulacje 3Com SuperStack II
4 Name:           A3Com
5 Version:        0.2.3
6 Release:        1
7 License:        GPL v2
8 Group:          Networking/Utilities
9 Source0:        http://www.kernel.org/pub/software/admin/A3Com/%{name}-%{version}.tar.bz2
10 URL:            http://www.kernel.org/software/A3Com/
11 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
12
13 %description
14 A3Com is a set of Perl 5 modules which allow manipulation of 3Com
15 SuperStack II 3900/9300 and CoreBuilder 3500 LAN switches. Currently
16 there are modules which can use either the SNMP or telnet interface
17 to:
18
19     - -dump the ARP tables
20     - -dump bridge tables
21     - -search switches for a MAC address, IP address, or hostname
22     - -change admin passwords in batch mode
23     - -save and restore switch configurations via SNMP
24     - -upload new firmware via SNMP (batch mode)
25     - -and collect per-port ethernet details like current autonegotiation
26       mode and duplex settings
27     - -keep global caches of ARP and bridge tables for fast searches
28     - -keep global ARP history as a merged ARP database
29
30 %description -l pl
31 A3Com to zestaw modu³ów Perla pozwalaj±cych na konfigurowanie switchy
32 LAN firmy 3Com: SuperStack II 3900/9300 i CoreBuilder 3500. Aktualnie
33 modu³y te mog± u¿ywaæ interfejsu SNMP lub telnet do:
34 - wypisania tablic ARP
35 - wypisania tablic bridgingu
36 - wyszukiwania adresów MAC, IP lub nazw hostów
37 - zmiany hase³ administratora w trybie wsadowym
38 - zapisywania i odtwarzania konfiguracji switchy po SNMP
39 - przesy³ania nowego firmware'u po SNMP (w trybie wsadowym)
40 - zbierania dotycz±cych poszczególnych portów informacji takich jak
41   aktualny tryb autonegocjacji i duplex
42 - przechowywania globalnego cache tablic ARP i bridgingu w celu
43   szybkiego przeszukiwania
44 - przechowywania globalnej historii ARP jako po³±czonej bazy danych.
45
46 %prep
47 %setup -q
48
49 %build
50 # Change path for perl:
51 for i in tools/*; do
52         cat $i | sed -e "s/\/usr\/local\/bin/\%{_prefix}\/bin/" > tmp
53         mv tmp $i
54 done
55 # Change location of config:
56 for i in A3Com/*; do
57         cat $i | sed -e "s/\/usr\/local\/etc/\/etc/" > tmp
58         mv tmp $i
59 done
60
61 # Make modules:
62 perl Makefile.PL
63 %{__make}
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 install -d $RPM_BUILD_ROOT{%{_bindir},/var/lib/A3Com,%{_sysconfdir}}
68
69 %{__make} DESTDIR=$RPM_BUILD_ROOT install
70
71 install tools/*         $RPM_BUILD_ROOT%{_bindir}
72
73 cat << EOF >$RPM_BUILD_ROOT%{_sysconfdir}/a3com.conf
74 GLOBALCACHEDIR = /var/lib/A3Com
75 EOF
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %files
81 %defattr(644,root,root,755)
82 %doc CHANGELOG TODO README test.pl
83 %attr(777,root,root) %dir /var/lib/A3Com
84 %attr(644,root,root) %{_sysconfdir}/a3com.conf
85 %attr(755,root,root) %{_bindir}/*
86 %{perl_sitelib}/A3Com/*.pm
This page took 0.050341 seconds and 3 git commands to generate.