]> git.pld-linux.org Git - packages/A3Com.git/blob - A3Com.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/A3Com.git] / A3Com.spec
1 Summary:        A3Com - manipulation of 3Com SuperStack II
2 Summary(pl.UTF-8):      A3Com - manipulacje 3Com SuperStack II
3 Name:           A3Com
4 Version:        0.2.3
5 Release:        2
6 License:        GPL v2
7 Group:          Networking/Utilities
8 Source0:        http://www.kernel.org/pub/software/admin/A3Com/%{name}-%{version}.tar.bz2
9 # Source0-md5:  16133ebf73fe3883b0d46ed88f03377a
10 URL:            http://www.kernel.org/software/A3Com/
11 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
12
13 %description
14 A3Com is a set of Perl 5 modules which allow manipulation of 3Com
15 SuperStack II 3900/9300 and CoreBuilder 3500 LAN switches. Currently
16 there are modules which can use either the SNMP or telnet interface
17 to:
18
19 - dump the ARP tables
20 - dump bridge tables
21 - search switches for a MAC address, IP address, or hostname
22 - change admin passwords in batch mode
23 - save and restore switch configurations via SNMP
24 - upload new firmware via SNMP (batch mode)
25 - and collect per-port ethernet details like current autonegotiation
26   mode and duplex settings
27 - keep global caches of ARP and bridge tables for fast searches
28 - keep global ARP history as a merged ARP database
29
30 %description -l pl.UTF-8
31 A3Com to zestaw modułów Perla pozwalających na konfigurowanie switchy
32 LAN firmy 3Com: SuperStack II 3900/9300 i CoreBuilder 3500. Aktualnie
33 moduły te mogą używać interfejsu SNMP lub telnet do:
34 - wypisania tablic ARP
35 - wypisania tablic bridgingu
36 - wyszukiwania adresów MAC, IP lub nazw hostów
37 - zmiany haseł administratora w trybie wsadowym
38 - zapisywania i odtwarzania konfiguracji switchy po SNMP
39 - przesyłania nowego firmware'u po SNMP (w trybie wsadowym)
40 - zbierania dotyczących poszczególnych portów informacji takich jak
41   aktualny tryb autonegocjacji i duplex
42 - przechowywania globalnego cache tablic ARP i bridgingu w celu
43   szybkiego przeszukiwania
44 - przechowywania globalnej historii ARP jako połączonej bazy danych.
45
46 %prep
47 %setup -q
48
49 %build
50 # Change path for perl:
51 for i in tools/*; do
52         cat $i | sed -e "s/\/usr\/local\/bin/\%{_prefix}\/bin/" > tmp
53         mv tmp $i
54 done
55 # Change location of config:
56 for i in A3Com/*; do
57         cat $i | sed -e "s/\/usr\/local\/etc/\/etc/" > tmp
58         mv tmp $i
59 done
60
61 # Make modules:
62 %{__perl} Makefile.PL \
63         INSTALLDIRS=vendor
64 %{__make}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 install -d $RPM_BUILD_ROOT{%{_bindir},/var/lib/A3Com,%{_sysconfdir}}
69
70 %{__make} install \
71         DESTDIR=$RPM_BUILD_ROOT
72
73 install tools/*         $RPM_BUILD_ROOT%{_bindir}
74
75 cat << EOF >$RPM_BUILD_ROOT%{_sysconfdir}/a3com.conf
76 GLOBALCACHEDIR = /var/lib/A3Com
77 EOF
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %files
83 %defattr(644,root,root,755)
84 %doc CHANGELOG TODO README test.pl
85 %attr(777,root,root) %dir /var/lib/A3Com
86 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/a3com.conf
87 %attr(755,root,root) %{_bindir}/*
88 %dir %{perl_vendorlib}/A3Com
89 %{perl_vendorlib}/A3Com/*.pm
This page took 0.102412 seconds and 4 git commands to generate.