]> git.pld-linux.org Git - packages/cronie.git/blobdiff - cronie.spec
- rel 16; don't leak fds
[packages/cronie.git] / cronie.spec
index 4d3cecf1e8a5bdbd6da6b41f1d607bd92413afbb..55d53119f4b2561d68168552854947ce3c2e32a4 100644 (file)
@@ -17,7 +17,7 @@
 Summary:       Cron daemon for executing programs at set times
 Name:          cronie
 Version:       1.4.8
-Release:       5
+Release:       16
 License:       MIT and BSD and GPL v2
 Group:         Daemons
 Source0:       https://fedorahosted.org/releases/c/r/cronie/%{name}-%{version}.tar.gz
@@ -32,6 +32,7 @@ Source7:      crond.service
 Patch0:                inotify-nosys.patch
 Patch1:                %{name}-nosyscrontab.patch
 Patch2:                sendmail-path.patch
+Patch3:                cronie-1.4.8-inotify-fix.patch
 URL:           https://fedorahosted.org/cronie/
 %{?with_audit:BuildRequires:   audit-libs-devel}
 BuildRequires: autoconf
@@ -39,7 +40,7 @@ BuildRequires:        automake
 %{?with_selinux:BuildRequires: libselinux-devel}
 BuildRequires: pam-devel
 BuildRequires: rpm >= 4.4.9-56
-BuildRequires: rpmbuild(macros) >= 1.623
+BuildRequires: rpmbuild(macros) >= 1.626
 Requires(post):        fileutils
 Requires(post,preun):  /sbin/chkconfig
 Requires(postun):      /usr/sbin/groupdel
@@ -48,6 +49,7 @@ Requires(pre):        /usr/sbin/groupadd
 Requires:      /bin/run-parts
 Requires:      psmisc >= 20.1
 Requires:      rc-scripts >= 0.4.3.0
+Requires:      systemd-units >= 37-0.10
 %{?with_inotify:Requires:      uname(release) >= 2.6.13}
 Provides:      crondaemon
 Provides:      crontabs = 1.7
@@ -56,6 +58,7 @@ Provides:     group(crontab)
 Provides:      vixie-cron = 4.3-1
 %endif
 Obsoletes:     crondaemon
+Obsoletes:     cronie-systemd
 Obsoletes:     crontabs
 %if "%{pld_release}" == "th"
 Obsoletes:     vixie-cron < 4.3-1
@@ -92,20 +95,12 @@ Upstart job description for Cronie.
 %description upstart -l pl.UTF-8
 Opis zadania Upstart dla Cronie.
 
-%package systemd
-Summary:       systemd units for cronie
-Group:         Base
-Requires:      %{name} = %{version}-%{release}
-Requires:      systemd-units
-
-%description systemd
-systemd units for cronie.
-
 %prep
 %setup -q
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 %build
 %{__aclocal}
@@ -128,7 +123,7 @@ systemd units for cronie.
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{/var/{log,spool/{ana,}cron},%{_mandir},/lib/systemd/system}\
+install -d $RPM_BUILD_ROOT{/var/{log,spool/{ana,}cron},%{_mandir},%{systemdunitdir}}\
        $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig,init} \
        $RPM_BUILD_ROOT%{_sysconfdir}/{cron,cron.{d,hourly,daily,weekly,monthly},pam.d}
 
@@ -143,8 +138,7 @@ cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/cron
 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/crontab
 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/crond
 cp -a %{SOURCE6} $RPM_BUILD_ROOT/etc/init/crond.conf
-cp -a %{SOURCE7} $RPM_BUILD_ROOT%{systemdunitdir}/cronie.service
-ln -s cronie.service $RPM_BUILD_ROOT%{systemdunitdir}/crond.service
+cp -a %{SOURCE7} $RPM_BUILD_ROOT%{systemdunitdir}/crond.service
 
 touch $RPM_BUILD_ROOT/var/log/cron
 
@@ -171,17 +165,35 @@ if [ ! -f /var/log/cron ]; then
 fi
 /sbin/chkconfig --add crond
 %service crond restart "Cron Daemon"
+%systemd_post crond.service
 
 %preun
 if [ "$1" = "0" ]; then
        %service crond stop
        /sbin/chkconfig --del crond
 fi
+%systemd_preun crond.service
 
 %postun
 if [ "$1" = "0" ]; then
        %groupremove crontab
 fi
+%systemd_reload
+
+%triggerpostun -- cronie < 1.4.8-13
+if [ -f /etc/sysconfig/cron ]; then
+       . /etc/sysconfig/cron
+       __CROND_ARGS=
+       [ "$CROND_SYSLOG_RESULT" = "yes" ] && __CROND_ARGS="-s"
+       [ -n "$CROND_MAIL_PROG" ] && __CROND_ARGS="$__CROND_ARGS -m $CROND_MAIL_PROG"
+       if [ -n "$__CROND_ARGS" ]; then
+               %{__cp} -f /etc/sysconfig/cron{,.rpmsave}
+               echo >>/etc/sysconfig/cron
+               echo "# Added by rpm trigger" >>/etc/sysconfig/cron
+               echo "CROND_ARGS=\"$CROND_ARGS $__CROND_ARGS\"" >>/etc/sysconfig/cron
+       fi
+fi
+%systemd_trigger crond.service
 
 %triggerun -- hc-cron,fcron,vixie-cron
 # Prevent preun from crond from working
@@ -200,16 +212,6 @@ chmod 754 /etc/rc.d/init.d/crond
 %postun upstart
 %upstart_postun crond
 
-%post systemd
-%systemd_post
-%systemd_enable cronie.service
-
-%preun systemd
-%systemd_preun cornie.service
-
-%postun systemd
-%systemd_postun cornie.service
-
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog README
@@ -221,6 +223,7 @@ chmod 754 /etc/rc.d/init.d/crond
 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/crond
 %attr(754,root,root) /etc/rc.d/init.d/crond
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/cron
+%{systemdunitdir}/crond.service
 %attr(755,root,root) %{_sbindir}/crond
 %attr(2755,root,crontab) %{_bindir}/crontab
 
@@ -246,8 +249,3 @@ chmod 754 /etc/rc.d/init.d/crond
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) /etc/init/crond.conf
 %endif
-
-%files systemd
-%defattr(644,root,root,755)
-%{systemdunitdir}/crond.service
-%{systemdunitdir}/cronie.service
This page took 0.284591 seconds and 4 git commands to generate.