]> git.pld-linux.org Git - packages/cronie.git/commitdiff
- rel 16; don't leak fds auto/th/cronie-1_4_8-16
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Fri, 2 Mar 2012 12:35:26 +0000 (12:35 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    cronie-1.4.8-inotify-fix.patch -> 1.1
    cronie.spec -> 1.59

cronie-1.4.8-inotify-fix.patch [new file with mode: 0644]
cronie.spec

diff --git a/cronie-1.4.8-inotify-fix.patch b/cronie-1.4.8-inotify-fix.patch
new file mode 100644 (file)
index 0000000..edfe274
--- /dev/null
@@ -0,0 +1,94 @@
+diff --git a/src/cron.c b/src/cron.c
+index 7dc2958..7917589 100644
+--- a/src/cron.c
++++ b/src/cron.c
+@@ -64,11 +64,19 @@ static int DisableInotify;
+ int wd[NUM_WATCHES];
+ const char *watchpaths[NUM_WATCHES] = {SPOOL_DIR, SYS_CROND_DIR, SYSCRONTAB};
++static void reset_watches(void) {
++      int i;
++
++      for (i = 0; i < sizeof (wd) / sizeof (wd[0]); ++i) {
++              wd[i] = -2;
++      }
++}
++
+ void set_cron_unwatched(int fd) {
+       int i;
+       for (i = 0; i < sizeof (wd) / sizeof (wd[0]); ++i) {
+-              if (wd[i] < 0) {
++              if (wd[i] > 0) {
+                       inotify_rm_watch(fd, wd[i]);
+                       wd[i] = -1;
+               }
+@@ -87,22 +95,21 @@ void set_cron_watched(int fd) {
+       for (i = 0; i < sizeof (wd) / sizeof (wd[0]); ++i) {
+               int w;
+-              if (open(watchpaths[i], O_RDONLY | O_NONBLOCK, 0) != -1) {
+-                      w = inotify_add_watch(fd, watchpaths[i],
+-                              IN_CREATE | IN_CLOSE_WRITE | IN_ATTRIB | IN_MODIFY | IN_MOVED_TO |
+-                              IN_MOVED_FROM | IN_MOVE_SELF | IN_DELETE | IN_DELETE_SELF);
+-                      if (w < 0) {
+-                              if (wd[i] != -1) {
+-                                      log_it("CRON", pid, "This directory or file can't be watched",
+-                                              watchpaths[i], errno);
+-                                      log_it("CRON", pid, "INFO", "running without inotify support", 0);
+-                              }
+-                              inotify_enabled = 0;
+-                              set_cron_unwatched(fd);
+-                              return;
++              w = inotify_add_watch(fd, watchpaths[i],
++                      IN_CREATE | IN_CLOSE_WRITE | IN_ATTRIB | IN_MODIFY | IN_MOVED_TO |
++                      IN_MOVED_FROM | IN_MOVE_SELF | IN_DELETE | IN_DELETE_SELF);
++              if (w < 0 && errno != ENOENT) {
++                      if (wd[i] != -1) {
++                              log_it("CRON", pid, "This directory or file can't be watched",
++                                      watchpaths[i], errno);
++                              log_it("CRON", pid, "INFO", "running without inotify support",
++                                      0);
+                       }
+-                      wd[i] = w;
++                      inotify_enabled = 0;
++                      set_cron_unwatched(fd);
++                      return;
+               }
++              wd[i] = w;
+       }
+       if (!inotify_enabled) {
+@@ -120,6 +127,7 @@ static void handle_signals(cron_db * database) {
+               /* watches must be reinstated on reload */
+               if (inotify_enabled && (EnableClustering != 1)) {
+                       set_cron_unwatched(database->ifd);
++                      reset_watches();
+                       inotify_enabled = 0;
+               }
+ #endif
+@@ -158,9 +166,6 @@ int main(int argc, char *argv[]) {
+       char *cs;
+       pid_t pid = getpid();
+       long oldGMToff;
+-#if defined WITH_INOTIFY
+-      int i;
+-#endif
+       ProgramName = argv[0];
+       MailCmd[0] = '\0';
+@@ -261,13 +266,7 @@ int main(int argc, char *argv[]) {
+                       "", 0);
+       }
+       else {
+-              for (i = 0; i < sizeof (wd) / sizeof (wd[0]); ++i) {
+-                      /* initialize to negative number other than -1
+-                       * so an eventual error is reported for the first time
+-                       */
+-                      wd[i] = -2;
+-              }
+-
++              reset_watches();
+               database.ifd = fd = inotify_init();
+               fcntl(fd, F_SETFD, FD_CLOEXEC);
+               if (fd < 0)
index 7b07b4815d51cde593e5d54e9d77fb6052ef4f6e..55d53119f4b2561d68168552854947ce3c2e32a4 100644 (file)
@@ -17,7 +17,7 @@
 Summary:       Cron daemon for executing programs at set times
 Name:          cronie
 Version:       1.4.8
-Release:       15
+Release:       16
 License:       MIT and BSD and GPL v2
 Group:         Daemons
 Source0:       https://fedorahosted.org/releases/c/r/cronie/%{name}-%{version}.tar.gz
@@ -32,6 +32,7 @@ Source7:      crond.service
 Patch0:                inotify-nosys.patch
 Patch1:                %{name}-nosyscrontab.patch
 Patch2:                sendmail-path.patch
+Patch3:                cronie-1.4.8-inotify-fix.patch
 URL:           https://fedorahosted.org/cronie/
 %{?with_audit:BuildRequires:   audit-libs-devel}
 BuildRequires: autoconf
@@ -99,6 +100,7 @@ Opis zadania Upstart dla Cronie.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 %build
 %{__aclocal}
This page took 0.064864 seconds and 4 git commands to generate.