]> git.pld-linux.org Git - packages/cmake.git/blobdiff - cmake.spec
globally disable completness check
[packages/cmake.git] / cmake.spec
index a4e160dfe356113df651d0e39a6a9dfc61f9af6c..cb92b16a616708e532e06518fd14188a830527fb 100644 (file)
@@ -1,59 +1,62 @@
 # TODO:
-# - system kwiml?
+# - system kwiml >= 1.0?
 # - make lib64/libx32 patch changes applicable everywhere
 # - any valid CMAKE_BUILD_TYPE causes overriding of our optflags
 #   (and default non-verbose makefiles are hiding it!)
 # - rpmldflags/rpmcppflags are not passed through %%cmake macro at all
 #   (is there any standard way???)
+# - FindJNI.cmake module is a PoS full of random incorrect paths,
+#   needs lib64/libx32 awareness
 #
 # Conditional build:
 %bcond_with    bootstrap       # use internal versions of some libraries
 %bcond_without gui             # don't build gui package
-%bcond_with    xmlrpc          # XMLRPC submission method in CTest
 %bcond_with    tests           # perform "make test"
 %bcond_without doc             # don't build documentation
 
-%if %{with bootstrap}
-%undefine      with_xmlrpc
-%endif
 Summary:       Cross-platform, open-source make system
 Summary(pl.UTF-8):     Wieloplatformowy system make o otwartych źródłach
 Name:          cmake
-Version:       3.10.0
-Release:       1
+Version:       3.24.1
+Release:       2
 License:       BSD
 Group:         Development/Building
-Source0:       https://cmake.org/files/v3.10/%{name}-%{version}.tar.gz
-# Source0-md5: f3f8e70ca3055f3cd288f89ff233057e
+Source0:       https://cmake.org/files/v3.24/%{name}-%{version}.tar.gz
+# Source0-md5: 3360abcd5576dc028204cd4583e6d4e9
 Patch0:                %{name}-lib64.patch
 Patch1:                %{name}-libx32.patch
-Patch2:                %{name}-helpers.patch
+Patch2:                %{name}-jni.patch
 Patch3:                %{name}-findruby.patch
 Patch4:                %{name}-findruby2.patch
-Patch5:                man-syntax.patch
-
-Patch7:                %{name}-xmlrpc.patch
+Patch5:                disable-completness-check.patch
 URL:           https://cmake.org/
+# system zlib,bzip2,xz,zstd used only when without system libarchive
 %if %{with gui}
 BuildRequires: Qt5Core-devel >= 5.0
 BuildRequires: Qt5Gui-devel >= 5.0
 BuildRequires: Qt5Widgets-devel >= 5.0
 %endif
-%{!?with_xmlrpc:BuildRequires: curl-devel}
+BuildRequires: curl-devel
 BuildRequires: expat-devel
 BuildRequires: jsoncpp-devel >= 1.6.2-2
-BuildRequires: libarchive-devel
-BuildRequires: libstdc++-devel
-BuildRequires: libuv-devel
+BuildRequires: libarchive-devel >= 3.3.3
+BuildRequires: libstdc++-devel >= 6:4.7
+BuildRequires: libuv-devel >= 1.28.0
 BuildRequires: ncurses-devel > 5.9-3
+BuildRequires: ncurses-ext-devel > 5.9-3
+BuildRequires: nghttp2-devel
 %{?with_gui:BuildRequires:     qt5-build >= 5.0}
 %{?with_gui:BuildRequires:     qt5-qmake >= 5.0}
 BuildRequires: rhash-devel
+BuildRequires: rpm-build >= 4.6
 BuildRequires: rpmbuild(macros) >= 1.167
 %{?with_doc:BuildRequires:     sphinx-pdg}
-%{?with_xmlrpc:BuildRequires:  xmlrpc-c-devel >= 1.4.12-2}
-%{!?with_xmlrpc:BuildRequires: zlib-devel}
+BuildRequires: xz-devel
+BuildRequires: zlib-devel
+BuildRequires: zstd-devel
 Requires:      filesystem >= 3.0-52
+Requires:      libarchive >= 3.3.3
+Requires:      libuv >= 1.28.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -114,10 +117,8 @@ Summary:   bash-completion for cmake
 Summary(pl.UTF-8):     Bashowe dopełnianie parametrów dla cmake'a
 Group:         Applications/Shells
 Requires:      %{name} = %{version}-%{release}
-Requires:      bash-completion >= 2.0
-%if "%{_rpmversion}" >= "5"
+Requires:      bash-completion >= 1:2.0
 BuildArch:     noarch
-%endif
 
 %description -n bash-completion-%{name}
 bash-completion for cmake.
@@ -138,7 +139,8 @@ Bashowe dopełnianie parametrów dla cmake'a.
 %patch4 -p1
 %patch5 -p1
 
-%patch7 -p1
+%{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+bash(\s|$),#!/bin/bash\1,' \
+      Modules/Compiler/XL-Fortran/cpp
 
 cat > "init.cmake" <<EOF
 SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
@@ -165,19 +167,23 @@ export LDFLAGS="%{rpmldflags}"
        --qt-qmake=%{_bindir}/qmake-qt5 \
        %{?with_doc:--sphinx-html} \
        %{?with_doc:--sphinx-man} \
-       --verbose \
-       -- \
-       %{?with_xmlrpc:-DCTEST_USE_XMLRPC=ON}
+       %{?__jobs:--parallel=%{__jobs}} \
+       --verbose
 
-%{__make} VERBOSE=1
+%{__make} \
+       VERBOSE=1
 
 %{?with_tests:%{__make} test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
+
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+# just a bit more recent than packaged in vim.spec
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/vim
+# packaged as %doc
 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc
 
 %clean
@@ -195,17 +201,20 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/cmake.1*
 %{_mandir}/man1/cpack.1*
 %{_mandir}/man1/ctest.1*
+%{_mandir}/man7/cpack-generators.7*
 %{_mandir}/man7/cmake-buildsystem.7*
 %{_mandir}/man7/cmake-commands.7*
 %{_mandir}/man7/cmake-compile-features.7*
 %{_mandir}/man7/cmake-developer.7*
 %{_mandir}/man7/cmake-env-variables.7*
+%{_mandir}/man7/cmake-file-api.7*
 %{_mandir}/man7/cmake-generator-expressions.7*
 %{_mandir}/man7/cmake-generators.7*
 %{_mandir}/man7/cmake-language.7*
 %{_mandir}/man7/cmake-modules.7*
 %{_mandir}/man7/cmake-packages.7*
 %{_mandir}/man7/cmake-policies.7*
+%{_mandir}/man7/cmake-presets.7*
 %{_mandir}/man7/cmake-properties.7*
 %{_mandir}/man7/cmake-qt.7*
 %{_mandir}/man7/cmake-server.7*
@@ -217,7 +226,6 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/cmake/Modules/.NoDartCoverage
 %{_datadir}/cmake/Modules/*
 %{_datadir}/cmake/Templates
-%{_datadir}/cmake/editors
 %{_datadir}/cmake/include
 %{_aclocaldir}/cmake.m4
 
@@ -235,8 +243,10 @@ rm -rf $RPM_BUILD_ROOT
 %{_desktopdir}/cmake-gui.desktop
 %{_iconsdir}/hicolor/128x128/apps/CMakeSetup.png
 %{_iconsdir}/hicolor/32x32/apps/CMakeSetup.png
+%if %{with doc}
 %{_mandir}/man1/cmake-gui.1*
 %endif
+%endif
 
 %files emacs
 %defattr(644,root,root,755)
This page took 0.03404 seconds and 4 git commands to generate.