]> git.pld-linux.org Git - packages/cmake.git/commitdiff
globally disable completness check
authorJan Palus <atler@pld-linux.org>
Tue, 27 Sep 2022 20:16:28 +0000 (22:16 +0200)
committerJan Palus <atler@pld-linux.org>
Tue, 27 Sep 2022 20:16:28 +0000 (22:16 +0200)
causes more issues for distributions with split packaging than it solves
and even cmake's own comment is not sure whether it's good idea:

https://gitlab.kitware.com/cmake/cmake/-/blob/164a156c7c26aaf4f30e73ae0cdb6d2e8a10e0a4/Source/cmExportFileGenerator.cxx#L1185-1192

cmake.spec
disable-completness-check.patch [new file with mode: 0644]

index c23154ee13bceeebb3eca9932b60c8801ffd1b81..cb92b16a616708e532e06518fd14188a830527fb 100644 (file)
@@ -28,6 +28,7 @@ Patch1:               %{name}-libx32.patch
 Patch2:                %{name}-jni.patch
 Patch3:                %{name}-findruby.patch
 Patch4:                %{name}-findruby2.patch
+Patch5:                disable-completness-check.patch
 URL:           https://cmake.org/
 # system zlib,bzip2,xz,zstd used only when without system libarchive
 %if %{with gui}
@@ -136,6 +137,7 @@ Bashowe dopełnianie parametrów dla cmake'a.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
 
 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+bash(\s|$),#!/bin/bash\1,' \
       Modules/Compiler/XL-Fortran/cpp
diff --git a/disable-completness-check.patch b/disable-completness-check.patch
new file mode 100644 (file)
index 0000000..c3ec11e
--- /dev/null
@@ -0,0 +1,11 @@
+--- cmake-3.24.1/Source/cmExportInstallFileGenerator.cxx.orig  2022-08-17 18:54:57.000000000 +0200
++++ cmake-3.24.1/Source/cmExportInstallFileGenerator.cxx       2022-09-27 11:07:37.195039337 +0200
+@@ -163,7 +163,7 @@ bool cmExportInstallFileGenerator::Gener
+   this->LoadConfigFiles(os);
+   this->CleanupTemporaryVariables(os);
+-  this->GenerateImportedFileCheckLoop(os);
++  //this->GenerateImportedFileCheckLoop(os);
+   bool result = true;
+   // Generate an import file for each configuration.
This page took 0.250816 seconds and 4 git commands to generate.