]> git.pld-linux.org Git - packages/cmake.git/blobdiff - cmake.spec
globally disable completness check
[packages/cmake.git] / cmake.spec
index 2f563fdd9b248614371c3933edb4b2859bd267f2..cb92b16a616708e532e06518fd14188a830527fb 100644 (file)
@@ -1,10 +1,12 @@
 # TODO:
-# - system kwiml?
+# - system kwiml >= 1.0?
 # - make lib64/libx32 patch changes applicable everywhere
 # - any valid CMAKE_BUILD_TYPE causes overriding of our optflags
 #   (and default non-verbose makefiles are hiding it!)
 # - rpmldflags/rpmcppflags are not passed through %%cmake macro at all
 #   (is there any standard way???)
+# - FindJNI.cmake module is a PoS full of random incorrect paths,
+#   needs lib64/libx32 awareness
 #
 # Conditional build:
 %bcond_with    bootstrap       # use internal versions of some libraries
 Summary:       Cross-platform, open-source make system
 Summary(pl.UTF-8):     Wieloplatformowy system make o otwartych źródłach
 Name:          cmake
-Version:       3.14.1
-Release:       1
+Version:       3.24.1
+Release:       2
 License:       BSD
 Group:         Development/Building
-Source0:       https://cmake.org/files/v3.14/%{name}-%{version}.tar.gz
-# Source0-md5: 7efe5394e85c3292ad020b8b70e55669
+Source0:       https://cmake.org/files/v3.24/%{name}-%{version}.tar.gz
+# Source0-md5: 3360abcd5576dc028204cd4583e6d4e9
 Patch0:                %{name}-lib64.patch
 Patch1:                %{name}-libx32.patch
-Patch2:                %{name}-helpers.patch
+Patch2:                %{name}-jni.patch
 Patch3:                %{name}-findruby.patch
 Patch4:                %{name}-findruby2.patch
+Patch5:                disable-completness-check.patch
 URL:           https://cmake.org/
+# system zlib,bzip2,xz,zstd used only when without system libarchive
 %if %{with gui}
 BuildRequires: Qt5Core-devel >= 5.0
 BuildRequires: Qt5Gui-devel >= 5.0
@@ -35,17 +39,24 @@ BuildRequires:      Qt5Widgets-devel >= 5.0
 BuildRequires: curl-devel
 BuildRequires: expat-devel
 BuildRequires: jsoncpp-devel >= 1.6.2-2
-BuildRequires: libarchive-devel
-BuildRequires: libstdc++-devel
-BuildRequires: libuv-devel
+BuildRequires: libarchive-devel >= 3.3.3
+BuildRequires: libstdc++-devel >= 6:4.7
+BuildRequires: libuv-devel >= 1.28.0
 BuildRequires: ncurses-devel > 5.9-3
+BuildRequires: ncurses-ext-devel > 5.9-3
+BuildRequires: nghttp2-devel
 %{?with_gui:BuildRequires:     qt5-build >= 5.0}
 %{?with_gui:BuildRequires:     qt5-qmake >= 5.0}
 BuildRequires: rhash-devel
+BuildRequires: rpm-build >= 4.6
 BuildRequires: rpmbuild(macros) >= 1.167
 %{?with_doc:BuildRequires:     sphinx-pdg}
+BuildRequires: xz-devel
 BuildRequires: zlib-devel
+BuildRequires: zstd-devel
 Requires:      filesystem >= 3.0-52
+Requires:      libarchive >= 3.3.3
+Requires:      libuv >= 1.28.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -106,10 +117,8 @@ Summary:   bash-completion for cmake
 Summary(pl.UTF-8):     Bashowe dopełnianie parametrów dla cmake'a
 Group:         Applications/Shells
 Requires:      %{name} = %{version}-%{release}
-Requires:      bash-completion >= 2.0
-%if "%{_rpmversion}" >= "5"
+Requires:      bash-completion >= 1:2.0
 BuildArch:     noarch
-%endif
 
 %description -n bash-completion-%{name}
 bash-completion for cmake.
@@ -128,6 +137,10 @@ Bashowe dopełnianie parametrów dla cmake'a.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
+
+%{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+bash(\s|$),#!/bin/bash\1,' \
+      Modules/Compiler/XL-Fortran/cpp
 
 cat > "init.cmake" <<EOF
 SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
@@ -154,6 +167,7 @@ export LDFLAGS="%{rpmldflags}"
        --qt-qmake=%{_bindir}/qmake-qt5 \
        %{?with_doc:--sphinx-html} \
        %{?with_doc:--sphinx-man} \
+       %{?__jobs:--parallel=%{__jobs}} \
        --verbose
 
 %{__make} \
@@ -163,9 +177,13 @@ export LDFLAGS="%{rpmldflags}"
 
 %install
 rm -rf $RPM_BUILD_ROOT
+
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+# just a bit more recent than packaged in vim.spec
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/vim
+# packaged as %doc
 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc
 
 %clean
@@ -196,6 +214,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man7/cmake-modules.7*
 %{_mandir}/man7/cmake-packages.7*
 %{_mandir}/man7/cmake-policies.7*
+%{_mandir}/man7/cmake-presets.7*
 %{_mandir}/man7/cmake-properties.7*
 %{_mandir}/man7/cmake-qt.7*
 %{_mandir}/man7/cmake-server.7*
@@ -207,7 +226,6 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/cmake/Modules/.NoDartCoverage
 %{_datadir}/cmake/Modules/*
 %{_datadir}/cmake/Templates
-%{_datadir}/cmake/editors
 %{_datadir}/cmake/include
 %{_aclocaldir}/cmake.m4
 
@@ -225,8 +243,10 @@ rm -rf $RPM_BUILD_ROOT
 %{_desktopdir}/cmake-gui.desktop
 %{_iconsdir}/hicolor/128x128/apps/CMakeSetup.png
 %{_iconsdir}/hicolor/32x32/apps/CMakeSetup.png
+%if %{with doc}
 %{_mandir}/man1/cmake-gui.1*
 %endif
+%endif
 
 %files emacs
 %defattr(644,root,root,755)
This page took 0.02819 seconds and 4 git commands to generate.