]> git.pld-linux.org Git - packages/gstreamer.git/blob - gstreamer.spec
- use new config.sub to allow build on amd64
[packages/gstreamer.git] / gstreamer.spec
1 Summary:        GStreamer Streaming-media framework runtime
2 Summary(pl):    GStreamer - biblioteki ¶rodowiska do obróbki strumieni
3 Name:           gstreamer
4 Version:        0.6.4
5 Release:        2
6 License:        LGPL
7 Group:          Libraries
8 Source0:        http://ftp.gnome.org/pub/gnome/sources/%{name}/0.6/%{name}-%{version}.tar.bz2
9 # Source0-md5:  d607f42d4a6de9e79d74ccaa6469ded6
10 Patch0:         %{name}-libtool.patch
11 Patch1:         %{name}-without_ps_pdf.patch
12 Patch2:         %{name}-doc-destdir.patch
13 Patch3:         %{name}-ppc.patch
14 URL:            http://gstreamer.net/
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  bison
18 BuildRequires:  flex
19 BuildRequires:  glib2-devel >= 2.0.1
20 BuildRequires:  gtk-doc >= 0.7
21 BuildRequires:  libtool
22 BuildRequires:  libxml2-devel >= 2.4.17
23 BuildRequires:  nasm
24 BuildRequires:  pkgconfig
25 BuildRequires:  popt-devel >= 1.6.1
26 BuildRequires:  transfig
27 BuildRequires:  xmlto
28 Requires(post): /sbin/ldconfig
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         _gstlibdir      %{_libdir}/gstreamer-0.6
32 %define         _gstincludedir  %{_includedir}/gstreamer-0.6
33 %define         _gstcachedir    %{_var}/cache/gstreamer-0.6
34
35 %description
36 GStreamer is a streaming-media framework, based on graphs of filters
37 which operate on media data. Applications using this library can do
38 anything from real-time sound processing to playing videos, and just
39 about anything else media-related. Its plugin-based architecture means
40 that new data types or processing capabilities can be added simply by
41 installing new plugins.
42
43 %description -l pl
44 GStreamer to ¶rodowisko obróbki danych strumieniowych, bazuj±ce na
45 grafie filtrów operuj±cych na danych medialnych. Aplikacje u¿ywaj±ce
46 tej biblioteki mog± robiæ wszystko od przetwarzania d¼wiêku w czasie
47 rzeczywistym, do odtwarzania filmów i czegokolwiek innego zwi±zego z
48 mediami. Architektura bazuj±ca na wtyczkach pozwala na ³atwe dodawanie
49 nowych typów danych lub mo¿liwo¶ci obróbki.
50
51 %package devel
52 Summary:        Include files for GStreamer streaming-media framework
53 Summary(pl):    Pliki nag³ówkowe do ¶rodowiska obróbki strumieni GStreamer
54 Group:          Development/Libraries
55 Requires:       %{name} = %{version}
56 Requires:       glib2-devel >= 2.0.1
57 Requires:       libxml2-devel >= 2.4.17
58 Requires:       popt-devel >= 1.6.1
59
60 %description devel
61 This package contains the includes files necessary to develop
62 applications and plugins for GStreamer.
63
64 %description devel -l pl
65 Ten pakiet zawiera pliki nag³ówkowe potrzebne do rozwijania aplikacji
66 i wtyczek do GStreamera.
67
68 %package static
69 Summary:        GStreamer static libraries
70 Summary(pl):    Biblioteki statyczne GStreamer
71 Group:          Development/Libraries
72 Requires:       %{name}-devel = %{version}
73
74 %description static
75 Static versions of GStreamer libraries.
76
77 %description static -l pl
78 Statyczne wersje bibliotek GStreamer.
79
80 %prep
81 %setup -q
82 %patch0 -p1
83 %patch1 -p1
84 %patch2 -p1
85 %patch3 -p1
86
87 %build
88 %{__libtoolize}
89 %{__aclocal} -I common/m4
90 %{__autoconf}
91 %{__autoheader}
92 %{__automake}
93 cp -f /usr/share/automake/config.sub libs/ext/cothreads/
94
95 %configure \
96 %ifarch i586 i686 athlon
97         --enable-fast-stack-trash \
98 %else
99         --disable-fast-stack-trash \
100 %endif
101         --enable-glib2 \
102         --enable-libmmx \
103         --enable-atomic \
104         --disable-examples \
105         --disable-tests \
106         --disable-debug \
107         --disable-debug-color \
108         --enable-docs-build \
109         --with-html-dir=%{_gtkdocdir} \
110         --with-cachedir=%{_gstcachedir}
111         
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120
121 install -d $RPM_BUILD_ROOT%{_gstcachedir}
122 touch $RPM_BUILD_ROOT%{_gstcachedir}/registry.xml
123
124 # no static modules and *.la for them - shut up check files
125 rm -f $RPM_BUILD_ROOT%{_gstlibdir}/lib*.{la,a}
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %post
131 /sbin/ldconfig
132 %{_bindir}/gst-register --gst-mask=0
133
134 %postun -p /sbin/ldconfig
135
136 %files
137 %defattr(644,root,root,755)
138 %doc AUTHORS README RELEASE NEWS TODO ChangeLog
139 %attr(755,root,root) %{_bindir}/*
140 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
141 %dir %{_gstlibdir}
142 %attr(755,root,root) %{_gstlibdir}/*.so
143 %dir %{_gstcachedir}
144 %ghost %{_gstcachedir}/registry.xml
145 %{_mandir}/man1/*
146
147 %files devel
148 %defattr(644,root,root,755)
149 %attr(755,root,root) %{_libdir}/lib*.so
150 %{_libdir}/lib*.la
151 %{_gstincludedir}
152 %{_gtkdocdir}/*
153 %{_pkgconfigdir}/*
154 %{_aclocaldir}/*
155
156 %files static
157 %defattr(644,root,root,755)
158 %{_libdir}/lib*.a
This page took 0.079701 seconds and 4 git commands to generate.