]> git.pld-linux.org Git - packages/forcefield.git/blob - forcefield.spec
- init
[packages/forcefield.git] / forcefield.spec
1 #
2 # TODO:
3 # - more meaningful translation
4 # - check BR-s and R-s
5 # - investigate if the cracklib patch realy make forcefield *not*
6 #   require python-crypt
7 # - correct update_icons
8 #
9 %define     _snap   20070924
10 Summary:        A GNOME GUI for TrueCrypt
11 Summary(pl.UTF-8):GNOME-owe GUI dla TrueCrypta
12 Name:           forcefield
13 Version:        0.92
14 Release:        0.%{_snap}
15 License:        GPL
16 Group:          Applications/System
17 # Download current version with: svn checkout
18 # http://bockcay.de/svn/forcefield/trunk
19 Source0:        %{name}-%{_snap}.tar.bz2
20 # Source0-md5:  6e403a32487c24eeb0fea2ec30500276
21 Source1:        %{name}.desktop
22 URL:            http://www.bockcay.de/forcefield
23 Patch0:         %{name}-install.patch
24 Patch1:         %{name}-cracklib.patch
25 BuildRequires:  automake >= 1.9
26 BuildRequires:  python >= 2.5
27 BuildRequires:  python-gnome-devel
28 BuildRequires:  python-pygtk-devel
29 Requires:       GConf2 >= 2.4.0
30 Requires:       cracklib
31 Requires:       python >= 2.5
32 Requires:       python-cracklib
33 Requires:       python-gnome
34 Requires:       python-gnome-extras
35 Requires:       python-gnome-gconf
36 Requires:       python-pexpect
37 Requires:       python-pygtk-glade
38 Requires:       python-pygtk-gtk
39 Requires:       python-pynotify
40 Requires:       truecrypt
41 BuildArch:      noarch
42 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 A GNOME GUI for TrueCrypt.
46
47 %description -l pl.UTF-8
48 GNOME-owe GUI dla TrueCrypta.
49
50 %prep
51 %setup -q -n %{name}-%{_snap}
52 %patch0 -p1
53 %patch1 -p1
54
55 %build
56 %{__aclocal}
57 %{__autoconf}
58 %{__automake}
59 %configure
60 %{__perl} -pi -e 's|python2.4|python2.5|g' src/lib/Makefile.in
61 %{__make}
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
66 %{__make} install \
67         DESTDIR=$RPM_BUILD_ROOT
68 unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
69
70 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
71
72 %find_lang %{name}
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %post
78 %gconf_schema_install %{name}.schemas
79 %update_icon_cache
80 %update_mime_database hicolor
81
82 %postun
83 %gconf_schema_uninstall
84 %update_mime_database hicolor
85
86
87 %files -f %{name}.lang
88 %defattr(644,root,root,755)
89 %doc README AUTHORS ChangeLog
90 %attr(755,root,root) %{_bindir}/%{name}
91 %{_sysconfdir}/gconf/schemas/%{name}.schemas
92 %dir %{py_sitedir}/%{name}
93 %{py_sitedir}/%{name}/*.py[co]
94 %{py_sitedir}/%{name}/*.so
95 %{_datadir}/%{name}
96 %{_iconsdir}/hicolor/24x24/apps/%{name}.png
97 %{_desktopdir}/%{name}.desktop
98 %{_datadir}/mime/packages/%{name}.xml
This page took 0.120853 seconds and 4 git commands to generate.