]> git.pld-linux.org Git - packages/dbus-glib.git/blob - dbus-glib.spec
- BR: gettext-devel, gtk-doc-automake
[packages/dbus-glib.git] / dbus-glib.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 #
5 %define         dbus_version    0.93
6 %define         expat_version   1:1.95.5
7 %define         glib_version    1:2.10.1
8 #
9 Summary:        GLib-based library for using D-BUS
10 Summary(pl.UTF-8):      Biblioteka do używania D-BUS oparta o GLib
11 Name:           dbus-glib
12 Version:        0.76
13 Release:        1
14 License:        AFL v2.1 or GPL v2
15 Group:          Libraries
16 Source0:        http://dbus.freedesktop.org/releases/dbus-glib/%{name}-%{version}.tar.gz
17 # Source0-md5:  d3b716a7e798faa1c6a867675f00306a
18 Source1:        dbus-bus-introspect.xml
19 Patch0:         %{name}-configure.patch
20 Patch1:         %{name}-nolibs.patch
21 URL:            http://www.freedesktop.org/Software/DBusBindings
22 BuildRequires:  autoconf >= 2.52
23 BuildRequires:  automake >= 1:1.9
24 BuildRequires:  dbus-devel >= %{dbus_version}
25 BuildRequires:  expat-devel >= %{expat_version}
26 BuildRequires:  gettext-devel
27 BuildRequires:  glib2-devel >= %{glib_version}
28 %{?with_apidocs:BuildRequires:  gtk-doc-automake >= 1.8}
29 BuildRequires:  libtool
30 BuildRequires:  pkgconfig
31 BuildRequires:  rpmbuild(macros) >= 1.98
32 Requires:       dbus-libs >= %{dbus_version}
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 D-BUS add-on library to integrate the standard D-BUS library with the
37 GLib thread abstraction and main loop.
38
39 %description -l pl.UTF-8
40 Dodatkowa biblioteka D-BUS do integracji standardowej biblioteki D-BUS
41 z abstrakcją wątków i główną pętlą GLib.
42
43 %package devel
44 Summary:        Header files for GLib-based library for using D-BUS
45 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki do używania D-BUS opartej o GLib
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       dbus-devel >= %{dbus_version}
49 Requires:       glib2-devel >= %{glib2_version}
50
51 %description devel
52 Header files for GLib-based library for using D-BUS.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe biblioteki do używania D-BUS opartej o GLib.
56
57 %package static
58 Summary:        Static GLib-based library for using D-BUS
59 Summary(pl.UTF-8):      Statyczna biblioteka do używania D-BUS oparta o GLib
60 Group:          Development/Libraries
61 Requires:       %{name}-devel = %{version}-%{release}
62
63 %description static
64 Static GLib-based library for using D-BUS.
65
66 %description static -l pl.UTF-8
67 Statyczna biblioteka do używania D-BUS oparta o GLib.
68
69 %package apidocs
70 Summary:        D-BUS-GLib API documentation
71 Summary(pl.UTF-8):      Dokumentacja API D-BUS-GLib
72 Group:          Documentation
73 Requires:       gtk-doc-common
74
75 %description apidocs
76 D-BUS-GLib API documentation.
77
78 %description apidocs -l pl.UTF-8
79 Dokumentacja API D-BUS-GLib.
80
81 %prep
82 %setup -q
83 %patch0 -p1
84 %patch1 -p1
85
86 %if !%{with apidocs}
87 echo 'EXTRA_DIST=' > gtk-doc.make
88 echo 'AC_DEFUN([GTK_DOC_CHECK],[])' >> acinclude.m4
89 %endif
90
91 %build
92 %{__libtoolize}
93 %{__aclocal}
94 %{__autoconf}
95 %{__autoheader}
96 %{__automake}
97 %configure \
98         %{!?with_apidocs:--disable-gtk-doc} \
99         %{?with_apidocs:--with-html-dir=%{_gtkdocdir}} \
100         --with-xml=expat
101
102 cp %{SOURCE1} tools
103
104 %{__make}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post   -p /sbin/ldconfig
116 %postun -p /sbin/ldconfig
117
118 %files
119 %defattr(644,root,root,755)
120 # AFL not in common-licenses, so COPYING included
121 %doc AUTHORS COPYING ChangeLog NEWS README
122 %attr(755,root,root) %{_libdir}/libdbus-glib-1.so.*.*.*
123 %attr(755,root,root) %ghost %{_libdir}/libdbus-glib-1.so.2
124
125 %files devel
126 %defattr(644,root,root,755)
127 %attr(755,root,root) %{_bindir}/dbus-binding-tool
128 %attr(755,root,root) %{_libdir}/libdbus-glib-1.so
129 %{_libdir}/libdbus-glib-1.la
130 %{_includedir}/dbus*/dbus/dbus-glib*.h
131 %{_includedir}/dbus*/dbus/dbus-gtype-specialized.h
132 %{_pkgconfigdir}/dbus-glib-1.pc
133
134 %files static
135 %defattr(644,root,root,755)
136 %{_libdir}/libdbus-glib-1.a
137
138 %if %{with apidocs}
139 %files apidocs
140 %defattr(644,root,root,755)
141 %{_gtkdocdir}/dbus-glib
142 %endif
This page took 0.073596 seconds and 4 git commands to generate.