]> git.pld-linux.org Git - packages/dbus-glib.git/blob - dbus-glib.spec
- without static_libs bcond
[packages/dbus-glib.git] / dbus-glib.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_without  static_libs     # don't build static library
5 #
6 %define         dbus_version    0.93
7 %define         expat_version   1:1.95.5
8 %define         glib_version    1:2.10.1
9 #
10 Summary:        GLib-based library for using D-BUS
11 Summary(pl.UTF-8):      Biblioteka do używania D-BUS oparta o GLib
12 Name:           dbus-glib
13 Version:        0.76
14 Release:        1
15 License:        AFL v2.1 or GPL v2
16 Group:          Libraries
17 Source0:        http://dbus.freedesktop.org/releases/dbus-glib/%{name}-%{version}.tar.gz
18 # Source0-md5:  d3b716a7e798faa1c6a867675f00306a
19 Source1:        dbus-bus-introspect.xml
20 Patch0:         %{name}-configure.patch
21 Patch1:         %{name}-nolibs.patch
22 URL:            http://www.freedesktop.org/Software/DBusBindings
23 BuildRequires:  autoconf >= 2.52
24 BuildRequires:  automake >= 1:1.9
25 BuildRequires:  dbus-devel >= %{dbus_version}
26 BuildRequires:  expat-devel >= %{expat_version}
27 BuildRequires:  gettext-devel
28 BuildRequires:  glib2-devel >= %{glib_version}
29 %{?with_apidocs:BuildRequires:  gtk-doc-automake >= 1.8}
30 BuildRequires:  libtool
31 BuildRequires:  pkgconfig
32 BuildRequires:  rpmbuild(macros) >= 1.98
33 Requires:       dbus-libs >= %{dbus_version}
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 D-BUS add-on library to integrate the standard D-BUS library with the
38 GLib thread abstraction and main loop.
39
40 %description -l pl.UTF-8
41 Dodatkowa biblioteka D-BUS do integracji standardowej biblioteki D-BUS
42 z abstrakcją wątków i główną pętlą GLib.
43
44 %package devel
45 Summary:        Header files for GLib-based library for using D-BUS
46 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki do używania D-BUS opartej o GLib
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       dbus-devel >= %{dbus_version}
50 Requires:       glib2-devel >= %{glib2_version}
51
52 %description devel
53 Header files for GLib-based library for using D-BUS.
54
55 %description devel -l pl.UTF-8
56 Pliki nagłówkowe biblioteki do używania D-BUS opartej o GLib.
57
58 %package static
59 Summary:        Static GLib-based library for using D-BUS
60 Summary(pl.UTF-8):      Statyczna biblioteka do używania D-BUS oparta o GLib
61 Group:          Development/Libraries
62 Requires:       %{name}-devel = %{version}-%{release}
63
64 %description static
65 Static GLib-based library for using D-BUS.
66
67 %description static -l pl.UTF-8
68 Statyczna biblioteka do używania D-BUS oparta o GLib.
69
70 %package apidocs
71 Summary:        D-BUS-GLib API documentation
72 Summary(pl.UTF-8):      Dokumentacja API D-BUS-GLib
73 Group:          Documentation
74 Requires:       gtk-doc-common
75
76 %description apidocs
77 D-BUS-GLib API documentation.
78
79 %description apidocs -l pl.UTF-8
80 Dokumentacja API D-BUS-GLib.
81
82 %prep
83 %setup -q
84 %patch0 -p1
85 %patch1 -p1
86
87 %if !%{with apidocs}
88 echo 'EXTRA_DIST=' > gtk-doc.make
89 echo 'AC_DEFUN([GTK_DOC_CHECK],[])' >> acinclude.m4
90 %endif
91
92 %build
93 %{__libtoolize}
94 %{__aclocal}
95 %{__autoconf}
96 %{__autoheader}
97 %{__automake}
98 %configure \
99         %{!?with_apidocs:--disable-gtk-doc} \
100         %{?with_apidocs:--with-html-dir=%{_gtkdocdir}} \
101         %{!?with_static_libs:--disable-static} \
102         --with-xml=expat
103
104 cp %{SOURCE1} tools
105
106 %{__make}
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110
111 %{__make} install \
112         DESTDIR=$RPM_BUILD_ROOT
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %post   -p /sbin/ldconfig
118 %postun -p /sbin/ldconfig
119
120 %files
121 %defattr(644,root,root,755)
122 # AFL not in common-licenses, so COPYING included
123 %doc AUTHORS COPYING ChangeLog NEWS README
124 %attr(755,root,root) %{_libdir}/libdbus-glib-1.so.*.*.*
125 %attr(755,root,root) %ghost %{_libdir}/libdbus-glib-1.so.2
126
127 %files devel
128 %defattr(644,root,root,755)
129 %attr(755,root,root) %{_bindir}/dbus-binding-tool
130 %attr(755,root,root) %{_libdir}/libdbus-glib-1.so
131 %{_libdir}/libdbus-glib-1.la
132 %{_includedir}/dbus*/dbus/dbus-glib*.h
133 %{_includedir}/dbus*/dbus/dbus-gtype-specialized.h
134 %{_pkgconfigdir}/dbus-glib-1.pc
135
136 %if %{with static_libs}
137 %files static
138 %defattr(644,root,root,755)
139 %{_libdir}/libdbus-glib-1.a
140 %endif
141
142 %if %{with apidocs}
143 %files apidocs
144 %defattr(644,root,root,755)
145 %{_gtkdocdir}/dbus-glib
146 %endif
This page took 0.046501 seconds and 4 git commands to generate.