]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
up to 26.0.1410.12
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  cups                    # with cups
4 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
5 %bcond_without  gconf                   # with GConf
6 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
7 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
8 %bcond_without  libjpegturbo    # use libjpeg-turbo features
9 %bcond_without  nacl                    # build Native Client support
10 %bcond_without  pulseaudio              # with pulseaudio
11 %bcond_without  sandboxing              # with sandboxing
12 %bcond_with             selinux                 # with SELinux (need policy first)
13 %bcond_with             shared_libs             # with shared libs
14 %bcond_with             sse2                    # use SSE2 instructions
15 %bcond_without  system_flac             # system flac
16 %bcond_without  system_ffmpeg   # system ffmpeg instead of ffmpegsumo
17 %bcond_without  system_harfbuzz # system harfbuzz
18 %bcond_without  system_jsoncpp  # system jsoncpp
19 %bcond_without  system_libexif  # system libexif
20 %bcond_without  system_libmtp   # system libmtp
21 %bcond_without  system_libusb   # system libusb-1
22 %bcond_without  system_libwebp  # system libwebp
23 %bcond_without  system_libxnvctrl       # system libxnvctrl
24 %bcond_without  system_minizip  # system minizip
25 %bcond_without  system_opus             # system opus codec support, http://www.opus-codec.org/examples/
26 %bcond_without  system_protobuf # system protobuf
27 %bcond_without  system_speex    # system speex
28 %bcond_with             system_sqlite   # system sqlite
29 %bcond_without  system_libsrtp  # system srtp (can be used if using bundled libjingle)
30 %bcond_with             system_v8               # system v8
31 # system vpx broken currently due unreleased VP9 codec: https://code.google.com/p/chromium/issues/detail?id=174287
32 %bcond_without  system_libvpx   # system libvpx
33 %bcond_without  system_yasm             # system yasm
34 %bcond_without  system_zlib             # system zlib
35 %bcond_without  tcmalloc                # use tcmalloc
36 %bcond_without  verbose                 # verbose build (V=1)
37
38 # TODO
39 # - check system sqlite linking problems
40 # - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
41 # - use_system_ssl (use_openssl: http://crbug.com/62803)
42 # - use_system_hunspell
43 # - use_system_stlport
44 # - other defaults: src/build/common.gypi
45
46 # NOTES:
47 # - mute BEEP mixer if you do not want to hear horrible system bell when
48 #   pressing home/end in url bar or more ^F search results on page.
49 # - space considerations:
50 #   - unpacked sources: ~490MiB
51 #   - built code: ~1.4GiB (x86_64/i686)
52 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
53 # - to look for new tarball, use update-source.sh script
54
55 # NOTE TO USERS:
56 # To use chromium nightly beta builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
57 # http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
58 # http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
59
60 %define         branch          26.0.1410
61 %define         basever         12
62 #define         patchver        70
63 %define         gyp_rev 1014
64 Summary:        A WebKit powered web browser
65 Name:           chromium-browser
66 %if "%{?patchver}" != ""
67 Version:        %{branch}.%{patchver}
68 %else
69 Version:        %{branch}.%{basever}
70 %endif
71 Release:        1
72 License:        BSD, LGPL v2+ (ffmpeg)
73 Group:          X11/Applications/Networking
74 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/dev/%{name}-%{branch}.%{basever}.tar.gz
75 # Source0-md5:  d005fc9e50c28a2e3c71eee7310417f4
76 %if "%{?patchver}" != ""
77 Patch0:         http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
78 # Patch0-md5:   37675cd75c578d26d6210259877f3947
79 %endif
80 Source1:        %{name}.default
81 Source2:        %{name}.sh
82 Source3:        %{name}.desktop
83 Source5:        find-lang.sh
84 Source6:        update-source.sh
85 Source7:        clean-source.sh
86 Source8:        get-source.sh
87 Source9:        master_preferences.json
88 Patch1:         plugin-searchdirs.patch
89 #Patch2:                system-nspr.patch
90 Patch3:         disable_dlog_and_dcheck_in_release_builds.patch
91 Patch4:         path-libpdf.patch
92 Patch6:         get-webkit_revision.patch
93 Patch7:         dlopen_sonamed_gl.patch
94 Patch8:         chromium_useragent.patch.in
95 Patch9:         chromium-ppapi.patch
96 Patch10:        system-libxnvctrl.patch
97 # https://bugs.gentoo.org/show_bug.cgi?id=393471
98 # libjpeg-turbo >= 1.1.90 supports that feature
99 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
100 Patch12:        system-ffmpeg.patch
101 Patch15:        nacl-build-irt.patch
102 Patch16:        nacl-linkingfix.patch
103 Patch18:        nacl-no-untar.patch
104 Patch19:        system-jsoncpp.patch
105 Patch24:        nacl-verbose.patch
106 Patch25:        gnome3-volume-control.patch
107 Patch26:        master-prefs-path.patch
108 Patch27:        tcmalloc-glibc2.16.patch
109 URL:            http://www.chromium.org/Home
110 %{?with_gconf:BuildRequires:    GConf2-devel}
111 BuildRequires:  alsa-lib-devel
112 BuildRequires:  atk-devel
113 BuildRequires:  bison
114 BuildRequires:  bzip2-devel
115 %{?with_nacl:BuildRequires:     crossnacl-binutils >= 2.20.1}
116 %{?with_nacl:BuildRequires:     crossnacl-gcc >= 4.4.3}
117 %{?with_nacl:BuildRequires:     crossnacl-gcc-c++ >= 4.4.3}
118 %{?with_nacl:BuildRequires:     crossnacl-newlib >= 1.20.0-3}
119 %{?with_cups:BuildRequires:     cups-devel}
120 BuildRequires:  elfutils-devel
121 BuildRequires:  expat-devel
122 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 1.0}
123 %{?with_system_flac:BuildRequires:      flac-devel >= 1.2.1-7}
124 BuildRequires:  fontconfig-devel
125 BuildRequires:  glib2-devel
126 BuildRequires:  gperf
127 BuildRequires:  gtest-devel
128 BuildRequires:  gtk+2-devel
129 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-devel}
130 %{?with_kerberos:BuildRequires: heimdal-devel}
131 BuildRequires:  hicolor-icon-theme
132 %{?with_system_jsoncpp:BuildRequires:   jsoncpp-devel}
133 %{?with_system_libxnvctrl:BuildRequires:        libXNVCtrl-devel >= 310.19}
134 BuildRequires:  libevent-devel
135 %{?with_system_libexif:BuildRequires:   libexif-devel >= 1:0.6.21}
136 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
137 BuildRequires:  libicu-devel >= 4.6
138 %{!?with_libjpegturbo:BuildRequires:    libjpeg-devel}
139 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
140 %{?with_system_libmtp:BuildRequires:    libmtp-devel >= 1.1.3}
141 BuildRequires:  libpng-devel
142 %{?with_selinux:BuildRequires:  libselinux-devel}
143 BuildRequires:  libstdc++-devel
144 %{?with_system_libusb:BuildRequires:    libusb-devel >= 1.0}
145 %{?with_system_libvpx:BuildRequires:    libvpx-devel >= 0.9.5-2}
146 %{?with_system_libwebp:BuildRequires:   libwebp-devel >= 0.1.99}
147 BuildRequires:  libxml2-devel
148 BuildRequires:  libxslt-devel
149 BuildRequires:  man-db
150 %{?with_system_minizip:BuildRequires:   minizip-devel}
151 BuildRequires:  nspr-devel
152 BuildRequires:  nss-devel >= 1:3.12.3
153 %{?with_system_opus:BuildRequires:      opus-devel >= 1.0.2}
154 BuildRequires:  pam-devel
155 BuildRequires:  pango-devel
156 BuildRequires:  pciutils-devel
157 BuildRequires:  perl-modules
158 BuildRequires:  pkgconfig
159 %{?with_system_protobuf:BuildRequires:  protobuf-devel}
160 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
161 BuildRequires:  python
162 #BuildRequires: python-gyp >= 1-%{gyp_rev}
163 BuildRequires:  python-modules
164 BuildRequires:  python-ply
165 BuildRequires:  rpm >= 4.4.9-56
166 BuildRequires:  rpmbuild(macros) >= 1.453
167 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
168 BuildRequires:  sqlite3-devel >= 3.6.1
169 %{?with_system_libsrtp:BuildRequires:   srtp-devel >= 1.4.4}
170 BuildRequires:  subversion
171 BuildRequires:  tar >= 1:1.22
172 BuildRequires:  udev-devel
173 BuildRequires:  usbutils
174 BuildRequires:  util-linux
175 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
176 BuildRequires:  which
177 BuildRequires:  xorg-lib-libXScrnSaver-devel
178 BuildRequires:  xz
179 %{?with_system_yasm:BuildRequires:      yasm}
180 %{?with_system_zlib:BuildRequires:      zlib-devel}
181 Requires:       browser-plugins >= 2.0
182 Requires:       desktop-file-utils
183 %{?with_system_flac:Requires:   flac >= 1.2.1-7}
184 # crashes if no fontconfig font present
185 Requires:       fonts-Type1-urw
186 Requires:       hicolor-icon-theme
187 Requires:       libevent >= 2.0.21
188 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
189 %{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
190 Requires:       lsb-release
191 Requires:       shared-mime-info
192 Requires:       xdg-utils >= 1.0.2-4
193 Requires:       xorg-lib-libX11 >= 1.4.99.1
194 Provides:       wwwbrowser
195 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
196 Obsoletes:      chromium-browser-inspector < 15.0.863.0
197 ExclusiveArch:  %{ix86} %{x8664} arm
198 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
199
200 %define         find_lang       sh find-lang.sh %{buildroot}
201
202 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
203 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
204
205 %if %{without debuginfo}
206 %define         _enable_debug_packages  0
207 %endif
208
209 %description
210 Chromium is an open-source browser project that aims to build a safer,
211 faster, and more stable way for all Internet users to experience the
212 web.
213
214 Chromium serves as a base for Google Chrome, which is Chromium
215 rebranded (name and logo) with very few additions such as usage
216 tracking and an auto-updater system.
217
218 %package l10n
219 Summary:        chromium-browser language packages
220 Group:          I18n
221 Requires:       %{name} = %{version}-%{release}
222
223 %description l10n
224 Chromium is an open-source browser project that aims to build a safer,
225 faster, and more stable way for all Internet users to experience the
226 web.
227
228 This package contains language packages for 50 languages:
229
230 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
231 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
232 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
233 zh-TW
234
235 %prep
236 %setup -qc
237 %if "%{?patchver}" != ""
238 cd %{name}-%{branch}.%{basever}
239 %patch0 -p1
240 cd ..
241 %endif
242 mv %{name}-%{branch}.%{basever}/src .
243
244 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
245 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
246 . ./src/chrome/VERSION
247 ver=$MAJOR.$MINOR.$BUILD.$PATCH
248 test "$ver" = %{version}
249
250 gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
251 test "$gyp_rev" = %{gyp_rev} || :
252
253 v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
254
255 # add chromium and pld to useragent
256 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
257 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
258     -e 's/@BUILD_DIST_NAME@/PLD/g' \
259     -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
260     < %{PATCH8} | %{__patch} -p1
261
262 %{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
263 ln -s %{SOURCE7} src
264
265 %patch1 -p1
266 %patch3 -p1
267 %patch4 -p1
268 %patch6 -p1
269 %patch7 -p1
270 %patch10 -p1
271 %patch15 -p1
272 cd src
273 %patch9 -p0
274 #%patch2 -p1
275 %{!?with_libjpegturbo:%patch11 -p0}
276 %patch12 -p1
277 %patch16 -p1
278 %patch19 -p1
279 %patch27 -p1
280 cd ..
281 %patch25 -p1
282 %patch18 -p1
283 %patch24 -p1
284 %patch26 -p1
285
286 cd src
287
288 sh -x clean-source.sh \
289         %{!?with_nacl:nacl=0} \
290         %{!?with_system_protobuf:protobuf=0} \
291         %{!?with_system_v8:v8=0} \
292         %{!?with_system_zlib:zlib=0} \
293         %{!?with_system_libvpx:libvpx=0} \
294         %{!?with_system_libxnvctrl:libXNVCtrl=0} \
295         %{nil}
296
297 %build
298 cd src
299
300 %if %{with nacl}
301 rm -rf native_client/toolchain/linux_x86_newlib
302 if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
303 # Make symlinks for NaCL
304 install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
305
306 cd native_client/toolchain/linux_x86_newlib
307 ln -s x86_64-nacl/bin bin
308 cd x86_64-nacl/bin
309 __cc='%{__cc}'
310 if [ "${__cc#ccache}" != "$__cc" ]; then
311         echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
312         echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
313         %{__sed} -i -e '1i#!/bin/sh' gcc g++
314         chmod +x gcc g++
315 else
316         ln -s %{_bindir}/x86_64-nacl-gcc gcc
317         ln -s %{_bindir}/x86_64-nacl-g++ g++
318 fi
319 ln -s gcc x86_64-nacl-gcc
320 ln -s g++ x86_64-nacl-g++
321 ln -s %{_bindir}/x86_64-nacl-ar .
322 ln -s %{_bindir}/x86_64-nacl-ar ar
323 ln -s %{_bindir}/x86_64-nacl-as as
324 ln -s %{_bindir}/x86_64-nacl-ranlib .
325 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
326 ln -s %{_bindir}/x86_64-nacl-strip .
327 ln -s %{_bindir}/x86_64-nacl-strip strip
328 ln -s %{_prefix}/x86_64-nacl/lib ../lib
329 ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
330 ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
331 cd ../../../../..
332 fi
333 %endif
334
335 test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
336 test -e Makefile || \
337         CC="%{__cc}" \
338         CXX="%{__cxx}" \
339         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
340         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
341         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
342 %{__python} build/gyp_chromium \
343         --format=make \
344         -Goutput_dir=../out \
345         build/all.gyp \
346 %ifarch %{ix86}
347         -Dtarget_arch=ia32 \
348 %endif
349 %ifarch %{x8664}
350         -Dtarget_arch=x64 \
351 %endif
352 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
353         -Dno_strict_aliasing=1 -Dgcc_version=44 \
354 %endif
355 %if %{with sandboxing}
356         -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
357         -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
358 %endif
359         %{!?debug:-Dwerror=} \
360         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
361         %{?with_shared_libs:-Dlibrary=shared_library} \
362         %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1 -Dproprietary_codecs=1} \
363         -Dinclude_tests=0 \
364 %if %{with nacl}
365         -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
366         -Ddisable_glibc_untar=1 \
367         -Ddisable_newlib_untar=1 \
368         -Ddisable_glibc=1 \
369         -Ddisable_pnacl=1 \
370         -Dbuild_pnacl_newlib=0 \
371 %else
372         -Ddisable_pnacl_untar=1 \
373         -Ddisable_nacl=1 \
374 %endif
375         %{!?with_sse2:-Ddisable_sse2=1} \
376         %{?with_selinux:-Dselinux=1} \
377         -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
378         -Dlinux_link_libpci=1 \
379         %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
380         -Dlinux_use_gold_binary=0 \
381         -Dlinux_use_gold_flags=0 \
382         %{gyp_with cups} \
383         %{gyp_with gconf} -Dlinux_link_gsettings=0 \
384         %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
385         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
386         %{gyp_with pulseaudio} \
387         %{gyp_with system_ffmpeg} \
388         %{gyp_with system_flac} \
389         %{gyp_with system_harfbuzz} \
390         %{gyp_with system_libexif} \
391         %{gyp_with system_libmtp} \
392         %{gyp_with system_libsrtp} \
393         %{gyp_with system_libusb} \
394         %{gyp_with system_libvpx} \
395         %{gyp_with system_libwebp} \
396         %{gyp_with system_libxnvctrl} \
397         %{gyp_with system_minizip} \
398         %{gyp_with system_opus} \
399         %{gyp_with system_protobuf} \
400         %{gyp_with system_speex} \
401         %{gyp_with system_sqlite} \
402         %{gyp_with system_v8} \
403         %{gyp_with system_yasm} \
404         %{gyp_with system_zlib} \
405         -Duse_system_bzip2=1 \
406         -Duse_system_expat=1 \
407         -Duse_system_icu=1 \
408         -Duse_system_libevent=1 \
409         -Duse_system_libjpeg=1 \
410         -Duse_system_libpng=1 \
411         -Duse_system_libxml=1 \
412         -Duse_system_libxslt=1 \
413         -Duse_system_xdg_utils=1 \
414
415 # need {CC/CXX/LDFLAGS}.host overrides for v8 build
416 %{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
417         BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
418         %{?with_verbose:V=1} \
419         CC.host="%{__cc}" \
420         CXX.host="%{__cxx}" \
421         LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
422
423 cd ../out/%{!?debug:Release}%{?debug:Debug}
424 MANWIDTH=80 man ./chrome.1 > man.out
425 %{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
426
427 %install
428 rm -rf $RPM_BUILD_ROOT
429 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
430         $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
431
432 cd out/%{!?debug:Release}%{?debug:Debug}
433 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
434 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
435 %{__sed} -i -e '
436         s,@libdir@,%{_libdir}/%{name},
437
438         /@OPTIONS@/ {
439                 r options.txt
440                 d
441         }
442 ' $RPM_BUILD_ROOT%{_bindir}/%{name}
443 cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
444 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
445 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
446 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
447 %if %{without system_ffmpeg}
448 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
449 %endif
450 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
451 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
452
453 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
454
455 %if %{with nacl}
456 # Install Native Client files on platforms that support it.
457 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
458 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
459 %ifarch %{x8664}
460 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
461 %endif
462 %ifarch %{ix86}
463 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
464 %endif
465 %endif
466
467 cd -
468
469 for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
470         size=${icon##*/product_logo_}
471         size=${size%.png}
472
473         # this will skip non-numeric (22_mono_invert, 22_mono)
474         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
475         test -d "$dir" || continue
476
477         install -d $RPM_BUILD_ROOT$dir
478         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
479 done
480
481 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
482 # http://code.google.com/p/chromium/issues/detail?id=24507
483 gecko-mediaplayer*.so
484 EOF
485
486 # find locales
487 %find_lang %{name}.lang
488 # always package en-US
489 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
490
491 %clean
492 rm -rf $RPM_BUILD_ROOT
493
494 %post
495 %update_icon_cache hicolor
496 %update_desktop_database
497 %update_browser_plugins
498
499 %postun
500 if [ "$1" = 0 ]; then
501         %update_icon_cache hicolor
502         %update_browser_plugins
503 fi
504
505 %files
506 %defattr(644,root,root,755)
507 %doc src/{AUTHORS,LICENSE}
508 %{_browserpluginsconfdir}/browsers.d/%{name}.*
509 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
510 %dir %{_sysconfdir}/%{name}
511 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
512 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
513 %attr(755,root,root) %{_bindir}/%{name}
514 %{_mandir}/man1/%{name}.1*
515 %{_desktopdir}/*.desktop
516 %{_iconsdir}/hicolor/*/apps/%{name}.png
517 %dir %{_libdir}/%{name}
518 %{_libdir}/%{name}/chrome*.pak
519 %{_libdir}/%{name}/content_resources.pak
520 %{_libdir}/%{name}/resources.pak
521 %dir %{_libdir}/%{name}/locales
522 %{_libdir}/%{name}/locales/en-US.pak
523 %dir %{_libdir}/%{name}/resources
524 %{_libdir}/%{name}/resources/inspector
525 %dir %{_libdir}/%{name}/themes
526 %dir %{_libdir}/%{name}/extensions
527 %dir %{_libdir}/%{name}/plugins
528 %attr(755,root,root) %{_libdir}/%{name}/%{name}
529 # These unique permissions are intentional and necessary for the sandboxing
530 %attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
531
532 # ffmpeg libs
533 %if %{without system_ffmpeg}
534 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
535 %endif
536
537 %if %{with nacl}
538 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
539 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
540 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
541 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
542 %endif
543
544 %files l10n -f %{name}.lang
545 %defattr(644,root,root,755)
This page took 0.071216 seconds and 4 git commands to generate.