]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
up to 26.0.1410.12
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
ba685303 3%bcond_without cups # with cups
2108baf2 4%bcond_without debuginfo # disable debuginfo creation (it is huge)
ba685303 5%bcond_without gconf # with GConf
8171fe68 6%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
2108baf2 7%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
ba685303 8%bcond_without libjpegturbo # use libjpeg-turbo features
6c8531c6 9%bcond_without nacl # build Native Client support
ba685303 10%bcond_without pulseaudio # with pulseaudio
2108baf2
ER
11%bcond_without sandboxing # with sandboxing
12%bcond_with selinux # with SELinux (need policy first)
13%bcond_with shared_libs # with shared libs
14%bcond_with sse2 # use SSE2 instructions
ba685303 15%bcond_without system_flac # system flac
4e881737 16%bcond_without system_ffmpeg # system ffmpeg instead of ffmpegsumo
108c5f7c 17%bcond_without system_harfbuzz # system harfbuzz
ba685303 18%bcond_without system_jsoncpp # system jsoncpp
62950103
ER
19%bcond_without system_libexif # system libexif
20%bcond_without system_libmtp # system libmtp
ba685303
ER
21%bcond_without system_libusb # system libusb-1
22%bcond_without system_libwebp # system libwebp
4884fc99 23%bcond_without system_libxnvctrl # system libxnvctrl
126ea630 24%bcond_without system_minizip # system minizip
62950103 25%bcond_without system_opus # system opus codec support, http://www.opus-codec.org/examples/
108c5f7c 26%bcond_without system_protobuf # system protobuf
ba685303
ER
27%bcond_without system_speex # system speex
28%bcond_with system_sqlite # system sqlite
9bd2659c 29%bcond_without system_libsrtp # system srtp (can be used if using bundled libjingle)
ba685303 30%bcond_with system_v8 # system v8
f2f193c6 31# system vpx broken currently due unreleased VP9 codec: https://code.google.com/p/chromium/issues/detail?id=174287
4b411ffe 32%bcond_without system_libvpx # system libvpx
ba685303 33%bcond_without system_yasm # system yasm
1c00315b 34%bcond_without system_zlib # system zlib
d2781a31 35%bcond_without tcmalloc # use tcmalloc
7e136323 36%bcond_without verbose # verbose build (V=1)
0c480b89 37
6d92f81c 38# TODO
f1b276d4 39# - check system sqlite linking problems
2108baf2 40# - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
a3140cd1 41# - use_system_ssl (use_openssl: http://crbug.com/62803)
d617ab39 42# - use_system_hunspell
32a2443e 43# - use_system_stlport
a3140cd1
ER
44# - other defaults: src/build/common.gypi
45
e53ecfb5 46# NOTES:
4fe038cb
ER
47# - mute BEEP mixer if you do not want to hear horrible system bell when
48# pressing home/end in url bar or more ^F search results on page.
7c638678 49# - space considerations:
0bb93ab2 50# - unpacked sources: ~490MiB
c1ecd31f 51# - built code: ~1.4GiB (x86_64/i686)
f1b276d4 52# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 53# - to look for new tarball, use update-source.sh script
f1b276d4 54
e68aa7e7 55# NOTE TO USERS:
c8b02491 56# To use chromium nightly beta builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
a3cc7091 57# http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
c8b02491 58# http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
e68aa7e7 59
f2f193c6
ER
60%define branch 26.0.1410
61%define basever 12
92fcbe12 62#define patchver 70
a3140cd1 63%define gyp_rev 1014
11ad81c4 64Summary: A WebKit powered web browser
05f72ae2 65Name: chromium-browser
f73369da
ER
66%if "%{?patchver}" != ""
67Version: %{branch}.%{patchver}
68%else
69Version: %{branch}.%{basever}
70%endif
f6284fe2 71Release: 1
05f72ae2 72License: BSD, LGPL v2+ (ffmpeg)
e53ecfb5 73Group: X11/Applications/Networking
f2f193c6 74Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/dev/%{name}-%{branch}.%{basever}.tar.gz
b60866e3 75# Source0-md5: d005fc9e50c28a2e3c71eee7310417f4
3c73e180
ER
76%if "%{?patchver}" != ""
77Patch0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
f6284fe2 78# Patch0-md5: 37675cd75c578d26d6210259877f3947
3c73e180 79%endif
37ceaf05 80Source1: %{name}.default
8b53130d
ER
81Source2: %{name}.sh
82Source3: %{name}.desktop
56c6e811
ER
83Source5: find-lang.sh
84Source6: update-source.sh
85Source7: clean-source.sh
836b1cac 86Source8: get-source.sh
0562b864 87Source9: master_preferences.json
48b341f5 88Patch1: plugin-searchdirs.patch
70258ccd 89#Patch2: system-nspr.patch
7abc645c 90Patch3: disable_dlog_and_dcheck_in_release_builds.patch
72cb20c1 91Patch4: path-libpdf.patch
0e5636cb 92Patch6: get-webkit_revision.patch
5aa5df39 93Patch7: dlopen_sonamed_gl.patch
4765ddf1 94Patch8: chromium_useragent.patch.in
c0808220 95Patch9: chromium-ppapi.patch
8456d676 96Patch10: system-libxnvctrl.patch
1347c76c
AM
97# https://bugs.gentoo.org/show_bug.cgi?id=393471
98# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 99Patch11: chromium-revert-jpeg-swizzle-r2.patch
108c5f7c 100Patch12: system-ffmpeg.patch
5997e180
ER
101Patch15: nacl-build-irt.patch
102Patch16: nacl-linkingfix.patch
9516ca97 103Patch18: nacl-no-untar.patch
08b25440 104Patch19: system-jsoncpp.patch
6897926c 105Patch24: nacl-verbose.patch
c5b396f3
ER
106Patch25: gnome3-volume-control.patch
107Patch26: master-prefs-path.patch
d2781a31 108Patch27: tcmalloc-glibc2.16.patch
750b48f7 109URL: http://www.chromium.org/Home
ae3fe89f 110%{?with_gconf:BuildRequires: GConf2-devel}
05f72ae2
ER
111BuildRequires: alsa-lib-devel
112BuildRequires: atk-devel
113BuildRequires: bison
11ad81c4 114BuildRequires: bzip2-devel
5997e180
ER
115%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
116%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
117%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
9516ca97 118%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
ae3fe89f 119%{?with_cups:BuildRequires: cups-devel}
92965b0e 120BuildRequires: elfutils-devel
77f32fa3 121BuildRequires: expat-devel
7d0dbc8d 122%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 1.0}
8f5f6775 123%{?with_system_flac:BuildRequires: flac-devel >= 1.2.1-7}
11ad81c4 124BuildRequires: fontconfig-devel
f1b276d4 125BuildRequires: glib2-devel
05f72ae2 126BuildRequires: gperf
bbad64b7 127BuildRequires: gtest-devel
8b53130d 128BuildRequires: gtk+2-devel
01b4dc8e 129%{?with_system_harfbuzz:BuildRequires: harfbuzz-devel}
a3140cd1 130%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 131BuildRequires: hicolor-icon-theme
ed514974 132%{?with_system_jsoncpp:BuildRequires: jsoncpp-devel}
ef121064 133%{?with_system_libxnvctrl:BuildRequires: libXNVCtrl-devel >= 310.19}
05f72ae2 134BuildRequires: libevent-devel
8456d676 135%{?with_system_libexif:BuildRequires: libexif-devel >= 1:0.6.21}
7f40f3f4 136%{?with_keyring:BuildRequires: libgnome-keyring-devel}
0b214002 137BuildRequires: libicu-devel >= 4.6
39c71b4c 138%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
f4a8da6a 139%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
8456d676 140%{?with_system_libmtp:BuildRequires: libmtp-devel >= 1.1.3}
05f72ae2 141BuildRequires: libpng-devel
e266589e 142%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 143BuildRequires: libstdc++-devel
ba685303 144%{?with_system_libusb:BuildRequires: libusb-devel >= 1.0}
4b411ffe 145%{?with_system_libvpx:BuildRequires: libvpx-devel >= 0.9.5-2}
dd1509bd 146%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.1.99}
f1b276d4 147BuildRequires: libxml2-devel
11ad81c4 148BuildRequires: libxslt-devel
535cb410 149BuildRequires: man-db
62950103 150%{?with_system_minizip:BuildRequires: minizip-devel}
05f72ae2 151BuildRequires: nspr-devel
f1b276d4 152BuildRequires: nss-devel >= 1:3.12.3
8456d676 153%{?with_system_opus:BuildRequires: opus-devel >= 1.0.2}
35902862 154BuildRequires: pam-devel
f1b276d4 155BuildRequires: pango-devel
ef121064 156BuildRequires: pciutils-devel
48b341f5 157BuildRequires: perl-modules
158BuildRequires: pkgconfig
75a27c2e 159%{?with_system_protobuf:BuildRequires: protobuf-devel}
ae3fe89f 160%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 161BuildRequires: python
46cdefee 162#BuildRequires: python-gyp >= 1-%{gyp_rev}
48b341f5 163BuildRequires: python-modules
92965b0e 164BuildRequires: python-ply
0cad051b 165BuildRequires: rpm >= 4.4.9-56
f1b276d4 166BuildRequires: rpmbuild(macros) >= 1.453
0cad051b 167%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
f1b276d4 168BuildRequires: sqlite3-devel >= 3.6.1
9bd2659c 169%{?with_system_libsrtp:BuildRequires: srtp-devel >= 1.4.4}
89f0dde4 170BuildRequires: subversion
0cad051b 171BuildRequires: tar >= 1:1.22
0a424ee2 172BuildRequires: udev-devel
7d1152d4 173BuildRequires: usbutils
2303ed45 174BuildRequires: util-linux
c14cd342 175%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 176BuildRequires: which
f1b276d4 177BuildRequires: xorg-lib-libXScrnSaver-devel
836b1cac 178BuildRequires: xz
a3140cd1 179%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 180%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 181Requires: browser-plugins >= 2.0
0cad051b 182Requires: desktop-file-utils
8f5f6775 183%{?with_system_flac:Requires: flac >= 1.2.1-7}
ae20377c
ER
184# crashes if no fontconfig font present
185Requires: fonts-Type1-urw
0eb19b0b 186Requires: hicolor-icon-theme
56403697 187Requires: libevent >= 2.0.21
c1edaafa 188%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
4b411ffe 189%{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
b809ab60 190Requires: lsb-release
3700ba38 191Requires: shared-mime-info
4dc49133 192Requires: xdg-utils >= 1.0.2-4
2cbfc1a4 193Requires: xorg-lib-libX11 >= 1.4.99.1
e53ecfb5 194Provides: wwwbrowser
c3582150 195Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 196Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 197ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 198BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 199
589d90ea 200%define find_lang sh find-lang.sh %{buildroot}
2446ebb3 201
e7fa0817
ER
202# Usage: gyp_with BCOND_NAME [OPTION_NAME]
203%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 204
6b113615
ER
205%if %{without debuginfo}
206%define _enable_debug_packages 0
207%endif
208
11ad81c4 209%description
80838854
ER
210Chromium is an open-source browser project that aims to build a safer,
211faster, and more stable way for all Internet users to experience the
212web.
213
214Chromium serves as a base for Google Chrome, which is Chromium
215rebranded (name and logo) with very few additions such as usage
216tracking and an auto-updater system.
217
f1b276d4
ER
218%package l10n
219Summary: chromium-browser language packages
220Group: I18n
221Requires: %{name} = %{version}-%{release}
222
223%description l10n
224Chromium is an open-source browser project that aims to build a safer,
225faster, and more stable way for all Internet users to experience the
226web.
227
228This package contains language packages for 50 languages:
229
e7fa0817
ER
230ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
231he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
232pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
233zh-TW
f1b276d4
ER
234
235%prep
3c73e180
ER
236%setup -qc
237%if "%{?patchver}" != ""
238cd %{name}-%{branch}.%{basever}
239%patch0 -p1
240cd ..
241%endif
242mv %{name}-%{branch}.%{basever}/src .
589d90ea 243
05f72ae2
ER
244# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
245# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
0c480b89
ER
246. ./src/chrome/VERSION
247ver=$MAJOR.$MINOR.$BUILD.$PATCH
a3140cd1
ER
248test "$ver" = %{version}
249
250gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 251test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 252
836b1cac 253v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
33b04c7d 254
4765ddf1
ER
255# add chromium and pld to useragent
256%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
257sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
258 -e 's/@BUILD_DIST_NAME@/PLD/g' \
259 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
74a58b60 260 < %{PATCH8} | %{__patch} -p1
4765ddf1 261
56c6e811
ER
262%{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
263ln -s %{SOURCE7} src
f1b276d4 264
05f72ae2 265%patch1 -p1
7abc645c 266%patch3 -p1
72cb20c1 267%patch4 -p1
0e5636cb 268%patch6 -p1
5aa5df39 269%patch7 -p1
42e551c9 270%patch10 -p1
e9abb380 271%patch15 -p1
77f32fa3 272cd src
c0808220 273%patch9 -p0
70258ccd 274#%patch2 -p1
f4a8da6a 275%{!?with_libjpegturbo:%patch11 -p0}
108c5f7c 276%patch12 -p1
5997e180 277%patch16 -p1
08b25440 278%patch19 -p1
d2781a31 279%patch27 -p1
1347c76c 280cd ..
f2f193c6 281%patch25 -p1
9516ca97 282%patch18 -p1
6897926c 283%patch24 -p1
c5b396f3 284%patch26 -p1
0c480b89 285
828bdd1a 286cd src
e9abb380 287
75a27c2e
ER
288sh -x clean-source.sh \
289 %{!?with_nacl:nacl=0} \
290 %{!?with_system_protobuf:protobuf=0} \
291 %{!?with_system_v8:v8=0} \
292 %{!?with_system_zlib:zlib=0} \
f2f193c6 293 %{!?with_system_libvpx:libvpx=0} \
ef121064 294 %{!?with_system_libxnvctrl:libXNVCtrl=0} \
75a27c2e 295 %{nil}
fded59be 296
e266589e 297%build
f1b276d4 298cd src
5997e180
ER
299
300%if %{with nacl}
108c5f7c 301rm -rf native_client/toolchain/linux_x86_newlib
fded59be 302if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
dcea0d6b 303# Make symlinks for NaCL
108c5f7c 304install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
2e4113fd 305
108c5f7c
ER
306cd native_client/toolchain/linux_x86_newlib
307ln -s x86_64-nacl/bin bin
308cd x86_64-nacl/bin
2e4113fd 309__cc='%{__cc}'
f64e73f6 310if [ "${__cc#ccache}" != "$__cc" ]; then
2e4113fd
ER
311 echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
312 echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
313 %{__sed} -i -e '1i#!/bin/sh' gcc g++
314 chmod +x gcc g++
315else
316 ln -s %{_bindir}/x86_64-nacl-gcc gcc
317 ln -s %{_bindir}/x86_64-nacl-g++ g++
318fi
108c5f7c
ER
319ln -s gcc x86_64-nacl-gcc
320ln -s g++ x86_64-nacl-g++
321ln -s %{_bindir}/x86_64-nacl-ar .
5997e180
ER
322ln -s %{_bindir}/x86_64-nacl-ar ar
323ln -s %{_bindir}/x86_64-nacl-as as
108c5f7c 324ln -s %{_bindir}/x86_64-nacl-ranlib .
5997e180 325ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
108c5f7c 326ln -s %{_bindir}/x86_64-nacl-strip .
5997e180 327ln -s %{_bindir}/x86_64-nacl-strip strip
108c5f7c
ER
328ln -s %{_prefix}/x86_64-nacl/lib ../lib
329ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
dcea0d6b
ER
330ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
331cd ../../../../..
fded59be 332fi
5997e180
ER
333%endif
334
c5b396f3 335test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
b4d75247
ER
336test -e Makefile || \
337 CC="%{__cc}" \
338 CXX="%{__cxx}" \
339 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
340 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
341 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
342%{__python} build/gyp_chromium \
673aee14
ER
343 --format=make \
344 -Goutput_dir=../out \
345 build/all.gyp \
f1b276d4
ER
346%ifarch %{ix86}
347 -Dtarget_arch=ia32 \
348%endif
349%ifarch %{x8664}
0c480b89
ER
350 -Dtarget_arch=x64 \
351%endif
7b454a31
AM
352%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
353 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4
ER
354%endif
355%if %{with sandboxing}
356 -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
357 -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
358%endif
359 %{!?debug:-Dwerror=} \
c980b122 360 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 361 %{?with_shared_libs:-Dlibrary=shared_library} \
6e2c5572 362 %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1 -Dproprietary_codecs=1} \
b5a3dda3 363 -Dinclude_tests=0 \
c0808220 364%if %{with nacl}
038f76b9 365 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
9516ca97
ER
366 -Ddisable_glibc_untar=1 \
367 -Ddisable_newlib_untar=1 \
8fb1dc98
ER
368 -Ddisable_glibc=1 \
369 -Ddisable_pnacl=1 \
370 -Dbuild_pnacl_newlib=0 \
c0808220 371%else
8fb1dc98 372 -Ddisable_pnacl_untar=1 \
c0808220
ER
373 -Ddisable_nacl=1 \
374%endif
a3140cd1
ER
375 %{!?with_sse2:-Ddisable_sse2=1} \
376 %{?with_selinux:-Dselinux=1} \
7d1152d4 377 -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
05998197
ER
378 -Dlinux_link_libpci=1 \
379 %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
380 -Dlinux_use_gold_binary=0 \
381 -Dlinux_use_gold_flags=0 \
e7fa0817 382 %{gyp_with cups} \
8dda6bbc 383 %{gyp_with gconf} -Dlinux_link_gsettings=0 \
e7fa0817
ER
384 %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
385 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
386 %{gyp_with pulseaudio} \
7d0dbc8d 387 %{gyp_with system_ffmpeg} \
8f5f6775 388 %{gyp_with system_flac} \
01b4dc8e 389 %{gyp_with system_harfbuzz} \
62950103
ER
390 %{gyp_with system_libexif} \
391 %{gyp_with system_libmtp} \
9bd2659c 392 %{gyp_with system_libsrtp} \
581aec44 393 %{gyp_with system_libusb} \
4b411ffe 394 %{gyp_with system_libvpx} \
ba685303 395 %{gyp_with system_libwebp} \
4884fc99 396 %{gyp_with system_libxnvctrl} \
126ea630 397 %{gyp_with system_minizip} \
62950103 398 %{gyp_with system_opus} \
75a27c2e 399 %{gyp_with system_protobuf} \
e7fa0817
ER
400 %{gyp_with system_speex} \
401 %{gyp_with system_sqlite} \
402 %{gyp_with system_v8} \
403 %{gyp_with system_yasm} \
404 %{gyp_with system_zlib} \
0c480b89 405 -Duse_system_bzip2=1 \
62950103 406 -Duse_system_expat=1 \
0b214002 407 -Duse_system_icu=1 \
f1b276d4 408 -Duse_system_libevent=1 \
0c480b89 409 -Duse_system_libjpeg=1 \
f1b276d4
ER
410 -Duse_system_libpng=1 \
411 -Duse_system_libxml=1 \
412 -Duse_system_libxslt=1 \
7f40f3f4 413 -Duse_system_xdg_utils=1 \
11ad81c4 414
b4d75247 415# need {CC/CXX/LDFLAGS}.host overrides for v8 build
48ffbc5e 416%{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
f1b276d4
ER
417 BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
418 %{?with_verbose:V=1} \
f1b276d4
ER
419 CC.host="%{__cc}" \
420 CXX.host="%{__cxx}" \
b4d75247 421 LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
11ad81c4 422
535cb410
ER
423cd ../out/%{!?debug:Release}%{?debug:Debug}
424MANWIDTH=80 man ./chrome.1 > man.out
425%{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
426
11ad81c4
AM
427%install
428rm -rf $RPM_BUILD_ROOT
56c6e811 429install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
37ceaf05 430 $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
e266589e 431
673aee14 432cd out/%{!?debug:Release}%{?debug:Debug}
37ceaf05 433cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4 434install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
535cb410
ER
435%{__sed} -i -e '
436 s,@libdir@,%{_libdir}/%{name},
437
438 /@OPTIONS@/ {
439 r options.txt
440 d
441 }
442' $RPM_BUILD_ROOT%{_bindir}/%{name}
97fac491 443cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
7f40f3f4 444cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 445install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
e53ecfb5 446install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
fcc48c19 447%if %{without system_ffmpeg}
f1b276d4 448install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 449%endif
e7fa0817 450cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
0562b864 451cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
164020eb 452
c0808220
ER
453%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
454
164020eb
ER
455%if %{with nacl}
456# Install Native Client files on platforms that support it.
457install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
458install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
459%ifarch %{x8664}
460install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
461%endif
462%ifarch %{ix86}
463install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
464%endif
465%endif
466
0c480b89
ER
467cd -
468
0eb19b0b
ER
469for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
470 size=${icon##*/product_logo_}
471 size=${size%.png}
472
473 # this will skip non-numeric (22_mono_invert, 22_mono)
474 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
475 test -d "$dir" || continue
476
477 install -d $RPM_BUILD_ROOT$dir
478 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
479done
7f40f3f4 480
13840bc2
AM
481%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
482# http://code.google.com/p/chromium/issues/detail?id=24507
483gecko-mediaplayer*.so
484EOF
11ad81c4 485
589d90ea
ER
486# find locales
487%find_lang %{name}.lang
e7fa0817 488# always package en-US
f1b276d4 489%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 490
11ad81c4
AM
491%clean
492rm -rf $RPM_BUILD_ROOT
493
f1b276d4 494%post
0eb19b0b 495%update_icon_cache hicolor
b7a6e4ee 496%update_desktop_database
f1b276d4
ER
497%update_browser_plugins
498
499%postun
500if [ "$1" = 0 ]; then
0eb19b0b 501 %update_icon_cache hicolor
f1b276d4
ER
502 %update_browser_plugins
503fi
504
1d2b9616 505%files
11ad81c4 506%defattr(644,root,root,755)
531537e5 507%doc src/{AUTHORS,LICENSE}
f1b276d4
ER
508%{_browserpluginsconfdir}/browsers.d/%{name}.*
509%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
510%dir %{_sysconfdir}/%{name}
511%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
0562b864 512%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
f1b276d4
ER
513%attr(755,root,root) %{_bindir}/%{name}
514%{_mandir}/man1/%{name}.1*
11ad81c4 515%{_desktopdir}/*.desktop
0eb19b0b 516%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89 517%dir %{_libdir}/%{name}
e9abb380 518%{_libdir}/%{name}/chrome*.pak
c14cd342 519%{_libdir}/%{name}/content_resources.pak
97fac491 520%{_libdir}/%{name}/resources.pak
589d90ea 521%dir %{_libdir}/%{name}/locales
f1b276d4
ER
522%{_libdir}/%{name}/locales/en-US.pak
523%dir %{_libdir}/%{name}/resources
a3140cd1 524%{_libdir}/%{name}/resources/inspector
f1b276d4
ER
525%dir %{_libdir}/%{name}/themes
526%dir %{_libdir}/%{name}/extensions
527%dir %{_libdir}/%{name}/plugins
528%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 529# These unique permissions are intentional and necessary for the sandboxing
e53ecfb5 530%attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
f1b276d4
ER
531
532# ffmpeg libs
fcc48c19 533%if %{without system_ffmpeg}
f1b276d4 534%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 535%endif
f1b276d4 536
164020eb
ER
537%if %{with nacl}
538%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
539%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
540%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
541%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
542%endif
543
f1b276d4
ER
544%files l10n -f %{name}.lang
545%defattr(644,root,root,755)
This page took 0.185636 seconds and 4 git commands to generate.