]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
up to 39.0.2171.71
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  cups                    # with cups
4 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
5 %bcond_with     dev                     # with dev optimizations (skip clean source)
6 %bcond_without  gconf                   # with GConf
7 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
8 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
9 %bcond_with             gps                     # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
10 %bcond_without  libjpegturbo    # use libjpeg-turbo features
11 %bcond_with     nacl                    # build Native Client support, disabled: http://crbug.com/269560
12 %bcond_without  ninja                   # use Ninja instead of make to build
13 %bcond_without  pulseaudio              # with pulseaudio
14 %bcond_without  sandboxing              # with sandboxing
15 %bcond_with             selinux                 # with SELinux (need policy first)
16 %bcond_with             shared_libs             # with shared libs
17 %bcond_with             sse2                    # use SSE2 instructions
18 %bcond_without  system_flac             # system flac
19 %bcond_with     system_ffmpeg   # system ffmpeg instead of ffmpegsumo
20 %bcond_without  system_harfbuzz # system harfbuzz
21 %bcond_without  system_icu      # system icu
22 %bcond_without  system_jsoncpp  # system jsoncpp
23 %bcond_without  system_libexif  # system libexif
24 %bcond_without  system_libmtp   # system libmtp
25 %bcond_with     system_libusb   # system libusb-1, disabled: http://crbug.com/266149
26 %bcond_without  system_libwebp  # system libwebp
27 %bcond_without  system_libxnvctrl       # system libxnvctrl
28 %bcond_with     system_mesa             # system Mesa
29 %bcond_without  system_minizip  # system minizip
30 %bcond_without  system_opus             # system opus codec support, http://www.opus-codec.org/examples/
31 %bcond_without  system_protobuf # system protobuf
32 %bcond_without  system_re2              # system re2
33 %bcond_without  system_snappy   # system snappy
34 %bcond_without  system_speex    # system speex
35 %bcond_with     system_sqlite   # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
36 %bcond_without  system_libsrtp  # system srtp (can be used if using bundled libjingle)
37 %bcond_with             system_v8               # system v8
38 %bcond_with     system_libvpx   # system libvpx
39 %bcond_without  system_yasm             # system yasm
40 %bcond_without  system_zlib             # system zlib
41 %bcond_with     tcmalloc                # use tcmalloc
42 %bcond_without  verbose                 # verbose build (V=1)
43
44 %ifarch %{ix86}
45 # GLsizeiptr different size, track: http://bugs.gentoo.org/457130
46 %undefine       with_system_mesa
47
48 # unable build with debuginfo on 32bit build systems
49 # /usr/bin/ld.gold: fatal error: chrome: mmap: failed to allocate 2994044872 bytes for output file: Cannot allocate memory
50 %undefine       with_debuginfo
51 %endif
52
53 %ifarch %{x8664}
54 # x86_64 systems fail with debugedit crashing
55 # /usr/lib/rpm/bin/debugedit: canonicalization unexpectedly shrank by one character
56 %undefine       with_debuginfo
57 %endif
58
59 # TODO
60 # - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
61 # - use_system_skia
62 # - use_system_ssl (use_openssl: http://crbug.com/62803)
63 # - use_system_stlport (android specific)
64 # - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
65
66 # NOTES:
67 # - mute BEEP mixer if you do not want to hear horrible system bell when
68 #   pressing home/end in url bar or more ^F search results on page.
69 # - space considerations:
70 #   - unpacked sources: ~490MiB
71 #   - built code: ~1.4GiB (x86_64/i686)
72 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
73 # - to look for new tarball, use update-source.sh script
74
75 %define         branch          39.0.2171
76 %define         basever         71
77 #define         patchver        122
78 %define         gyp_rev 1014
79 Summary:        A WebKit powered web browser
80 Name:           chromium-browser
81 %if "%{?patchver}" != ""
82 Version:        %{branch}.%{patchver}
83 %else
84 Version:        %{branch}.%{basever}
85 %endif
86 Release:        1
87 License:        BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
88 Group:          X11/Applications/Networking
89 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
90 # Source0-md5:  238cbf816f3d3c01a58894a32eb9995d
91 %if "%{?patchver}" != ""
92 Patch0:         http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
93 # Patch0-md5:   7c392cf685e1cd16dba424af2eb6f4f4
94 %endif
95 Source1:        %{name}.default
96 Source2:        %{name}.sh
97 Source3:        %{name}.desktop
98 Source5:        find-lang.sh
99 Source6:        update-source.sh
100 Source7:        clean-source.sh
101 Source8:        get-source.sh
102 Source9:        master_preferences.json
103 Patch2:         enable-video-decode-accel.patch
104 Patch4:         path-libpdf.patch
105 Patch7:         dlopen_sonamed_gl.patch
106 Patch8:         chromium_useragent.patch.in
107 # https://bugs.gentoo.org/show_bug.cgi?id=393471
108 # libjpeg-turbo >= 1.1.90 supports that feature
109 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
110 Patch15:        nacl-build-irt.patch
111 Patch16:        nacl-linkingfix.patch
112 Patch18:        nacl-no-untar.patch
113 Patch24:        nacl-verbose.patch
114 Patch25:        gnome3-volume-control.patch
115 Patch26:        master-prefs-path.patch
116 Patch28:        system-mesa.patch
117 Patch31:        system-jinja.patch
118 Patch32:        remove_bundled_libraries-stale.patch
119 Patch35:        etc-dir.patch
120 Patch36:        angle.patch
121 Patch37:        %{name}-build.patch
122 URL:            http://www.chromium.org/Home
123 %{?with_gconf:BuildRequires:    GConf2-devel}
124 %{?with_system_mesa:BuildRequires:      Mesa-libGL-devel >= 9.1}
125 BuildRequires:  Mesa-libGLES-devel >= 9.1
126 %{?with_system_mesa:BuildRequires:      Mesa-libGLU-devel}
127 %{?with_system_mesa:BuildRequires:      Mesa-libOSMesa-devel >= 9.1}
128 BuildRequires:  alsa-lib-devel
129 BuildRequires:  atk-devel
130 BuildRequires:  bison
131 BuildRequires:  bzip2-devel
132 %{?with_nacl:BuildRequires:     crossnacl-binutils >= 2.20.1}
133 %{?with_nacl:BuildRequires:     crossnacl-gcc >= 4.4.3}
134 %{?with_nacl:BuildRequires:     crossnacl-gcc-c++ >= 4.4.3}
135 %{?with_nacl:BuildRequires:     crossnacl-newlib >= 1.20.0-3}
136 %{?with_cups:BuildRequires:     cups-devel}
137 BuildRequires:  elfutils-devel
138 BuildRequires:  expat-devel
139 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 1.0}
140 %{?with_system_flac:BuildRequires:      flac-devel >= 1.2.1-7}
141 BuildRequires:  fontconfig-devel
142 BuildRequires:  glib2-devel
143 BuildRequires:  gperf
144 %{?with_gps:BuildRequires:      gpsd-devel}
145 BuildRequires:  gtest-devel
146 BuildRequires:  gtk+2-devel
147 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-devel}
148 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-icu-devel}
149 %{?with_kerberos:BuildRequires: heimdal-devel}
150 BuildRequires:  hicolor-icon-theme
151 %{?with_system_jsoncpp:BuildRequires:   jsoncpp-devel}
152 %{?with_system_libxnvctrl:BuildRequires:        libXNVCtrl-devel >= 310.19}
153 BuildRequires:  libevent-devel
154 %{?with_system_libexif:BuildRequires:   libexif-devel >= 1:0.6.21}
155 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
156 %{?with_system_icu:BuildRequires:       libicu-devel >= 4.6}
157 %{!?with_libjpegturbo:BuildRequires:    libjpeg-devel}
158 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
159 %{?with_system_libmtp:BuildRequires:    libmtp-devel >= 1.1.3}
160 BuildRequires:  libpng-devel
161 %{?with_selinux:BuildRequires:  libselinux-devel}
162 BuildRequires:  libstdc++-devel
163 %{?with_system_libusb:BuildRequires:    libusb-devel >= 1.0}
164 %{?with_system_libvpx:BuildRequires:    libvpx-devel >= 1.3.0}
165 %{?with_system_libwebp:BuildRequires:   libwebp-devel >= 0.4.0}
166 BuildRequires:  libxml2-devel
167 BuildRequires:  libxslt-devel
168 BuildRequires:  man-db
169 %{?with_system_minizip:BuildRequires:   minizip-devel}
170 %{?with_ninja:BuildRequires:    ninja >= 1.3.0}
171 BuildRequires:  nspr-devel
172 BuildRequires:  nss-devel >= 1:3.12.3
173 %{?with_system_opus:BuildRequires:      opus-devel >= 1.0.2}
174 BuildRequires:  pam-devel
175 BuildRequires:  pango-devel
176 BuildRequires:  pciutils-devel
177 BuildRequires:  perl-JSON
178 BuildRequires:  perl-modules
179 BuildRequires:  pkgconfig
180 %{?with_system_protobuf:BuildRequires:  protobuf-devel}
181 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
182 BuildRequires:  python
183 #BuildRequires: python-gyp >= 1-%{gyp_rev}
184 BuildRequires:  python-jinja2 >= 2.7
185 BuildRequires:  python-modules
186 BuildRequires:  python-ply >= 3.4
187 %{?with_system_re2:BuildRequires:       re2-devel >= 20130115-2}
188 BuildRequires:  rpm >= 4.4.9-56
189 BuildRequires:  rpmbuild(macros) >= 1.453
190 %{?with_system_snappy:BuildRequires:    snappy-devel}
191 BuildRequires:  speech-dispatcher-devel >= 0.8
192 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
193 %{?with_system_sqlite:BuildRequires:    sqlite3-devel >= 3.7}
194 %{?with_system_libsrtp:BuildRequires:   srtp-devel >= 1.4.4}
195 BuildRequires:  tar >= 1:1.22
196 BuildRequires:  udev-devel
197 BuildRequires:  usbutils
198 BuildRequires:  util-linux
199 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
200 BuildRequires:  which
201 BuildRequires:  xorg-lib-libXScrnSaver-devel
202 BuildRequires:  xorg-lib-libXtst-devel
203 BuildRequires:  xz
204 %{?with_system_yasm:BuildRequires:      yasm}
205 %{?with_system_zlib:BuildRequires:      zlib-devel}
206 Requires:       browser-plugins >= 2.0
207 Requires:       desktop-file-utils
208 %{?with_system_flac:Requires:   flac >= 1.2.1-7}
209 # crashes if no fontconfig font present
210 Requires:       fonts-Type1-urw
211 Requires:       hicolor-icon-theme
212 Requires:       libevent >= 2.0.21
213 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
214 %{?with_system_libvpx:Requires: libvpx >= 1.3.0}
215 Requires:       lsb-release
216 %{?with_system_re2:Requires:    re2 >= 20130115-2}
217 %{?with_system_protobuf:Requires:       protobuf-libs >= 2.5.0-2}
218 Requires:       shared-mime-info
219 %{?with_system_sqlite:Requires: sqlite3(icu)}
220 Requires:       xdg-utils >= 1.0.2-4
221 Requires:       xorg-lib-libX11 >= 1.4.99.1
222 Provides:       wwwbrowser
223 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
224 Obsoletes:      chromium-browser-inspector < 15.0.863.0
225 ExclusiveArch:  %{ix86} %{x8664} arm
226 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
227
228 # Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
229 # Note: these are for PLD Linux use ONLY.
230 # For your own distribution, please get your own set of keys.
231 %define         google_api_key AIzaSyD1tTgDbP-N6BGXKZ7VqSos_IU1QflGbyg
232 %define         google_default_client_id 724288223830.apps.googleusercontent.com
233 %define         google_default_client_secret rHmKOPygcI6G-clFHb-RfuHb
234
235 %define         find_lang       sh find-lang.sh %{buildroot}
236
237 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
238 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
239
240 %ifarch %{ix86}
241 %define         target_arch ia32
242 %endif
243 %ifarch %{x8664}
244 %define         target_arch x64
245 %endif
246
247 %define         buildtype       %{?debug:Debug}%{!?debug:Release}
248 %define         builddir        out/%{buildtype}
249
250 %if %{without debuginfo}
251 %define         _enable_debug_packages  0
252 %endif
253
254 %description
255 Chromium is an open-source browser project that aims to build a safer,
256 faster, and more stable way for all Internet users to experience the
257 web.
258
259 Chromium serves as a base for Google Chrome, which is Chromium
260 rebranded (name and logo) with very few additions such as usage
261 tracking and an auto-updater system.
262
263 %package l10n
264 Summary:        chromium-browser language packages
265 Group:          I18n
266 Requires:       %{name} = %{version}-%{release}
267 %if "%{_rpmversion}" >= "5"
268 BuildArch:      noarch
269 %endif
270
271 %description l10n
272 Chromium is an open-source browser project that aims to build a safer,
273 faster, and more stable way for all Internet users to experience the
274 web.
275
276 This package contains language packages for 50 languages:
277
278 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
279 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
280 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
281 zh-TW
282
283 %prep
284 %setup -qc
285 %if "%{?patchver}" != ""
286 cd chromium*-%{branch}.%{basever}
287 %patch0 -p1
288 cd ..
289 %endif
290 mv chromium*-%{branch}.%{basever}/* .
291
292 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
293 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
294 . ./chrome/VERSION
295 chrome=$MAJOR.$MINOR.$BUILD.$PATCH
296 test "$chrome" = %{version}
297
298 gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
299 test "$gyp_rev" = %{gyp_rev} || :
300
301 # add chromium and pld to useragent
302 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
303 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
304         -e 's/@BUILD_DIST_NAME@/PLD/g' \
305         -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
306         < %{PATCH8} | %{__patch} -p1
307
308 %{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
309 ln -s %{SOURCE7} .
310
311 #%patch2 -p1 NOT COMPILING
312 %patch4 -p3
313 %patch7 -p1
314 %patch15 -p2
315 %{!?with_libjpegturbo:%patch11 -p0}
316 %patch16 -p1
317 %patch28 -p1
318 %patch25 -p1
319 %{?with_nacl:%patch18 -p1}
320 %patch24 -p1
321 %patch26 -p2
322 %patch31 -p0
323 %patch32 -p1
324 %patch35 -p1
325 %patch36 -p1
326 %patch37 -p1
327
328 %{?with_dev:exit 0}
329
330 sh -x clean-source.sh \
331         %{!?with_nacl:nacl=0} \
332         %{!?with_system_libvpx:libvpx=0} \
333         %{!?with_system_libxnvctrl:libXNVCtrl=0} \
334         %{!?with_system_mesa:mesa=0} \
335         %{!?with_system_protobuf:protobuf=0} \
336         %{!?with_system_re2:re2=0} \
337         %{!?with_system_snappy:snappy=0} \
338         %{!?with_system_sqlite:sqlite=0} \
339         %{!?with_system_v8:v8=0} \
340         %{!?with_system_libwebp:libwebp=0} \
341         %{!?with_system_zlib:zlib=0} \
342         %{!?with_system_ffmpeg:ffmpeg=0} \
343         %{nil}
344
345 %build
346 %if %{with nacl}
347 rm -rf native_client/toolchain/linux_x86_newlib
348 if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
349 # Make symlinks for NaCL
350 install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
351
352 cd native_client/toolchain/linux_x86_newlib
353 ln -s x86_64-nacl/bin bin
354 cd x86_64-nacl/bin
355 __cc='%{__cc}'
356 if [ "${__cc#ccache}" != "$__cc" ]; then
357         echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
358         echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
359         %{__sed} -i -e '1i#!/bin/sh' gcc g++
360         chmod +x gcc g++
361 else
362         ln -s %{_bindir}/x86_64-nacl-gcc gcc
363         ln -s %{_bindir}/x86_64-nacl-g++ g++
364 fi
365 ln -s gcc x86_64-nacl-gcc
366 ln -s g++ x86_64-nacl-g++
367 ln -s %{_bindir}/x86_64-nacl-ar .
368 ln -s %{_bindir}/x86_64-nacl-ar ar
369 ln -s %{_bindir}/x86_64-nacl-as as
370 ln -s %{_bindir}/x86_64-nacl-ranlib .
371 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
372 ln -s %{_bindir}/x86_64-nacl-strip .
373 ln -s %{_bindir}/x86_64-nacl-strip strip
374 ln -s %{_bindir}/x86_64-nacl-objcopy .
375 ln -s %{_prefix}/x86_64-nacl/lib ../lib
376 ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
377 ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
378 cd ../../../../..
379 fi
380 %endif
381
382 %if %{without system_ffmpeg}
383 if [ ! -d third_party/ffmpeg/build.%{target_arch}.linux ]; then
384         # Re-configure bundled ffmpeg
385         cd third_party/ffmpeg
386         chromium/scripts/build_ffmpeg.py linux %{target_arch} \
387                 --branding Chromium
388         chromium/scripts/copy_config.sh
389         chromium/scripts/generate_gyp.py
390         cd -
391 fi
392 %endif
393
394 third_party/libaddressinput/chromium/tools/update-strings.py
395
396 flags="
397         -Dtarget_arch=%{target_arch} \
398         -Dpython_arch=%{target_arch} \
399         -Dffmpeg_branding=Chromium \
400         -Dsystem_libdir=%{_lib} \
401         -Dpython_ver=%{py_ver} \
402 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
403         -Dno_strict_aliasing=1 -Dgcc_version=44 \
404 %endif
405         %{!?debug:-Dwerror= -Ddisable_fatal_linker_warnings=} \
406         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
407         %{?with_shared_libs:-Dlibrary=shared_library} \
408         %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} \
409         -Dinclude_tests__=0 \
410 %if %{with nacl}
411         -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
412         -Ddisable_glibc_untar=1 \
413         -Ddisable_newlib_untar=1 \
414         -Ddisable_glibc=1 \
415         -Ddisable_pnacl=1 \
416         -Dbuild_pnacl_newlib=0 \
417 %else
418         -Ddisable_pnacl_untar=1 \
419         -Ddisable_nacl=1 \
420 %endif
421         %{!?with_sse2:-Ddisable_sse2=1} \
422         %{?with_selinux:-Dselinux=1} \
423         -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
424         -Dlinux_link_libpci=1 \
425         -Dlinux_link_libspeechd=1 -Dlibspeechd_h_prefix=speech-dispatcher/ \
426         -Duse_allocator=%{!?with_tcmalloc:none}%{?with_tcmalloc:tcmalloc} \
427         %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
428         -Dclang=0 \
429         -Dhost_clang=0 \
430         -Dlinux_use_bundled_binutils=0 \
431         -Dlinux_use_bundled_gold=0 \
432         -Dlinux_use_gold_flags=0 \
433         -Dlogging_like_official_build=1 \
434         -Dgoogle_api_key=%{google_api_key} \
435         -Dgoogle_default_client_id=%{google_default_client_id} \
436         -Dgoogle_default_client_secret=%{google_default_client_secret} \
437         %{gyp_with cups} \
438         %{gyp_with gconf} -Dlinux_link_gsettings=0 \
439         %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
440         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
441         %{gyp_with pulseaudio} \
442         %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
443         %{gyp_with system_flac} \
444         %{gyp_with system_harfbuzz} \
445         %{gyp_with system_icu} %{?with_system_icu:-Dicu_use_data_file_flag=0} \
446         %{gyp_with system_jsoncpp} \
447         %{gyp_with system_libexif} \
448         %{gyp_with system_libmtp} \
449         %{gyp_with system_libsrtp} \
450         %{gyp_with system_libusb} \
451         %{gyp_with system_libvpx} -Dmedia_use_libvpx=1 \
452         %{gyp_with system_libwebp} \
453         %{gyp_with system_libxnvctrl} \
454         %{gyp_with system_mesa} \
455         %{gyp_with system_minizip} \
456         %{gyp_with system_opus} \
457         %{gyp_with system_protobuf} \
458         %{gyp_with system_re2} \
459         %{gyp_with system_snappy} \
460         %{gyp_with system_speex} \
461         %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
462         %{gyp_with system_v8} \
463         %{gyp_with system_yasm} \
464         %{gyp_with system_zlib} \
465         -Duse_system_bzip2=1 \
466         -Duse_system_expat=1 \
467         -Duse_system_libevent=1 \
468         -Duse_system_libjpeg=1 \
469         -Duse_system_libpng=1 \
470         -Duse_system_libxml=1 \
471         -Duse_system_libxslt=1 \
472         -Duse_system_nspr=1 \
473         -Duse_system_xdg_utils=1 \
474 "
475
476 build/linux/unbundle/replace_gyp_files.py $flags
477
478 %if %{with ninja}
479 chkfile=%{builddir}/build.ninja
480 %else
481 chkfile=Makefile
482 %endif
483 test %{_specdir}/%{name}.spec -nt $chkfile && %{__rm} -f $chkfile
484 test -e $chkfile || \
485         CC="%{__cc}" \
486         CXX="%{__cxx}" \
487         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
488         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
489         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
490         CC_host="%{__cc}" \
491         CXX_host="%{__cxx}" \
492         LD_host="%{__cxx}" \
493 %{__python} build/gyp_chromium \
494         --format=%{?with_ninja:ninja}%{!?with_ninja:make} \
495         --depth=. \
496         build/all.gyp \
497         $flags
498
499 %if %{with ninja}
500 ninja %{?_smp_mflags} %{?with_verbose:-v} -C %{builddir} \
501 %else
502 # need {CC/CXX/LDFLAGS}.host overrides for v8 build
503 %{__make} -r \
504         BUILDTYPE=%{buildtype} \
505         %{?with_verbose:V=1} \
506         CC.host="%{__cc}" \
507         CXX.host="%{__cxx}" \
508         LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
509 %endif
510         chrome %{?with_sandboxing:chrome_sandbox} \
511         %{nil}
512
513 cd %{builddir}
514 MANWIDTH=80 man ./chrome.1 > man.out
515 %{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
516
517 %install
518 rm -rf $RPM_BUILD_ROOT
519 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
520         $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
521         $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_desktopdir}} \
522         $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{native-messaging-hosts,policies/managed}
523
524 cd %{builddir}
525 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
526 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
527 %{__sed} -i -e '
528         s,@libdir@,%{_libdir}/%{name},
529
530         /@OPTIONS@/ {
531                 r options.txt
532                 d
533         }
534 ' $RPM_BUILD_ROOT%{_bindir}/%{name}
535 cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
536 cp -p *.pak $RPM_BUILD_ROOT%{_libdir}/%{name}
537 ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
538 ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
539 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
540 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
541 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome-sandbox
542 %if %{without system_ffmpeg}
543 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
544 %endif
545 install -p libpdf.so $RPM_BUILD_ROOT%{_libdir}/%{name}
546 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
547 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
548
549 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
550
551 %if %{with nacl}
552 # Install Native Client files on platforms that support it.
553 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
554 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
555 %ifarch %{x8664}
556 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
557 %endif
558 %ifarch %{ix86}
559 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
560 %endif
561 %endif
562
563 cd -
564
565 for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
566         size=${icon##*/product_logo_}
567         size=${size%.png}
568
569         # this will skip non-numeric (22_mono_invert, 22_mono)
570         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
571         test -d "$dir" || continue
572
573         install -d $RPM_BUILD_ROOT$dir
574         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
575 done
576
577 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
578 # http://code.google.com/p/chromium/issues/detail?id=24507
579 gecko-mediaplayer*.so
580 EOF
581
582 # find locales
583 %find_lang %{name}.lang
584 # always package en-US
585 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
586
587 %clean
588 rm -rf $RPM_BUILD_ROOT
589
590 %pretrans
591 for d in locales resources; do
592         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
593                 install -d %{_datadir}/%{name}
594                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
595         fi
596 done
597 exit 0
598
599 %post
600 %update_icon_cache hicolor
601 %update_desktop_database
602 %update_browser_plugins
603
604 %postun
605 if [ "$1" = 0 ]; then
606         %update_icon_cache hicolor
607         %update_browser_plugins
608 fi
609
610 %files
611 %defattr(644,root,root,755)
612 %doc AUTHORS LICENSE
613 %{_browserpluginsconfdir}/browsers.d/%{name}.*
614 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
615 %dir %{_sysconfdir}/%{name}
616 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
617 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
618 %dir %{_sysconfdir}/%{name}/native-messaging-hosts
619 %dir %{_sysconfdir}/%{name}/policies
620 %dir %{_sysconfdir}/%{name}/policies/managed
621 %attr(755,root,root) %{_bindir}/%{name}
622 %{_mandir}/man1/%{name}.1*
623 %{_desktopdir}/*.desktop
624 %{_iconsdir}/hicolor/*/apps/%{name}.png
625 %dir %{_libdir}/%{name}
626 %{_libdir}/%{name}/chrome*.pak
627 %{_libdir}/%{name}/content_resources.pak
628 %{_libdir}/%{name}/keyboard_resources.pak
629 %{_libdir}/%{name}/resources.pak
630 %{_libdir}/%{name}/locales
631 %{_libdir}/%{name}/resources
632
633 # conflicts with browser-plugin-chrome-pdf?
634 %attr(755,root,root) %{_libdir}/%{name}/libpdf.so
635
636 %dir %{_datadir}/%{name}
637 %dir %{_datadir}/%{name}/locales
638 %{_datadir}/%{name}/locales/en-US.pak
639 %dir %{_datadir}/%{name}/resources
640 %{_datadir}/%{name}/resources/inspector
641
642 %dir %{_libdir}/%{name}/plugins
643 %attr(755,root,root) %{_libdir}/%{name}/%{name}
644 # These unique permissions are intentional and necessary for the sandboxing
645 %attr(4555,root,root) %{_libdir}/%{name}/chrome-sandbox
646
647 # ffmpeg libs
648 %if %{without system_ffmpeg}
649 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
650 %endif
651
652 %if %{with nacl}
653 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
654 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
655 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
656 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
657 %endif
658
659 %files l10n -f %{name}.lang
660 %defattr(644,root,root,755)
This page took 0.180874 seconds and 3 git commands to generate.