]> git.pld-linux.org Git - packages/chromium-browser.git/commitdiff
up to 39.0.2171.71 auto/th/chromium-browser-39.0.2171.71-1
authorElan Ruusamäe <glen@delfi.ee>
Thu, 4 Dec 2014 20:08:07 +0000 (22:08 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Thu, 4 Dec 2014 22:16:26 +0000 (00:16 +0200)
chromium-browser.spec
clean-source.sh
system-jinja.patch
system-ply.patch [deleted file]

index 04c4d0eaa73ddafcafe1c256665e74a534ebc860..95485a02e14ee87bcb8c8acf46a8ccc4a4782170 100644 (file)
@@ -18,6 +18,7 @@
 %bcond_without system_flac             # system flac
 %bcond_with    system_ffmpeg   # system ffmpeg instead of ffmpegsumo
 %bcond_without system_harfbuzz # system harfbuzz
+%bcond_without system_icu      # system icu
 %bcond_without system_jsoncpp  # system jsoncpp
 %bcond_without system_libexif  # system libexif
 %bcond_without system_libmtp   # system libmtp
@@ -71,9 +72,9 @@
 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
 # - to look for new tarball, use update-source.sh script
 
-%define                branch          38.0.2125
-%define                basever         101
-%define                patchver        122
+%define                branch          39.0.2171
+%define                basever         71
+#define                patchver        122
 %define                gyp_rev 1014
 Summary:       A WebKit powered web browser
 Name:          chromium-browser
@@ -82,11 +83,11 @@ Version:    %{branch}.%{patchver}
 %else
 Version:       %{branch}.%{basever}
 %endif
-Release:       3
+Release:       1
 License:       BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
 Group:         X11/Applications/Networking
 Source0:       http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
-# Source0-md5: f2ec6a50864d8b2ddcda0baef50e9c33
+# Source0-md5: 238cbf816f3d3c01a58894a32eb9995d
 %if "%{?patchver}" != ""
 Patch0:                http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
 # Patch0-md5:  7c392cf685e1cd16dba424af2eb6f4f4
@@ -113,7 +114,6 @@ Patch24:    nacl-verbose.patch
 Patch25:       gnome3-volume-control.patch
 Patch26:       master-prefs-path.patch
 Patch28:       system-mesa.patch
-Patch30:       system-ply.patch
 Patch31:       system-jinja.patch
 Patch32:       remove_bundled_libraries-stale.patch
 Patch35:       etc-dir.patch
@@ -153,7 +153,7 @@ BuildRequires:      hicolor-icon-theme
 BuildRequires: libevent-devel
 %{?with_system_libexif:BuildRequires:  libexif-devel >= 1:0.6.21}
 %{?with_keyring:BuildRequires: libgnome-keyring-devel}
-BuildRequires: libicu-devel >= 4.6
+%{?with_system_icu:BuildRequires:      libicu-devel >= 4.6}
 %{!?with_libjpegturbo:BuildRequires:   libjpeg-devel}
 %{?with_libjpegturbo:BuildRequires:    libjpeg-turbo-devel >= 1.2.0}
 %{?with_system_libmtp:BuildRequires:   libmtp-devel >= 1.1.3}
@@ -319,8 +319,7 @@ ln -s %{SOURCE7} .
 %{?with_nacl:%patch18 -p1}
 %patch24 -p1
 %patch26 -p2
-#%patch30 -p1
-#%patch31 -p0
+%patch31 -p0
 %patch32 -p1
 %patch35 -p1
 %patch36 -p1
@@ -443,6 +442,7 @@ flags="
        %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
        %{gyp_with system_flac} \
        %{gyp_with system_harfbuzz} \
+       %{gyp_with system_icu} %{?with_system_icu:-Dicu_use_data_file_flag=0} \
        %{gyp_with system_jsoncpp} \
        %{gyp_with system_libexif} \
        %{gyp_with system_libmtp} \
@@ -464,7 +464,6 @@ flags="
        %{gyp_with system_zlib} \
        -Duse_system_bzip2=1 \
        -Duse_system_expat=1 \
-       -Duse_system_icu=1 -Dicu_use_data_file_flag=0 \
        -Duse_system_libevent=1 \
        -Duse_system_libjpeg=1 \
        -Duse_system_libpng=1 \
index 36238cf090aa2662f333b00da229126acdaf9f0b..917d500a7644219528d439a889f27d01a80a70a0 100755 (executable)
@@ -85,7 +85,7 @@ remove_nonessential_dirs() {
        chrome/browser/ui/webui/ntp/android \
        chrome/browser/ui/webui/options/chromeos \
        chrome/common/extensions/docs \
-       chrome/common/mac \
+       chrome/common/mac_ \
        chrome/installer/mac \
        chrome/installer/mac/third_party/xz/config/mac \
        chrome/installer/tools \
@@ -606,6 +606,7 @@ clean_third_party() {
                '!' -path 'third_party/cld/*' \
                '!' -path 'third_party/cld_2/*' \
                '!' -path 'third_party/cros_system_api/*' \
+               '!' -path 'third_party/cython/python_flags.py' \
                '!' -path 'third_party/dom_distiller_js/*' \
                '!' -path 'third_party/ffmpeg/*' \
                '!' -path 'third_party/fips181/*' \
@@ -1065,6 +1066,7 @@ remove_bundled_libraries() {
                'third_party/cacheinvalidation' \
                'third_party/cld_2' \
                'third_party/cros_system_api' \
+               'third_party/cython/python_flags.py' \
                'third_party/dom_distiller_js' \
                'third_party/dom_distiller_js/package/proto_gen/third_party/dom_distiller_js' \
                'third_party/ffmpeg' \
@@ -1099,7 +1101,6 @@ remove_bundled_libraries() {
                'third_party/pdfium/third_party/numerics' \
                'third_party/pdfium/third_party/template_util.h' \
                'third_party/polymer' \
-               'third_party/protobuf' \
                'third_party/qcms' \
                'third_party/readability' \
                'third_party/sfntly' \
index 6a3ae46b7697ee3eaaa201f77f63719483b702d8..fe28e12c333c3ab995bde4d6dea27e6f6a555829 100644 (file)
              'hasher.py',
              'in_file.py',
              'in_generator.py',
---- third_party/WebKit/Source/bindings/core/v8/generated.gyp.orig      2014-08-19 10:15:53.874850750 +0000
-+++ third_party/WebKit/Source/bindings/core/v8/generated.gyp   2014-08-19 10:16:04.163050746 +0000
-@@ -80,7 +80,6 @@
-       # Update that regex if command line changes (other than changing flags)
-       'action': [
-         'python',
--        '-S',  # skip 'import site' to speed up startup
-         '<(bindings_scripts_dir)/idl_compiler.py',
-         '--cache-dir',
-         '<(bindings_scripts_output_dir)',
---- third_party/WebKit/Source/bindings/modules/v8/generated.gyp.orig   2014-08-19 10:17:07.340279760 +0000
-+++ third_party/WebKit/Source/bindings/modules/v8/generated.gyp        2014-08-19 10:17:13.556400768 +0000
-@@ -68,7 +68,6 @@
-       # Update that regex if command line changes (other than changing flags)
-       'action': [
-         'python',
--        '-S',  # skip 'import site' to speed up startup
-         '<(bindings_scripts_dir)/idl_compiler.py',
-         '--cache-dir',
-         '<(bindings_scripts_output_dir)',
 --- third_party/WebKit/Source/bindings/scripts/scripts.gypi.orig       2014-08-19 10:53:02.824618979 +0000
 +++ third_party/WebKit/Source/bindings/scripts/scripts.gypi    2014-08-19 10:53:20.784957370 +0000
 @@ -12,9 +12,6 @@
diff --git a/system-ply.patch b/system-ply.patch
deleted file mode 100644 (file)
index 068eaad..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./third_party/WebKit/Source/bindings/derived_sources.gyp.orig      2013-09-09 17:53:37.709978765 +0000
-+++ ./third_party/WebKit/Source/bindings/derived_sources.gyp   2013-09-09 17:53:50.540054303 +0000
-@@ -57,8 +57,6 @@
-     ],
-     'compiler_module_files': [
-         'scripts/idl_compiler.py',
--        '<(DEPTH)/third_party/ply/lex.py',
--        '<(DEPTH)/third_party/ply/yacc.py',
-         '<(DEPTH)/tools/idl_parser/idl_lexer.py',
-         '<(DEPTH)/tools/idl_parser/idl_node.py',
-         '<(DEPTH)/tools/idl_parser/idl_parser.py',
This page took 0.050102 seconds and 4 git commands to generate.