]> git.pld-linux.org Git - packages/cacti-plugin-npc.git/blob - cacti-plugin-npc.spec
- add todo
[packages/cacti-plugin-npc.git] / cacti-plugin-npc.spec
1 #TODO
2 #-  Edit the MySQL options on line 143 of /cacti/plugins/npc/neb/inserter.c
3 %define         namesrc npc
4 %include        /usr/lib/rpm/macros.perl
5 Summary:        Plugin for Cacti - NPC
6 Summary(pl):    Wtyczka do Cacti - NPC
7 Name:           cacti-plugin-npc
8 Version:        0.1.1a
9 Release:        0.1
10 License:        GPL v2
11 Group:          Applications/WWW
12 Source0:        http://www.divagater.com/npc/%{namesrc}-%{version}.tar.gz
13 # Source0-md5:  325f2e49070420346b55b7b4e2994d34
14 URL:            http://www.divagater.com/npc/
15 BuildRequires:  rpm-perlprov
16 BuildRequires:  nagios-devel
17 BuildRequires:  mysql-devel >= 4.1.0
18 Requires:       cacti >= 0.8.6h # with plugin-architecture
19 Requires:       nagios >= 2.0b4  ### compiled with --enable-event-broker
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         webcactipluginroot /usr/share/cacti/plugins/%{namesrc}
23 %define         pathtonagiosmodules     /path/to/nagios/modules
24
25 %description
26 Plugin for Cacti - A UI replacement for Nagios integrated into Cacti.
27
28 %description -l pl
29 Wtyczka do Cacti - zamiennik interfejsu u¿ytkownika dla Nagiosa
30 zintegrowany z Cacti.
31
32 %prep
33 %setup -q -n %{namesrc}
34
35 %build
36 # copy ./npc/neb/inserter.c and ./npc/neb/makefile to module/ under Nagios source directory and run make.
37 cd ./neb
38 %{__make}
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 install -d $RPM_BUILD_ROOT%{webcactipluginroot}
43 install -d $RPM_BUILD_ROOT%{pathtonagiosmodules}
44 install ./neb/inserter.o $RPM_BUILD_ROOT%{pathtonagiosmodules}
45 rm -fr ./neb
46 cp -aRf * $RPM_BUILD_ROOT%{webcactipluginroot}
47
48 # Edit nagios.cfg and set:
49 #
50 #        retain_state_information=0
51 #        event_broker_options=-1
52 #        broker_module=%{pathtonagiosmodules}/inserter.o
53
54 # Setting retain_state_information=0 causes all hosts and services to
55 # go to a pending state until rechecked by Nagios. Without this setting
56 # the inserter module will never update any data in NPC. Its a minor
57 # inconvenience that I will try to fix in the inserter module.
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc TODO README 
65 %{webcactipluginroot}
66 %{pathtonagiosmodules}/inserter.o
This page took 0.141201 seconds and 4 git commands to generate.