]> git.pld-linux.org Git - packages/cacti-plugin-npc.git/commitdiff
- add todo
authorMichał 'Wolvverine' Panasiewicz <wolvverine@pld-linux.org>
Mon, 27 Mar 2006 03:01:05 +0000 (03:01 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- NFY
- TODO compile module for nagios
- TODO integration with nagios

Changed files:
    cacti-plugin-npc.spec -> 1.5

cacti-plugin-npc.spec

index 29ed2ccef45d420784832f77d20d860bb52d86c3..40d30094243929483359b42045f5a0002e5c2fc2 100644 (file)
@@ -1,3 +1,5 @@
+#TODO
+#-  Edit the MySQL options on line 143 of /cacti/plugins/npc/neb/inserter.c
 %define                namesrc npc
 %include       /usr/lib/rpm/macros.perl
 Summary:       Plugin for Cacti - NPC
@@ -11,11 +13,14 @@ Source0:    http://www.divagater.com/npc/%{namesrc}-%{version}.tar.gz
 # Source0-md5: 325f2e49070420346b55b7b4e2994d34
 URL:           http://www.divagater.com/npc/
 BuildRequires: rpm-perlprov
-Requires:      cacti
-BuildArch:     noarch
+BuildRequires: nagios-devel
+BuildRequires: mysql-devel >= 4.1.0
+Requires:      cacti >= 0.8.6h # with plugin-architecture
+Requires:      nagios >= 2.0b4  ### compiled with --enable-event-broker
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                webcactipluginroot /usr/share/cacti/plugins/%{namesrc}
+%define                pathtonagiosmodules     /path/to/nagios/modules
 
 %description
 Plugin for Cacti - A UI replacement for Nagios integrated into Cacti.
@@ -27,11 +32,30 @@ zintegrowany z Cacti.
 %prep
 %setup -q -n %{namesrc}
 
+%build
+# copy ./npc/neb/inserter.c and ./npc/neb/makefile to module/ under Nagios source directory and run make.
+cd ./neb
+%{__make}
+
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{webcactipluginroot}
+install -d $RPM_BUILD_ROOT%{pathtonagiosmodules}
+install ./neb/inserter.o $RPM_BUILD_ROOT%{pathtonagiosmodules}
+rm -fr ./neb
 cp -aRf * $RPM_BUILD_ROOT%{webcactipluginroot}
 
+# Edit nagios.cfg and set:
+#
+#        retain_state_information=0
+#        event_broker_options=-1
+#        broker_module=%{pathtonagiosmodules}/inserter.o
+
+# Setting retain_state_information=0 causes all hosts and services to
+# go to a pending state until rechecked by Nagios. Without this setting
+# the inserter module will never update any data in NPC. Its a minor
+# inconvenience that I will try to fix in the inserter module.
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -39,3 +63,4 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc TODO README 
 %{webcactipluginroot}
+%{pathtonagiosmodules}/inserter.o
This page took 0.094034 seconds and 4 git commands to generate.