]> git.pld-linux.org Git - packages/wine.git/blame - wine.spec
- Obsoletes for old wine-doc-pdf package
[packages/wine.git] / wine.spec
CommitLineData
7a30e9d7 1#
2# Conditional build:
931f130b
JB
3%bcond_without alsa # don't build ALSA mm driver
4%bcond_without arts # don't build aRts mm driver
931f130b 5%bcond_without jack # don't build JACK mm driver
a393647c 6%bcond_without nas # don't build NAS mm driver
16e36f25
JB
7%bcond_without sane # don't build TWAIN DLL with scanning support (through SANE)
8%bcond_without cups # without CUPS printing support in winspool,wineps DLLs
7a30e9d7 9#
546bbb82 10# NOTE: wine detects the following SONAMES for dlopen at build time:
16e36f25
JB
11# libcrypto,libssl (wininet.dll)
12# libcups (winspool.dll.so,wineps.dll.so)
13# libcurses/libncurses (wineconsole program)
14# libfontconfig (gdi32.dll.so)
15# libfreetype (wineps.dll.so,gdi32.dll.so)
16# libGL (x11drv.dll.so,ddraw.dll.so)
17# libjack (winejack.drv.so - explicit dependency in subpackage)
e7acaf22 18# libX11, libXext, libXi, libXrender (x11drv.dll.so)
546bbb82 19# thus requires rebuild after change of any of the above.
931f130b
JB
20#
21# JACK requires ALSA
666ba35e 22%if !%{with alsa}
931f130b
JB
23%undefine with_jack
24%endif
698e86e7 25Summary: Program that lets you launch Win applications
93e41e44
ER
26Summary(es.UTF-8): Ejecuta programas Windows en Linux
27Summary(pl.UTF-8): Program pozwalający uruchamiać aplikacje Windows
28Summary(pt_BR.UTF-8): Executa programas Windows no Linux
5c4ec57b 29Name: wine
14685caf 30Version: 0.9.34
a4a10255 31Release: 1
46114a9a 32Epoch: 1
528c1138 33License: LGPL
5c4ec57b 34Group: Applications/Emulators
46114a9a 35Source0: http://ibiblio.org/pub/linux/system/emulators/wine/%{name}-%{version}.tar.bz2
14685caf 36# Source0-md5: 0a06628d3be8f3b28a263f9f5f2c66bc
b68a79ec 37Patch0: %{name}-fontcache.patch
a0ff0658 38Patch1: %{name}-makedep.patch
a4a10255 39Patch2: %{name}-ncurses.patch
1803184e 40#PatchX: %{name}-dga.patch
1b3d8891 41URL: http://www.winehq.org/
489ca66c 42BuildRequires: OpenGL-GLU-devel
6547534c
KK
43%{?with_alsa:BuildRequires: alsa-lib-devel}
44%{?with_arts:BuildRequires: artsc-devel}
c7af491d
JB
45BuildRequires: autoconf
46BuildRequires: automake
d3c41437 47BuildRequires: bison
5715e1d1 48%{?with_cups:BuildRequires: cups-devel}
f88a3451 49BuildRequires: docbook-dtd31-sgml
50BuildRequires: docbook-utils
5fc34681 51BuildRequires: flex
16e36f25 52BuildRequires: fontconfig-devel
22432818 53BuildRequires: fontforge
5fc34681 54BuildRequires: freetype-devel >= 2.0.5
734deeec 55BuildRequires: giflib-devel
931f130b 56%{?with_jack:BuildRequires: jack-audio-connection-kit-devel}
5fc34681 57BuildRequires: libjpeg-devel
1e160e6e 58BuildRequires: libtool
931f130b 59%{?with_nas:BuildRequires: nas-devel}
8a1d358f 60BuildRequires: ncurses-devel
16e36f25
JB
61# db2* failed previously - probably openjade or opensp bug
62BuildRequires: openjade >= 1:1.3.3-0.pre1
63BuildRequires: opensp >= 1:1.5.1
2c81f5eb 64BuildRequires: openssl-devel >= 0.9.7d
5715e1d1 65%{?with_sane:BuildRequires: sane-backends-devel}
452e2226 66BuildRequires: valgrind
c66c3406 67BuildRequires: xorg-lib-libXi-devel
68BuildRequires: xorg-lib-libXmu-devel
69BuildRequires: xorg-lib-libXrender-devel
70BuildRequires: xorg-lib-libXxf86dga-devel
71BuildRequires: xorg-lib-libXxf86vm-devel
2a437456 72Requires: binfmt-detector
52b6007b
JB
73# link to wine/ntdll.dll.so, without any SONAME
74Provides: libntdll.dll.so
7212da21 75Obsoletes: wine-doc-pdf
d9590b9e 76ExclusiveArch: %{ix86}
206eed29 77ExcludeArch: i386
0403821a 78BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
5c4ec57b 79
e8f81a0a 80%define _noautoreqdep libGL.so.1 libGLU.so.1
81%define no_install_post_strip 1
82
e8f81a0a 83%define _winedir %{_datadir}/%{name}
6731627f 84
65c325f6 85%define getsoname() %((objdump -p %{1} 2>/dev/null || echo SONAME ERROR) | awk '/SONAME/ { print $2; s=1 }; END { if(s==0) print "ERROR" }')
16e36f25 86
344ce2c2 87%undefine debuginfocflags
88
5c4ec57b 89%description
6731627f 90Wine is a program which allows running Microsoft Windows programs
a519bc4f 91(including DOS, Windows 3.x and Win32 executables) on Unix. It
92consists of a program loader which loads and executes a Microsoft
93Windows binary, and a library that implements Windows API calls using
94their Unix or X11 equivalents. The library may also be used for
95porting Win32 code into native Unix executables.
5c4ec57b 96
c967e47d 97%description -l es.UTF-8
f33a1517 98Ejecuta programas Windows en Linux.
99
c967e47d
JR
100%description -l pl.UTF-8
101Wine jest programem dzięki któremu można uruchamiać programy napisane
102dla Microsoft Windows pod systemami uniksowymi. Składa się on z
103loadera, który pozwala wczytywać i uruchamiać programy w formacie
104Microsoft Windows, oraz z biblioteki, która implementuje API Windows
105przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
106także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
5c4ec57b 107
c967e47d
JR
108%description -l pt_BR.UTF-8
109O Wine é um programa que permite rodar programas MS-Windows no X11.
f33a1517 110Ele consiste de um carregador de programa, que carrega e executa um
c967e47d 111binário MS-Windows, e de uma biblioteca de emulação que traduz as
f33a1517 112chamadas da API para as equivalentes Unix/X11.
113
5c4ec57b 114%package devel
7a050f82 115Summary: Wine - header files
93e41e44
ER
116Summary(es.UTF-8): Biblioteca de desarrollo de wine
117Summary(pl.UTF-8): Wine - pliki nagłowkowe
118Summary(pt_BR.UTF-8): Biblioteca de desenvolvimento do wine
7a050f82 119Group: Development/Libraries
46114a9a 120Requires: %{name} = %{epoch}:%{version}-%{release}
6ab2e9fc 121
5c4ec57b 122%description devel
123Wine - header files.
124
c967e47d 125%description devel -l es.UTF-8
f33a1517 126Biblioteca de desarrollo de wine.
127
c967e47d
JR
128%description devel -l pl.UTF-8
129Wine - pliki nagłówkowe.
5c4ec57b 130
c967e47d
JR
131%description devel -l pt_BR.UTF-8
132Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
f33a1517 133WINE.
134
e8f81a0a 135%package programs
136Summary: Wine - programs
93e41e44 137Summary(pl.UTF-8): Wine - programy
e8f81a0a 138Group: Applications
46114a9a 139Requires: %{name} = %{epoch}:%{version}-%{release}
e8f81a0a 140
141%description programs
0a7c5d50 142Wine - programs.
e8f81a0a 143
c967e47d 144%description programs -l pl.UTF-8
0a7c5d50 145Wine - programy.
e8f81a0a 146
16e36f25
JB
147%package dll-d3d
148Summary: Direct3D implementation DLLs for Wine
93e41e44 149Summary(pl.UTF-8): Biblioteki DLL z implementacją Direct3D dla Wine
16e36f25 150Group: Applications/Emulators
46114a9a 151Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
152Requires: OpenGL
153
154%description dll-d3d
155Direct3D implementation DLLs for Wine (through OpenGL).
156
c967e47d
JR
157%description dll-d3d -l pl.UTF-8
158Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
16e36f25
JB
159
160%package dll-gl
161Summary: OpenGL implementation DLLs for Wine
93e41e44 162Summary(pl.UTF-8): Biblioteki DLL z implementacją OpenGL dla Wine
16e36f25 163Group: Applications/Emulators
46114a9a 164Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
165Requires: OpenGL
166
167%description dll-gl
168OpenGL implementation DLLs for Wine.
169
c967e47d
JR
170%description dll-gl -l pl.UTF-8
171Biblioteki DLL z implementacją OpenGL dla Wine.
16e36f25
JB
172
173%package dll-twain
174Summary: TWAIN implementation DLL for Wine
93e41e44 175Summary(pl.UTF-8): Biblioteka DLL z implementacją TWAIN dla Wine
16e36f25 176Group: Applications/Emulators
46114a9a 177Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
178
179%description dll-twain
180TWAIN implementation DLL for Wine (through SANE).
181
c967e47d
JR
182%description dll-twain -l pl.UTF-8
183Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
16e36f25
JB
184
185%package drv-alsa
186Summary: ALSA driver for WINE mm.dll implementation
93e41e44 187Summary(pl.UTF-8): Sterownik ALSA dla implementacji mm.dll w Wine
16e36f25 188Group: Applications/Emulators
46114a9a 189Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
190
191%description drv-alsa
192ALSA driver for WINE mm.dll (multimedia system) implementation.
193
c967e47d
JR
194%description drv-alsa -l pl.UTF-8
195Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
16e36f25
JB
196
197%package drv-arts
198Summary: aRts driver for WINE mm.dll implementation
93e41e44 199Summary(pl.UTF-8): Sterownik aRts dla implementacji mm.dll w Wine
16e36f25 200Group: Applications/Emulators
46114a9a 201Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
202
203%description drv-arts
204aRts driver for WINE mm.dll (multimedia system) implementation.
205
c967e47d
JR
206%description drv-arts -l pl.UTF-8
207Sterownik aRts dla implementacji mm.dll (systemu multimediów) w Wine.
16e36f25
JB
208
209%package drv-jack
210Summary: JACK driver for WINE mm.dll implementation
93e41e44 211Summary(pl.UTF-8): Sterownik JACK-a dla implementacji mm.dll w Wine
16e36f25 212Group: Applications/Emulators
46114a9a 213Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
214Requires: jack-audio-connection-kit
215# dlopened by SONAME detected at build time
42c123f0 216%{?with_jack:Requires: %{getsoname /usr/%{_lib}/libjack.so}}
16e36f25
JB
217
218%description drv-jack
219JACK driver for WINE mm.dll (multimedia system) implementation.
220
c967e47d
JR
221%description drv-jack -l pl.UTF-8
222Sterownik JACK-a dla implementacji mm.dll (systemu multimediów) w
b9f73ce4 223Wine.
16e36f25
JB
224
225%package drv-nas
226Summary: NAS driver for WINE mm.dll implementation
93e41e44 227Summary(pl.UTF-8): Sterownik NAS dla implementacji mm.dll w Wine
16e36f25 228Group: Applications/Emulators
46114a9a 229Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
230
231%description drv-nas
232NAS driver for WINE mm.dll (multimedia system) implementation.
233
c967e47d
JR
234%description drv-nas -l pl.UTF-8
235Sterownik NAS dla implementacji mm.dll (systemu multimediów) w Wine.
16e36f25 236
5c4ec57b 237%prep
238%setup -q
2fbbb535 239%patch0 -p1
240%patch1 -p1
ab25825d 241%patch2 -p1
591d55ba 242
243# turn off compilation of some tools
a6c536e0 244sed -i -e "s|winetest \\\|\\\|;s|avitools||" programs/Makefile.in
245#sed -i -e "s|avitools||" programs/Makefile.in
5c4ec57b 246
247%build
2fbbb535 248%{__autoconf}
103d8328 249%{__autoheader}
9d6a128d 250%configure \
2d927a35 251 %{!?debug:--disable-debug} \
252 %{!?debug:--disable-trace} \
8a1d358f 253 --enable-curses \
c40010b9 254 --enable-opengl \
698e86e7 255 --with-x
05eb066b 256%{__make} depend
4aafdd81 257%{__make}
e8f81a0a 258%{__make} -C programs
a393647c 259#%{__make} -C programs/regapi
e8f81a0a 260
5c4ec57b 261%install
262rm -rf $RPM_BUILD_ROOT
ffb676e0 263install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
5c4ec57b 264
c7af491d
JB
265%{__make} install \
266 DESTDIR=$RPM_BUILD_ROOT
267
268%{__make} -C programs install \
269 DESTDIR=$RPM_BUILD_ROOT
e8f81a0a 270
6a79cc08 271install tools/fnt2bdf $RPM_BUILD_ROOT%{_bindir}
f88a3451 272
0b87866b 273install aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
274#mv -f $RPM_BUILD_ROOT{/usr/X11R6/share/aclocal,%{_aclocaldir}}/wine.m4
275
2a437456 276install -d \
65c325f6 277 $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
278 "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
a91c2692 279 $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
280 $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
281 $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
282
a91c2692 283touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
284touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
285touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
286
287cat >$RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<EOF
288[mci]
289cdaudio=mcicda.drv
290sequencer=mciseq.drv
291waveaudio=mciwave.drv
292avivideo=mciavi.drv
293videodisc=mcipionr.drv
294vcr=mciviscd.drv
295MPEGVideo=mciqtz.drv
5c4ec57b 296EOF
297
e8f81a0a 298%if %{?debug:0}%{!?debug:1}
f1f3af79
JB
299echo "Strip executable binaries and shared object files."
300filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*"`
301elfexelist=`echo $filelist | xargs -r file | \
302 awk '/ELF.*executable/ {print $1}' | cut -d: -f1`
303elfsharedlist=`echo $filelist | xargs -r file | \
304 awk '/LF.*shared object/ {print $1}' | cut -d: -f1`; \
305if [ -n "$elfexelist" ]; then \
306 strip -R .note -R .comment $elfexelist
307fi
308if [ -n "$elfsharedlist" ]; then
65c325f6 309 strip --strip-unneeded -R .note -R .comment $elfsharedlist
f1f3af79 310fi
e8f81a0a 311%endif
f1f3af79 312
80496098 313# /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
5c4ec57b 314
c257af95 315programs="notepad progman regedit regsvr32 uninstaller wineconsole winefile winemine winepath winhelp"
0b87866b 316
8d493411 317BZZZ=`pwd`
318rm -f files.so; touch files.so
319rm -f files.programs; touch files.programs
55a96819 320cd $RPM_BUILD_ROOT%{_libdir}/wine
321for f in *.so; do
16e36f25 322 case $f in
1c5f02ef 323 d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|winearts.drv.so|winejack.drv.so|winenas.drv.so)
a6deb44f 324 ;;
325 *)
326 echo "%attr(755,root,root) %{_libdir}/wine/$f" >>$BZZZ/files.so
16e36f25 327 esac
55a96819 328done
329cd -
2f6853f9 330for p in $programs; do
8d493411 331 echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
332 echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
333 grep -v "$p\.exe\.so$" files.so > files.so.
334 mv -f files.so. files.so
55a96819 335done
55a96819 336
5c4ec57b 337%clean
338rm -rf $RPM_BUILD_ROOT
339
d142aa07 340%post -p /sbin/ldconfig
f1f3af79
JB
341%postun -p /sbin/ldconfig
342
d142aa07 343%triggerpostun -- wine < 1:0.9.12-1.9
ccb219e0 344rm -f /var/lock/subsys/wine
d142aa07
JB
345if [ -x /sbin/chkconfig ]; then
346 /sbin/chkconfig --del wine
347fi
348
55a96819 349%files -f files.so
5c4ec57b 350%defattr(644,root,root,755)
12057076 351%doc README ChangeLog AUTHORS ANNOUNCE
12b1296e 352%lang(de) %doc documentation/README.de
353%lang(es) %doc documentation/README.es
354%lang(fr) %doc documentation/README.fr
355%lang(it) %doc documentation/README.it
7b9e958b 356%lang(ko) %doc documentation/README.ko
58a0e5f4 357%lang(nb) %doc documentation/README.no
12b1296e 358%lang(pt) %doc documentation/README.pt
74de5921 359%lang(pt_BR) %doc documentation/README.pt_br
82432451 360%attr(755,root,root) %{_bindir}/msiexec
591d55ba 361%attr(755,root,root) %{_bindir}/wine
d479f953 362%attr(755,root,root) %{_bindir}/wineboot
34f03014 363%attr(755,root,root) %{_bindir}/winebrowser
d479f953 364%attr(755,root,root) %{_bindir}/winecfg
55a96819 365%attr(755,root,root) %{_bindir}/winedbg
5c36538d 366%attr(755,root,root) %{_bindir}/wine-kthread
1ae1bca2 367%attr(755,root,root) %{_bindir}/winelauncher
5c36538d 368%attr(755,root,root) %{_bindir}/wineprefixcreate
369%attr(755,root,root) %{_bindir}/wine-preloader
370%attr(755,root,root) %{_bindir}/wine-pthread
591d55ba 371%attr(755,root,root) %{_bindir}/wineserver
591d55ba 372%attr(755,root,root) %{_bindir}/wineshelllink
8a1d358f 373%attr(755,root,root) %{_libdir}/*.so*
861238d3 374%dir %{_libdir}/wine
489ca66c 375%{_libdir}/wine/*.dll16
376%{_libdir}/wine/*.drv16
377%{_libdir}/wine/*.exe16
b86f1c34 378%{_mandir}/man1/wine.1*
72ede285 379%{_mandir}/man1/winedbg.1*
b86f1c34
JB
380%{_mandir}/man1/wineprefixcreate.1*
381%{_mandir}/man1/wineserver.1*
a91c2692 382%{_winedir}
a6c536e0 383%{_desktopdir}/wine.desktop
5c4ec57b 384
55a96819 385%files programs -f files.programs
e8f81a0a 386%defattr(644,root,root,755)
e8f81a0a 387
5c4ec57b 388%files devel
389%defattr(644,root,root,755)
d479f953 390%attr(755,root,root) %{_bindir}/fnt2bdf
391%attr(755,root,root) %{_bindir}/function_grep.pl
d479f953 392%attr(755,root,root) %{_bindir}/widl
55a96819 393%attr(755,root,root) %{_bindir}/winebuild
55a96819 394%attr(755,root,root) %{_bindir}/winedump
1ae1bca2 395%attr(755,root,root) %{_bindir}/wineg++
d479f953 396%attr(755,root,root) %{_bindir}/winegcc
397%attr(755,root,root) %{_bindir}/winemaker
8593fdc2 398#%attr(755,root,root) %{_bindir}/winewrap
55a96819 399%attr(755,root,root) %{_bindir}/wmc
d479f953 400%attr(755,root,root) %{_bindir}/wrc
7265d9f2
JB
401%{_libdir}/wine/lib*.def
402# no shared variants, so not separated
403%{_libdir}/wine/lib*.def.a
404%{_libdir}/wine/libdx*.a
405%{_libdir}/wine/libstrmiids.a
406%{_libdir}/wine/libuuid.a
407%{_libdir}/wine/libwinecrt0.a
5c4ec57b 408%{_includedir}/wine
34f03014
JB
409%{_mandir}/man1/widl.1*
410%{_mandir}/man1/winedump.1*
bff06719 411%{_mandir}/man1/winegcc.1*
34f03014
JB
412%{_mandir}/man1/winemaker.1*
413%{_mandir}/man1/winebuild.1*
414%{_mandir}/man1/wmc.1*
415%{_mandir}/man1/wrc.1*
2b5050a8 416%{_aclocaldir}/*.m4
f18f723c 417
16e36f25
JB
418%files dll-d3d
419%defattr(644,root,root,755)
420%attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
421%attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
422%attr(755,root,root) %{_libdir}/wine/d3dx8.dll.so
423%attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
424
425%files dll-gl
426%defattr(644,root,root,755)
427%attr(755,root,root) %{_libdir}/wine/glu32.dll.so
428%attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
429
430%if %{with sane}
431%files dll-twain
432%defattr(644,root,root,755)
b08b16bf 433%attr(755,root,root) %{_libdir}/wine/sane.ds.so
72878a4c 434%attr(755,root,root) %{_libdir}/wine/twain*.dll.so
16e36f25
JB
435%endif
436
437%if %{with alsa}
438%files drv-alsa
439%defattr(644,root,root,755)
440%attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
441%endif
442
443%if %{with arts}
444%files drv-arts
445%defattr(644,root,root,755)
446%attr(755,root,root) %{_libdir}/wine/winearts.drv.so
447%endif
448
449%if %{with jack}
450%files drv-jack
451%defattr(644,root,root,755)
452%attr(755,root,root) %{_libdir}/wine/winejack.drv.so
453%endif
454
455%if %{with nas}
456%files drv-nas
457%defattr(644,root,root,755)
458%attr(755,root,root) %{_libdir}/wine/winenas.drv.so
459%endif
460
461# additional dependencies in *.so not separated (yet?) from main package
462# ddraw.dll.so,x11drv.dll.so depend on X11 libs
463# ole2disp.dll.so,oleaut32.dll.so,typelib.dll.so depend on lib(un)gif,libjpeg,libX11
464# ttydrv.dll.so depends on ncurses
This page took 0.145823 seconds and 4 git commands to generate.