]> git.pld-linux.org Git - packages/wine.git/blame - wine.spec
- corrected
[packages/wine.git] / wine.spec
CommitLineData
7a30e9d7 1#
2# Conditional build:
931f130b 3%bcond_without alsa # don't build ALSA mm driver
931f130b 4%bcond_without jack # don't build JACK mm driver
a393647c 5%bcond_without nas # don't build NAS mm driver
16e36f25
JB
6%bcond_without sane # don't build TWAIN DLL with scanning support (through SANE)
7%bcond_without cups # without CUPS printing support in winspool,wineps DLLs
7a30e9d7 8#
0d46bf62 9# NOTE: wineconsole is a bit broken: try wineconsole cmd to see what will happen
10# As a workaroound use `wineconsole --backend=user cmd' (works fine)
11#
546bbb82 12# NOTE: wine detects the following SONAMES for dlopen at build time:
16e36f25
JB
13# libcrypto,libssl (wininet.dll)
14# libcups (winspool.dll.so,wineps.dll.so)
15# libcurses/libncurses (wineconsole program)
16# libfontconfig (gdi32.dll.so)
17# libfreetype (wineps.dll.so,gdi32.dll.so)
18# libGL (x11drv.dll.so,ddraw.dll.so)
19# libjack (winejack.drv.so - explicit dependency in subpackage)
e7acaf22 20# libX11, libXext, libXi, libXrender (x11drv.dll.so)
546bbb82 21# thus requires rebuild after change of any of the above.
931f130b
JB
22#
23# JACK requires ALSA
c226320b 24%if %{without alsa}
931f130b
JB
25%undefine with_jack
26%endif
698e86e7 27Summary: Program that lets you launch Win applications
93e41e44
ER
28Summary(es.UTF-8): Ejecuta programas Windows en Linux
29Summary(pl.UTF-8): Program pozwalający uruchamiać aplikacje Windows
30Summary(pt_BR.UTF-8): Executa programas Windows no Linux
5c4ec57b 31Name: wine
0d46bf62 32Version: 0.9.41
96a957f0 33Release: 1
46114a9a 34Epoch: 1
528c1138 35License: LGPL
5c4ec57b 36Group: Applications/Emulators
46114a9a 37Source0: http://ibiblio.org/pub/linux/system/emulators/wine/%{name}-%{version}.tar.bz2
0d46bf62 38# Source0-md5: 014e3760c07ac71906ba47c27f0471ab
b68a79ec 39Patch0: %{name}-fontcache.patch
a0ff0658 40Patch1: %{name}-makedep.patch
a4a10255 41Patch2: %{name}-ncurses.patch
1803184e 42#PatchX: %{name}-dga.patch
1b3d8891 43URL: http://www.winehq.org/
489ca66c 44BuildRequires: OpenGL-GLU-devel
6547534c
KK
45%{?with_alsa:BuildRequires: alsa-lib-devel}
46%{?with_arts:BuildRequires: artsc-devel}
c7af491d
JB
47BuildRequires: autoconf
48BuildRequires: automake
d3c41437 49BuildRequires: bison
5715e1d1 50%{?with_cups:BuildRequires: cups-devel}
f88a3451 51BuildRequires: docbook-dtd31-sgml
52BuildRequires: docbook-utils
5fc34681 53BuildRequires: flex
16e36f25 54BuildRequires: fontconfig-devel
22432818 55BuildRequires: fontforge
5fc34681 56BuildRequires: freetype-devel >= 2.0.5
734deeec 57BuildRequires: giflib-devel
931f130b 58%{?with_jack:BuildRequires: jack-audio-connection-kit-devel}
5fc34681 59BuildRequires: libjpeg-devel
1e160e6e 60BuildRequires: libtool
931f130b 61%{?with_nas:BuildRequires: nas-devel}
8a1d358f 62BuildRequires: ncurses-devel
16e36f25
JB
63# db2* failed previously - probably openjade or opensp bug
64BuildRequires: openjade >= 1:1.3.3-0.pre1
65BuildRequires: opensp >= 1:1.5.1
2c81f5eb 66BuildRequires: openssl-devel >= 0.9.7d
5715e1d1 67%{?with_sane:BuildRequires: sane-backends-devel}
452e2226 68BuildRequires: valgrind
c66c3406 69BuildRequires: xorg-lib-libXi-devel
70BuildRequires: xorg-lib-libXmu-devel
71BuildRequires: xorg-lib-libXrender-devel
72BuildRequires: xorg-lib-libXxf86dga-devel
73BuildRequires: xorg-lib-libXxf86vm-devel
a88e781b 74#Suggests: binfmt-detector
52b6007b
JB
75# link to wine/ntdll.dll.so, without any SONAME
76Provides: libntdll.dll.so
7212da21 77Obsoletes: wine-doc-pdf
93b34e12 78Obsoletes: wine-drv-arts
d9590b9e 79ExclusiveArch: %{ix86}
206eed29 80ExcludeArch: i386
0403821a 81BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
5c4ec57b 82
e8f81a0a 83%define _noautoreqdep libGL.so.1 libGLU.so.1
84%define no_install_post_strip 1
85
e8f81a0a 86%define _winedir %{_datadir}/%{name}
6731627f 87
65c325f6 88%define getsoname() %((objdump -p %{1} 2>/dev/null || echo SONAME ERROR) | awk '/SONAME/ { print $2; s=1 }; END { if(s==0) print "ERROR" }')
16e36f25 89
344ce2c2 90%undefine debuginfocflags
91
5c4ec57b 92%description
6731627f 93Wine is a program which allows running Microsoft Windows programs
a519bc4f 94(including DOS, Windows 3.x and Win32 executables) on Unix. It
95consists of a program loader which loads and executes a Microsoft
96Windows binary, and a library that implements Windows API calls using
97their Unix or X11 equivalents. The library may also be used for
98porting Win32 code into native Unix executables.
5c4ec57b 99
c967e47d 100%description -l es.UTF-8
f33a1517 101Ejecuta programas Windows en Linux.
102
c967e47d
JR
103%description -l pl.UTF-8
104Wine jest programem dzięki któremu można uruchamiać programy napisane
105dla Microsoft Windows pod systemami uniksowymi. Składa się on z
106loadera, który pozwala wczytywać i uruchamiać programy w formacie
107Microsoft Windows, oraz z biblioteki, która implementuje API Windows
108przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
109także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
5c4ec57b 110
c967e47d
JR
111%description -l pt_BR.UTF-8
112O Wine é um programa que permite rodar programas MS-Windows no X11.
f33a1517 113Ele consiste de um carregador de programa, que carrega e executa um
c967e47d 114binário MS-Windows, e de uma biblioteca de emulação que traduz as
f33a1517 115chamadas da API para as equivalentes Unix/X11.
116
5c4ec57b 117%package devel
7a050f82 118Summary: Wine - header files
93e41e44
ER
119Summary(es.UTF-8): Biblioteca de desarrollo de wine
120Summary(pl.UTF-8): Wine - pliki nagłowkowe
121Summary(pt_BR.UTF-8): Biblioteca de desenvolvimento do wine
7a050f82 122Group: Development/Libraries
46114a9a 123Requires: %{name} = %{epoch}:%{version}-%{release}
6ab2e9fc 124
5c4ec57b 125%description devel
126Wine - header files.
127
c967e47d 128%description devel -l es.UTF-8
f33a1517 129Biblioteca de desarrollo de wine.
130
c967e47d
JR
131%description devel -l pl.UTF-8
132Wine - pliki nagłówkowe.
5c4ec57b 133
c967e47d
JR
134%description devel -l pt_BR.UTF-8
135Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
f33a1517 136WINE.
137
e8f81a0a 138%package programs
139Summary: Wine - programs
93e41e44 140Summary(pl.UTF-8): Wine - programy
e8f81a0a 141Group: Applications
46114a9a 142Requires: %{name} = %{epoch}:%{version}-%{release}
e8f81a0a 143
144%description programs
0a7c5d50 145Wine - programs.
e8f81a0a 146
c967e47d 147%description programs -l pl.UTF-8
0a7c5d50 148Wine - programy.
e8f81a0a 149
16e36f25
JB
150%package dll-d3d
151Summary: Direct3D implementation DLLs for Wine
93e41e44 152Summary(pl.UTF-8): Biblioteki DLL z implementacją Direct3D dla Wine
16e36f25 153Group: Applications/Emulators
46114a9a 154Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
155Requires: OpenGL
156
157%description dll-d3d
158Direct3D implementation DLLs for Wine (through OpenGL).
159
c967e47d
JR
160%description dll-d3d -l pl.UTF-8
161Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
16e36f25
JB
162
163%package dll-gl
164Summary: OpenGL implementation DLLs for Wine
93e41e44 165Summary(pl.UTF-8): Biblioteki DLL z implementacją OpenGL dla Wine
16e36f25 166Group: Applications/Emulators
46114a9a 167Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
168Requires: OpenGL
169
170%description dll-gl
171OpenGL implementation DLLs for Wine.
172
c967e47d
JR
173%description dll-gl -l pl.UTF-8
174Biblioteki DLL z implementacją OpenGL dla Wine.
16e36f25
JB
175
176%package dll-twain
177Summary: TWAIN implementation DLL for Wine
93e41e44 178Summary(pl.UTF-8): Biblioteka DLL z implementacją TWAIN dla Wine
16e36f25 179Group: Applications/Emulators
46114a9a 180Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
181
182%description dll-twain
183TWAIN implementation DLL for Wine (through SANE).
184
c967e47d
JR
185%description dll-twain -l pl.UTF-8
186Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
16e36f25
JB
187
188%package drv-alsa
189Summary: ALSA driver for WINE mm.dll implementation
93e41e44 190Summary(pl.UTF-8): Sterownik ALSA dla implementacji mm.dll w Wine
16e36f25 191Group: Applications/Emulators
46114a9a 192Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
193
194%description drv-alsa
195ALSA driver for WINE mm.dll (multimedia system) implementation.
196
c967e47d
JR
197%description drv-alsa -l pl.UTF-8
198Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
16e36f25 199
16e36f25
JB
200%package drv-jack
201Summary: JACK driver for WINE mm.dll implementation
93e41e44 202Summary(pl.UTF-8): Sterownik JACK-a dla implementacji mm.dll w Wine
16e36f25 203Group: Applications/Emulators
46114a9a 204Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
205Requires: jack-audio-connection-kit
206# dlopened by SONAME detected at build time
42c123f0 207%{?with_jack:Requires: %{getsoname /usr/%{_lib}/libjack.so}}
16e36f25
JB
208
209%description drv-jack
210JACK driver for WINE mm.dll (multimedia system) implementation.
211
c967e47d
JR
212%description drv-jack -l pl.UTF-8
213Sterownik JACK-a dla implementacji mm.dll (systemu multimediów) w
b9f73ce4 214Wine.
16e36f25
JB
215
216%package drv-nas
217Summary: NAS driver for WINE mm.dll implementation
93e41e44 218Summary(pl.UTF-8): Sterownik NAS dla implementacji mm.dll w Wine
16e36f25 219Group: Applications/Emulators
46114a9a 220Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
221
222%description drv-nas
223NAS driver for WINE mm.dll (multimedia system) implementation.
224
c967e47d
JR
225%description drv-nas -l pl.UTF-8
226Sterownik NAS dla implementacji mm.dll (systemu multimediów) w Wine.
16e36f25 227
5c4ec57b 228%prep
229%setup -q
2fbbb535 230%patch0 -p1
231%patch1 -p1
ab25825d 232%patch2 -p1
591d55ba 233
234# turn off compilation of some tools
a6c536e0 235sed -i -e "s|winetest \\\|\\\|;s|avitools||" programs/Makefile.in
236#sed -i -e "s|avitools||" programs/Makefile.in
5c4ec57b 237
238%build
2fbbb535 239%{__autoconf}
103d8328 240%{__autoheader}
9d6a128d 241%configure \
2d927a35 242 %{!?debug:--disable-debug} \
243 %{!?debug:--disable-trace} \
8a1d358f 244 --enable-curses \
c40010b9 245 --enable-opengl \
698e86e7 246 --with-x
05eb066b 247%{__make} depend
4aafdd81 248%{__make}
e8f81a0a 249%{__make} -C programs
a393647c 250#%{__make} -C programs/regapi
e8f81a0a 251
5c4ec57b 252%install
253rm -rf $RPM_BUILD_ROOT
ffb676e0 254install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
5c4ec57b 255
c7af491d
JB
256%{__make} install \
257 DESTDIR=$RPM_BUILD_ROOT
258
259%{__make} -C programs install \
260 DESTDIR=$RPM_BUILD_ROOT
e8f81a0a 261
6a79cc08 262install tools/fnt2bdf $RPM_BUILD_ROOT%{_bindir}
f88a3451 263
0b87866b 264install aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
265#mv -f $RPM_BUILD_ROOT{/usr/X11R6/share/aclocal,%{_aclocaldir}}/wine.m4
266
2a437456 267install -d \
65c325f6 268 $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
269 "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
a91c2692 270 $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
271 $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
272 $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
273
a91c2692 274touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
275touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
276touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
277
278cat >$RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<EOF
279[mci]
280cdaudio=mcicda.drv
281sequencer=mciseq.drv
282waveaudio=mciwave.drv
283avivideo=mciavi.drv
284videodisc=mcipionr.drv
285vcr=mciviscd.drv
286MPEGVideo=mciqtz.drv
5c4ec57b 287EOF
288
e8f81a0a 289%if %{?debug:0}%{!?debug:1}
f1f3af79
JB
290echo "Strip executable binaries and shared object files."
291filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*"`
292elfexelist=`echo $filelist | xargs -r file | \
293 awk '/ELF.*executable/ {print $1}' | cut -d: -f1`
294elfsharedlist=`echo $filelist | xargs -r file | \
295 awk '/LF.*shared object/ {print $1}' | cut -d: -f1`; \
296if [ -n "$elfexelist" ]; then \
297 strip -R .note -R .comment $elfexelist
298fi
299if [ -n "$elfsharedlist" ]; then
65c325f6 300 strip --strip-unneeded -R .note -R .comment $elfsharedlist
f1f3af79 301fi
e8f81a0a 302%endif
f1f3af79 303
80496098 304# /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
5c4ec57b 305
c257af95 306programs="notepad progman regedit regsvr32 uninstaller wineconsole winefile winemine winepath winhelp"
0b87866b 307
8d493411 308BZZZ=`pwd`
309rm -f files.so; touch files.so
310rm -f files.programs; touch files.programs
55a96819 311cd $RPM_BUILD_ROOT%{_libdir}/wine
312for f in *.so; do
16e36f25 313 case $f in
ce2cb51b 314 d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|winejack.drv.so|winenas.drv.so)
a6deb44f 315 ;;
316 *)
317 echo "%attr(755,root,root) %{_libdir}/wine/$f" >>$BZZZ/files.so
16e36f25 318 esac
55a96819 319done
320cd -
2f6853f9 321for p in $programs; do
8d493411 322 echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
323 echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
324 grep -v "$p\.exe\.so$" files.so > files.so.
325 mv -f files.so. files.so
55a96819 326done
55a96819 327
5c4ec57b 328%clean
329rm -rf $RPM_BUILD_ROOT
330
d142aa07 331%post -p /sbin/ldconfig
f1f3af79
JB
332%postun -p /sbin/ldconfig
333
d142aa07 334%triggerpostun -- wine < 1:0.9.12-1.9
ccb219e0 335rm -f /var/lock/subsys/wine
d142aa07
JB
336if [ -x /sbin/chkconfig ]; then
337 /sbin/chkconfig --del wine
338fi
339
55a96819 340%files -f files.so
5c4ec57b 341%defattr(644,root,root,755)
12057076 342%doc README ChangeLog AUTHORS ANNOUNCE
12b1296e 343%lang(de) %doc documentation/README.de
344%lang(es) %doc documentation/README.es
345%lang(fr) %doc documentation/README.fr
346%lang(it) %doc documentation/README.it
7b9e958b 347%lang(ko) %doc documentation/README.ko
58a0e5f4 348%lang(nb) %doc documentation/README.no
12b1296e 349%lang(pt) %doc documentation/README.pt
74de5921 350%lang(pt_BR) %doc documentation/README.pt_br
82432451 351%attr(755,root,root) %{_bindir}/msiexec
591d55ba 352%attr(755,root,root) %{_bindir}/wine
d479f953 353%attr(755,root,root) %{_bindir}/wineboot
34f03014 354%attr(755,root,root) %{_bindir}/winebrowser
d479f953 355%attr(755,root,root) %{_bindir}/winecfg
55a96819 356%attr(755,root,root) %{_bindir}/winedbg
5c36538d 357%attr(755,root,root) %{_bindir}/wine-kthread
1ae1bca2 358%attr(755,root,root) %{_bindir}/winelauncher
5c36538d 359%attr(755,root,root) %{_bindir}/wineprefixcreate
360%attr(755,root,root) %{_bindir}/wine-preloader
361%attr(755,root,root) %{_bindir}/wine-pthread
591d55ba 362%attr(755,root,root) %{_bindir}/wineserver
591d55ba 363%attr(755,root,root) %{_bindir}/wineshelllink
8a1d358f 364%attr(755,root,root) %{_libdir}/*.so*
861238d3 365%dir %{_libdir}/wine
489ca66c 366%{_libdir}/wine/*.dll16
367%{_libdir}/wine/*.drv16
368%{_libdir}/wine/*.exe16
b86f1c34 369%{_mandir}/man1/wine.1*
72ede285 370%{_mandir}/man1/winedbg.1*
b86f1c34
JB
371%{_mandir}/man1/wineprefixcreate.1*
372%{_mandir}/man1/wineserver.1*
a91c2692 373%{_winedir}
a6c536e0 374%{_desktopdir}/wine.desktop
5c4ec57b 375
55a96819 376%files programs -f files.programs
e8f81a0a 377%defattr(644,root,root,755)
e8f81a0a 378
5c4ec57b 379%files devel
380%defattr(644,root,root,755)
d479f953 381%attr(755,root,root) %{_bindir}/fnt2bdf
382%attr(755,root,root) %{_bindir}/function_grep.pl
d479f953 383%attr(755,root,root) %{_bindir}/widl
55a96819 384%attr(755,root,root) %{_bindir}/winebuild
55a96819 385%attr(755,root,root) %{_bindir}/winedump
1ae1bca2 386%attr(755,root,root) %{_bindir}/wineg++
d479f953 387%attr(755,root,root) %{_bindir}/winegcc
388%attr(755,root,root) %{_bindir}/winemaker
8593fdc2 389#%attr(755,root,root) %{_bindir}/winewrap
55a96819 390%attr(755,root,root) %{_bindir}/wmc
d479f953 391%attr(755,root,root) %{_bindir}/wrc
7265d9f2
JB
392%{_libdir}/wine/lib*.def
393# no shared variants, so not separated
394%{_libdir}/wine/lib*.def.a
395%{_libdir}/wine/libdx*.a
396%{_libdir}/wine/libstrmiids.a
397%{_libdir}/wine/libuuid.a
398%{_libdir}/wine/libwinecrt0.a
5c4ec57b 399%{_includedir}/wine
34f03014
JB
400%{_mandir}/man1/widl.1*
401%{_mandir}/man1/winedump.1*
bff06719 402%{_mandir}/man1/winegcc.1*
34f03014
JB
403%{_mandir}/man1/winemaker.1*
404%{_mandir}/man1/winebuild.1*
405%{_mandir}/man1/wmc.1*
406%{_mandir}/man1/wrc.1*
2b5050a8 407%{_aclocaldir}/*.m4
f18f723c 408
16e36f25
JB
409%files dll-d3d
410%defattr(644,root,root,755)
411%attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
412%attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
413%attr(755,root,root) %{_libdir}/wine/d3dx8.dll.so
414%attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
415
416%files dll-gl
417%defattr(644,root,root,755)
418%attr(755,root,root) %{_libdir}/wine/glu32.dll.so
419%attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
420
421%if %{with sane}
422%files dll-twain
423%defattr(644,root,root,755)
b08b16bf 424%attr(755,root,root) %{_libdir}/wine/sane.ds.so
72878a4c 425%attr(755,root,root) %{_libdir}/wine/twain*.dll.so
16e36f25
JB
426%endif
427
428%if %{with alsa}
429%files drv-alsa
430%defattr(644,root,root,755)
431%attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
432%endif
433
16e36f25
JB
434%if %{with jack}
435%files drv-jack
436%defattr(644,root,root,755)
437%attr(755,root,root) %{_libdir}/wine/winejack.drv.so
438%endif
439
440%if %{with nas}
441%files drv-nas
442%defattr(644,root,root,755)
443%attr(755,root,root) %{_libdir}/wine/winenas.drv.so
444%endif
445
446# additional dependencies in *.so not separated (yet?) from main package
447# ddraw.dll.so,x11drv.dll.so depend on X11 libs
448# ole2disp.dll.so,oleaut32.dll.so,typelib.dll.so depend on lib(un)gif,libjpeg,libX11
449# ttydrv.dll.so depends on ncurses
This page took 0.113063 seconds and 4 git commands to generate.