]> git.pld-linux.org Git - packages/wine.git/blame - wine.spec
- ExcludeArch: i386 (from Ac-branch)
[packages/wine.git] / wine.spec
CommitLineData
7a30e9d7 1#
2# Conditional build:
931f130b
JB
3%bcond_without alsa # don't build ALSA mm driver
4%bcond_without arts # don't build aRts mm driver
931f130b 5%bcond_without jack # don't build JACK mm driver
a393647c 6%bcond_without nas # don't build NAS mm driver
16e36f25
JB
7%bcond_without sane # don't build TWAIN DLL with scanning support (through SANE)
8%bcond_without cups # without CUPS printing support in winspool,wineps DLLs
7a30e9d7 9#
546bbb82 10# NOTE: wine detects the following SONAMES for dlopen at build time:
16e36f25
JB
11# libcrypto,libssl (wininet.dll)
12# libcups (winspool.dll.so,wineps.dll.so)
13# libcurses/libncurses (wineconsole program)
14# libfontconfig (gdi32.dll.so)
15# libfreetype (wineps.dll.so,gdi32.dll.so)
16# libGL (x11drv.dll.so,ddraw.dll.so)
17# libjack (winejack.drv.so - explicit dependency in subpackage)
e7acaf22 18# libX11, libXext, libXi, libXrender (x11drv.dll.so)
546bbb82 19# thus requires rebuild after change of any of the above.
931f130b
JB
20#
21# JACK requires ALSA
666ba35e 22%if !%{with alsa}
931f130b
JB
23%undefine with_jack
24%endif
698e86e7 25Summary: Program that lets you launch Win applications
93e41e44
ER
26Summary(es.UTF-8): Ejecuta programas Windows en Linux
27Summary(pl.UTF-8): Program pozwalający uruchamiać aplikacje Windows
28Summary(pt_BR.UTF-8): Executa programas Windows no Linux
5c4ec57b 29Name: wine
14685caf 30Version: 0.9.34
a4a10255 31Release: 1
46114a9a 32Epoch: 1
528c1138 33License: LGPL
5c4ec57b 34Group: Applications/Emulators
46114a9a 35Source0: http://ibiblio.org/pub/linux/system/emulators/wine/%{name}-%{version}.tar.bz2
14685caf 36# Source0-md5: 0a06628d3be8f3b28a263f9f5f2c66bc
b68a79ec 37Patch0: %{name}-fontcache.patch
a0ff0658 38Patch1: %{name}-makedep.patch
a4a10255 39Patch2: %{name}-ncurses.patch
1803184e 40#PatchX: %{name}-dga.patch
1b3d8891 41URL: http://www.winehq.org/
489ca66c 42BuildRequires: OpenGL-GLU-devel
6547534c
KK
43%{?with_alsa:BuildRequires: alsa-lib-devel}
44%{?with_arts:BuildRequires: artsc-devel}
c7af491d
JB
45BuildRequires: autoconf
46BuildRequires: automake
d3c41437 47BuildRequires: bison
5715e1d1 48%{?with_cups:BuildRequires: cups-devel}
f88a3451 49BuildRequires: docbook-dtd31-sgml
50BuildRequires: docbook-utils
5fc34681 51BuildRequires: flex
16e36f25 52BuildRequires: fontconfig-devel
22432818 53BuildRequires: fontforge
5fc34681 54BuildRequires: freetype-devel >= 2.0.5
734deeec 55BuildRequires: giflib-devel
931f130b 56%{?with_jack:BuildRequires: jack-audio-connection-kit-devel}
5fc34681 57BuildRequires: libjpeg-devel
1e160e6e 58BuildRequires: libtool
931f130b 59%{?with_nas:BuildRequires: nas-devel}
8a1d358f 60BuildRequires: ncurses-devel
16e36f25
JB
61# db2* failed previously - probably openjade or opensp bug
62BuildRequires: openjade >= 1:1.3.3-0.pre1
63BuildRequires: opensp >= 1:1.5.1
2c81f5eb 64BuildRequires: openssl-devel >= 0.9.7d
5715e1d1 65%{?with_sane:BuildRequires: sane-backends-devel}
452e2226 66BuildRequires: valgrind
c66c3406 67BuildRequires: xorg-lib-libXi-devel
68BuildRequires: xorg-lib-libXmu-devel
69BuildRequires: xorg-lib-libXrender-devel
70BuildRequires: xorg-lib-libXxf86dga-devel
71BuildRequires: xorg-lib-libXxf86vm-devel
2a437456 72Requires: binfmt-detector
52b6007b
JB
73# link to wine/ntdll.dll.so, without any SONAME
74Provides: libntdll.dll.so
d9590b9e 75ExclusiveArch: %{ix86}
206eed29 76ExcludeArch: i386
0403821a 77BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
5c4ec57b 78
e8f81a0a 79%define _noautoreqdep libGL.so.1 libGLU.so.1
80%define no_install_post_strip 1
81
e8f81a0a 82%define _winedir %{_datadir}/%{name}
6731627f 83
65c325f6 84%define getsoname() %((objdump -p %{1} 2>/dev/null || echo SONAME ERROR) | awk '/SONAME/ { print $2; s=1 }; END { if(s==0) print "ERROR" }')
16e36f25 85
344ce2c2 86%undefine debuginfocflags
87
5c4ec57b 88%description
6731627f 89Wine is a program which allows running Microsoft Windows programs
a519bc4f 90(including DOS, Windows 3.x and Win32 executables) on Unix. It
91consists of a program loader which loads and executes a Microsoft
92Windows binary, and a library that implements Windows API calls using
93their Unix or X11 equivalents. The library may also be used for
94porting Win32 code into native Unix executables.
5c4ec57b 95
c967e47d 96%description -l es.UTF-8
f33a1517 97Ejecuta programas Windows en Linux.
98
c967e47d
JR
99%description -l pl.UTF-8
100Wine jest programem dzięki któremu można uruchamiać programy napisane
101dla Microsoft Windows pod systemami uniksowymi. Składa się on z
102loadera, który pozwala wczytywać i uruchamiać programy w formacie
103Microsoft Windows, oraz z biblioteki, która implementuje API Windows
104przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
105także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
5c4ec57b 106
c967e47d
JR
107%description -l pt_BR.UTF-8
108O Wine é um programa que permite rodar programas MS-Windows no X11.
f33a1517 109Ele consiste de um carregador de programa, que carrega e executa um
c967e47d 110binário MS-Windows, e de uma biblioteca de emulação que traduz as
f33a1517 111chamadas da API para as equivalentes Unix/X11.
112
5c4ec57b 113%package devel
7a050f82 114Summary: Wine - header files
93e41e44
ER
115Summary(es.UTF-8): Biblioteca de desarrollo de wine
116Summary(pl.UTF-8): Wine - pliki nagłowkowe
117Summary(pt_BR.UTF-8): Biblioteca de desenvolvimento do wine
7a050f82 118Group: Development/Libraries
46114a9a 119Requires: %{name} = %{epoch}:%{version}-%{release}
6ab2e9fc 120
5c4ec57b 121%description devel
122Wine - header files.
123
c967e47d 124%description devel -l es.UTF-8
f33a1517 125Biblioteca de desarrollo de wine.
126
c967e47d
JR
127%description devel -l pl.UTF-8
128Wine - pliki nagłówkowe.
5c4ec57b 129
c967e47d
JR
130%description devel -l pt_BR.UTF-8
131Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
f33a1517 132WINE.
133
e8f81a0a 134%package programs
135Summary: Wine - programs
93e41e44 136Summary(pl.UTF-8): Wine - programy
e8f81a0a 137Group: Applications
46114a9a 138Requires: %{name} = %{epoch}:%{version}-%{release}
e8f81a0a 139
140%description programs
0a7c5d50 141Wine - programs.
e8f81a0a 142
c967e47d 143%description programs -l pl.UTF-8
0a7c5d50 144Wine - programy.
e8f81a0a 145
16e36f25
JB
146%package dll-d3d
147Summary: Direct3D implementation DLLs for Wine
93e41e44 148Summary(pl.UTF-8): Biblioteki DLL z implementacją Direct3D dla Wine
16e36f25 149Group: Applications/Emulators
46114a9a 150Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
151Requires: OpenGL
152
153%description dll-d3d
154Direct3D implementation DLLs for Wine (through OpenGL).
155
c967e47d
JR
156%description dll-d3d -l pl.UTF-8
157Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
16e36f25
JB
158
159%package dll-gl
160Summary: OpenGL implementation DLLs for Wine
93e41e44 161Summary(pl.UTF-8): Biblioteki DLL z implementacją OpenGL dla Wine
16e36f25 162Group: Applications/Emulators
46114a9a 163Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
164Requires: OpenGL
165
166%description dll-gl
167OpenGL implementation DLLs for Wine.
168
c967e47d
JR
169%description dll-gl -l pl.UTF-8
170Biblioteki DLL z implementacją OpenGL dla Wine.
16e36f25
JB
171
172%package dll-twain
173Summary: TWAIN implementation DLL for Wine
93e41e44 174Summary(pl.UTF-8): Biblioteka DLL z implementacją TWAIN dla Wine
16e36f25 175Group: Applications/Emulators
46114a9a 176Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
177
178%description dll-twain
179TWAIN implementation DLL for Wine (through SANE).
180
c967e47d
JR
181%description dll-twain -l pl.UTF-8
182Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
16e36f25
JB
183
184%package drv-alsa
185Summary: ALSA driver for WINE mm.dll implementation
93e41e44 186Summary(pl.UTF-8): Sterownik ALSA dla implementacji mm.dll w Wine
16e36f25 187Group: Applications/Emulators
46114a9a 188Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
189
190%description drv-alsa
191ALSA driver for WINE mm.dll (multimedia system) implementation.
192
c967e47d
JR
193%description drv-alsa -l pl.UTF-8
194Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
16e36f25
JB
195
196%package drv-arts
197Summary: aRts driver for WINE mm.dll implementation
93e41e44 198Summary(pl.UTF-8): Sterownik aRts dla implementacji mm.dll w Wine
16e36f25 199Group: Applications/Emulators
46114a9a 200Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
201
202%description drv-arts
203aRts driver for WINE mm.dll (multimedia system) implementation.
204
c967e47d
JR
205%description drv-arts -l pl.UTF-8
206Sterownik aRts dla implementacji mm.dll (systemu multimediów) w Wine.
16e36f25
JB
207
208%package drv-jack
209Summary: JACK driver for WINE mm.dll implementation
93e41e44 210Summary(pl.UTF-8): Sterownik JACK-a dla implementacji mm.dll w Wine
16e36f25 211Group: Applications/Emulators
46114a9a 212Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
213Requires: jack-audio-connection-kit
214# dlopened by SONAME detected at build time
42c123f0 215%{?with_jack:Requires: %{getsoname /usr/%{_lib}/libjack.so}}
16e36f25
JB
216
217%description drv-jack
218JACK driver for WINE mm.dll (multimedia system) implementation.
219
c967e47d
JR
220%description drv-jack -l pl.UTF-8
221Sterownik JACK-a dla implementacji mm.dll (systemu multimediów) w
b9f73ce4 222Wine.
16e36f25
JB
223
224%package drv-nas
225Summary: NAS driver for WINE mm.dll implementation
93e41e44 226Summary(pl.UTF-8): Sterownik NAS dla implementacji mm.dll w Wine
16e36f25 227Group: Applications/Emulators
46114a9a 228Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
229
230%description drv-nas
231NAS driver for WINE mm.dll (multimedia system) implementation.
232
c967e47d
JR
233%description drv-nas -l pl.UTF-8
234Sterownik NAS dla implementacji mm.dll (systemu multimediów) w Wine.
16e36f25 235
5c4ec57b 236%prep
237%setup -q
2fbbb535 238%patch0 -p1
239%patch1 -p1
ab25825d 240%patch2 -p1
591d55ba 241
242# turn off compilation of some tools
a6c536e0 243sed -i -e "s|winetest \\\|\\\|;s|avitools||" programs/Makefile.in
244#sed -i -e "s|avitools||" programs/Makefile.in
5c4ec57b 245
246%build
2fbbb535 247%{__autoconf}
103d8328 248%{__autoheader}
9d6a128d 249%configure \
2d927a35 250 %{!?debug:--disable-debug} \
251 %{!?debug:--disable-trace} \
8a1d358f 252 --enable-curses \
c40010b9 253 --enable-opengl \
698e86e7 254 --with-x
05eb066b 255%{__make} depend
4aafdd81 256%{__make}
e8f81a0a 257%{__make} -C programs
a393647c 258#%{__make} -C programs/regapi
e8f81a0a 259
5c4ec57b 260%install
261rm -rf $RPM_BUILD_ROOT
ffb676e0 262install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
5c4ec57b 263
c7af491d
JB
264%{__make} install \
265 DESTDIR=$RPM_BUILD_ROOT
266
267%{__make} -C programs install \
268 DESTDIR=$RPM_BUILD_ROOT
e8f81a0a 269
6a79cc08 270install tools/fnt2bdf $RPM_BUILD_ROOT%{_bindir}
f88a3451 271
0b87866b 272install aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
273#mv -f $RPM_BUILD_ROOT{/usr/X11R6/share/aclocal,%{_aclocaldir}}/wine.m4
274
2a437456 275install -d \
65c325f6 276 $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
277 "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
a91c2692 278 $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
279 $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
280 $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
281
a91c2692 282touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
283touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
284touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
285
286cat >$RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<EOF
287[mci]
288cdaudio=mcicda.drv
289sequencer=mciseq.drv
290waveaudio=mciwave.drv
291avivideo=mciavi.drv
292videodisc=mcipionr.drv
293vcr=mciviscd.drv
294MPEGVideo=mciqtz.drv
5c4ec57b 295EOF
296
e8f81a0a 297%if %{?debug:0}%{!?debug:1}
f1f3af79
JB
298echo "Strip executable binaries and shared object files."
299filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*"`
300elfexelist=`echo $filelist | xargs -r file | \
301 awk '/ELF.*executable/ {print $1}' | cut -d: -f1`
302elfsharedlist=`echo $filelist | xargs -r file | \
303 awk '/LF.*shared object/ {print $1}' | cut -d: -f1`; \
304if [ -n "$elfexelist" ]; then \
305 strip -R .note -R .comment $elfexelist
306fi
307if [ -n "$elfsharedlist" ]; then
65c325f6 308 strip --strip-unneeded -R .note -R .comment $elfsharedlist
f1f3af79 309fi
e8f81a0a 310%endif
f1f3af79 311
80496098 312# /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
5c4ec57b 313
c257af95 314programs="notepad progman regedit regsvr32 uninstaller wineconsole winefile winemine winepath winhelp"
0b87866b 315
8d493411 316BZZZ=`pwd`
317rm -f files.so; touch files.so
318rm -f files.programs; touch files.programs
55a96819 319cd $RPM_BUILD_ROOT%{_libdir}/wine
320for f in *.so; do
16e36f25 321 case $f in
1c5f02ef 322 d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|winearts.drv.so|winejack.drv.so|winenas.drv.so)
a6deb44f 323 ;;
324 *)
325 echo "%attr(755,root,root) %{_libdir}/wine/$f" >>$BZZZ/files.so
16e36f25 326 esac
55a96819 327done
328cd -
2f6853f9 329for p in $programs; do
8d493411 330 echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
331 echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
332 grep -v "$p\.exe\.so$" files.so > files.so.
333 mv -f files.so. files.so
55a96819 334done
55a96819 335
5c4ec57b 336%clean
337rm -rf $RPM_BUILD_ROOT
338
d142aa07 339%post -p /sbin/ldconfig
f1f3af79
JB
340%postun -p /sbin/ldconfig
341
d142aa07 342%triggerpostun -- wine < 1:0.9.12-1.9
ccb219e0 343rm -f /var/lock/subsys/wine
d142aa07
JB
344if [ -x /sbin/chkconfig ]; then
345 /sbin/chkconfig --del wine
346fi
347
55a96819 348%files -f files.so
5c4ec57b 349%defattr(644,root,root,755)
12057076 350%doc README ChangeLog AUTHORS ANNOUNCE
12b1296e 351%lang(de) %doc documentation/README.de
352%lang(es) %doc documentation/README.es
353%lang(fr) %doc documentation/README.fr
354%lang(it) %doc documentation/README.it
7b9e958b 355%lang(ko) %doc documentation/README.ko
58a0e5f4 356%lang(nb) %doc documentation/README.no
12b1296e 357%lang(pt) %doc documentation/README.pt
74de5921 358%lang(pt_BR) %doc documentation/README.pt_br
82432451 359%attr(755,root,root) %{_bindir}/msiexec
591d55ba 360%attr(755,root,root) %{_bindir}/wine
d479f953 361%attr(755,root,root) %{_bindir}/wineboot
34f03014 362%attr(755,root,root) %{_bindir}/winebrowser
d479f953 363%attr(755,root,root) %{_bindir}/winecfg
55a96819 364%attr(755,root,root) %{_bindir}/winedbg
5c36538d 365%attr(755,root,root) %{_bindir}/wine-kthread
1ae1bca2 366%attr(755,root,root) %{_bindir}/winelauncher
5c36538d 367%attr(755,root,root) %{_bindir}/wineprefixcreate
368%attr(755,root,root) %{_bindir}/wine-preloader
369%attr(755,root,root) %{_bindir}/wine-pthread
591d55ba 370%attr(755,root,root) %{_bindir}/wineserver
591d55ba 371%attr(755,root,root) %{_bindir}/wineshelllink
8a1d358f 372%attr(755,root,root) %{_libdir}/*.so*
861238d3 373%dir %{_libdir}/wine
489ca66c 374%{_libdir}/wine/*.dll16
375%{_libdir}/wine/*.drv16
376%{_libdir}/wine/*.exe16
b86f1c34 377%{_mandir}/man1/wine.1*
72ede285 378%{_mandir}/man1/winedbg.1*
b86f1c34
JB
379%{_mandir}/man1/wineprefixcreate.1*
380%{_mandir}/man1/wineserver.1*
a91c2692 381%{_winedir}
a6c536e0 382%{_desktopdir}/wine.desktop
5c4ec57b 383
55a96819 384%files programs -f files.programs
e8f81a0a 385%defattr(644,root,root,755)
e8f81a0a 386
5c4ec57b 387%files devel
388%defattr(644,root,root,755)
d479f953 389%attr(755,root,root) %{_bindir}/fnt2bdf
390%attr(755,root,root) %{_bindir}/function_grep.pl
d479f953 391%attr(755,root,root) %{_bindir}/widl
55a96819 392%attr(755,root,root) %{_bindir}/winebuild
55a96819 393%attr(755,root,root) %{_bindir}/winedump
1ae1bca2 394%attr(755,root,root) %{_bindir}/wineg++
d479f953 395%attr(755,root,root) %{_bindir}/winegcc
396%attr(755,root,root) %{_bindir}/winemaker
8593fdc2 397#%attr(755,root,root) %{_bindir}/winewrap
55a96819 398%attr(755,root,root) %{_bindir}/wmc
d479f953 399%attr(755,root,root) %{_bindir}/wrc
7265d9f2
JB
400%{_libdir}/wine/lib*.def
401# no shared variants, so not separated
402%{_libdir}/wine/lib*.def.a
403%{_libdir}/wine/libdx*.a
404%{_libdir}/wine/libstrmiids.a
405%{_libdir}/wine/libuuid.a
406%{_libdir}/wine/libwinecrt0.a
5c4ec57b 407%{_includedir}/wine
34f03014
JB
408%{_mandir}/man1/widl.1*
409%{_mandir}/man1/winedump.1*
bff06719 410%{_mandir}/man1/winegcc.1*
34f03014
JB
411%{_mandir}/man1/winemaker.1*
412%{_mandir}/man1/winebuild.1*
413%{_mandir}/man1/wmc.1*
414%{_mandir}/man1/wrc.1*
2b5050a8 415%{_aclocaldir}/*.m4
f18f723c 416
16e36f25
JB
417%files dll-d3d
418%defattr(644,root,root,755)
419%attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
420%attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
421%attr(755,root,root) %{_libdir}/wine/d3dx8.dll.so
422%attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
423
424%files dll-gl
425%defattr(644,root,root,755)
426%attr(755,root,root) %{_libdir}/wine/glu32.dll.so
427%attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
428
429%if %{with sane}
430%files dll-twain
431%defattr(644,root,root,755)
b08b16bf 432%attr(755,root,root) %{_libdir}/wine/sane.ds.so
72878a4c 433%attr(755,root,root) %{_libdir}/wine/twain*.dll.so
16e36f25
JB
434%endif
435
436%if %{with alsa}
437%files drv-alsa
438%defattr(644,root,root,755)
439%attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
440%endif
441
442%if %{with arts}
443%files drv-arts
444%defattr(644,root,root,755)
445%attr(755,root,root) %{_libdir}/wine/winearts.drv.so
446%endif
447
448%if %{with jack}
449%files drv-jack
450%defattr(644,root,root,755)
451%attr(755,root,root) %{_libdir}/wine/winejack.drv.so
452%endif
453
454%if %{with nas}
455%files drv-nas
456%defattr(644,root,root,755)
457%attr(755,root,root) %{_libdir}/wine/winenas.drv.so
458%endif
459
460# additional dependencies in *.so not separated (yet?) from main package
461# ddraw.dll.so,x11drv.dll.so depend on X11 libs
462# ole2disp.dll.so,oleaut32.dll.so,typelib.dll.so depend on lib(un)gif,libjpeg,libX11
463# ttydrv.dll.so depends on ncurses
This page took 0.268161 seconds and 4 git commands to generate.