]> git.pld-linux.org Git - packages/kde4-knetworkmanager.git/blame - kde4-knetworkmanager.spec
- remove nonsensical deps
[packages/kde4-knetworkmanager.git] / kde4-knetworkmanager.spec
CommitLineData
1083a40b 1#
a085f693 2# Conditional build:
3%bcond_with verbose # verbose build
4
7e7dd977 5%define qtver 4.6.4
a085f693 6%define origname networkmanagement
7
8Summary: Plasma applet that controls network via NetworkManager backend
9Name: kde4-knetworkmanager
26e290d6 10Version: 0.9.0.11
44ffd7df 11Release: 2
d2cd6ab5 12Epoch: 1
a085f693 13License: GPL v2
14Group: X11/Applications
6248bc32 15# git clone git://anongit.kde.org/networkmanagement.git
7e7dd977 16# git checkout nm09 (until is merged to master)
685f9e94 17Source0: ftp://ftp.kde.org/pub/kde/unstable/networkmanagement/%{version}/src/%{origname}-%{version}.tar.xz
26e290d6 18# Source0-md5: f1b5d6ae1cfd869ca2c377f3d4647cbf
6a7387ce 19Patch0: %{origname}-kill_rest_sr.patch
fa70895a 20Patch1: %{name}-solid.patch
a085f693 21URL: http://en.opensuse.org/Projects/KNetworkManager
685f9e94 22BuildRequires: NetworkManager-devel >= 2:0.9.8
a085f693 23BuildRequires: Qt3Support-devel >= %{qtver}
24BuildRequires: QtCore-devel >= %{qtver}
25BuildRequires: QtDBus-devel >= %{qtver}
26BuildRequires: QtGui-devel >= %{qtver}
27BuildRequires: QtNetwork-devel >= %{qtver}
28BuildRequires: QtXml-devel >= %{qtver}
29BuildRequires: automoc4 >= 0.9.88
837ab99b 30BuildRequires: cmake >= 2.8.0
f09d4d3b
JR
31BuildRequires: kde4-kdebase-workspace-devel
32BuildRequires: kde4-kdelibs-devel
e60e58f6 33BuildRequires: mobile-broadband-provider-info-devel
7e7dd977
AM
34BuildRequires: openconnect-devel >= 3.12
35BuildRequires: openssl-devel
a085f693 36BuildRequires: qt4-build >= %{qtver}
37BuildRequires: qt4-qmake >= %{qtver}
38BuildRequires: rpmbuild(macros) >= 1.293
d2cd6ab5 39Requires: NetworkManager >= 2:0.9.0
a085f693 40Obsoletes: kde4-kdeplasma-addons-networkmanager
41BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43%description
44Plasma applet that controls network via NetworkManager backend.
45
46%prep
6248bc32 47%setup -q -n %{origname}-%{version}
6a7387ce 48%patch0 -p1
fa70895a 49%patch1 -p1
a085f693 50
51%build
52install -d build
53cd build
54%cmake \
55 -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
56 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
57 %{?with_verbose:-DCMAKE_VERBOSE_MAKEFILE=true} \
58 -DDBUS_SYSTEM_POLICY_DIR=/etc/dbus-1/system.d \
59%if "%{_lib}" != "lib"
60 -DLIB_SUFFIX=64 \
61%endif
62 ../
63
64%{__make}
65
66%install
67rm -rf $RPM_BUILD_ROOT
68
69%{__make} -C build install \
70 DESTDIR=$RPM_BUILD_ROOT
71
5071f8da
BZ
72%find_lang %{name} --all-name
73
a085f693 74%clean
75rm -rf $RPM_BUILD_ROOT
76
77%post -p /sbin/ldconfig
78%postun -p /sbin/ldconfig
79
5071f8da 80%files -f %{name}.lang
a085f693 81%defattr(644,root,root,755)
82%doc DESIGN TODO
5071f8da
BZ
83#%config(noreplace) %verify(not md5 mtime size) /etc/dbus-1/system.d/*.conf
84
a085f693 85%attr(755,root,root) %{_libdir}/kde4/kcm_networkmanagement.so
a085f693 86%attr(755,root,root) %{_libdir}/kde4/kcm_networkmanagement_tray.so
87%attr(755,root,root) %{_libdir}/kde4/kded_networkmanagement.so
5071f8da 88%attr(755,root,root) %{_libdir}/kde4/libexec/networkmanagement_configshell
a085f693 89%attr(755,root,root) %{_libdir}/kde4/networkmanagement_novellvpnui.so
7e7dd977 90%attr(755,root,root) %{_libdir}/kde4/networkmanagement_openconnectui.so
5071f8da 91%attr(755,root,root) %{_libdir}/kde4/networkmanagement_openvpnui.so
a085f693 92%attr(755,root,root) %{_libdir}/kde4/networkmanagement_pptpui.so
29856f56 93%attr(755,root,root) %{_libdir}/kde4/networkmanagement_strongswanui.so
e60e58f6 94%attr(755,root,root) %{_libdir}/kde4/networkmanagement_vpncui.so
5071f8da
BZ
95%attr(755,root,root) %{_libdir}/kde4/plasma_applet_networkmanagement.so
96%attr(755,root,root) %{_libdir}/kde4/plasma_engine_networkmanagement.so
48023a29 97%attr(755,root,root) %{_libdir}/kde4/solid_modemmanager05.so
7e7dd977 98%attr(755,root,root) %{_libdir}/kde4/solid_networkmanager09.so
5071f8da
BZ
99%attr(755,root,root) %{_libdir}/libknmclient.so
100%attr(755,root,root) %{_libdir}/libknmclient.so.*.*.*
101%attr(755,root,root) %ghost %{_libdir}/libknmclient.so.?
102%attr(755,root,root) %{_libdir}/libknminternals.so
103%attr(755,root,root) %{_libdir}/libknminternals.so.*.*.*
104%attr(755,root,root) %ghost %{_libdir}/libknminternals.so.?
105%attr(755,root,root) %{_libdir}/libknm_nm.so
106%attr(755,root,root) %{_libdir}/libknmservice.so
107%attr(755,root,root) %{_libdir}/libknmservice.so.*.*.*
108%attr(755,root,root) %ghost %{_libdir}/libknmservice.so.?
109%attr(755,root,root) %{_libdir}/libknmui.so
110%attr(755,root,root) %{_libdir}/libknmui.so.*.*.*
111%attr(755,root,root) %ghost %{_libdir}/libknmui.so.?
112%attr(755,root,root) %{_libdir}/libsolidcontrolfuture.so
113%attr(755,root,root) %{_libdir}/libsolidcontrolnm09ifaces.so
114%attr(755,root,root) %{_libdir}/libsolidcontrolnm09ifaces.so.*.*.*
115%attr(755,root,root) %ghost %{_libdir}/libsolidcontrolnm09ifaces.so.?
116%attr(755,root,root) %{_libdir}/libsolidcontrolnm09.so
117%attr(755,root,root) %{_libdir}/libsolidcontrolnm09.so.*.*.*
118%attr(755,root,root) %ghost %{_libdir}/libsolidcontrolnm09.so.?
119
120%{_datadir}/apps/desktoptheme/default/icons/network2.svgz
a085f693 121%{_datadir}/apps/networkmanagement
122%{_datadir}/kde4/services/*.desktop
123%{_datadir}/kde4/services/kded/*.desktop
124%{_datadir}/kde4/servicetypes/*.desktop
48023a29 125%{_iconsdir}/oxygen/*x*/apps/networkmanager.png
a085f693 126%{_iconsdir}/oxygen/*x*/devices/network-wireless*.png
127%{_iconsdir}/oxygen/*x*/devices/network-wired-activated.png
29856f56 128%{_iconsdir}/oxygen/*x*/devices/network-defaultroute.png
This page took 0.089463 seconds and 4 git commands to generate.