]> git.pld-linux.org Git - packages/glibc.git/blame - glibc.spec
- there is TLS and NPTL for sparc64 (dunno if working)
[packages/glibc.git] / glibc.spec
CommitLineData
98a7741e 1#
2# You can define min_kernel macro by "rpm --define 'min_kernel version'"
02f7fa95 3# default is 2.4.6 for linuxthreads, 2.6.0 for NPTL
029d2051 4#
b287d865 5# Conditional build:
60cb42b4 6%bcond_with omitfp # build without frame pointer (pass \--enable-omitfp)
fd1d4127 7%bcond_without memusage # don't build memusage utility
a7536a5d 8%bcond_with kernelheaders # use headers from %{_kernelsrcdir} instead of
b2327ef2 9 # linux-libc-headers (evil, breakage etc., don't use)
40240acb
JB
10%bcond_without linuxthreads # don't build linuxthreads version (NPTL only)
11%bcond_without nptl # don't build NPTL version (linuxthreads only)
e03cf19f
JB
12%bcond_without tls # don't support TLS at all (implies no NPTL)
13%bcond_with __thread # use TLS in linuxthreads
757f96eb 14%bcond_without selinux # without SELinux support (in nscd)
c9d8e545 15%bcond_with tests # perform "make test"
4cceaf33 16%bcond_with tests_nptl # perform NPTL tests on dual build (requires 2.6.x kernel)
0a85848c 17%bcond_without localedb # don't build localedb-all (is time consuming)
61918272 18
b287d865 19#
37cd6ebc
JB
20# TODO:
21# - localedb-gen man pages(?)
4acad1ec 22# - fix what trojan broke while upgreading (getaddrinfo-workaround)
feca75cc
JB
23# - math/{test-fenv,test-tgmath,test-float,test-ifloat},
24# linuxthreads/tst-cancel8, debug/backtrace-tst(SEGV) fail on alpha
cfac0d25
JB
25# - problem compiling with --enable-bounded (must be reported to libc-alpha)
26# (is this comment still valid???)
27
76f01b70 28#
61918272 29
3900e225 30%{!?min_kernel:%global min_kernel 2.4.6}
76131947 31%if "%{min_kernel}" < "2.6.0"
40240acb
JB
32%global nptl_min_kernel 2.6.0
33%else
34%global nptl_min_kernel %{min_kernel}
76131947 35%endif
40240acb 36
e03cf19f
JB
37%if %{with tls}
38# sparc temporarily removed (broken)
4bcd7e8c 39%ifnarch %{ix86} amd64 ia64 alpha s390 s390x sparc64 sparcv9 ppc ppc64
e03cf19f
JB
40%undefine with_tls
41%endif
42%endif
43
40240acb
JB
44%if %{with nptl}
45# nptl on x86 uses cmpxchgl (available since i486)
4bcd7e8c 46%ifnarch i486 i586 i686 pentium3 pentium4 athlon amd64 ia64 alpha s390 s390x sparc64 sparcv9 ppc ppc64
40240acb 47%undefine with_nptl
e03cf19f
JB
48%else
49%if %{without tls}
50%undefine with_nptl
3900e225 51%endif
61918272 52%endif
f3f771b7
AM
53%endif
54
e24149ab
PS
55%ifarch sparc64
56%undefine with_memusage
57%endif
58
40240acb
JB
59%if %{with linuxthreads} && %{with nptl}
60%define with_dual 1
61%endif
62
121eb47e 63%define llh_version 7:2.6.6.0
969145b1 64%define _snap 20041122
e8c60795 65
236a5027 66Summary: GNU libc
67Summary(de): GNU libc
4a04bb32 68Summary(es): GNU libc
236a5027 69Summary(fr): GNU libc
c5387ad5 70