]> git.pld-linux.org Git - packages/geos.git/blame - geos.spec
- ver. 3.0.0 rc4
[packages/geos.git] / geos.spec
CommitLineData
38386277 1# Conditional build:
2%bcond_without ruby # build without ruby
3#
7070463c 4Summary: Geometry Engine - Open Source
fd0ef9fd 5Summary(pl.UTF-8): GEOS - silnik geometryczny z otwartymi źródłami
7070463c 6Name: geos
11971862 7Version: 3.0.0
8%define _rc rc4
9Release: 0.%{_rc}.1
7070463c
JB
10License: LGPL
11Group: Libraries
11971862 12Source0: http://geos.refractions.net/%{name}-%{version}%{_rc}.tar.bz2
13# Source0-md5: 90d4dba51dd75f8f1f12378e0f910d76
7070463c
JB
14URL: http://geos.refractions.net/
15BuildRequires: automake
16BuildRequires: libstdc++-devel
08e05e00
JB
17BuildRequires: python >= 1:2.5
18BuildRequires: python-devel >= 1:2.5
68bc5314 19BuildRequires: rpm-pythonprov
38386277 20%{?with_ruby:BuildRequires: ruby-devel}
68bc5314 21BuildRequires: swig-python >= 1.3.29
38386277 22%{?with_ruby:BuildRequires: swig-ruby >= 1.3.29}
7070463c
JB
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26GEOS (Geometry Engine - Open Source) is a C++ port of the Java
27Topology Suite (JTS). As such, it aims to contain the complete
28functionality of JTS in C++. This includes all the OpenGIS "Simple
29Features for SQL" spatial predicate functions and spatial operators,
30as well as specific JTS topology functions such as IsValid().
31
e0dd9005 32%description -l pl.UTF-8
7070463c 33GEOS (Geometry Engine - Open Source, czyli silnik geometryczny z
e0dd9005
JR
34otwartymi źródłami) to port C++ biblioteki Java Topology Suite (JTS).
35Celem biblioteki jako takiej jest implementacja pełnej funkcjonalności
36JTS w C++. Obejmuje to wszystkie funkcje predykatów przestrzennych
7070463c 37wg "Simple Features for SQL" OpenGIS oraz operatory przestrzenne, a
e0dd9005 38także specyficzne dla JTS funkcje topologiczne takie jak IsValid().
7070463c
JB
39
40%package devel
41Summary: Header files for GEOS library
fd0ef9fd 42Summary(pl.UTF-8): Pliki nagłówkowe biblioteki GEOS
7070463c
JB
43Group: Development/Libraries
44Requires: %{name} = %{version}-%{release}
45Requires: libstdc++-devel
46
47%description devel
48Header files for GEOS library.
49
e0dd9005
JR
50%description devel -l pl.UTF-8
51Pliki nagłówkowe biblioteki GEOS.
7070463c
JB
52
53%package static
54Summary: Static GEOS library
fd0ef9fd 55Summary(pl.UTF-8): Statyczna biblioteka GEOS
7070463c
JB
56Group: Development/Libraries
57Requires: %{name}-devel = %{version}-%{release}
58
59%description static
60Static GEOS library.
61
e0dd9005 62%description static -l pl.UTF-8
7070463c
JB
63Statyczna biblioteka GEOS.
64
2172c3d9 65%package -n python-geos
66Summary: Python bindings for Geometry Engine - Open Source
fd0ef9fd 67Summary(pl.UTF-8): Wiązania Pythona do biblioteki GEOS
adc066a8 68Group: Development/Languages/Python
2172c3d9 69Requires: %{name} = %{version}-%{release}
70
71%description -n python-geos
adc066a8 72Python bindings for Geometry Engine - Open Source.
2172c3d9 73
e0dd9005
JR
74%description -n python-geos -l pl.UTF-8
75Wiązania Pythona do biblioteki GEOS.
2172c3d9 76
68bc5314
JB
77%package -n ruby-geos
78Summary: Ruby bindings for Geometry Engine - Open Source
fd0ef9fd 79Summary(pl.UTF-8): Wiązania języka Ruby do biblioteki GEOS
68bc5314
JB
80Group: Development/Languages/Python
81Requires: %{name} = %{version}-%{release}
82
83%description -n ruby-geos
84Ruby bindings for Geometry Engine - Open Source.
85
e0dd9005
JR
86%description -n ruby-geos -l pl.UTF-8
87Wiązania języka Ruby do biblioteki GEOS.
68bc5314 88
7070463c 89%prep
11971862 90%setup -q -n %{name}-%{version}%{_rc}
7070463c
JB
91
92%build
93cp -f /usr/share/automake/config.* .
11971862 94%configure \
95 --enable-python \
96 %{?with_ruby:--enable-ruby}
97
7070463c
JB
98%{__make} \
99 pkglibdir=%{_libdir}
100
68bc5314 101
7070463c
JB
102%install
103rm -rf $RPM_BUILD_ROOT
104
105%{__make} install \
106 DESTDIR=$RPM_BUILD_ROOT \
107 pkglibdir=%{_libdir}
108
02cf38a4 109%py_postclean
68bc5314 110
7070463c
JB
111%clean
112rm -rf $RPM_BUILD_ROOT
113
114%post -p /sbin/ldconfig
115%postun -p /sbin/ldconfig
116
117%files
118%defattr(644,root,root,755)
02cf38a4 119%doc AUTHORS ChangeLog NEWS README TODO
11971862 120# fixme?:
121%attr(755,root,root) %{_libdir}/libgeos-3.0*.so
122#%attr(755,root,root) %{_libdir}/libgeos.so.*.*.*
6a9f7429 123%attr(755,root,root) %{_libdir}/libgeos_c.so.*.*.*
7070463c
JB
124
125%files devel
126%defattr(644,root,root,755)
127%attr(755,root,root) %{_bindir}/geos-config
6a9f7429
JB
128%attr(755,root,root) %{_libdir}/libgeos.so
129%attr(755,root,root) %{_libdir}/libgeos_c.so
130%{_libdir}/libgeos.la
131%{_libdir}/libgeos_c.la
7070463c 132%{_includedir}/geos
413fb971 133%{_includedir}/geos.h
6a9f7429 134%{_includedir}/geos_c.h
7070463c
JB
135
136%files static
137%defattr(644,root,root,755)
6a9f7429
JB
138%{_libdir}/libgeos.a
139%{_libdir}/libgeos_c.a
2172c3d9 140
141%files -n python-geos
142%defattr(644,root,root,755)
11971862 143%dir %{py_sitedir}/geos
144%attr(755,root,root) %{py_sitedir}/geos/_geos.so
145%{py_sitescriptdir}/geos*
68bc5314 146
38386277 147%if %{with ruby}
68bc5314
JB
148%files -n ruby-geos
149%defattr(644,root,root,755)
150%attr(755,root,root) %{ruby_archdir}/geos.so
38386277 151%endif
This page took 0.105367 seconds and 4 git commands to generate.