]> git.pld-linux.org Git - packages/geos.git/blame - geos.spec
- converted to UTF-8
[packages/geos.git] / geos.spec
CommitLineData
7070463c 1Summary: Geometry Engine - Open Source
e0dd9005 2Summary(pl.UTF-8): GEOS - silnik geometryczny z otwartymi źródłami
7070463c 3Name: geos
02cf38a4 4Version: 2.2.3
7070463c
JB
5Release: 1
6License: LGPL
7Group: Libraries
c2c031fa 8Source0: http://geos.refractions.net/%{name}-%{version}.tar.bz2
02cf38a4 9# Source0-md5: 440be2b11fd3d711e950a47ea6f1b424
68bc5314 10Patch0: %{name}-swig.patch
7070463c
JB
11URL: http://geos.refractions.net/
12BuildRequires: automake
13BuildRequires: libstdc++-devel
08e05e00
JB
14BuildRequires: python >= 1:2.5
15BuildRequires: python-devel >= 1:2.5
68bc5314
JB
16BuildRequires: rpm-pythonprov
17BuildRequires: ruby-devel
18BuildRequires: swig-python >= 1.3.29
19BuildRequires: swig-ruby >= 1.3.29
7070463c
JB
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%description
23GEOS (Geometry Engine - Open Source) is a C++ port of the Java
24Topology Suite (JTS). As such, it aims to contain the complete
25functionality of JTS in C++. This includes all the OpenGIS "Simple
26Features for SQL" spatial predicate functions and spatial operators,
27as well as specific JTS topology functions such as IsValid().
28
e0dd9005 29%description -l pl.UTF-8
7070463c 30GEOS (Geometry Engine - Open Source, czyli silnik geometryczny z
e0dd9005
JR
31otwartymi źródłami) to port C++ biblioteki Java Topology Suite (JTS).
32Celem biblioteki jako takiej jest implementacja pełnej funkcjonalności
33JTS w C++. Obejmuje to wszystkie funkcje predykatów przestrzennych
7070463c 34wg "Simple Features for SQL" OpenGIS oraz operatory przestrzenne, a
e0dd9005 35także specyficzne dla JTS funkcje topologiczne takie jak IsValid().
7070463c
JB
36
37%package devel
38Summary: Header files for GEOS library
e0dd9005 39Summary(pl.UTF-8): Pliki nagłówkowe biblioteki GEOS
7070463c
JB
40Group: Development/Libraries
41Requires: %{name} = %{version}-%{release}
42Requires: libstdc++-devel
43
44%description devel
45Header files for GEOS library.
46
e0dd9005
JR
47%description devel -l pl.UTF-8
48Pliki nagłówkowe biblioteki GEOS.
7070463c
JB
49
50%package static
51Summary: Static GEOS library
e0dd9005 52Summary(pl.UTF-8): Statyczna biblioteka GEOS
7070463c
JB
53Group: Development/Libraries
54Requires: %{name}-devel = %{version}-%{release}
55
56%description static
57Static GEOS library.
58
e0dd9005 59%description static -l pl.UTF-8
7070463c
JB
60Statyczna biblioteka GEOS.
61
2172c3d9 62%package -n python-geos
63Summary: Python bindings for Geometry Engine - Open Source
e0dd9005 64Summary(pl.UTF-8): Wiązania Pythona do biblioteki GEOS
adc066a8 65Group: Development/Languages/Python
2172c3d9 66Requires: %{name} = %{version}-%{release}
67
68%description -n python-geos
adc066a8 69Python bindings for Geometry Engine - Open Source.
2172c3d9 70
e0dd9005
JR
71%description -n python-geos -l pl.UTF-8
72Wiązania Pythona do biblioteki GEOS.
2172c3d9 73
68bc5314
JB
74%package -n ruby-geos
75Summary: Ruby bindings for Geometry Engine - Open Source
e0dd9005 76Summary(pl.UTF-8): Wiązania języka Ruby do biblioteki GEOS
68bc5314
JB
77Group: Development/Languages/Python
78Requires: %{name} = %{version}-%{release}
79
80%description -n ruby-geos
81Ruby bindings for Geometry Engine - Open Source.
82
e0dd9005
JR
83%description -n ruby-geos -l pl.UTF-8
84Wiązania języka Ruby do biblioteki GEOS.
68bc5314 85
7070463c 86%prep
c2c031fa 87%setup -q
7070463c
JB
88%patch0 -p1
89
90%build
91cp -f /usr/share/automake/config.* .
92%configure
93%{__make} \
94 pkglibdir=%{_libdir}
95
2172c3d9 96cd swig/python
97swig -c++ -python -modern -o geos_wrap.cxx ../geos.i
98python setup.py build
99
68bc5314
JB
100cd ../ruby
101swig -c++ -ruby -autorename -o geos_wrap.cxx ../geos.i
102%{__cxx} %{rpmcxxflags} -I../../source/headers -I%{ruby_archdir} -c geos_wrap.cxx
103%{__cxx} -shared -o geos.so geos_wrap.o -lruby -L../../source/geom/.libs -lgeos
104
7070463c
JB
105%install
106rm -rf $RPM_BUILD_ROOT
107
108%{__make} install \
109 DESTDIR=$RPM_BUILD_ROOT \
110 pkglibdir=%{_libdir}
111
02cf38a4
JB
112cd swig
113install -D ruby/geos.so $RPM_BUILD_ROOT%{ruby_archdir}/geos.so
2172c3d9 114
02cf38a4
JB
115cd python
116python setup.py install \
117 --optimize=2 \
118 --root=$RPM_BUILD_ROOT
119
120%py_postclean
68bc5314 121
7070463c
JB
122%clean
123rm -rf $RPM_BUILD_ROOT
124
125%post -p /sbin/ldconfig
126%postun -p /sbin/ldconfig
127
128%files
129%defattr(644,root,root,755)
02cf38a4 130%doc AUTHORS ChangeLog NEWS README TODO
6a9f7429
JB
131%attr(755,root,root) %{_libdir}/libgeos.so.*.*.*
132%attr(755,root,root) %{_libdir}/libgeos_c.so.*.*.*
7070463c
JB
133
134%files devel
135%defattr(644,root,root,755)
136%attr(755,root,root) %{_bindir}/geos-config
6a9f7429
JB
137%attr(755,root,root) %{_libdir}/libgeos.so
138%attr(755,root,root) %{_libdir}/libgeos_c.so
139%{_libdir}/libgeos.la
140%{_libdir}/libgeos_c.la
7070463c 141%{_includedir}/geos
413fb971 142%{_includedir}/geos.h
6a9f7429 143%{_includedir}/geos_c.h
7070463c
JB
144
145%files static
146%defattr(644,root,root,755)
6a9f7429
JB
147%{_libdir}/libgeos.a
148%{_libdir}/libgeos_c.a
2172c3d9 149
150%files -n python-geos
151%defattr(644,root,root,755)
2172c3d9 152%attr(755,root,root) %{py_sitedir}/_geos.so
02cf38a4
JB
153%{py_sitedir}/geos.py[co]
154%{py_sitedir}/PyGEOS-*.egg-info
68bc5314
JB
155
156%files -n ruby-geos
157%defattr(644,root,root,755)
158%attr(755,root,root) %{ruby_archdir}/geos.so
This page took 0.171778 seconds and 4 git commands to generate.