]> git.pld-linux.org Git - packages/eigen3.git/blame - eigen3.spec
- new, based on eigen 2 .spec
[packages/eigen3.git] / eigen3.spec
CommitLineData
86cdc95d
JB
1Summary: C++ template library for linear algebra
2Summary(pl.UTF-8): Biblioteka szablonów C++ do algebry liniowej
3Name: eigen3
4Version: 3.0.4
5Release: 1
6License: LGPL v3+ or GPL v2+
7Group: Development/Libraries
8Source0: http://bitbucket.org/eigen/eigen/get/%{version}.tar.bz2
9# Source0-md5: c4a403660311ad8d62a28c118883310f
10Patch0: %{name}-buildtype.patch
11URL: http://eigen.tuxfamily.org/
12BuildRequires: cmake >= 2.6.2
13BuildRequires: rpmbuild(macros) >= 1.605
14Requires: libstdc++-devel
15BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17%description
18Eigen is a C++ template library for linear algebra: vectors, matrices,
19and related algorithms. It is versatile, fast, elegant and
20compiler-friendly.
21
22Eigen handles, without code duplication and in a completely integrated
23way:
24 - both fixed-size and dynamic-size matrices and vectors
25 - both dense and sparse (the latter is still experimental) matrices
26 and vectors
27 - both plain matrices/vectors and abstract expressions
28 - both column-major (the default) and row-major matrix storage
29 - both basic matrix/vector manipulation and many more advanced,
30 specialized modules providing algorithms for linear algebra,
31 geometry, quaternions, or advanced array manipulation.
32
33%description -l pl.UTF-8
34Eigen to biblioteka szablonów C++ do algebry liniowej: wektorów,
35macierzy i związanych z nimi algorytmów. Jest elastyczna, szybka,
36elegancka i przyjazna dla kompilatorów.
37
38Obsługuje bez powielania kodu i w całkowicie zintegrowany sposób:
39 - macierze i wektory o stałym i dynamicznym rozmiarze
40 - macierze i wektory gęste i rzadkie (te drugie jeszcze
41 eksperymentalnie)
42 - zwykłe macierze/wektory jak i abstrakcyjne wyrażenia
43 - przechowywanie danych kolumnowe (domyślne) oraz wierszowe
44 - podstawowe operacje na macierzach/wektorach, jak i wiele
45 bardziej zaawansowanych, specjalizowanych modułów z algorytmami
46 algebry liniowej, geometrii, kwaternionów i zaawansowanych operacji
47 na tablicach.
48
49%prep
50%setup -q -n eigen-eigen-13a11181fc5a
51%patch0 -p1
52
53%build
54install -d build
55cd build
56%cmake .. \
57 -DCMAKE_CXX_COMPILER_WORKS=1 \
58 -DCMAKE_CXX_COMPILER="%{__cc}"
59
60%{__make}
61
62%install
63rm -rf $RPM_BUILD_ROOT
64
65%{__make} -C build install \
66 DESTDIR=$RPM_BUILD_ROOT
67
68%clean
69rm -rf $RPM_BUILD_ROOT
70
71%files
72%defattr(644,root,root,755)
73%{_includedir}/eigen3
74%{_npkgconfigdir}/eigen3.pc
This page took 0.075213 seconds and 4 git commands to generate.