]> git.pld-linux.org Git - packages/eigen3.git/commitdiff
- new, based on eigen 2 .spec
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 31 Jan 2012 16:30:01 +0000 (16:30 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- added buildtype patch to allow "PLD" as cmake build type

Changed files:
    eigen3-buildtype.patch -> 1.1
    eigen3.spec -> 1.1

eigen3-buildtype.patch [new file with mode: 0644]
eigen3.spec [new file with mode: 0644]

diff --git a/eigen3-buildtype.patch b/eigen3-buildtype.patch
new file mode 100644 (file)
index 0000000..811943d
--- /dev/null
@@ -0,0 +1,16 @@
+--- eigen-eigen-13a11181fc5a/CMakeLists.txt.orig       2011-12-06 14:15:10.000000000 +0100
++++ eigen-eigen-13a11181fc5a/CMakeLists.txt    2012-01-31 17:26:58.373450532 +0100
+@@ -14,13 +14,6 @@
+   set(CMAKE_BUILD_TYPE "Release")
+ endif()
+-string(TOLOWER "${CMAKE_BUILD_TYPE}" cmake_build_type_tolower)
+-if(    NOT cmake_build_type_tolower STREQUAL "debug"
+-   AND NOT cmake_build_type_tolower STREQUAL "release"
+-   AND NOT cmake_build_type_tolower STREQUAL "relwithdebinfo")
+-  message(FATAL_ERROR "Unknown build type \"${CMAKE_BUILD_TYPE}\". Allowed values are Debug, Release, RelWithDebInfo (case-insensitive).")
+-endif()
+-
+ #############################################################################
+ # retrieve version infomation                                               #
diff --git a/eigen3.spec b/eigen3.spec
new file mode 100644 (file)
index 0000000..3ce96d4
--- /dev/null
@@ -0,0 +1,74 @@
+Summary:       C++ template library for linear algebra
+Summary(pl.UTF-8):     Biblioteka szablonów C++ do algebry liniowej
+Name:          eigen3
+Version:       3.0.4
+Release:       1
+License:       LGPL v3+ or GPL v2+
+Group:         Development/Libraries
+Source0:       http://bitbucket.org/eigen/eigen/get/%{version}.tar.bz2
+# Source0-md5: c4a403660311ad8d62a28c118883310f
+Patch0:                %{name}-buildtype.patch
+URL:           http://eigen.tuxfamily.org/
+BuildRequires: cmake >= 2.6.2
+BuildRequires: rpmbuild(macros) >= 1.605
+Requires:      libstdc++-devel
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+Eigen is a C++ template library for linear algebra: vectors, matrices,
+and related algorithms. It is versatile, fast, elegant and
+compiler-friendly.
+
+Eigen handles, without code duplication and in a completely integrated
+way:
+ - both fixed-size and dynamic-size matrices and vectors
+ - both dense and sparse (the latter is still experimental) matrices
+   and vectors
+ - both plain matrices/vectors and abstract expressions
+ - both column-major (the default) and row-major matrix storage
+ - both basic matrix/vector manipulation and many more advanced,
+   specialized modules providing algorithms for linear algebra,
+   geometry, quaternions, or advanced array manipulation.
+
+%description -l pl.UTF-8
+Eigen to biblioteka szablonów C++ do algebry liniowej: wektorów,
+macierzy i związanych z nimi algorytmów. Jest elastyczna, szybka,
+elegancka i przyjazna dla kompilatorów.
+
+Obsługuje bez powielania kodu i w całkowicie zintegrowany sposób:
+ - macierze i wektory o stałym i dynamicznym rozmiarze
+ - macierze i wektory gęste i rzadkie (te drugie jeszcze
+   eksperymentalnie)
+ - zwykłe macierze/wektory jak i abstrakcyjne wyrażenia
+ - przechowywanie danych kolumnowe (domyślne) oraz wierszowe
+ - podstawowe operacje na macierzach/wektorach, jak i wiele
+   bardziej zaawansowanych, specjalizowanych modułów z algorytmami
+   algebry liniowej, geometrii, kwaternionów i zaawansowanych operacji
+   na tablicach.
+
+%prep
+%setup -q -n eigen-eigen-13a11181fc5a
+%patch0 -p1
+
+%build
+install -d build
+cd build
+%cmake .. \
+       -DCMAKE_CXX_COMPILER_WORKS=1 \
+       -DCMAKE_CXX_COMPILER="%{__cc}"
+
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} -C build install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%{_includedir}/eigen3
+%{_npkgconfigdir}/eigen3.pc
This page took 0.100393 seconds and 4 git commands to generate.