]> git.pld-linux.org Git - packages/efreet.git/blame - efreet.spec
- really updated to 1.0.0.beta3
[packages/efreet.git] / efreet.spec
CommitLineData
d470277b
JB
1#
2# Conditional build:
3%bcond_without static_libs # don't build static library
4#
8223c02f 5%define ecore_ver 1.0.0
04827781 6%define eet_ver 1.4.0
07e33737 7
d470277b
JB
8Summary: freedesktop.org standards implementation for the EFL
9Summary(pl.UTF-8): Implementacja standardów freedesktop.org dla EFL
10Name: efreet
308b4065 11%define subver beta3
8223c02f 12Version: 1.0.0
13Release: 0.%{subver}.1
04827781 14License: BSD
d470277b 15Group: X11/Libraries
8223c02f 16Source0: http://download.enlightenment.org/releases/%{name}-%{version}.%{subver}.tar.bz2
308b4065 17# Source0-md5: 2e79009e049613dfbfe3801e264937ca
d470277b 18URL: http://enlightenment.org/p.php?p=about/libs/efreet
93cc5570
JB
19BuildRequires: autoconf >= 2.52
20BuildRequires: automake >= 1.6
07e33737 21BuildRequires: ecore-devel >= %{ecore_ver}
04827781
JB
22BuildRequires: ecore-file-devel >= %{ecore_ver}
23BuildRequires: eet-devel >= %{eet_ver}
d470277b 24BuildRequires: libtool
04827781
JB
25BuildRequires: pkgconfig >= 1:0.22
26Requires: eet >= %{eet_ver}
27Requires: ecore >= %{ecore_ver}
07e33737 28Requires: ecore-file >= %{ecore_ver}
d470277b
JB
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
32Efreet is an implementation of the following specifications from
33freedesktop.org:
34 - Base Directory - Locations for system and user specific desktop
35 configuration files,
36 - Desktop Entries - The metadata associated with the applications
37 installed on a system,
38 - Application Menus - The arrangement of available applications into
39 a hierarchical menu,
40 - Icon Themes - A means of associating icons with various objects on
41 the desktop in a themable fashion.
42
43By following these specifications, Enlightenment 0.17 uses the same
44format for describing application launchers, menus and icon themes as
45the GNOME, KDE and XFCE Desktop Environments. A system must only
46provide a single set of this data for use with any of these desktops.
47
48%description -l pl.UTF-8
49Efreet to implementacja następujących specyfikacji z freedesktop.org:
50 - Base Directory - położenie plików konfiguracyjnych środowiska dla
51 systemu i użytkownika,
52 - Desktop Entries - metadane związane z aplikacjami zainstalowanymi w
53 systemie,
54 - Application Menus - uporządkowanie dostępnych aplikacji w menu
55 hierarchiczne,
56 - Icon Themes - sposób wiązania ikon z różnymi obiektami w środowisku
57 w sposób pozwalający na ustawianie motywów.
58
59%package devel
60Summary: Efreet header files
61Summary(pl.UTF-8): Pliki nagłówkowe Efreet
62Group: Development/Libraries
63Requires: %{name} = %{version}-%{release}
04827781
JB
64Requires: ecore-devel >= %{ecore_ver}
65Requires: ecore-file-devel >= %{ecore_ver}
66Requires: eet-devel >= %{eet_ver}
d470277b
JB
67
68%description devel
69Header files for Efreet.
70
71%description devel -l pl.UTF-8
72Pliki nagłówkowe Efreet.
73
74%package static
75Summary: Static Efreet library
76Summary(pl.UTF-8): Statyczna biblioteka Efreet
77Group: Development/Libraries
78Requires: %{name}-devel = %{version}-%{release}
79
80%description static
81Static Efreet library.
82
83%description static -l pl.UTF-8
84Statyczna biblioteka Efreet.
85
86%prep
8223c02f 87%setup -q -n %{name}-%{version}.%{subver}
d470277b 88
d470277b
JB
89%build
90%{__libtoolize}
91%{__aclocal} -I m4
92%{__autoconf}
93%{__autoheader}
94%{__automake}
95%configure \
04827781 96 --disable-silent-rules \
d470277b 97 %{!?with_static_libs:--disable-static}
04827781 98%{__make}
d470277b
JB
99
100%install
101rm -rf $RPM_BUILD_ROOT
102
103%{__make} install \
104 DESTDIR=$RPM_BUILD_ROOT
105
106# just tests
04827781
JB
107%{__rm} $RPM_BUILD_ROOT%{_bindir}/efreet_{alloc,menu_alloc,test,spec_test,cache_test}
108%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/test
d470277b
JB
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%post -p /sbin/ldconfig
114%postun -p /sbin/ldconfig
115
116%files
117%defattr(644,root,root,755)
118%doc AUTHORS COPYING README TODO
04827781
JB
119%attr(755,root,root) %{_libdir}/libefreet.so.*.*.*
120%attr(755,root,root) %ghost %{_libdir}/libefreet.so.1
121%attr(755,root,root) %{_libdir}/libefreet_mime.so.*.*.*
122%attr(755,root,root) %ghost %{_libdir}/libefreet_mime.so.1
123%attr(755,root,root) %{_libdir}/libefreet_trash.so.*.*.*
124%attr(755,root,root) %ghost %{_libdir}/libefreet_trash.so.1
125%dir %{_libdir}/efreet
126%attr(755,root,root) %{_libdir}/efreet/efreet_desktop_cache_create
d470277b
JB
127
128%files devel
129%defattr(644,root,root,755)
93cc5570
JB
130%attr(755,root,root) %{_libdir}/libefreet.so
131%attr(755,root,root) %{_libdir}/libefreet_mime.so
adf62b9b 132%attr(755,root,root) %{_libdir}/libefreet_trash.so
93cc5570
JB
133%{_libdir}/libefreet.la
134%{_libdir}/libefreet_mime.la
adf62b9b 135%{_libdir}/libefreet_trash.la
04827781 136%{_includedir}/efreet-1
93cc5570
JB
137%{_pkgconfigdir}/efreet.pc
138%{_pkgconfigdir}/efreet-mime.pc
adf62b9b 139%{_pkgconfigdir}/efreet-trash.pc
d470277b
JB
140
141%if %{with static_libs}
142%files static
143%defattr(644,root,root,755)
93cc5570
JB
144%{_libdir}/libefreet.a
145%{_libdir}/libefreet_mime.a
adf62b9b 146%{_libdir}/libefreet_trash.a
d470277b 147%endif
This page took 0.07229 seconds and 4 git commands to generate.