]> git.pld-linux.org Git - packages/domoticz.git/blame - domoticz.spec
- up to 2020.2
[packages/domoticz.git] / domoticz.spec
CommitLineData
9dda6696
AM
1Summary: Open source Home Automation System
2Name: domoticz
72784cf7 3Version: 2020.2
10f7a92e 4Release: 1
9dda6696
AM
5License: GPLv3+ and ASL 2.0 and Boost and BSD and MIT
6Group: Base
7URL: http://www.domoticz.com
72784cf7
AM
8Source0: https://github.com/domoticz/domoticz/archive/%{version}.tar.gz
9# Source0-md5: fd383a13d13d0976c72f332d6db1d24e
9dda6696
AM
10Source1: %{name}.service
11Source2: %{name}.conf
10f7a92e 12
9dda6696
AM
13# Use system tinyxpath (https://github.com/domoticz/domoticz/pull/1759)
14Patch2: %{name}-tinyxpath.patch
15# Use system openzwave includes
16Patch3: %{name}-openzwave.patch
17# Work against Dev branch of OpenZWave upstream
18Patch4: %{name}-openzwave-Dev.patch
19# Fix python detection (https://github.com/domoticz/domoticz/pull/1749)
20Patch5: %{name}-python.patch
21BuildRequires: boost-devel
72784cf7 22BuildRequires: cereal-devel
9dda6696
AM
23BuildRequires: cmake
24BuildRequires: curl-devel
25BuildRequires: libmosquitto-devel
26BuildRequires: libmosquittopp-devel
27BuildRequires: libopenzwave-devel >= 1.5.0
28BuildRequires: libstdc++-devel
29BuildRequires: libusb-devel
30BuildRequires: lua-devel
72784cf7 31BuildRequires: minizip-devel
9dda6696
AM
32BuildRequires: openssl-devel
33BuildRequires: python3-devel
34BuildRequires: sqlite-devel
35BuildRequires: systemd-devel
36BuildRequires: tinyxpath-devel
37BuildRequires: zlib-devel
06cb1c68
AM
38Requires(pre): /usr/sbin/groupadd
39Requires(pre): /usr/sbin/useradd
9dda6696
AM
40Requires(post): systemd
41Requires(postun): systemd
42Requires(preun): systemd
06cb1c68 43Requires: fonts-TTF-Google-Droid
9dda6696
AM
44Provides: bundled(js-ace)
45Provides: bundled(js-angular-ui-bootstrap) = 0.13.4
46Provides: bundled(js-angularamd) = 0.2.1
47Provides: bundled(js-angularjs) = 1.5.8
48Provides: bundled(js-blockly)
49Provides: bundled(js-bootbox)
50Provides: bundled(js-bootstrap) = 3.2.0
51Provides: bundled(js-colpick)
52Provides: bundled(js-d3)
53Provides: bundled(js-datatables-datatools) = 2.2.3
54Provides: bundled(js-dateformat) = 1.2.3
55Provides: bundled(js-filesaver) = 0.0-git20140725
56Provides: bundled(js-highcharts) = 4.2.6
57Provides: bundled(js-html5shiv) = 3.6.2
58Provides: bundled(js-i18next) = 1.8.0
59Provides: bundled(js-ion-sound) = 3.0.6
60Provides: bundled(js-jquery) = 1.12.0
61Provides: bundled(js-jquery-noty) = 2.1.0
62Provides: bundled(js-less) = 1.3.0
63Provides: bundled(js-ngdraggable)
64Provides: bundled(js-nggrid)
65Provides: bundled(js-ozwcp)
66Provides: bundled(js-require) = 2.1.14
67Provides: bundled(js-respond) = 1.1.0
68Provides: bundled(js-wow) = 0.1.9
69Provides: bundled(js-zeroclipboard) = 1.0.4
70
71%description
72Domoticz is a Home Automation System that lets you monitor and
73configure various devices like: Lights, Switches, various
74sensors/meters like Temperature, Rain, Wind, UV, Electra, Gas, Water
75and much more. Notifications/Alerts can be sent to any mobile device
76
77%prep
72784cf7 78%setup -q
10f7a92e
AM
79
80APPVERSION="%{version}"
81echo "#define APPVERSION ${APPVERSION##*.}" > appversion.h
82echo '#define APPHASH "%{snap}"' >> appversion.h
83APPDATE=$(date --date="%{date}" "+%s")
84echo "#define APPDATE ${APPDATE}" >> appversion.h
85
9dda6696
AM
86%patch2 -p1 -b.tinyxpath
87%patch3 -p1 -b.openzwave
86ad2462 88#%patch4 -p1 -b.openzwave-Dev
9dda6696 89%patch5 -p1 -b.python
10f7a92e 90
9dda6696
AM
91rm -f hardware/openzwave/*.h
92rm -rf hardware/openzwave/aes
93rm -rf hardware/openzwave/command_classes
94rm -rf hardware/openzwave/platform
95rm -rf hardware/openzwave/value_classes
96rm -rf sqlite/
97rm -rf tinyxpath/
98
99%build
100install -d build && cd build
101%cmake \
71593ba7
JR
102 -DUSE_OPENSSL_STATIC=NO \
103 -DUSE_STATIC_LIBSTDCXX=NO \
104 -DUSE_STATIC_OPENZWAVE=NO \
72784cf7
AM
105 -DUSE_OPENSSL_STATIC=NO \
106 -DUSE_BUILTIN_JSONCPP=NO \
71593ba7 107 -DUSE_BUILTIN_LUA=NO \
72784cf7 108 -DUSE_BUILTIN_MINIZIP=NO \
71593ba7
JR
109 -DUSE_BUILTIN_MQTT=NO \
110 -DUSE_BUILTIN_SQLITE=NO \
111 -DUSE_BUILTIN_TINYXPATH=NO \
112 -DUSE_STATIC_BOOST=NO \
113 -DCMAKE_INSTALL_PREFIX=%{_datadir}/%{name} \
114 ..
00bce45c 115
9dda6696
AM
116%{__make}
117
118%install
119rm -rf $RPM_BUILD_ROOT
00bce45c
AM
120%{__make} -C build install \
121 DESTDIR=$RPM_BUILD_ROOT
9dda6696
AM
122
123# remove docs, we grab them in files below
124rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/*.txt
125
126# move binary to standard directory
127install -d $RPM_BUILD_ROOT%{_bindir}/
128mv $RPM_BUILD_ROOT%{_datadir}/%{name}/%{name} $RPM_BUILD_ROOT%{_bindir}/
129
130# install systemd service and config
131install -d $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/
132install -d $RPM_BUILD_ROOT%{systemdunitdir}/
133cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdunitdir}/
134cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
135
136# create database/ssl cert directory
137install -d $RPM_BUILD_ROOT%{_sharedstatedir}/%{name}/
138
139# Disable the app's self-update script
140
141# Unbundle DroidSans.ttf
142rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/elemental/fonts/DroidSans.ttf
06cb1c68 143ln -s /usr/share/fonts/TTF/DroidSans.ttf \
9dda6696
AM
144 $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/elemental/fonts/
145rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-light/fonts/DroidSans.ttf
06cb1c68 146ln -s /usr/share/fonts/TTF/DroidSans.ttf \
9dda6696
AM
147 $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-light/fonts/
148rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-dark/fonts/DroidSans.ttf
06cb1c68 149ln -s /usr/share/fonts/TTF/DroidSans.ttf \
9dda6696
AM
150 $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-dark/fonts/
151
152# OpenZWave Control Panel temp file
153ln -s %{_sharedstatedir}/%{name}/ozwcp.poll.XXXXXX.xml \
154 $RPM_BUILD_ROOT%{_datadir}/%{name}/ozwcp.poll.XXXXXX.xml
155
156%clean
157rm -rf $RPM_BUILD_ROOT
158
159%pre
160getent group domoticz >/dev/null || groupadd -r domoticz
161getent passwd domoticz >/dev/null || \
162useradd -r -g domoticz -d %{_datadir}/%{name} -s /sbin/nologin \
163-c "Domoticz Home Automation Server" domoticz
164# For OpenZWave USB access (/dev/ttyACM#)
165usermod -G domoticz,dialout domoticz
166
167%post
168%systemd_post %{name}.service
169
170%preun
171%systemd_preun %{name}.service
172
173%postun
5ac2f181 174%systemd_reload
9dda6696
AM
175
176%files
177%defattr(644,root,root,755)
178%doc License.txt
179%doc README.md History.txt
180%attr(755,root,root) %{_bindir}/%{name}
181%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
182%{_datadir}/%{name}/
183%attr(755,domoticz,domoticz) %{_sharedstatedir}/%{name}/
184%{systemdunitdir}/%{name}.service
This page took 0.087711 seconds and 4 git commands to generate.