]> git.pld-linux.org Git - packages/docker.git/blame - docker.spec
use make.sh to build binary, package udev rules
[packages/docker.git] / docker.spec
CommitLineData
a73bca1d
ER
1#
2# Conditional build:
3%bcond_with tests # build without tests
b2c07037 4
f4565fa4 5Summary: Docker: the open-source application container engine
47009a45 6Name: docker
f4565fa4 7Version: 1.3.3
e4252f76 8Release: 0.2
b877f7b7
ER
9License: Apache v2.0
10Group: Applications/System
f4565fa4
ER
11Source0: https://github.com/docker/docker/archive/v%{version}/%{name}-%{version}.tar.gz
12# Source0-md5: 3fdcb25a498961f6eb14a9c1d81e9244
c74634f7 13Source5: %{name}.service
345101bd 14Source6: %{name}.init
f4565fa4 15URL: https://github.com/docker/docker
d17c4352 16BuildRequires: btrfs-progs-devel
3d4f96d7 17BuildRequires: device-mapper-devel
f4565fa4 18BuildRequires: golang >= 1.3.1
345101bd 19BuildRequires: rpmbuild(macros) >= 1.228
678a84bd 20BuildRequires: sqlite3-devel >= 3.7.9
d88043a2
ER
21Requires(post,preun): /sbin/chkconfig
22Requires(postun): /usr/sbin/groupdel
23Requires(pre): /usr/bin/getgid
24Requires(pre): /usr/sbin/groupadd
2e42e913 25Requires: iproute2 >= 3.5
b5920dfc 26Requires: iptables
2e42e913 27Requires: lxc >= 0.8
345101bd 28Requires: rc-scripts >= 0.4.0.10
2e42e913 29Requires: tar >= 1:1.26
2015cb19 30Requires: uname(release) >= 3.8
db150373 31Requires: xz
2e42e913 32Suggests: git-core >= 1.7
46a6d8ab 33Suggests: libcgroup
2e42e913 34Suggests: xz >= 1:4.9
d88043a2 35Provides: group(docker)
47009a45
ER
36Obsoletes: lxc-docker < 1.1.1
37Patch0: lxc-%{name}-nosha.patch
d2670441 38# only runs on x64 hosts for now:
f4565fa4
ER
39# https://github.com/docker/docker/issues/136
40# https://github.com/docker/docker/issues/611
345101bd 41ExclusiveArch: %{x8664}
b877f7b7
ER
42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
8c352669 44%define bash_compdir %{_datadir}/bash-completion/completions
f891ae41 45%define _vimdatadir %{_datadir}/vim
8c352669 46
434d66d3
ER
47# binary stripped or something
48%define _enable_debug_packages 0
49
b877f7b7 50%description
f4565fa4
ER
51Docker is an open source project to pack, ship and run any application
52as a lightweight container
53
54Docker containers are both hardware-agnostic and platform-agnostic.
55This means that they can run anywhere, from your laptop to the largest
56EC2 compute instance and everything in between - and they don't
57require that you use a particular language, framework or packaging
58system. That makes them great building blocks for deploying and
59scaling web apps, databases and backend services without depending on
60a particular stack or provider.
61
62Docker is an open-source implementation of the deployment engine which
63powers dotCloud, a popular Platform-as-a-Service. It benefits directly
64from the experience accumulated over several years of large-scale
65operation and support of hundreds of thousands of applications and
66databases.
b877f7b7 67
f891ae41 68%package -n bash-completion-%{name}
8c352669
ER
69Summary: bash-completion for Docker
70Summary(pl.UTF-8): bashowe uzupełnianie nazw dla Dockera
71Group: Applications/Shells
72Requires: %{name}
73Requires: bash-completion >= 2.0
47009a45 74Obsoletes: bash-completion-lxc-docker < 1.1.1
8c352669
ER
75%if "%{_rpmversion}" >= "5"
76BuildArch: noarch
77%endif
78
47009a45 79%description -n bash-completion-%{name}
8c352669
ER
80This package provides bash-completion for Docker.
81
47009a45 82%description -n bash-completion-%{name} -l pl.UTF-8
8c352669
ER
83Pakiet ten dostarcza bashowe uzupełnianie nazw dla Dockera.
84
f891ae41
ER
85%package -n vim-syntax-%{name}
86Summary: Vim syntax: Docker
87Group: Applications/Editors/Vim
88Requires: %{name} = %{version}-%{release}
89Requires: vim-rt >= 4:7.2.170
47009a45 90Obsoletes: vim-syntax-lxc-docker < 1.1.1
f891ae41
ER
91%if "%{_rpmversion}" >= "5"
92BuildArch: noarch
93%endif
94
95%description -n vim-syntax-%{name}
96This plugin provides syntax highlighting in Dockerfile.
97
b877f7b7 98%prep
47009a45 99%setup -q
98d3177c 100%patch0 -p1
b877f7b7 101
f4565fa4
ER
102install -d vendor/src/github.com/docker
103ln -s $(pwd) vendor/src/github.com/docker/docker
b877f7b7 104
692548c0
ER
105%build
106export GOPATH=$(pwd)/vendor
e4252f76
ER
107export DOCKER_GITCOMMIT="pld/%{version}"
108
109DEBUG=1 hack/make.sh dynbinary
a73bca1d 110
b877f7b7
ER
111%install
112rm -rf $RPM_BUILD_ROOT
c74634f7 113install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,/etc/rc.d/init.d,%{systemdunitdir},/var/lib/docker/{containers,graph,volumes}}
e4252f76
ER
114
115install -p bundles/%{version}/dynbinary/docker-%{version} $RPM_BUILD_ROOT%{_bindir}/docker
116install -p bundles/%{version}/dynbinary/dockerinit-%{version} $RPM_BUILD_ROOT%{_bindir}/dockerinit
117cp -p %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}
47009a45 118install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/docker
f891ae41 119#cp -p packaging/debian/lxc-docker.1 $RPM_BUILD_ROOT%{_mandir}/man1
b877f7b7 120
e4252f76
ER
121# install udev rules
122install -d $RPM_BUILD_ROOT/lib/udev/rules.d
123cp -p contrib/udev/80-docker.rules $RPM_BUILD_ROOT/lib/udev/rules.d
124
8c352669
ER
125# bash completion
126install -d $RPM_BUILD_ROOT%{bash_compdir}
47009a45 127cp -p contrib/completion/bash/docker $RPM_BUILD_ROOT%{bash_compdir}/docker
8c352669 128
f891ae41
ER
129# vim syntax
130install -d $RPM_BUILD_ROOT%{_vimdatadir}
7db50491 131cp -a contrib/syntax/vim/* $RPM_BUILD_ROOT%{_vimdatadir}
f891ae41
ER
132%{__rm} $RPM_BUILD_ROOT%{_vimdatadir}/{LICENSE,README.md}
133
d88043a2
ER
134%pre
135%groupadd -g 296 docker
136
345101bd
ER
137%post
138/sbin/chkconfig --add %{name}
139%service -n %{name} restart
140
141%preun
142if [ "$1" = "0" ]; then
143 %service -q %{name} stop
144 /sbin/chkconfig --del %{name}
145fi
146
d88043a2
ER
147%postun
148if [ "$1" = "0" ]; then
149 %groupremove docker
150fi
151
b877f7b7
ER
152%clean
153rm -rf $RPM_BUILD_ROOT
154
155%files
156%defattr(644,root,root,755)
f4565fa4 157%doc README.md CHANGELOG.md CONTRIBUTING.md LICENSE AUTHORS NOTICE MAINTAINERS
47009a45
ER
158%{systemdunitdir}/docker.service
159%attr(754,root,root) /etc/rc.d/init.d/docker
9c77b76c 160%attr(755,root,root) %{_bindir}/docker
3d4f96d7 161%attr(755,root,root) %{_bindir}/dockerinit
e4252f76 162/lib/udev/rules.d/80-docker.rules
f891ae41 163#%{_mandir}/man1/lxc-docker.1*
af991618
ER
164%dir %attr(700,root,root) /var/lib/docker
165%dir %attr(700,root,root) /var/lib/docker/containers
166%dir %attr(700,root,root) /var/lib/docker/graph
167%dir %attr(700,root,root) /var/lib/docker/volumes
8c352669 168
f891ae41 169%files -n bash-completion-%{name}
8c352669 170%defattr(644,root,root,755)
8c352669 171%{bash_compdir}/docker
f891ae41
ER
172
173%files -n vim-syntax-%{name}
174%defattr(644,root,root,755)
7db50491 175%doc contrib/syntax/vim/{README.md,LICENSE}
f891ae41
ER
176%{_vimdatadir}/doc/dockerfile.txt
177%{_vimdatadir}/ftdetect/dockerfile.vim
178%{_vimdatadir}/syntax/dockerfile.vim
This page took 0.0942730000000001 seconds and 4 git commands to generate.