]> git.pld-linux.org Git - packages/docker.git/blame - docker.spec
up to 1.3.3 (2014-12-11)
[packages/docker.git] / docker.spec
CommitLineData
a73bca1d
ER
1#
2# Conditional build:
3%bcond_with tests # build without tests
b2c07037 4
f4565fa4 5Summary: Docker: the open-source application container engine
47009a45 6Name: docker
f4565fa4 7Version: 1.3.3
47009a45 8Release: 0.1
b877f7b7
ER
9License: Apache v2.0
10Group: Applications/System
f4565fa4
ER
11Source0: https://github.com/docker/docker/archive/v%{version}/%{name}-%{version}.tar.gz
12# Source0-md5: 3fdcb25a498961f6eb14a9c1d81e9244
c74634f7 13Source5: %{name}.service
345101bd 14Source6: %{name}.init
f4565fa4 15URL: https://github.com/docker/docker
d17c4352 16BuildRequires: btrfs-progs-devel
3d4f96d7 17BuildRequires: device-mapper-devel
f4565fa4 18BuildRequires: golang >= 1.3.1
345101bd 19BuildRequires: rpmbuild(macros) >= 1.228
678a84bd 20BuildRequires: sqlite3-devel >= 3.7.9
d88043a2
ER
21Requires(post,preun): /sbin/chkconfig
22Requires(postun): /usr/sbin/groupdel
23Requires(pre): /usr/bin/getgid
24Requires(pre): /usr/sbin/groupadd
2e42e913 25Requires: iproute2 >= 3.5
b5920dfc 26Requires: iptables
2e42e913 27Requires: lxc >= 0.8
345101bd 28Requires: rc-scripts >= 0.4.0.10
2e42e913 29Requires: tar >= 1:1.26
2015cb19 30Requires: uname(release) >= 3.8
db150373 31Requires: xz
2e42e913 32Suggests: git-core >= 1.7
46a6d8ab 33Suggests: libcgroup
2e42e913 34Suggests: xz >= 1:4.9
d88043a2 35Provides: group(docker)
47009a45
ER
36Obsoletes: lxc-docker < 1.1.1
37Patch0: lxc-%{name}-nosha.patch
d2670441 38# only runs on x64 hosts for now:
f4565fa4
ER
39# https://github.com/docker/docker/issues/136
40# https://github.com/docker/docker/issues/611
345101bd 41ExclusiveArch: %{x8664}
b877f7b7
ER
42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
8c352669 44%define bash_compdir %{_datadir}/bash-completion/completions
f891ae41 45%define _vimdatadir %{_datadir}/vim
8c352669 46
434d66d3
ER
47# binary stripped or something
48%define _enable_debug_packages 0
49
b877f7b7 50%description
f4565fa4
ER
51Docker is an open source project to pack, ship and run any application
52as a lightweight container
53
54Docker containers are both hardware-agnostic and platform-agnostic.
55This means that they can run anywhere, from your laptop to the largest
56EC2 compute instance and everything in between - and they don't
57require that you use a particular language, framework or packaging
58system. That makes them great building blocks for deploying and
59scaling web apps, databases and backend services without depending on
60a particular stack or provider.
61
62Docker is an open-source implementation of the deployment engine which
63powers dotCloud, a popular Platform-as-a-Service. It benefits directly
64from the experience accumulated over several years of large-scale
65operation and support of hundreds of thousands of applications and
66databases.
b877f7b7 67
f891ae41 68%package -n bash-completion-%{name}
8c352669
ER
69Summary: bash-completion for Docker
70Summary(pl.UTF-8): bashowe uzupełnianie nazw dla Dockera
71Group: Applications/Shells
72Requires: %{name}
73Requires: bash-completion >= 2.0
47009a45 74Obsoletes: bash-completion-lxc-docker < 1.1.1
8c352669
ER
75%if "%{_rpmversion}" >= "5"
76BuildArch: noarch
77%endif
78
47009a45 79%description -n bash-completion-%{name}
8c352669
ER
80This package provides bash-completion for Docker.
81
47009a45 82%description -n bash-completion-%{name} -l pl.UTF-8
8c352669
ER
83Pakiet ten dostarcza bashowe uzupełnianie nazw dla Dockera.
84
f891ae41
ER
85%package -n vim-syntax-%{name}
86Summary: Vim syntax: Docker
87Group: Applications/Editors/Vim
88Requires: %{name} = %{version}-%{release}
89Requires: vim-rt >= 4:7.2.170
47009a45 90Obsoletes: vim-syntax-lxc-docker < 1.1.1
f891ae41
ER
91%if "%{_rpmversion}" >= "5"
92BuildArch: noarch
93%endif
94
95%description -n vim-syntax-%{name}
96This plugin provides syntax highlighting in Dockerfile.
97
b877f7b7 98%prep
47009a45 99%setup -q
98d3177c 100%patch0 -p1
b877f7b7 101
f4565fa4
ER
102install -d vendor/src/github.com/docker
103ln -s $(pwd) vendor/src/github.com/docker/docker
b877f7b7 104
692548c0
ER
105%build
106export GOPATH=$(pwd)/vendor
107install -d build
108cd build
f4565fa4 109DOCKER_PKG="github.com/docker/docker"
3c4fee36 110VERSION=%{version}
7eb37230 111GITCOMMIT=pld-%{version}-%{release} # use RPM_PACKAGE_RELEASE for this
3c4fee36
ER
112# Use these flags when compiling the tests and final binary
113# without '-d', as that fails now
f4565fa4
ER
114LDFLAGS="-X $DOCKER_PKG/dockerversion.GITCOMMIT $GITCOMMIT -X $DOCKER_PKG/dockerversion.VERSION $VERSION -w"
115go build -v -ldflags "$LDFLAGS" -a github.com/docker/docker/docker
3d4f96d7 116go build -v -ldflags "$LDFLAGS" -a ../dockerinit/dockerinit.go
a73bca1d 117
b877f7b7
ER
118%install
119rm -rf $RPM_BUILD_ROOT
c74634f7 120install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,/etc/rc.d/init.d,%{systemdunitdir},/var/lib/docker/{containers,graph,volumes}}
47009a45 121install -p build/docker $RPM_BUILD_ROOT%{_bindir}/docker
3d4f96d7 122install -p build/dockerinit $RPM_BUILD_ROOT%{_bindir}/dockerinit
47009a45
ER
123install -p %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}
124install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/docker
f891ae41 125#cp -p packaging/debian/lxc-docker.1 $RPM_BUILD_ROOT%{_mandir}/man1
b877f7b7 126
8c352669
ER
127# bash completion
128install -d $RPM_BUILD_ROOT%{bash_compdir}
47009a45 129cp -p contrib/completion/bash/docker $RPM_BUILD_ROOT%{bash_compdir}/docker
8c352669 130
f891ae41
ER
131# vim syntax
132install -d $RPM_BUILD_ROOT%{_vimdatadir}
7db50491 133cp -a contrib/syntax/vim/* $RPM_BUILD_ROOT%{_vimdatadir}
f891ae41
ER
134%{__rm} $RPM_BUILD_ROOT%{_vimdatadir}/{LICENSE,README.md}
135
d88043a2
ER
136%pre
137%groupadd -g 296 docker
138
345101bd
ER
139%post
140/sbin/chkconfig --add %{name}
141%service -n %{name} restart
142
143%preun
144if [ "$1" = "0" ]; then
145 %service -q %{name} stop
146 /sbin/chkconfig --del %{name}
147fi
148
d88043a2
ER
149%postun
150if [ "$1" = "0" ]; then
151 %groupremove docker
152fi
153
b877f7b7
ER
154%clean
155rm -rf $RPM_BUILD_ROOT
156
157%files
158%defattr(644,root,root,755)
f4565fa4 159%doc README.md CHANGELOG.md CONTRIBUTING.md LICENSE AUTHORS NOTICE MAINTAINERS
47009a45
ER
160%{systemdunitdir}/docker.service
161%attr(754,root,root) /etc/rc.d/init.d/docker
9c77b76c 162%attr(755,root,root) %{_bindir}/docker
3d4f96d7 163%attr(755,root,root) %{_bindir}/dockerinit
f891ae41 164#%{_mandir}/man1/lxc-docker.1*
af991618
ER
165%dir %attr(700,root,root) /var/lib/docker
166%dir %attr(700,root,root) /var/lib/docker/containers
167%dir %attr(700,root,root) /var/lib/docker/graph
168%dir %attr(700,root,root) /var/lib/docker/volumes
8c352669 169
f891ae41 170%files -n bash-completion-%{name}
8c352669 171%defattr(644,root,root,755)
8c352669 172%{bash_compdir}/docker
f891ae41
ER
173
174%files -n vim-syntax-%{name}
175%defattr(644,root,root,755)
7db50491 176%doc contrib/syntax/vim/{README.md,LICENSE}
f891ae41
ER
177%{_vimdatadir}/doc/dockerfile.txt
178%{_vimdatadir}/ftdetect/dockerfile.vim
179%{_vimdatadir}/syntax/dockerfile.vim
This page took 0.090462 seconds and 4 git commands to generate.