]> git.pld-linux.org Git - packages/docker-compose.git/blame - docker-compose.spec
- commit updated patch
[packages/docker-compose.git] / docker-compose.spec
CommitLineData
a4a04e42
ER
1#
2# Conditional build:
3%bcond_with tests # do not perform "make test"
4
390264ed
ER
5%define module compose
6%define egg_name docker_compose
0293309f 7%define pypi_name docker-compose
a4a04e42
ER
8Summary: Multi-container orchestration for Docker
9Name: docker-compose
3e925c10 10Version: 1.15.0
b030c146 11Release: 2
a4a04e42 12License: Apache v2.0
a4a04e42 13Group: Applications/System
1ea8eb34 14# https://github.com/docker/compose/releases
0293309f 15Source0: https://files.pythonhosted.org/packages/source/d/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
3e925c10 16# Source0-md5: 7da853bc1e8c2c53281b7997c2227057
a4a04e42 17Patch0: remove-requires-upper-bound.patch
1ea8eb34 18URL: https://docs.docker.com/compose/
a4a04e42
ER
19%if %{with tests}
20BuildRequires: python-PyYAML
b5506c5b 21BuildRequires: python-docker
a4a04e42
ER
22BuildRequires: python-docopt
23BuildRequires: python-requests
24BuildRequires: python-setuptools
25BuildRequires: python-texttable
26BuildRequires: python-websocket-client
27%endif
28BuildRequires: rpm-pythonprov
29BuildRequires: rpmbuild(macros) >= 1.714
1ea8eb34 30Requires: docker >= 1.10.0
a4a04e42
ER
31BuildArch: noarch
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%description
35Multi-container orchestration for Docker
36
37Docker-compose allows you to:
38- Define your application's environment with Docker so it can be
39 reproduced anywhere.
40- Define the services that make up your app so they can be run
41 together in an isolated environment.
42- Run 'docker-compose up', and docker-compose will start and run your
43 entire app.
44
45%prep
46%setup -q
47%patch0 -p1
48
a4a04e42
ER
49rm -r docker_compose.egg-info
50
51%build
52%py_build
53
54%install
55rm -rf $RPM_BUILD_ROOT
56%py_install
57%py_postclean
58
59%clean
60rm -rf $RPM_BUILD_ROOT
61
62%files
63%defattr(644,root,root,755)
390264ed 64%doc CHANGELOG.md CONTRIBUTING.md README.rst SWARM.md LICENSE
a4a04e42 65%attr(755,root,root) %{_bindir}/%{name}
390264ed
ER
66%{py_sitescriptdir}/%{module}
67%{py_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
This page took 0.073305 seconds and 4 git commands to generate.