]> git.pld-linux.org Git - packages/docker-compose.git/blame - docker-compose.spec
up to 1.7.1
[packages/docker-compose.git] / docker-compose.spec
CommitLineData
a4a04e42
ER
1#
2# Conditional build:
3%bcond_with tests # do not perform "make test"
4
5Summary: Multi-container orchestration for Docker
6Name: docker-compose
1ea8eb34 7Version: 1.7.1
49b0b583 8Release: 1
a4a04e42 9License: Apache v2.0
a4a04e42 10Group: Applications/System
1ea8eb34
ER
11# https://github.com/docker/compose/releases
12# https://pypi.python.org/pypi/docker-compose
13Source0: https://pypi.python.org/packages/b6/20/0a65e13ac06c4693f28ded22b87882ca1750239bdc0a05d4a4df4e3a9faa/%{name}-%{version}.tar.gz
14# Source0-md5: 8c2b9a88c3aa46dbef422c7eb6802108
a4a04e42 15Patch0: remove-requires-upper-bound.patch
1ea8eb34 16URL: https://docs.docker.com/compose/
a4a04e42
ER
17%if %{with tests}
18BuildRequires: python-PyYAML
b5506c5b 19BuildRequires: python-docker
a4a04e42
ER
20BuildRequires: python-docopt
21BuildRequires: python-requests
22BuildRequires: python-setuptools
23BuildRequires: python-texttable
24BuildRequires: python-websocket-client
25%endif
26BuildRequires: rpm-pythonprov
27BuildRequires: rpmbuild(macros) >= 1.714
1ea8eb34 28Requires: docker >= 1.10.0
a4a04e42
ER
29BuildArch: noarch
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33Multi-container orchestration for Docker
34
35Docker-compose allows you to:
36- Define your application's environment with Docker so it can be
37 reproduced anywhere.
38- Define the services that make up your app so they can be run
39 together in an isolated environment.
40- Run 'docker-compose up', and docker-compose will start and run your
41 entire app.
42
43%prep
44%setup -q
45%patch0 -p1
46
a4a04e42
ER
47rm -r docker_compose.egg-info
48
49%build
50%py_build
51
52%install
53rm -rf $RPM_BUILD_ROOT
54%py_install
55%py_postclean
56
57%clean
58rm -rf $RPM_BUILD_ROOT
59
60%files
61%defattr(644,root,root,755)
62%doc CHANGES.md CONTRIBUTING.md README.rst SWARM.md LICENSE
63%attr(755,root,root) %{_bindir}/%{name}
64%{py_sitescriptdir}/compose
65%{py_sitescriptdir}/docker_compose-%{version}-py*.egg-info
This page took 0.082169 seconds and 4 git commands to generate.