]> git.pld-linux.org Git - packages/docker-compose.git/blob - docker-compose.spec
- commit updated patch
[packages/docker-compose.git] / docker-compose.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # do not perform "make test"
4
5 %define         module          compose
6 %define         egg_name        docker_compose
7 %define         pypi_name       docker-compose
8 Summary:        Multi-container orchestration for Docker
9 Name:           docker-compose
10 Version:        1.15.0
11 Release:        2
12 License:        Apache v2.0
13 Group:          Applications/System
14 # https://github.com/docker/compose/releases
15 Source0:        https://files.pythonhosted.org/packages/source/d/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
16 # Source0-md5:  7da853bc1e8c2c53281b7997c2227057
17 Patch0:         remove-requires-upper-bound.patch
18 URL:            https://docs.docker.com/compose/
19 %if %{with tests}
20 BuildRequires:  python-PyYAML
21 BuildRequires:  python-docker
22 BuildRequires:  python-docopt
23 BuildRequires:  python-requests
24 BuildRequires:  python-setuptools
25 BuildRequires:  python-texttable
26 BuildRequires:  python-websocket-client
27 %endif
28 BuildRequires:  rpm-pythonprov
29 BuildRequires:  rpmbuild(macros) >= 1.714
30 Requires:       docker >= 1.10.0
31 BuildArch:      noarch
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Multi-container orchestration for Docker
36
37 Docker-compose allows you to:
38 - Define your application's environment with Docker so it can be
39   reproduced anywhere.
40 - Define the services that make up your app so they can be run
41   together in an isolated environment.
42 - Run 'docker-compose up', and docker-compose will start and run your
43   entire app.
44
45 %prep
46 %setup -q
47 %patch0 -p1
48
49 rm -r docker_compose.egg-info
50
51 %build
52 %py_build
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 %py_install
57 %py_postclean
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc CHANGELOG.md CONTRIBUTING.md README.rst SWARM.md LICENSE
65 %attr(755,root,root) %{_bindir}/%{name}
66 %{py_sitescriptdir}/%{module}
67 %{py_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
This page took 0.075081 seconds and 3 git commands to generate.