]> git.pld-linux.org Git - packages/depot_tools.git/blame - depot_tools.spec
insert PATH also in gclient tool
[packages/depot_tools.git] / depot_tools.spec
CommitLineData
e9bf62fa 1%define subver 20131210
676bbd7d 2%define rel 0.12
e2970781
ER
3Summary: A package of scripts called used to manage checkouts and code reviews
4Name: depot_tools
5Version: 0.1
e9bf62fa 6Release: 0.%{subver}.%{rel}
e2970781
ER
7License: BSD
8Group: Development/Tools
e9bf62fa
ER
9Source0: %{name}-%{subver}-aeab41a.tar.xz
10# Source0-md5: 5dd469c8ec03d03d48b7db886475bbfa
11Patch0: adjust-path.patch
e2970781 12URL: http://dev.chromium.org/developers/how-tos/depottools
e9bf62fa
ER
13BuildRequires: tar >= 1:1.22
14BuildRequires: xz
e2970781 15Requires: python
f59bfbe1 16BuildArch: noarch
e2970781
ER
17BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19%description
20Chromium uses a package of scripts, the depot_tools, to manage
21interaction with the Chromium source code repository and the Chromium
7bd89abe 22development process. It contains the following utilities:
e2970781 23
7bd89abe
ER
24- gclient: Meta-checkout tool managing both subversion and git
25 checkouts. It is similar to repo tool except that it works on Linux,
26 OS X, and Windows and supports both svn and git. On the other hand,
27 gclient doesn't integrate any code review functionality.
e2970781
ER
28- gcl: Rietveld code review tool for subversion. The gcl tool runs
29 presubmit scripts.
30- git-cl: Rietveld code review tool for git. The git-cl tool runs
31 presubmit scripts.
32- hammer: (Obsolete) Wrapper script for building Chromium with the
33 SCons software construction tool.
34- drover: Quickly revert svn commits.
7bd89abe 35- cpplint.py: Checks for C++ style compliance.
e2970781
ER
36- presubmit_support.py: Runs PRESUBMIT.py presubmit checks.
37- repo: The repo tool.
38- trychange.py: Try server tool. It is wrapped by gcl try and git-try.
39- git-try: Try change tool for git users
40- wtf: Displays the active git branches in a chromium os checkout.
41- weekly: Displays the log of checkins for a particular developer
42 since a particular date for git checkouts.
43- git-gs: Wrapper for git grep with relevant source types.
44- zsh-goodies: Completion for zsh users.
45
46%prep
e9bf62fa 47%setup -qn %{name}-%{subver}
407fa934 48%patch0 -p1
e2970781 49
2c66fa69
ER
50cat > py-wrap.sh <<'EOF'
51#!/bin/sh
52exec %{__python} -B %{_datadir}/%{name}/$(basename "$0").py "$@"
53EOF
54chmod +x *.sh
0afdc21d 55ln -s git_cl.py git-cl.py
2c66fa69 56
e2970781 57# python 2.4 components
92eda2a9 58rm -r third_party/pymox
e2970781 59
b03a4c59
ER
60# screw binaries and shipped dependencies and things useless to this platform
61rm ninja*
62find -type f '(' -name '*.exe' -o -name '*.bat' ')' | xargs rm -v
f59bfbe1
ER
63rm create-ntfs-junction.c
64
65# tests
66rm -r testing_support
67rm -r tests
68
e9bf62fa 69# other irrelevant junk
f59bfbe1 70rm -r bootstrap
e9bf62fa
ER
71rm .gitignore
72rm OWNERS WATCHLISTS
b03a4c59 73
e2970781
ER
74%install
75rm -rf $RPM_BUILD_ROOT
2c66fa69 76install -d $RPM_BUILD_ROOT{%{_datadir}/%{name},%{_bindir}}
e2970781 77cp -a . $RPM_BUILD_ROOT%{_datadir}/%{name}
f59bfbe1
ER
78# already in %doc
79rm $RPM_BUILD_ROOT%{_datadir}/%{name}/{LICENSE,README*}
80
e1627786 81for a in gclient gcl git-cl fetch; do
2c66fa69
ER
82 ln -s %{_datadir}/%{name}/py-wrap.sh $RPM_BUILD_ROOT%{_bindir}/$a
83done
e2970781
ER
84
85%clean
86rm -rf $RPM_BUILD_ROOT
87
88%files
89%defattr(644,root,root,755)
90%doc LICENSE README README.gclient
2c66fa69 91%attr(755,root,root) %{_bindir}/gcl
e2970781 92%attr(755,root,root) %{_bindir}/gclient
2c66fa69 93%attr(755,root,root) %{_bindir}/git-cl
e1627786 94%attr(755,root,root) %{_bindir}/fetch
92eda2a9 95%dir %{_datadir}/%{name}
f59bfbe1
ER
96%attr(755,root,root) %{_datadir}/%{name}/apply_issue
97%attr(755,root,root) %{_datadir}/%{name}/cbuildbot
98%attr(755,root,root) %{_datadir}/%{name}/chrome_set_ver
99%attr(755,root,root) %{_datadir}/%{name}/codereview.settings
100%attr(755,root,root) %{_datadir}/%{name}/create-chromium-git-src
101%attr(755,root,root) %{_datadir}/%{name}/cros
102%attr(755,root,root) %{_datadir}/%{name}/cros_sdk
103%attr(755,root,root) %{_datadir}/%{name}/crup-runner.sh
104%attr(755,root,root) %{_datadir}/%{name}/download_from_google_storage
105%attr(755,root,root) %{_datadir}/%{name}/drover
106%attr(755,root,root) %{_datadir}/%{name}/fetch
107%attr(755,root,root) %{_datadir}/%{name}/gcl
108%attr(755,root,root) %{_datadir}/%{name}/gclient
109%attr(755,root,root) %{_datadir}/%{name}/git-cl
110%attr(755,root,root) %{_datadir}/%{name}/git-cl-upload-hook
111%attr(755,root,root) %{_datadir}/%{name}/git-crsync
112%attr(755,root,root) %{_datadir}/%{name}/git-crup
113%attr(755,root,root) %{_datadir}/%{name}/git-gs
114%attr(755,root,root) %{_datadir}/%{name}/git-lkgr
e9bf62fa 115%attr(755,root,root) %{_datadir}/%{name}/git-number
f59bfbe1
ER
116%attr(755,root,root) %{_datadir}/%{name}/git-runhooks
117%attr(755,root,root) %{_datadir}/%{name}/git-try
e9bf62fa 118%attr(755,root,root) %{_datadir}/%{name}/gn
f59bfbe1 119%attr(755,root,root) %{_datadir}/%{name}/hammer
2c66fa69 120%attr(755,root,root) %{_datadir}/%{name}/py-wrap.sh
f59bfbe1
ER
121%attr(755,root,root) %{_datadir}/%{name}/pylint
122%attr(755,root,root) %{_datadir}/%{name}/pylintrc
123%attr(755,root,root) %{_datadir}/%{name}/repo
124%attr(755,root,root) %{_datadir}/%{name}/update_depot_tools
125%attr(755,root,root) %{_datadir}/%{name}/weekly
126%attr(755,root,root) %{_datadir}/%{name}/wtf
127
128%{_datadir}/%{name}/*.py
129%{_datadir}/%{name}/profile.xml
130%{_datadir}/%{name}/git-templates/
131%{_datadir}/%{name}/git_utils/
132%{_datadir}/%{name}/recipes/
133%{_datadir}/%{name}/support/
134%{_datadir}/%{name}/third_party/
135%{_datadir}/%{name}/zsh-goodies/
This page took 0.098333 seconds and 4 git commands to generate.