]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
clean webp (using system one)
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
ba685303 3%bcond_without cups # with cups
2108baf2 4%bcond_without debuginfo # disable debuginfo creation (it is huge)
ba685303 5%bcond_without gconf # with GConf
75f96a39 6%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
2108baf2 7%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
71d49434 8%bcond_with gps # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
ba685303 9%bcond_without libjpegturbo # use libjpeg-turbo features
3aa67e11 10%bcond_with nacl # build Native Client support, disabled: http://crbug.com/269560
ba685303 11%bcond_without pulseaudio # with pulseaudio
2108baf2
ER
12%bcond_without sandboxing # with sandboxing
13%bcond_with selinux # with SELinux (need policy first)
14%bcond_with shared_libs # with shared libs
15%bcond_with sse2 # use SSE2 instructions
ba685303 16%bcond_without system_flac # system flac
a323900c 17%bcond_with system_ffmpeg # system ffmpeg instead of ffmpegsumo
108c5f7c 18%bcond_without system_harfbuzz # system harfbuzz
ba685303 19%bcond_without system_jsoncpp # system jsoncpp
62950103
ER
20%bcond_without system_libexif # system libexif
21%bcond_without system_libmtp # system libmtp
3934d767 22%bcond_with system_libusb # system libusb-1, disabled: http://crbug.com/266149
88171dca 23%bcond_without system_libwebp # system libwebp
4884fc99 24%bcond_without system_libxnvctrl # system libxnvctrl
cca42012 25%bcond_with system_mesa # system Mesa
126ea630 26%bcond_without system_minizip # system minizip
62950103 27%bcond_without system_opus # system opus codec support, http://www.opus-codec.org/examples/
108c5f7c 28%bcond_without system_protobuf # system protobuf
543e99ac 29%bcond_without system_re2 # system re2
7e634b46 30%bcond_without system_snappy # system snappy
ba685303 31%bcond_without system_speex # system speex
a8f4f3ac 32%bcond_with system_sqlite # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
9bd2659c 33%bcond_without system_libsrtp # system srtp (can be used if using bundled libjingle)
ba685303 34%bcond_with system_v8 # system v8
4b411ffe 35%bcond_without system_libvpx # system libvpx
ba685303 36%bcond_without system_yasm # system yasm
1c00315b 37%bcond_without system_zlib # system zlib
d2781a31 38%bcond_without tcmalloc # use tcmalloc
7e136323 39%bcond_without verbose # verbose build (V=1)
0c480b89 40
b3fc6cb2
ER
41%ifarch %{ix86}
42# GLsizeiptr different size, track: http://bugs.gentoo.org/457130
43%undefine with_system_mesa
44%endif
45
6d92f81c 46# TODO
b363f856 47# - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
b363f856 48# - use_system_skia
a3140cd1 49# - use_system_ssl (use_openssl: http://crbug.com/62803)
b363f856 50# - use_system_stlport (android specific)
7b8f219a 51# - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
a3140cd1 52
e53ecfb5 53# NOTES:
4fe038cb
ER
54# - mute BEEP mixer if you do not want to hear horrible system bell when
55# pressing home/end in url bar or more ^F search results on page.
7c638678 56# - space considerations:
0bb93ab2 57# - unpacked sources: ~490MiB
c1ecd31f 58# - built code: ~1.4GiB (x86_64/i686)
f1b276d4 59# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 60# - to look for new tarball, use update-source.sh script
f1b276d4 61
a323900c
ER
62%define branch 33.0.1750
63%define basever 117
64#define patchver 107
a3140cd1 65%define gyp_rev 1014
11ad81c4 66Summary: A WebKit powered web browser
05f72ae2 67Name: chromium-browser
f73369da
ER
68%if "%{?patchver}" != ""
69Version: %{branch}.%{patchver}
70%else
71Version: %{branch}.%{basever}
72%endif
537abf9b 73Release: 1
5bb99ef4 74License: BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
e53ecfb5 75Group: X11/Applications/Networking
f177fdad
ER
76Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
77# Source0-md5: c14a4bcb8bed66ea2204cd698d938250
3c73e180
ER
78%if "%{?patchver}" != ""
79Patch0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
dd8bb9ff 80# Patch0-md5: 82e3012b5510187907bba50dadbe7137
3c73e180 81%endif
37ceaf05 82Source1: %{name}.default
8b53130d
ER
83Source2: %{name}.sh
84Source3: %{name}.desktop
56c6e811
ER
85Source5: find-lang.sh
86Source6: update-source.sh
87Source7: clean-source.sh
836b1cac 88Source8: get-source.sh
0562b864 89Source9: master_preferences.json
48b341f5 90Patch1: plugin-searchdirs.patch
72cb20c1 91Patch4: path-libpdf.patch
5aa5df39 92Patch7: dlopen_sonamed_gl.patch
4765ddf1 93Patch8: chromium_useragent.patch.in
8456d676 94Patch10: system-libxnvctrl.patch
1347c76c
AM
95# https://bugs.gentoo.org/show_bug.cgi?id=393471
96# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 97Patch11: chromium-revert-jpeg-swizzle-r2.patch
108c5f7c 98Patch12: system-ffmpeg.patch
5997e180
ER
99Patch15: nacl-build-irt.patch
100Patch16: nacl-linkingfix.patch
9516ca97 101Patch18: nacl-no-untar.patch
6897926c 102Patch24: nacl-verbose.patch
c5b396f3
ER
103Patch25: gnome3-volume-control.patch
104Patch26: master-prefs-path.patch
25d4e23c 105Patch28: system-mesa.patch
e0a7fe40 106Patch30: system-ply.patch
9cce36cb 107Patch31: system-jinja.patch
708e64c2 108Patch32: remove_bundled_libraries-stale.patch
a323900c 109Patch33: gn.patch
750b48f7 110URL: http://www.chromium.org/Home
ae3fe89f 111%{?with_gconf:BuildRequires: GConf2-devel}
a28c0ac3 112%{?with_system_mesa:BuildRequires: Mesa-libGL-devel >= 9.1}
3a3b7da9 113BuildRequires: Mesa-libGLES-devel >= 9.1
7b8f219a 114%{?with_system_mesa:BuildRequires: Mesa-libGLU-devel}
a28c0ac3 115%{?with_system_mesa:BuildRequires: Mesa-libOSMesa-devel >= 9.1}
05f72ae2
ER
116BuildRequires: alsa-lib-devel
117BuildRequires: atk-devel
118BuildRequires: bison
11ad81c4 119BuildRequires: bzip2-devel
5997e180
ER
120%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
121%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
122%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
9516ca97 123%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
ae3fe89f 124%{?with_cups:BuildRequires: cups-devel}
92965b0e 125BuildRequires: elfutils-devel
77f32fa3 126BuildRequires: expat-devel
7d0dbc8d 127%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 1.0}
8f5f6775 128%{?with_system_flac:BuildRequires: flac-devel >= 1.2.1-7}
11ad81c4 129BuildRequires: fontconfig-devel
f1b276d4 130BuildRequires: glib2-devel
05f72ae2 131BuildRequires: gperf
71d49434 132%{?with_gps:BuildRequires: gpsd-devel}
bbad64b7 133BuildRequires: gtest-devel
8b53130d 134BuildRequires: gtk+2-devel
01b4dc8e 135%{?with_system_harfbuzz:BuildRequires: harfbuzz-devel}
7ebeabb6 136%{?with_system_harfbuzz:BuildRequires: harfbuzz-icu-devel}
a3140cd1 137%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 138BuildRequires: hicolor-icon-theme
ed514974 139%{?with_system_jsoncpp:BuildRequires: jsoncpp-devel}
ef121064 140%{?with_system_libxnvctrl:BuildRequires: libXNVCtrl-devel >= 310.19}
05f72ae2 141BuildRequires: libevent-devel
8456d676 142%{?with_system_libexif:BuildRequires: libexif-devel >= 1:0.6.21}
7f40f3f4 143%{?with_keyring:BuildRequires: libgnome-keyring-devel}
0b214002 144BuildRequires: libicu-devel >= 4.6
39c71b4c 145%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
f4a8da6a 146%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
8456d676 147%{?with_system_libmtp:BuildRequires: libmtp-devel >= 1.1.3}
05f72ae2 148BuildRequires: libpng-devel
e266589e 149%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 150BuildRequires: libstdc++-devel
ba685303 151%{?with_system_libusb:BuildRequires: libusb-devel >= 1.0}
88171dca
ER
152%{?with_system_libvpx:BuildRequires: libvpx-devel >= 1.3.0}
153%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.4.0}
f1b276d4 154BuildRequires: libxml2-devel
11ad81c4 155BuildRequires: libxslt-devel
535cb410 156BuildRequires: man-db
62950103 157%{?with_system_minizip:BuildRequires: minizip-devel}
05f72ae2 158BuildRequires: nspr-devel
f1b276d4 159BuildRequires: nss-devel >= 1:3.12.3
8456d676 160%{?with_system_opus:BuildRequires: opus-devel >= 1.0.2}
35902862 161BuildRequires: pam-devel
f1b276d4 162BuildRequires: pango-devel
ef121064 163BuildRequires: pciutils-devel
3a3b7da9 164BuildRequires: perl-JSON
48b341f5 165BuildRequires: perl-modules
166BuildRequires: pkgconfig
75a27c2e 167%{?with_system_protobuf:BuildRequires: protobuf-devel}
ae3fe89f 168%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 169BuildRequires: python
46cdefee 170#BuildRequires: python-gyp >= 1-%{gyp_rev}
9cce36cb 171BuildRequires: python-jinja2 >= 2.7
48b341f5 172BuildRequires: python-modules
e0a7fe40 173BuildRequires: python-ply >= 3.4
543e99ac 174%{?with_system_re2:BuildRequires: re2-devel >= 20130115-2}
0cad051b 175BuildRequires: rpm >= 4.4.9-56
f1b276d4 176BuildRequires: rpmbuild(macros) >= 1.453
f099161f 177%{?with_system_snappy:BuildRequires: snappy-devel}
eda1bb04 178BuildRequires: speech-dispatcher-devel >= 0.8
0cad051b 179%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
5048b37a 180%{?with_system_sqlite:BuildRequires: sqlite3-devel >= 3.7}
9bd2659c 181%{?with_system_libsrtp:BuildRequires: srtp-devel >= 1.4.4}
0cad051b 182BuildRequires: tar >= 1:1.22
0a424ee2 183BuildRequires: udev-devel
7d1152d4 184BuildRequires: usbutils
2303ed45 185BuildRequires: util-linux
c14cd342 186%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 187BuildRequires: which
f1b276d4 188BuildRequires: xorg-lib-libXScrnSaver-devel
3a3b7da9 189BuildRequires: xorg-lib-libXtst-devel
836b1cac 190BuildRequires: xz
a3140cd1 191%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 192%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 193Requires: browser-plugins >= 2.0
0cad051b 194Requires: desktop-file-utils
8f5f6775 195%{?with_system_flac:Requires: flac >= 1.2.1-7}
ae20377c
ER
196# crashes if no fontconfig font present
197Requires: fonts-Type1-urw
0eb19b0b 198Requires: hicolor-icon-theme
56403697 199Requires: libevent >= 2.0.21
c1edaafa 200%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
88171dca 201%{?with_system_libvpx:Requires: libvpx >= 1.3.0}
b809ab60 202Requires: lsb-release
b2c4ae39 203%{?with_system_re2:Requires: re2 >= 20130115-2}
3700ba38 204Requires: shared-mime-info
f7b16691 205%{?with_system_sqlite:Requires: sqlite3(icu)}
4dc49133 206Requires: xdg-utils >= 1.0.2-4
2cbfc1a4 207Requires: xorg-lib-libX11 >= 1.4.99.1
e53ecfb5 208Provides: wwwbrowser
c3582150 209Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 210Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 211ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 212BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 213
319f81f7
ER
214# Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
215# Note: these are for PLD Linux use ONLY.
216# For your own distribution, please get your own set of keys.
217%define google_api_key AIzaSyD1tTgDbP-N6BGXKZ7VqSos_IU1QflGbyg
218%define google_default_client_id 724288223830.apps.googleusercontent.com
219%define google_default_client_secret rHmKOPygcI6G-clFHb-RfuHb
220
7ebeabb6 221%define find_lang sh find-lang.sh %{buildroot}
2446ebb3 222
e7fa0817
ER
223# Usage: gyp_with BCOND_NAME [OPTION_NAME]
224%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 225
a323900c
ER
226%ifarch %{ix86}
227%define target_arch ia32
228%endif
229%ifarch %{x8664}
230%define target_arch x64
231%endif
232
6b113615
ER
233%if %{without debuginfo}
234%define _enable_debug_packages 0
235%endif
236
11ad81c4 237%description
80838854
ER
238Chromium is an open-source browser project that aims to build a safer,
239faster, and more stable way for all Internet users to experience the
240web.
241
242Chromium serves as a base for Google Chrome, which is Chromium
243rebranded (name and logo) with very few additions such as usage
244tracking and an auto-updater system.
245
f1b276d4
ER
246%package l10n
247Summary: chromium-browser language packages
248Group: I18n
249Requires: %{name} = %{version}-%{release}
8da7b90b
ER
250%if "%{_rpmversion}" >= "5"
251BuildArch: noarch
252%endif
f1b276d4
ER
253
254%description l10n
255Chromium is an open-source browser project that aims to build a safer,
256faster, and more stable way for all Internet users to experience the
257web.
258
259This package contains language packages for 50 languages:
260
e7fa0817
ER
261ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
262he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
263pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
264zh-TW
f1b276d4
ER
265
266%prep
3c73e180
ER
267%setup -qc
268%if "%{?patchver}" != ""
269cd %{name}-%{branch}.%{basever}
270%patch0 -p1
271cd ..
272%endif
75f96a39 273mv %{name}-%{branch}.%{basever}/* .
589d90ea 274
05f72ae2
ER
275# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
276# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
75f96a39 277. ./chrome/VERSION
e00e4177
ER
278chrome=$MAJOR.$MINOR.$BUILD.$PATCH
279test "$chrome" = %{version}
a3140cd1 280
75f96a39 281gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 282test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 283
e00e4177
ER
284. ./v8.sh
285v8=$MAJOR_VERSION.$MINOR_VERSION.$BUILD_NUMBER.$PATCH_LEVEL
33b04c7d 286
4765ddf1
ER
287# add chromium and pld to useragent
288%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
289sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
25d4e23c
ER
290 -e 's/@BUILD_DIST_NAME@/PLD/g' \
291 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
71581184 292 < %{PATCH8} | %{__patch} -p1
4765ddf1 293
8da7b90b 294%{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
75f96a39
ER
295ln -s %{SOURCE7} .
296
fb336f24 297%patch1 -p1
75f96a39 298%patch4 -p3
7879021e
ER
299%patch7 -p1
300%patch10 -p1
75f96a39 301%patch15 -p2
f4a8da6a 302%{!?with_libjpegturbo:%patch11 -p0}
108c5f7c 303%patch12 -p1
5997e180 304%patch16 -p1
41d6a4b1 305%patch28 -p1
a323900c 306%patch25 -p1
3aa67e11 307%{?with_nacl:%patch18 -p1}
75f96a39
ER
308%patch24 -p2
309%patch26 -p2
63c64837 310%patch30 -p1
9cce36cb 311%patch31 -p0
708e64c2 312%patch32 -p1
a323900c 313%patch33 -p0
e9abb380 314
75a27c2e
ER
315sh -x clean-source.sh \
316 %{!?with_nacl:nacl=0} \
bbdce24d
ER
317 %{!?with_system_libvpx:libvpx=0} \
318 %{!?with_system_libxnvctrl:libXNVCtrl=0} \
25d4e23c 319 %{!?with_system_mesa:mesa=0} \
75a27c2e 320 %{!?with_system_protobuf:protobuf=0} \
bbdce24d 321 %{!?with_system_re2:re2=0} \
7e634b46 322 %{!?with_system_snappy:snappy=0} \
5048b37a 323 %{!?with_system_sqlite:sqlite=0} \
75a27c2e 324 %{!?with_system_v8:v8=0} \
0767a7a0 325 %{!?with_system_libwebp:libwebp=0} \
75a27c2e 326 %{!?with_system_zlib:zlib=0} \
f177fdad 327 %{!?with_system_ffmpeg:ffmpeg=0} \
75a27c2e 328 %{nil}
fded59be 329
e266589e 330%build
5997e180 331%if %{with nacl}
108c5f7c 332rm -rf native_client/toolchain/linux_x86_newlib
fded59be 333if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
dcea0d6b 334# Make symlinks for NaCL
108c5f7c 335install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
2e4113fd 336
108c5f7c
ER
337cd native_client/toolchain/linux_x86_newlib
338ln -s x86_64-nacl/bin bin
339cd x86_64-nacl/bin
2e4113fd 340__cc='%{__cc}'
f64e73f6 341if [ "${__cc#ccache}" != "$__cc" ]; then
2e4113fd
ER
342 echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
343 echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
344 %{__sed} -i -e '1i#!/bin/sh' gcc g++
345 chmod +x gcc g++
346else
347 ln -s %{_bindir}/x86_64-nacl-gcc gcc
348 ln -s %{_bindir}/x86_64-nacl-g++ g++
349fi
108c5f7c
ER
350ln -s gcc x86_64-nacl-gcc
351ln -s g++ x86_64-nacl-g++
352ln -s %{_bindir}/x86_64-nacl-ar .
5997e180
ER
353ln -s %{_bindir}/x86_64-nacl-ar ar
354ln -s %{_bindir}/x86_64-nacl-as as
108c5f7c 355ln -s %{_bindir}/x86_64-nacl-ranlib .
5997e180 356ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
108c5f7c 357ln -s %{_bindir}/x86_64-nacl-strip .
5997e180 358ln -s %{_bindir}/x86_64-nacl-strip strip
1ed01da3 359ln -s %{_bindir}/x86_64-nacl-objcopy .
108c5f7c
ER
360ln -s %{_prefix}/x86_64-nacl/lib ../lib
361ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
dcea0d6b
ER
362ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
363cd ../../../../..
fded59be 364fi
5997e180
ER
365%endif
366
a323900c
ER
367%if %{without system_ffmpeg}
368# Re-configure bundled ffmpeg
369cd third_party/ffmpeg
370chromium/scripts/build_ffmpeg.sh linux %{target_arch} "$PWD" config-only
371chromium/scripts/copy_config.sh
372cd -
0c480b89 373%endif
a323900c
ER
374
375flags="
376 -Dtarget_arch=%{target_arch} \
377 -Dpython_arch=%{target_arch} \
b91ce587 378 -Dsystem_libdir=%{_lib} \
a323900c 379 -Dpython_ver=%{py_ver} \
7b454a31
AM
380%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
381 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4
ER
382%endif
383 %{!?debug:-Dwerror=} \
c980b122 384 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 385 %{?with_shared_libs:-Dlibrary=shared_library} \
9da385b7 386 %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} -Dproprietary_codecs=1 \
b5a3dda3 387 -Dinclude_tests=0 \
c0808220 388%if %{with nacl}
038f76b9 389 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
9516ca97
ER
390 -Ddisable_glibc_untar=1 \
391 -Ddisable_newlib_untar=1 \
8fb1dc98
ER
392 -Ddisable_glibc=1 \
393 -Ddisable_pnacl=1 \
394 -Dbuild_pnacl_newlib=0 \
c0808220 395%else
8fb1dc98 396 -Ddisable_pnacl_untar=1 \
c0808220
ER
397 -Ddisable_nacl=1 \
398%endif
a3140cd1
ER
399 %{!?with_sse2:-Ddisable_sse2=1} \
400 %{?with_selinux:-Dselinux=1} \
7d1152d4 401 -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
05998197 402 -Dlinux_link_libpci=1 \
7879021e 403 -Dlinux_link_libspeechd=1 -Dlibspeechd_h_prefix=speech-dispatcher/ \
05998197 404 %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
71d49434 405 %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
05998197
ER
406 -Dlinux_use_gold_binary=0 \
407 -Dlinux_use_gold_flags=0 \
71581184 408 -Dlogging_like_official_build=1 \
319f81f7
ER
409 -Dgoogle_api_key=%{google_api_key} \
410 -Dgoogle_default_client_id=%{google_default_client_id} \
411 -Dgoogle_default_client_secret=%{google_default_client_secret} \
e7fa0817 412 %{gyp_with cups} \
8dda6bbc 413 %{gyp_with gconf} -Dlinux_link_gsettings=0 \
bd827d58 414 %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
e7fa0817
ER
415 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
416 %{gyp_with pulseaudio} \
41d6a4b1 417 %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
8f5f6775 418 %{gyp_with system_flac} \
01b4dc8e 419 %{gyp_with system_harfbuzz} \
2d65d095 420 %{gyp_with system_jsoncpp} \
62950103
ER
421 %{gyp_with system_libexif} \
422 %{gyp_with system_libmtp} \
9bd2659c 423 %{gyp_with system_libsrtp} \
581aec44 424 %{gyp_with system_libusb} \
88171dca 425 %{gyp_with system_libvpx} -Dmedia_use_libvpx=1 \
ba685303 426 %{gyp_with system_libwebp} \
4884fc99 427 %{gyp_with system_libxnvctrl} \
7b8f219a 428 %{gyp_with system_mesa} \
126ea630 429 %{gyp_with system_minizip} \
62950103 430 %{gyp_with system_opus} \
75a27c2e 431 %{gyp_with system_protobuf} \
bbdce24d 432 %{gyp_with system_re2} \
7e634b46 433 %{gyp_with system_snappy} \
e7fa0817 434 %{gyp_with system_speex} \
914ee37c 435 %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
e7fa0817
ER
436 %{gyp_with system_v8} \
437 %{gyp_with system_yasm} \
438 %{gyp_with system_zlib} \
0c480b89 439 -Duse_system_bzip2=1 \
62950103 440 -Duse_system_expat=1 \
0b214002 441 -Duse_system_icu=1 \
f1b276d4 442 -Duse_system_libevent=1 \
0c480b89 443 -Duse_system_libjpeg=1 \
f1b276d4
ER
444 -Duse_system_libpng=1 \
445 -Duse_system_libxml=1 \
446 -Duse_system_libxslt=1 \
b363f856 447 -Duse_system_nspr=1 \
7f40f3f4 448 -Duse_system_xdg_utils=1 \
7879021e
ER
449"
450
451build/linux/unbundle/replace_gyp_files.py $flags
452
453test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
454test -e Makefile || \
455 CC="%{__cc}" \
456 CXX="%{__cxx}" \
457 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
458 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
459 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
460 CC_host="%{__cc}" \
461 CXX_host="%{__cxx}" \
462 LD_host="%{__cxx}" \
463%{__python} build/gyp_chromium \
464 --format=make \
465 --depth=. \
466 build/all.gyp \
467 $flags
11ad81c4 468
b4d75247 469# need {CC/CXX/LDFLAGS}.host overrides for v8 build
48ffbc5e 470%{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
f1b276d4
ER
471 BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
472 %{?with_verbose:V=1} \
f1b276d4
ER
473 CC.host="%{__cc}" \
474 CXX.host="%{__cxx}" \
b4d75247 475 LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
11ad81c4 476
75f96a39 477cd out/%{!?debug:Release}%{?debug:Debug}
535cb410
ER
478MANWIDTH=80 man ./chrome.1 > man.out
479%{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
480
11ad81c4
AM
481%install
482rm -rf $RPM_BUILD_ROOT
8da7b90b
ER
483install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
484 $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
37ceaf05 485 $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
e266589e 486
673aee14 487cd out/%{!?debug:Release}%{?debug:Debug}
37ceaf05 488cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4 489install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
535cb410
ER
490%{__sed} -i -e '
491 s,@libdir@,%{_libdir}/%{name},
492
493 /@OPTIONS@/ {
494 r options.txt
495 d
496 }
497' $RPM_BUILD_ROOT%{_bindir}/%{name}
8da7b90b
ER
498cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
499cp -a *.pak $RPM_BUILD_ROOT%{_libdir}/%{name}
500ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
501ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
7f40f3f4 502cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 503install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
d1a83042 504install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome-sandbox
fcc48c19 505%if %{without system_ffmpeg}
f1b276d4 506install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 507%endif
e7fa0817 508cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
0562b864 509cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
164020eb 510
8da7b90b 511%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
c0808220 512
164020eb
ER
513%if %{with nacl}
514# Install Native Client files on platforms that support it.
515install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
516install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
517%ifarch %{x8664}
518install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
519%endif
520%ifarch %{ix86}
521install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
522%endif
523%endif
524
0c480b89
ER
525cd -
526
75f96a39 527for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
0eb19b0b
ER
528 size=${icon##*/product_logo_}
529 size=${size%.png}
530
531 # this will skip non-numeric (22_mono_invert, 22_mono)
532 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
533 test -d "$dir" || continue
534
535 install -d $RPM_BUILD_ROOT$dir
536 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
537done
7f40f3f4 538
13840bc2
AM
539%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
540# http://code.google.com/p/chromium/issues/detail?id=24507
541gecko-mediaplayer*.so
542EOF
11ad81c4 543
589d90ea
ER
544# find locales
545%find_lang %{name}.lang
e7fa0817 546# always package en-US
f1b276d4 547%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 548
11ad81c4
AM
549%clean
550rm -rf $RPM_BUILD_ROOT
551
8da7b90b
ER
552%pretrans
553for d in locales resources; do
554 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
555 install -d %{_datadir}/%{name}
556 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
557 fi
558done
559exit 0
560
f1b276d4 561%post
0eb19b0b 562%update_icon_cache hicolor
b7a6e4ee 563%update_desktop_database
f1b276d4
ER
564%update_browser_plugins
565
566%postun
567if [ "$1" = 0 ]; then
0eb19b0b 568 %update_icon_cache hicolor
f1b276d4
ER
569 %update_browser_plugins
570fi
571
1d2b9616 572%files
11ad81c4 573%defattr(644,root,root,755)
75f96a39 574%doc AUTHORS LICENSE
f1b276d4
ER
575%{_browserpluginsconfdir}/browsers.d/%{name}.*
576%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
577%dir %{_sysconfdir}/%{name}
578%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
0562b864 579%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
f1b276d4
ER
580%attr(755,root,root) %{_bindir}/%{name}
581%{_mandir}/man1/%{name}.1*
11ad81c4 582%{_desktopdir}/*.desktop
0eb19b0b 583%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89 584%dir %{_libdir}/%{name}
e9abb380 585%{_libdir}/%{name}/chrome*.pak
c14cd342 586%{_libdir}/%{name}/content_resources.pak
97fac491 587%{_libdir}/%{name}/resources.pak
8da7b90b
ER
588%{_libdir}/%{name}/locales
589%{_libdir}/%{name}/resources
590
591%dir %{_datadir}/%{name}
592%dir %{_datadir}/%{name}/locales
593%{_datadir}/%{name}/locales/en-US.pak
594%dir %{_datadir}/%{name}/resources
595%{_datadir}/%{name}/resources/inspector
596
f1b276d4
ER
597%dir %{_libdir}/%{name}/plugins
598%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 599# These unique permissions are intentional and necessary for the sandboxing
d1a83042 600%attr(4555,root,root) %{_libdir}/%{name}/chrome-sandbox
f1b276d4
ER
601
602# ffmpeg libs
fcc48c19 603%if %{without system_ffmpeg}
f1b276d4 604%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 605%endif
f1b276d4 606
164020eb
ER
607%if %{with nacl}
608%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
609%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
610%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
611%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
612%endif
613
f1b276d4
ER
614%files l10n -f %{name}.lang
615%defattr(644,root,root,755)
This page took 0.216167 seconds and 4 git commands to generate.