]> git.pld-linux.org Git - packages/adobe-flash.git/blame - adobe-flash.spec
- license-installer.sh moved to DistFiles
[packages/adobe-flash.git] / adobe-flash.spec
CommitLineData
e9cc6da3 1#
aa3cbbce 2# Conditional build:
3%bcond_with license_agreement # generates package
19d7e29f 4
0b37c64a
JB
5%define ver_major 10
6%define ver_minor 0
bf122041
AM
7%define ver_patch 42
8%define ver_serial 34
19d7e29f
ER
9
10%ifarch %{x8664}
11%define libmark ()(64bit)
12%else
b18d4034
AM
13%define libmark %{nil}
14%endif
19d7e29f 15
fdeb48aa 16%define base_name adobe-flash
bf122041 17%define rel 1
53f15d83 18Summary: Flash plugin for Netscape-compatible WWW browsers
989db712 19Summary(pl.UTF-8): Wtyczka Flash dla przeglądarek WWW zgodnych z Netscape
aa3cbbce 20%if %{with license_agreement}
21Name: %{base_name}
22%else
23Name: %{base_name}-installer
24%endif
5e11dd18
ER
25Version: %{ver_major}.%{ver_minor}.%{ver_patch}.%{ver_serial}
26Release: %{rel}%{?with_license_agreement:wla}
4ec0200b 27Epoch: 1
53f15d83 28License: Free to use, non-distributable
01b5e1fb 29Group: X11/Applications/Multimedia
aa3cbbce 30%if %{with license_agreement}
6fa8c0e6 31Source0: http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_10_linux.tar.gz
a2f26fd1 32# NoSource0-md5: aa694c7392d4519e4ef7812fd2922730
19d7e29f 33Source1: http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-%{version}.linux-x86_64.so.tar.gz
a2f26fd1 34# NoSource1-md5: 8b427c2991c0447af56a951c653ee383
18284157 35%else
d9720229 36Source2: http://svn.pld-linux.org/svn/license-installer/license-installer.sh
37# Source2-md5: 4fb1600353dd57fe088e0b12fb0ecac2
aa3cbbce 38%endif
ba9bcac5 39URL: http://www.adobe.com/products/flashplayer/
b68eb59b 40%if %{with license_agreement}
df79ad5e 41BuildRequires: rpmbuild(macros) >= 1.357
5f855dbc 42BuildRequires: sed >= 4.0
df79ad5e 43Requires: browser-plugins >= 2.0
15b3da69 44# dlopened by player
b18d4034
AM
45Requires: libasound.so.2%{libmark}
46Requires: libcurl.so.4%{libmark}
94ae04b2 47%else
7be1acc6 48Requires: rpm-build-tools >= 4.4.35
533db319 49%endif
bcccd50e 50Provides: browser(flash)
5f855dbc 51Provides: macromedia-flash
533db319 52Obsoletes: flash-plugin
533db319 53Obsoletes: konqueror-plugin-macromedia-flash
5891b1a0 54Obsoletes: macromedia-flash
a00d2cc2
ER
55Obsoletes: mozilla-firefox-plugin-macromedia-flash
56Obsoletes: mozilla-plugin-macromedia-flash
b18d4034 57ExclusiveArch: %{ix86} %{x8664}
01b5e1fb
PG
58BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
ed1085d2
ER
60%define _sysconfdir /etc/adobe
61
0fa08e0e
ER
62# So that building package on AC system won't write package name dep that Th system can't understand (libstdc++4)
63%define _noautoreqdep libstdc++.so.6
64
1fe30e9c
ER
65# No debuginfo to be stored
66%define _enable_debug_packages 0
67
01b5e1fb 68%description
65fff478 69Adobe(R) Flash(R) Player for Linux - the next-generation client
e338620c 70runtime for engaging with Flash content and applications on Linux.
53f15d83 71
5f2286aa
JR
72%description -l pl.UTF-8
73Adobe(R) Flash(R) Player - środowisko nowej generacji do obsługi
74treści i aplikacji we Flashu pod Linuksem.
53f15d83 75
01b5e1fb 76%prep
aa3cbbce 77%if %{with license_agreement}
b18d4034
AM
78%ifarch %{x8664}
79%setup -q -T -c -b 1
80%else
3170126a 81%setup -q -T -c -b 0
b18d4034 82%endif
d4052f7c
ER
83
84%build
85s='LNX %{ver_major},%{ver_minor},%{ver_patch},%{ver_serial}'
86v=$(strings libflashplayer.so | grep "$s")
87if [ "$v" != "$s" ]; then
88 : wrong version
89 exit 1
90fi
aa3cbbce 91%endif
01b5e1fb
PG
92
93%install
94rm -rf $RPM_BUILD_ROOT
ed1085d2 95%if %{without license_agreement}
aa3cbbce 96install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
97
18284157
ER
98sed -e '
99 s/@BASE_NAME@/%{base_name}/g
100 s/@TARGET_CPU@/%{_target_cpu}/g
101 s-@VERSION@-%{version}-g
102 s-@RELEASE@-%{release}-g
103 s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
cdd7950d 104' %{SOURCE2} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
aa3cbbce 105
106install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
107
108%else
109
ed1085d2
ER
110install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_browserpluginsdir}}
111cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/mms.cfg
112# http://www.adobe.com/cfusion/knowledgebase/index.cfm?id=16701594
e953e2c9 113# http://www.adobe.com/devnet/flashplayer/articles/flash_player_admin_guide.html
ed1085d2
ER
114AutoUpdateDisable=1
115AutoUpdateInterval=0
be05c7b7 116# OverrideGPUValidation=true
ed1085d2 117EOF
df79ad5e 118install *.so $RPM_BUILD_ROOT%{_browserpluginsdir}
aa3cbbce 119%endif
120
01b5e1fb
PG
121%clean
122rm -rf $RPM_BUILD_ROOT
123
df79ad5e 124%if %{without license_agreement}
ae33c71b 125%post
18284157 126%{_bindir}/%{base_name}.install
533db319 127%else
df79ad5e
ER
128%post
129%update_browser_plugins
533db319 130
df79ad5e
ER
131%postun
132if [ "$1" = 0 ]; then
133 %update_browser_plugins
134fi
533db319
ER
135%endif
136
aa3cbbce 137%files
138%defattr(644,root,root,755)
df79ad5e 139%if %{without license_agreement}
aa3cbbce 140%attr(755,root,root) %{_bindir}/%{base_name}.install
141%{_datadir}/%{base_name}
aa3cbbce 142%else
ed1085d2
ER
143%dir %{_sysconfdir}
144%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mms.cfg
df79ad5e 145%attr(755,root,root) %{_browserpluginsdir}/*.so
aa3cbbce 146%endif
This page took 0.11194 seconds and 4 git commands to generate.