]> git.pld-linux.org Git - packages/adobe-flash.git/commitdiff
- license-installer.sh moved to DistFiles
authorpawelz <pawelz@pld-linux.org>
Sat, 26 Dec 2009 11:30:39 +0000 (11:30 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    adobe-flash.spec -> 1.128
    license-installer.sh -> 1.13

adobe-flash.spec
license-installer.sh [deleted file]

index 88d24a8198af4ac187b1dd34684bc3d2d43efaa7..910bb9a008e1fd777b1b5f79c07f83ccc44c090c 100644 (file)
@@ -33,7 +33,8 @@ Source0:      http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_
 Source1:       http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-%{version}.linux-x86_64.so.tar.gz
 # NoSource1-md5:       8b427c2991c0447af56a951c653ee383
 %else
-Source2:       license-installer.sh
+Source2:       http://svn.pld-linux.org/svn/license-installer/license-installer.sh
+# Source2-md5: 4fb1600353dd57fe088e0b12fb0ecac2
 %endif
 URL:           http://www.adobe.com/products/flashplayer/
 %if %{with license_agreement}
diff --git a/license-installer.sh b/license-installer.sh
deleted file mode 100644 (file)
index 841b206..0000000
+++ /dev/null
@@ -1,57 +0,0 @@
-#!/bin/sh
-if [ "$1" = "--with" -a "$2" = "license_agreement" ]; then
-       tmp=$(mktemp -d)
-       SPECDIR="$tmp/packages/@BASE_NAME@"
-       SOURCEDIR="$tmp/packages/@BASE_NAME@"
-       SRPMDIR=`rpm --define "_topdir $tmp" --eval "%{_srcrpmdir}"`
-       BUILDDIR=`rpm --define "_topdir $tmp" --eval "%{_builddir}"`
-       RPMDIR=`rpm --define "_topdir $tmp" --eval "%{_rpmdir}"`
-       mkdir -p $SPECDIR $SRPMDIR $RPMDIR $SRPMDIR $SOURCEDIR $BUILDDIR
-
-       if echo "$3" | grep '\.src\.rpm$' >/dev/null; then
-               (
-               if echo "$3" | grep '://' >/dev/null; then
-                       cd $SRPMDIR
-                       wget --passive-ftp -t0 "$3"
-               else
-                       cp -f "$3" $SRPMDIR
-               fi
-               rpm2cpio `basename "$3"` | ( cd $SPECDIR; cpio -i @BASE_NAME@.spec )
-               if [ '@COPYSOURCES@' != '@'COPYSOURCES'@' ]; then
-                       rpm2cpio `basename "$3"` | ( cd $SOURCEDIR; cpio -i @COPYSOURCES@ )
-               fi
-               )
-       else
-               cp -i "$3" $SPECDIR || exit 1
-               if [ '@COPYSOURCES@' != '@'COPYSOURCES'@' ]; then
-                       for i in @COPYSOURCES@; do
-                               cp -i @DATADIR@/$i $SOURCEDIR/$i || exit 1
-                       done
-               fi
-       fi
-       ( cd $SPECDIR
-       nd=
-       if [ '@USE_DISTFILES@' = 'no' ]; then
-               nd=-nd
-       fi
-       /usr/bin/builder --define _topdir $tmp $nd -nm -nc -ncs --with license_agreement --target @TARGET_CPU@ @BASE_NAME@.spec
-       if [ "$?" -ne 0 ]; then
-               exit 2
-       fi
-       RPMNAMES="$RPMDIR/@BASE_NAME@-@VERSION@-@RELEASE@wla.@TARGET_CPU@.rpm"
-       rpm -Uhv $RPMNAMES || echo -e "Install manually the file(s):\n   $RPMNAMES" )
-else
-       if [ "@LICENSE@" != '@'LICENSE'@' ]; then
-               cat @LICENSE@
-               echo "
-If you accept the above license rebuild the package using:
-"
-       else
-               echo "
-License issues made us not to include inherent files into
-this package by default. If you want to create full working
-package please build it with the following command:
-"
-       fi
-       echo "$0 --with license_agreement @SPECFILE@"
-fi
This page took 0.03584 seconds and 4 git commands to generate.