]> git.pld-linux.org Git - packages/brltty.git/commitdiff
- fix python binding build error: auto/th/brltty-4.5-3 auto/ti/brltty-4.5-3
authorMarcin Krol <hawk@tld-linux.org>
Thu, 20 Jun 2013 07:37:21 +0000 (07:37 +0000)
committerMarcin Krol <hawk@tld-linux.org>
Thu, 20 Jun 2013 07:37:21 +0000 (07:37 +0000)
  Bindings/Python/brlapi.pyx:500:18: Syntax error in simple statement list

brltty-python.patch [new file with mode: 0644]
brltty.spec

diff --git a/brltty-python.patch b/brltty-python.patch
new file mode 100644 (file)
index 0000000..b40b5d5
--- /dev/null
@@ -0,0 +1,11 @@
+--- brltty-4.5/Bindings/Python/brlapi.pyx      2013-06-20 07:32:09.000000000 +0000
++++ brltty-4.5/Bindings/Python/brlapi.pyx      2013-06-20 07:32:52.064634045 +0000
+@@ -497,7 +497,7 @@
+               if (type(dots) == unicode):
+                       dots = dots.encode('latin1')
+               if (len(dots) < dispSize):
+-                      dots = dots + b"".center(dispSize - len(dots), '\0')
++                      dots = dots + "".center(dispSize - len(dots), '\0')
+               c_dots = dots
+               c_udots = <unsigned char *>c_dots
+               c_brlapi.Py_BEGIN_ALLOW_THREADS
index 589d9837c530efcbdd9c197ba459053ee95409dc..f9121dbbba590a922727627975aaf11c1affa1ed 100644 (file)
@@ -27,7 +27,7 @@ Summary:      Braille display driver for Linux/Unix
 Summary(pl.UTF-8):     Sterownik do wyƛwietlaczy Braille'a
 Name:          brltty
 Version:       4.5
-Release:       2
+Release:       3
 Group:         Daemons
 License:       GPL v2+ (brltty and drivers), LGPL v2.1+ (APIs)
 Source0:       http://mielke.cc/brltty/releases/%{name}-%{version}.tar.gz
@@ -35,6 +35,7 @@ Source0:      http://mielke.cc/brltty/releases/%{name}-%{version}.tar.gz
 Patch0:                %{name}-stat.patch
 Patch1:                %{name}-java.patch
 Patch2:                %{name}-speech-dispatcher.patch
+Patch3:                %{name}-python.patch
 URL:           http://mielke.cc/brltty/
 BuildRequires: alsa-lib-devel
 %{?with_at_spi:BuildRequires:  at-spi-devel}
@@ -234,6 +235,7 @@ Biblioteka BrlAPI dla Tcl.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 %build
 %{__autoconf}
This page took 0.106841 seconds and 4 git commands to generate.