]> git.pld-linux.org Git - packages/brltty.git/commitdiff
- updated to 5.0
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 16 Feb 2014 16:53:27 +0000 (17:53 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 16 Feb 2014 16:53:27 +0000 (17:53 +0100)
- removed obsolete stat patch
- added format patch (fixes build with -Werror=format-security)

brltty-format.patch [new file with mode: 0644]
brltty-stat.patch [deleted file]
brltty.spec

diff --git a/brltty-format.patch b/brltty-format.patch
new file mode 100644 (file)
index 0000000..39cc818
--- /dev/null
@@ -0,0 +1,11 @@
+--- brltty-5.0/Programs/async_io.c.orig        2014-01-27 19:39:26.000000000 +0100
++++ brltty-5.0/Programs/async_io.c     2014-02-16 16:27:20.807854232 +0100
+@@ -193,7 +193,7 @@
+ logOperation (const OperationEntry *operation, void *callback) {
+   logSymbol(LOG_CATEGORY(ASYNC_EVENTS),
+             callback,
+-            operation->function->methods->functionName);
++            "%s", operation->function->methods->functionName);
+ }
+ #ifdef __MINGW32__
diff --git a/brltty-stat.patch b/brltty-stat.patch
deleted file mode 100644 (file)
index fe095a8..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
---- brltty-4.2/Programs/sys_linux.c~   2010-05-07 07:10:01.000000000 +0200
-+++ brltty-4.2/Programs/sys_linux.c    2010-07-29 14:21:58.187188698 +0200
-@@ -24,6 +24,9 @@
- #include <fcntl.h>
- #include <sys/ioctl.h>
- #include <linux/kd.h>
-+#include <sys/types.h>
-+#include <sys/stat.h>
-+#include <unistd.h>
- #ifdef HAVE_LINUX_INPUT_H
- #include <linux/input.h>
index 4211826391389e6d00241ca1949d73e8f9fb48a2..6fa7fc656d852f2d3c38c15dda8d56462d00d35e 100644 (file)
 %bcond_without at_spi                  # AtSpi screen driver
 %bcond_without at_spi2                 # AtSpi2 screen driver
 #
-%define                brlapi_ver      0.6.0
+%define                brlapi_ver      0.6.1
 #
 %include       /usr/lib/rpm/macros.java
 Summary:       Braille display driver for Linux/Unix
 Summary(pl.UTF-8):     Sterownik do wyƛwietlaczy Braille'a
 Name:          brltty
-Version:       4.5
-Release:       4
+Version:       5.0
+Release:       1
 Group:         Daemons
 License:       GPL v2+ (brltty and drivers), LGPL v2.1+ (APIs)
-Source0:       http://mielke.cc/brltty/releases/%{name}-%{version}.tar.gz
-# Source0-md5: 7b52fa7746fed41ed344a1f75ce55951
-Patch0:                %{name}-stat.patch
+Source0:       http://mielke.cc/brltty/archive/%{name}-%{version}.tar.xz
+# Source0-md5: 44c71a973424658557b931f703017481
+Patch0:                %{name}-format.patch
 Patch1:                %{name}-java.patch
 Patch2:                %{name}-speech-dispatcher.patch
 Patch3:                %{name}-python.patch
@@ -56,11 +56,12 @@ BuildRequires:      libicu-devel
 BuildRequires: ncurses-devel
 %{?with_ocaml:BuildRequires:   ocaml}
 BuildRequires: pkgconfig
-%{?with_python:BuildRequires:  python-Pyrex}
+%{?with_python:BuildRequires:  python-Cython}
 %{?with_java:BuildRequires:    rpm-javaprov}
 %{?with_python:BuildRequires:  rpm-pythonprov}
 %{?with_speech_dispatcher:BuildRequires:       speech-dispatcher-devel >= 0.8}
-%{?with_tcl:BuildRequires:     tcl-devel}
+BuildRequires: tar >= 1:1.22
+%{?with_tcl:BuildRequires:     tcl-devel >= 8.5}
 %if %{with x}
 BuildRequires: xorg-lib-libX11-devel
 BuildRequires: xorg-lib-libXaw-devel
@@ -68,6 +69,7 @@ BuildRequires:        xorg-lib-libXext-devel
 BuildRequires: xorg-lib-libXt-devel
 BuildRequires: xorg-lib-libXtst-devel
 %endif
+BuildRequires: xz
 #%{?with_mikropuhe:BuildRequires:      Mikropuhe-devel (-lmikropuhe <mpwrfile.h>)}
 #%{?with_swift:BuildRequires:  Swift-devel (-lswift <swift.h>)}
 #%{?with_theta:BuildRequires:  Theta-devel (-ltheta <theta.h>)}
@@ -284,6 +286,8 @@ cat >$RPM_BUILD_ROOT/usr/lib/tmpfiles.d/brltty.conf <<EOF
 d /var/run/brltty 0755 root root -
 EOF
 
+%find_lang %{name}
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -566,7 +570,7 @@ exit 0
 %post  -n brlapi -p /sbin/ldconfig
 %postun        -n brlapi -p /sbin/ldconfig
 
-%files
+%files -f %{name}.lang
 %defattr(644,root,root,755)
 %doc Documents/{Manual-BRLTTY/English/BRLTTY*,ChangeLog,HISTORY,TODO}
 %doc doc/{Bindings,Bootdisks,Drivers,Patches,Tables,README,nsistrings.txt}
@@ -576,6 +580,7 @@ exit 0
 %attr(755,root,root) %{_bindir}/brltty-install
 %attr(755,root,root) %{_bindir}/brltty-trtxt
 %attr(755,root,root) %{_bindir}/brltty-ttb
+%attr(755,root,root) %{_bindir}/eutp
 %attr(755,root,root) %{_bindir}/vstp
 %{?with_x:%attr(755,root,root) %{_bindir}/xbrlapi}
 %dir %{_libdir}/brltty
@@ -601,6 +606,7 @@ exit 0
 %attr(755,root,root) %{_libdir}/brltty/libbrlttyblt.so
 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmb.so
 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmd.so
+%attr(755,root,root) %{_libdir}/brltty/libbrlttybmm.so
 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmn.so
 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmt.so
 %attr(755,root,root) %{_libdir}/brltty/libbrlttybnp.so
@@ -640,9 +646,15 @@ exit 0
 %dir /var/lib/BrlAPI
 %dir /var/run/brltty
 %{_mandir}/man1/brltty.1*
+%{_mandir}/man1/eutp.1*
 %{_mandir}/man1/vstp.1*
 %{?with_x:%{_mandir}/man1/xbrlapi.1*}
 
+%if %{with x}
+# gdm autostart - subpackage?
+#%{_datadir}/gdm/greeter/autostart/xbrlapi.desktop
+%endif
+
 %files -n brlapi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libbrlapi.so.*.*.*
This page took 0.220548 seconds and 4 git commands to generate.