]> git.pld-linux.org Git - packages/brltty.git/commitdiff
- rediff patches
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 2 Mar 2021 21:36:53 +0000 (22:36 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Tue, 2 Mar 2021 21:36:53 +0000 (22:36 +0100)
brltty-glibc25.patch
brltty-python.patch
brltty-speech-dispatcher.patch

index c8ffbf24b6db9187490e421723b3e796cfce925a..7a68e73ec42622a97e49d951fa196875e9884193 100644 (file)
@@ -1,10 +1,11 @@
---- brltty-5.5/Programs/brlapi_client.c~       2017-04-19 00:35:13.000000000 +0200
-+++ brltty-5.5/Programs/brlapi_client.c        2019-04-15 13:46:45.074072750 +0200
+diff -urNp -x '*.orig' brltty-6.1.org/Programs/brlapi_client.c brltty-6.1/Programs/brlapi_client.c
+--- brltty-6.1.org/Programs/brlapi_client.c    2020-04-05 12:35:34.000000000 +0200
++++ brltty-6.1/Programs/brlapi_client.c        2021-03-02 22:36:23.483472412 +0100
 @@ -28,6 +28,7 @@
  #include <errno.h>
  #include <fcntl.h>
  #include <sys/stat.h>
 +#include <sys/sysmacros.h>
  #include <locale.h>
- #ifndef __MINGW32__
+ #include <assert.h>
+ #include <limits.h>
index b40b5d5031b6a43218163049bbc91e4e6c23887d..b21ff7b9f9ff182b565ad0ebda2abff4aae32fe0 100644 (file)
@@ -1,6 +1,7 @@
---- brltty-4.5/Bindings/Python/brlapi.pyx      2013-06-20 07:32:09.000000000 +0000
-+++ brltty-4.5/Bindings/Python/brlapi.pyx      2013-06-20 07:32:52.064634045 +0000
-@@ -497,7 +497,7 @@
+diff -urNp -x '*.orig' brltty-6.1.org/Bindings/Python/brlapi.pyx brltty-6.1/Bindings/Python/brlapi.pyx
+--- brltty-6.1.org/Bindings/Python/brlapi.pyx  2020-04-05 12:35:34.000000000 +0200
++++ brltty-6.1/Bindings/Python/brlapi.pyx      2021-03-02 22:36:22.870140488 +0100
+@@ -652,7 +652,7 @@ cdef class Connection:
                if (type(dots) == unicode):
                        dots = dots.encode('latin1')
                if (len(dots) < dispSize):
@@ -8,4 +9,4 @@
 +                      dots = dots + "".center(dispSize - len(dots), '\0')
                c_dots = dots
                c_udots = <unsigned char *>c_dots
-               c_brlapi.Py_BEGIN_ALLOW_THREADS
+               with nogil:
index 054efa774be74b411f1c69a95c93214dcf735c89..b27e261d4861a85167e50ae95cd9747b43e62824 100644 (file)
@@ -1,20 +1,8 @@
---- brltty-4.5/configure.ac.orig       2013-03-27 23:54:58.000000000 +0100
-+++ brltty-4.5/configure.ac    2013-04-07 19:04:31.636980920 +0200
-@@ -1516,7 +1516,7 @@
-       ])
-    ])
--   BRLTTY_IF_PACKAGE([speech-dispatcher], [speechd], [include/libspeechd.h], [dnl
-+   BRLTTY_IF_PACKAGE([speech-dispatcher], [speechd], [include/speech-dispatcher/libspeechd.h], [dnl
-       BRLTTY_SPEECH_DRIVER([sd], [SpeechDispatcher])
-    ], [include], [lib], [speechd])
+diff -urNp -x '*.orig' brltty-6.1.org/Drivers/Speech/SpeechDispatcher/speech.c brltty-6.1/Drivers/Speech/SpeechDispatcher/speech.c
+--- brltty-6.1.org/Drivers/Speech/SpeechDispatcher/speech.c    2020-04-05 12:35:34.000000000 +0200
++++ brltty-6.1/Drivers/Speech/SpeechDispatcher/speech.c        2021-03-02 22:36:22.260141892 +0100
+@@ -34,7 +34,7 @@ typedef enum {
  
-    BRLTTY_IF_PACKAGE([Swift], [swift], [include/swift.h], [dnl
-       BRLTTY_SPEECH_DRIVER([sw], [Swift], [-L$(SWIFT_ROOT)/lib -lswift -lm])
---- brltty-4.5/Drivers/Speech/SpeechDispatcher/speech.c.orig   2013-03-27 23:51:36.000000000 +0100
-+++ brltty-4.5/Drivers/Speech/SpeechDispatcher/speech.c        2013-04-07 19:56:47.340248894 +0200
-@@ -38,7 +38,7 @@
- #define SPK_HAVE_PUNCTUATION
  #include "spk_driver.h"
  
 -#include <libspeechd.h>
  
  static SPDConnection *connectionHandle = NULL;
  static const char *moduleName;
+diff -urNp -x '*.orig' brltty-6.1.org/configure.ac brltty-6.1/configure.ac
+--- brltty-6.1.org/configure.ac        2020-04-06 10:12:58.000000000 +0200
++++ brltty-6.1/configure.ac    2021-03-02 22:36:22.260141892 +0100
+@@ -1847,7 +1847,7 @@ BRLTTY_ARG_DISABLE(
+       ])
+    ])
+-   BRLTTY_IF_PACKAGE([speech-dispatcher], [speechd], [include/libspeechd.h], [dnl
++   BRLTTY_IF_PACKAGE([speech-dispatcher], [speechd], [include/speech-dispatcher/libspeechd.h], [dnl
+       BRLTTY_SPEECH_DRIVER([sd], [SpeechDispatcher])
+    ], [include], [lib], [speechd])
This page took 0.065872 seconds and 4 git commands to generate.