]> git.pld-linux.org Git - packages/brltty.git/blob - brltty.spec
8b95e311cbc2f76f6091be68ab218498a3e50127
[packages/brltty.git] / brltty.spec
1 # TODO:
2 #       - what is that huge %post script?
3 #
4 # Conditional build:
5 %bcond_without  apidocs                 # documentation generated with doxygen
6 %bcond_without  java                    # Java bindings
7 %bcond_without  ocaml                   # OCaml bindings
8 %bcond_without  python                  # Python bindings
9 %bcond_without  python3                 # Python 3.x bindings
10 %bcond_without  tcl                     # Tcl bindings
11 %bcond_without  x                       # X11-based utilities
12 %bcond_without  gpm                     # mouse tracking via GPM
13 %bcond_without  libbraille              # libbraille Braille driver
14 %bcond_without  espeak                  # eSpeak synthesizer driver
15 %bcond_without  flite                   # Flite synthesizer driver
16 %bcond_with     mikropuhe               # Mikropuhe synthesizer driver [commercial, Finnish]
17 %bcond_without  speech_dispatcher       # Speech Dispatcher synthesizer driver
18 %bcond_with     swift                   # Swift synthesizer driver [commercial, from Cepstral]
19 %bcond_with     theta                   # Theta synthesizer driver [commercial, from Cepstral]
20 %bcond_with     viavoice                # IBM ViaVoice synthesizer driver [commercial]
21 %bcond_without  at_spi                  # AtSpi screen driver
22 %bcond_without  at_spi2                 # AtSpi2 screen driver
23 #
24 %define         brlapi_ver      0.6.1
25 #
26 %include        /usr/lib/rpm/macros.java
27 Summary:        Braille display driver for Linux/Unix
28 Summary(pl.UTF-8):      Sterownik do wyświetlaczy Braille'a
29 Name:           brltty
30 Version:        5.0
31 Release:        1
32 Group:          Daemons
33 License:        GPL v2+ (brltty and drivers), LGPL v2.1+ (APIs)
34 Source0:        http://mielke.cc/brltty/archive/%{name}-%{version}.tar.xz
35 # Source0-md5:  44c71a973424658557b931f703017481
36 Patch0:         %{name}-format.patch
37 Patch1:         %{name}-java.patch
38 Patch2:         %{name}-speech-dispatcher.patch
39 Patch3:         %{name}-python.patch
40 URL:            http://mielke.cc/brltty/
41 BuildRequires:  alsa-lib-devel
42 %{?with_at_spi:BuildRequires:   at-spi-devel}
43 BuildRequires:  autoconf >= 2.62
44 BuildRequires:  automake
45 BuildRequires:  bison
46 # just headers
47 BuildRequires:  bluez-libs-devel
48 %{?with_at_spi2:BuildRequires:  dbus-devel >= 1.0}
49 %{?with_apidocs:BuildRequires:  doxygen}
50 %{?with_espeak:BuildRequires:   espeak-devel}
51 %{?with_flite:BuildRequires:    flite-devel}
52 %{?with_gpm:BuildRequires:      gpm-devel}
53 %{?with_java:BuildRequires:     jdk}
54 %{?with_java:BuildRequires:     jpackage-utils}
55 %{?with_libbraille:BuildRequires:       libbraille-devel}
56 BuildRequires:  libicu-devel
57 BuildRequires:  ncurses-devel
58 %{?with_ocaml:BuildRequires:    ocaml}
59 BuildRequires:  pkgconfig
60 %{?with_python:BuildRequires:   python-Cython}
61 %{?with_python3:BuildRequires:  python3-Cython}
62 %{?with_java:BuildRequires:     rpm-javaprov}
63 %{?with_python:BuildRequires:   rpm-pythonprov}
64 %{?with_speech_dispatcher:BuildRequires:        speech-dispatcher-devel >= 0.8}
65 BuildRequires:  tar >= 1:1.22
66 %{?with_tcl:BuildRequires:      tcl-devel >= 8.5}
67 %if %{with x}
68 BuildRequires:  xorg-lib-libX11-devel
69 BuildRequires:  xorg-lib-libXaw-devel
70 BuildRequires:  xorg-lib-libXext-devel
71 BuildRequires:  xorg-lib-libXt-devel
72 BuildRequires:  xorg-lib-libXtst-devel
73 %endif
74 BuildRequires:  xz
75 #%{?with_mikropuhe:BuildRequires:       Mikropuhe-devel (-lmikropuhe <mpwrfile.h>)}
76 #%{?with_swift:BuildRequires:   Swift-devel (-lswift <swift.h>)}
77 #%{?with_theta:BuildRequires:   Theta-devel (-ltheta <theta.h>)}
78 #%{?with_viavoice:BuildRequires:        ViaVoice-devel (-libmeci50 <eci.h>)}
79 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
81 %description
82 BRLTTY is a background process (daemon) which provides access to the
83 Linux/Unix console (when in text mode) for a blind person using a
84 refreshable Braille display. It drives the Braille display, and
85 provides complete screen review functionality. Some speech capability
86 has also been incorporated.
87
88 %description -l pl.UTF-8
89 BRLTTY jest demonem, który udostępnia dostęp do linuksowej konsoli (w
90 trybie tekstowym) dla niewidomych używających wyświetlaczy Braille'a z
91 odświeżaniem (refreshable Braille display). BRLTTY steruje
92 wyświetlaczem Braille'a i dostarcza funkcjonalność całkowitego
93 przeglądu ekranu. Do tego pakietu została włączona możliwość syntezy
94 mowy.
95
96 %package -n brlapi
97 Summary:        Application Programming Interface for BRLTTY
98 Summary(pl.UTF-8):      API do BRLTTY
99 License:        LGPL v2.1+
100 Group:          Libraries
101
102 %description -n brlapi
103 This package provides the run-time support for the Application
104 Programming Interface to BRLTTY.
105
106 Install this package if you have an application which directly
107 accesses a refreshable Braille display.
108
109 %description -n brlapi -l pl.UTF-8
110 Ten pakiet zawiera środowisko uruchomieniowe dla programów
111 korzystających z API BRLTTY.
112
113 Zainstaluj ten pakiet jeśli masz aplikację, która bezpośrednio używa
114 wyświetlacza Braille'a z odświeżaniem.
115
116 %package -n brlapi-devel
117 Summary:        Headers and documentation for BrlAPI
118 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do BrlAPI
119 License:        LGPL v2.1+
120 Group:          Development/Libraries
121 Requires:       brlapi = %{version}-%{release}
122
123 %description -n brlapi-devel
124 This package provides the header files, shared object linker
125 reference, and reference documentation for BrlAPI (the Application
126 Programming Interface to BRLTTY). It enables the implementation of
127 applications which take direct advantage of a refreshable Braille
128 display in order to present information in ways which are more
129 appropriate for blind users and/or to provide user interfaces which
130 are more specifically atuned to their needs.
131
132 Install this package if you're developing or maintaining an
133 application which directly accesses a refreshable Braille display.
134
135 %description -n brlapi-devel -l pl.UTF-8
136 Ten pakiet zawiera pliki nagłówkowe oraz dokumentację do BrlAPI (API
137 do BRLTTY). BrlAPI pozwala implementować aplikacje, które bezpośrednio
138 korzystają z wyświetlaczy Braille'a dostarczając interfejs użytkownika
139 bardziej przystosowany dla osób niewidomych.
140
141 Zainstaluj ten pakiet, jeśli tworzysz lub nadzorujesz aplikację
142 korzystającą bezpośrednio z odświeżalnych wyświetlaczy Braille'a.
143
144 %package -n brlapi-static
145 Summary:        Static BrlAPI library
146 Summary(pl.UTF-8):      Statyczna biblioteka BrlAPI
147 License:        LGPL v2.1+
148 Group:          Development/Libraries
149 Requires:       brlapi-devel = %{version}-%{release}
150
151 %description -n brlapi-static
152 This is package with static BrlAPI library.
153
154 %description -n brlapi-static -l pl.UTF-8
155 Ten pakiet zawiera statyczną wersję biblioteki BrlAPI.
156
157 %package -n brlapi-apidocs
158 Summary:        BrlAPI documentation
159 Summary(pl.UTF-8):      Documentacja BrlAPI
160 Group:          Documentation
161
162 %description -n brlapi-apidocs
163 Documentation for BrlAPI in HTML format generated from brltty
164 sources by doxygen.
165
166 %description -n brlapi-apidocs -l pl.UTF-8
167 Dokumentacja BrlAPI w formacie HTML generowane ze
168 źrodeł brltty przez doxygen.
169
170 %package -n java-brlapi
171 Summary:        BrlAPI library for Java
172 Summary(pl.UTF-8):      Biblioteka BrlAPI dla Javy
173 License:        LGPL v2.1+
174 Group:          Libraries
175 Requires:       brlapi = %{version}-%{release}
176
177 %description -n java-brlapi
178 BrlAPI library for Java.
179
180 %description -n java-brlapi -l pl.UTF-8
181 Biblioteka BrlAPI dla Javy.
182
183 %package -n ocaml-brlapi
184 Summary:        OCaml binding for BrlAPI
185 Summary(pl.UTF-8):      Wiązania OCamla do BrlAPI
186 License:        LGPL v2.1+
187 Group:          Libraries
188 Requires:       brlapi = %{version}-%{release}
189 %requires_eq    ocaml-runtime
190
191 %description -n ocaml-brlapi
192 OCaml binding for BrlAPI.
193
194 %description -n ocaml-brlapi -l pl.UTF-8
195 Wiązania OCamla do BrlAPI.
196
197 %package -n ocaml-brlapi-devel
198 Summary:        OCaml binding for BrlAPI - development files
199 Summary(pl.UTF-8):      Wiązania OCamla do BrlAPI - pliki programistyczne
200 License:        LGPL v2.1+
201 Group:          Libraries
202 Requires:       ocaml-brlapi = %{version}-%{release}
203 %requires_eq    ocaml
204
205 %description -n ocaml-brlapi-devel
206 OCaml binding for BrlAPI - development files.
207
208 %description -n ocaml-brlapi-devel -l pl.UTF-8
209 Wiązania OCamla do BrlAPI - pliki programistyczne.
210
211 %package -n python-brlapi
212 Summary:        Python 2.x interface to BrlAPI
213 Summary(pl.UTF-8):      Interfejs Pythona 2.x do BrlAPI
214 License:        LGPL v2.1+
215 Group:          Libraries
216 Requires:       brlapi = %{version}-%{release}
217
218 %description -n python-brlapi
219 Python 2.x interface to BrlAPI.
220
221 %description -n python-brlapi -l pl.UTF-8
222 Interfejs Pythona 2.x do BrlAPI.
223
224 %package -n python3-brlapi
225 Summary:        Python 3.x interface to BrlAPI
226 Summary(pl.UTF-8):      Interfejs Pythona 3.x do BrlAPI
227 License:        LGPL v2.1+
228 Group:          Libraries
229 Requires:       brlapi = %{version}-%{release}
230
231 %description -n python3-brlapi
232 Python 3.x interface to BrlAPI.
233
234 %description -n python3-brlapi -l pl.UTF-8
235 Interfejs Pythona 3.x do BrlAPI.
236
237 %package -n brlapi-tcl
238 Summary:        BrlAPI library for Tcl
239 Summary(pl.UTF-8):      Biblioteka BrlAPI dla Tcl
240 License:        LGPL v2.1+
241 Group:          Libraries
242 Requires:       brlapi = %{version}-%{release}
243
244 %description -n brlapi-tcl
245 BrlAPI library for Tcl.
246
247 %description -n brlapi-tcl -l pl.UTF-8
248 Biblioteka BrlAPI dla Tcl.
249
250 %prep
251 %setup -q
252 %patch0 -p1
253 %patch1 -p1
254 %patch2 -p1
255 %patch3 -p1
256
257 %build
258 %{__autoconf}
259 CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
260 %configure \
261         %{?with_java:JAVA_HOME=%{java_home}} \
262         --with-install-root="$RPM_BUILD_ROOT" \
263         %{!?with_libbraille:--without-libbraille} \
264         %{!?with_espeak:--without-espeak} \
265         %{!?with_flite:--without-flite} \
266         %{!?with_speech_dispatcher:--without-speechd} \
267         %{!?with_ocaml:--disable-caml-bindings} \
268         %{!?with_gpm:--disable-gpm} \
269         %{!?with_java:--disable-java-bindings} \
270         %{!?with_python:--disable-python-bindings} \
271         %{!?with_tcl:--disable-tcl-bindings} \
272         %{!?with_x:--disable-x} \
273         --enable-api
274
275 %{__make} -j1
276
277 %if %{with python3}
278 cd Bindings/Python
279 %{__python3} setup.py build \
280         -b build-3
281 cd ../..
282 %endif
283
284 directory="doc"
285 mkdir -p "$directory"
286 for file in `find . \( -path "./$directory" -o -path ./Documents \) -prune -o \( -name 'README*' -o -name '*.txt' -o -name '*.html' -o -name '*.sgml' -o \( -path "./Bootdisks/*" -type f -perm +ugo=x \) \) -print`
287 do
288         mkdir -p "$directory/${file%/*}"
289         cp -rp "$file" "$directory/$file"
290 done
291
292 %install
293 rm -rf $RPM_BUILD_ROOT
294
295 %{__make} -j1 install \
296         OCAML_INSTALL_TARGET=install-without-findlib
297
298 %if %{with python3}
299 cd Bindings/Python
300 %{__python3} setup.py \
301         build \
302                 -b build-3 \
303         install \
304                 --optimize=2 \
305                 --skip-build \
306                 --root=$RPM_BUILD_ROOT
307 cd ../..
308 %endif
309
310 %if %{_lib} != "lib"
311         # Fix java plugin install path on 64-bit archs
312         install -d $RPM_BUILD_ROOT%{_libdir}/java
313         %{__mv} $RPM_BUILD_ROOT%{_prefix}/{lib,%{_lib}}/java/libbrlapi_java.so
314 %endif
315
316 install Documents/brltty.conf $RPM_BUILD_ROOT%{_sysconfdir}
317
318 install -d $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
319 cat >$RPM_BUILD_ROOT/usr/lib/tmpfiles.d/brltty.conf <<EOF
320 d /var/run/brltty 0755 root root -
321 EOF
322
323 %find_lang %{name}
324
325 %clean
326 rm -rf $RPM_BUILD_ROOT
327
328 %pre
329 # The pre-install scriptlet.
330
331 # If a configuration file already exists then rpm installs the new one as
332 # <path>.rpmnew. If this is done then the .rpmnew file is overwritten if it
333 # already exists.
334
335 # There's no explicit way to tell if a configuration file has been installed
336 # as itself or as a .rpmnew file. The way we'll figure it out, therefore, is by
337 # erasing the .rpmnew file now so that we can see if it gets created later.
338 rm -f "%{_sysconfdir}/brltty.conf.rpmnew"
339
340 %post
341 # The post-install scriptlet.
342
343 # If BRLTTY's boot parameter has been specified then update the just installed
344 # configuration file template to reflect the options supplied thereby.
345
346 # First, we need to determine which file to update. If there's a .rpmnew file
347 # then update it since a previous configuration file must already have existed.
348 file="%{_sysconfdir}/brltty.conf"
349 new="${file}.rpmnew"
350 [ -f "${new}" ] && file="${new}"
351
352 # Update the configuration file template via the Bootdisks/bp2cf script.
353 # Include it right within this scriptlet so that it needn't be installed.
354 # Imbed it within a subshell to ensure that it won't impact this scriptlet.
355 (
356         # First, set bp2cf's command line arguments.
357         set -- -u -f "${file}"
358
359 #!/bin/sh
360 ###############################################################################
361 # BRLTTY - A background process providing access to the Linux console (when in
362 #          text mode) for a blind person using a refreshable Braille display.
363 #
364 # Copyright (C) 1995-2003 by The BRLTTY Team. All rights reserved.
365 #
366 # BRLTTY comes with ABSOLUTELY NO WARRANTY.
367 #
368 # This is free software, placed under the terms of the
369 # GNU General Public License, as published by the Free Software
370 # Foundation.  Please see the file COPYING for details.
371 #
372 # Web Page: http://mielke.cc/brltty/
373 #
374 # This software is maintained by Dave Mielke <dave@mielke.cc>.
375 ###############################################################################
376
377 # Convert the boot parameter to configuration file directives.
378 # If /proc is mounted then use the brltty= boot parameter in /proc/cmdline.
379 # If /proc is not mounted then use the brltty environment variable.
380 # Invoke with -h for usage information.
381
382 programName="${0##*/}"
383 programMessage()
384 {
385         echo 2>&1 "${programName}: ${1}"
386 }
387 syntaxError()
388 {
389         programMessage "${1}"
390         exit 2
391 }
392 internalError()
393 {
394         programMessage "${1}"
395         exit 3
396 }
397
398 configurationFile=""
399 requestedAction=create
400 deviceTranslation=none
401 requestedParameter=""
402 OPTIND=1
403 while getopts ":f:cundop:h" option
404 do
405         case "${option}" in
406             f) configurationFile="${OPTARG}";;
407             c) requestedAction=create;;
408             u) requestedAction=update;;
409             n) deviceTranslation=none;;
410             d) deviceTranslation=devfs;;
411             o) deviceTranslation=old;;
412             p) requestedParameter="${OPTARG}";;
413             h)
414                 cat <<EOF
415 Usage: ${programName} [option ...]
416 -f file  The configuration file to create/update.
417 -c       Create the configuration file (write to stdout if no -f).
418 -u       Update the configuration file (copying from stdin to stdout if no -f).
419 -n       Do not translate device paths.
420 -d       Do old-style to devfs device path translation.
421 -o       Do devfs to old-style device path translation.
422 -p [driver][,[device][,[table]]]
423          Explicitly specify the boot parameter.
424 -h       Display this usage summary.
425 EOF
426                 exit 0
427                 ;;
428             \?) syntaxError "unknown option: -${OPTARG}";;
429             :) syntaxError "missing value: -${OPTARG}";;
430             *) internalError "unimplemented option: -${option}";;
431         esac
432 done
433 shift "`expr $OPTIND - 1`"
434 [ "${#}" -eq 0 ] || syntaxError "too many parameters."
435
436 case "${requestedAction}" in
437     create)
438         putConfigurationLine()
439         {
440                 echo "${1}" || exit 4
441         }
442         startConfigurationFile()
443         {
444                 [ -n "${configurationFile}" ] && exec >"${configurationFile}"
445                 putConfigurationLine "`makeHeaderLine Created`"
446                 putConfigurationLine "`makeParameterLine`"
447                 putConfigurationLine ""
448         }
449         putConfigurationDirective()
450         {
451                 putConfigurationLine "${1} ${2}"
452         }
453         finalizeConfigurationFile()
454         {
455                 :
456         }
457         ;;
458     update)
459         putSedCommand()
460         {
461                 sedScript="${sedScript}
462 ${1}"
463         }
464         startConfigurationFile()
465         {
466                 if [ -n "${configurationFile}" ]; then
467                         [ -e "${configurationFile}" ] || syntaxError "file not found: ${configurationFile}"
468                         [ -f "${configurationFile}" ] || syntaxError "not a file: ${configurationFile}"
469                         [ -r "${configurationFile}" ] || syntaxError "file not readable: ${configurationFile}"
470                         [ -w "${configurationFile}" ] || syntaxError "file not writable: ${configurationFile}"
471                         outputFile="${configurationFile}.new"
472                         exec <"${configurationFile}" >"${outputFile}"
473                 fi
474                 sedScript=""
475                 putSedCommand "1i\\
476 `makeHeaderLine Updated`\\
477 `makeParameterLine`\\
478 "
479         }
480         putConfigurationDirective()
481         {
482                 value="`echo "${2}" | sed -e 's%\\([/\\]\\)%\\\\\\1%g'`"
483                 putSedCommand "/^ *#\\(${1} .*\\)/s//\\1/"
484                 putSedCommand "/^ *\\(${1}\\) .*/s//\\1 ${value}/"
485         }
486         finalizeConfigurationFile()
487         {
488                 sed -e "${sedScript}"
489                 [ -n "${outputFile}" ] && mv -f "${outputFile}" "${configurationFile}"
490         }
491         ;;
492     *) internalError "unimplemented action: ${requestedAction}";;
493 esac
494
495 translateDevice_none()
496 {
497         :
498 }
499 translateDevice_devfs()
500 {
501         minor="${device#ttyS}"
502         if [ "${minor}" != "${device}" ]; then
503                 device="tts/${minor}"
504                 return 0
505         fi
506         minor="${device#lp}"
507         if [ "${minor}" != "${device}" ]; then
508                 device="printers/${minor}"
509                 return 0
510         fi
511         programMessage "unsupported old-style device: ${device}"
512 }
513 translateDevice_old()
514 {
515         major="${device%%/*}"
516         if [ "${major}" != "${device}" ]; then
517                 minor="${device#*/}"
518                 case "${major}" in
519                     tts) devfs="ttyS${minor}";;
520                     printers) devfs="lp${minor}";;
521                 esac
522         fi
523         if [ -n "${devfs}" ]; then
524                 device="${devfs}"
525         else
526                 programMessage "unsupported devfs device: ${device}"
527         fi
528 }
529
530 makeHeaderLine()
531 {
532         echo "# ${1} by brltty-bp2cf`date +' on %Y-%m-%d at %H:%M:%S %Z (UTC%z)'`."
533 }
534 makeParameterLine()
535 {
536         echo "# Boot Parameter:${bootParameter}"
537 }
538 putConfigurationFile()
539 {
540         startConfigurationFile
541         [ -n "${brailleDriver}" ] && putConfigurationDirective "braille-driver" "${brailleDriver}"
542         [ -n "${brailleDevice}" ] && {
543         device="`echo "${brailleDevice}" | sed -e 's%//*%/%g' -e 's%^/dev/%%'`"
544         if [ "${device#/}" = "${device}" ]; then
545                 translateDevice_${deviceTranslation}
546         fi
547         putConfigurationDirective "braille-device" "${device}"
548         }
549         [ -n "${textTable}" ] && putConfigurationDirective "text-table" "${textTable}"
550         finalizeConfigurationFile
551 }
552 parseBootParameter()
553 {
554         bootParameter="${bootParameter} ${1}"
555         number=1
556         while [ "${number}" -le 3 ]; do
557                 cut="cut -d, -f${number}"
558                 [ "${number}" -gt 1 ] && cut="${cut} -s"
559                 operand="`echo ${1} | ${cut}`"
560                 if [ -n "${operand}" ]; then
561                         case "${number}" in
562                             1) brailleDriver="${operand}";;
563                             2) brailleDevice="${operand}";;
564                             3) textTable="${operand}";;
565                         esac
566                 fi
567                 number="`expr ${number} + 1`"
568         done
569 }
570 putBootParameter()
571 {
572         parseBootParameter "${1}"
573         putConfigurationFile
574 }
575 parseBootCommand()
576 {
577         found=false
578         while [ "${#}" -gt 0 ]; do
579                 case "${1}" in
580                     "brltty="*)
581                         found=true
582                         parseBootParameter "${1#*=}"
583                         ;;
584                 esac
585                 shift
586         done
587         "${found}" && putConfigurationFile
588 }
589
590 brailleDriver=""
591 brailleDevice=""
592 textTable=""
593 bootCommandFile="/proc/cmdline"
594 if [ -n "${requestedParameter}" ]; then
595         putBootParameter "${requestedParameter}"
596 elif [ -f "${bootCommandFile}" ]; then
597         parseBootCommand `cat "${bootCommandFile}"`
598 elif [ -n "${brltty}" ]; then
599         putBootParameter "${brltty}"
600 fi
601 exit 0
602 )
603
604 %post   -n brlapi -p /sbin/ldconfig
605 %postun -n brlapi -p /sbin/ldconfig
606
607 %files -f %{name}.lang
608 %defattr(644,root,root,755)
609 %doc Documents/{Manual-BRLTTY/English/BRLTTY*,ChangeLog,HISTORY,TODO}
610 %doc doc/{Bindings,Bootdisks,Drivers,Patches,Tables,README,nsistrings.txt}
611 %attr(755,root,root) %{_bindir}/brltty
612 %attr(755,root,root) %{_bindir}/brltty-config
613 %attr(755,root,root) %{_bindir}/brltty-ctb
614 %attr(755,root,root) %{_bindir}/brltty-install
615 %attr(755,root,root) %{_bindir}/brltty-trtxt
616 %attr(755,root,root) %{_bindir}/brltty-ttb
617 %attr(755,root,root) %{_bindir}/eutp
618 %attr(755,root,root) %{_bindir}/vstp
619 %{?with_x:%attr(755,root,root) %{_bindir}/xbrlapi}
620 %dir %{_libdir}/brltty
621 # Braille drivers
622 %attr(755,root,root) %{_libdir}/brltty/libbrlttybal.so
623 %attr(755,root,root) %{_libdir}/brltty/libbrlttybat.so
624 %attr(755,root,root) %{_libdir}/brltty/libbrlttybba.so
625 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbc.so
626 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbd.so
627 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbl.so
628 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbm.so
629 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbn.so
630 %attr(755,root,root) %{_libdir}/brltty/libbrlttybcb.so
631 %attr(755,root,root) %{_libdir}/brltty/libbrlttybce.so
632 %attr(755,root,root) %{_libdir}/brltty/libbrlttybec.so
633 %attr(755,root,root) %{_libdir}/brltty/libbrlttybeu.so
634 %attr(755,root,root) %{_libdir}/brltty/libbrlttybfs.so
635 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhm.so
636 %attr(755,root,root) %{_libdir}/brltty/libbrlttybht.so
637 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhw.so
638 %attr(755,root,root) %{_libdir}/brltty/libbrlttybir.so
639 %{?with_libbraille:%attr(755,root,root) %{_libdir}/brltty/libbrlttyblb.so}
640 %attr(755,root,root) %{_libdir}/brltty/libbrlttyblt.so
641 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmb.so
642 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmd.so
643 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmm.so
644 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmn.so
645 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmt.so
646 %attr(755,root,root) %{_libdir}/brltty/libbrlttybnp.so
647 %attr(755,root,root) %{_libdir}/brltty/libbrlttybpg.so
648 %attr(755,root,root) %{_libdir}/brltty/libbrlttybpm.so
649 %attr(755,root,root) %{_libdir}/brltty/libbrlttybsk.so
650 %attr(755,root,root) %{_libdir}/brltty/libbrlttybtn.so
651 %attr(755,root,root) %{_libdir}/brltty/libbrlttybts.so
652 %attr(755,root,root) %{_libdir}/brltty/libbrlttybtt.so
653 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvd.so
654 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvo.so
655 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvr.so
656 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvs.so
657 %{?with_x:%attr(755,root,root) %{_libdir}/brltty/libbrlttybxw.so}
658 # speech synthesizer drivers
659 %attr(755,root,root) %{_libdir}/brltty/libbrlttysal.so
660 %attr(755,root,root) %{_libdir}/brltty/libbrlttysbl.so
661 %attr(755,root,root) %{_libdir}/brltty/libbrlttyscb.so
662 %{?with_espeak:%attr(755,root,root) %{_libdir}/brltty/libbrlttyses.so}
663 %{?with_flite:%attr(755,root,root) %{_libdir}/brltty/libbrlttysfl.so}
664 %attr(755,root,root) %{_libdir}/brltty/libbrlttysfv.so
665 %attr(755,root,root) %{_libdir}/brltty/libbrlttysgs.so
666 %{?with_mikropuhe:%attr(755,root,root) %{_libdir}/brltty/libbrlttysmp.so}
667 %{?with_speech_dispatcher:%attr(755,root,root) %{_libdir}/brltty/libbrlttyssd.so}
668 %{?with_swift:%attr(755,root,root) %{_libdir}/brltty/libbrlttyssw.so}
669 %{?with_theta:%attr(755,root,root) %{_libdir}/brltty/libbrlttysth.so}
670 %{?with_viavoice:%attr(755,root,root) %{_libdir}/brltty/libbrlttysvv.so}
671 %attr(755,root,root) %{_libdir}/brltty/libbrlttysxs.so
672 # screen drivers
673 %{?with_at_spi2:%attr(755,root,root) %{_libdir}/brltty/libbrlttyxa2.so}
674 %{?with_at_spi:%attr(755,root,root) %{_libdir}/brltty/libbrlttyxas.so}
675 %attr(755,root,root) %{_libdir}/brltty/libbrlttyxlx.so
676 %attr(755,root,root) %{_libdir}/brltty/libbrlttyxsc.so
677 %{_sysconfdir}/brltty
678 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/brltty.conf
679 /usr/lib/tmpfiles.d/brltty.conf
680 %dir /var/lib/BrlAPI
681 %dir /var/run/brltty
682 %{_mandir}/man1/brltty.1*
683 %{_mandir}/man1/eutp.1*
684 %{_mandir}/man1/vstp.1*
685 %{?with_x:%{_mandir}/man1/xbrlapi.1*}
686
687 %if %{with x}
688 # gdm autostart - subpackage?
689 #%{_datadir}/gdm/greeter/autostart/xbrlapi.desktop
690 %endif
691
692 %files -n brlapi
693 %defattr(644,root,root,755)
694 %attr(755,root,root) %{_libdir}/libbrlapi.so.*.*.*
695 %attr(755,root,root) %ghost %{_libdir}/libbrlapi.so.0.6
696
697 %files -n brlapi-devel
698 %defattr(644,root,root,755)
699 %doc Documents/Manual-BrlAPI/English/BrlAPI*
700 %attr(755,root,root) %{_libdir}/libbrlapi.so
701 %{_includedir}/brltty
702 %{_includedir}/brlapi*.h
703 %{_mandir}/man3/brlapi_*.3*
704
705 %files -n brlapi-static
706 %defattr(644,root,root,755)
707 %{_libdir}/libbrlapi.a
708
709 %if %{with apidocs}
710 %files -n brlapi-apidocs
711 %defattr(644,root,root,755)
712 %doc Documents/BrlAPIref/html/*
713 %endif
714
715 %if %{with java}
716 %files -n java-brlapi
717 %defattr(644,root,root,755)
718 %attr(755,root,root) %{_libdir}/java/libbrlapi_java.so
719 %{_javadir}/brlapi.jar
720 %endif
721
722 %if %{with ocaml}
723 %files -n ocaml-brlapi
724 %defattr(644,root,root,755)
725 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllbrlapi_stubs.so
726 %{_libdir}/ocaml/stublibs/dllbrlapi_stubs.so.owner
727
728 %files -n ocaml-brlapi-devel
729 %defattr(644,root,root,755)
730 %dir %{_libdir}/ocaml/brlapi
731 %{_libdir}/ocaml/brlapi/META
732 %{_libdir}/ocaml/brlapi/brlapi.cm[aix]*
733 %{_libdir}/ocaml/brlapi/brlapi.mli
734 %{_libdir}/ocaml/brlapi/libbrlapi_stubs.a
735 %endif
736
737 %if %{with python}
738 %files -n python-brlapi
739 %defattr(644,root,root,755)
740 %attr(755,root,root) %{py_sitedir}/brlapi.so
741 %{py_sitedir}/Brlapi-%{brlapi_ver}-py*.egg-info
742
743 %if %{with python3}
744 %files -n python3-brlapi
745 %defattr(644,root,root,755)
746 %attr(755,root,root) %{py3_sitedir}/brlapi.cpython-*.so
747 %{py3_sitedir}/Brlapi-%{brlapi_ver}-py*.egg-info
748 %endif
749 %endif
750
751 %if %{with tcl}
752 %files -n brlapi-tcl
753 %defattr(644,root,root,755)
754 %dir %{_libdir}/brlapi-%{brlapi_ver}
755 %attr(755,root,root) %{_libdir}/brlapi-%{brlapi_ver}/libbrlapi_tcl.so
756 %{_libdir}/brlapi-%{brlapi_ver}/pkgIndex.tcl
757 %endif
This page took 0.119678 seconds and 2 git commands to generate.